PDA

View Full Version : [kubuntu] 7.10->8.04 upgrade, Wireless dropping is back



imhavoc
May 17th, 2008, 04:59 PM
Tom,

After upgrading my Daru2 from Kubuntu 7.10 to 8.04, I'm experiencing the problem with my wireless card "disappearing" again. I can't find the thread (in the archives) that we used to solve it for 7.10. I applied what I thought was the solution from another thread, but it hasn't changed anything.

thanks.

thomasaaron
May 19th, 2008, 03:37 PM
Please provide more information on what you've already tried.
Also, what do you mean by saying your card disappeared? Is it just dropping the connection, or does it actually disappear from lspci?

imhavoc
May 19th, 2008, 07:09 PM
Wireless is dropping, and is not available at all until I reboot the machine.

I'll get you more info next time it crashses.

thomasaaron
May 19th, 2008, 09:41 PM
Do you have the 3945 card?

lspci | grep 3945

imhavoc
May 20th, 2008, 03:56 AM
02:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)

yep

thomasaaron
May 20th, 2008, 03:45 PM
OK. Here was the old fix.

echo blacklist ipw3945 | sudo tee -a /etc/modprobe.d/blacklist
echo iwl3945 | sudo tee -a /etc/modules

imhavoc
May 26th, 2008, 01:42 AM
I've already done that, and it didn't solve the problem.

Last time I did that, it changed the icon for the network management to a KDE wireless indicator. This time, it did not.

The drop today was so bad that I was forced to shutdown and power up. Usually, a reboot gets the wireless back online, but not today.

Just strange.

Is there any other information I can gather for you?

thomasaaron
May 26th, 2008, 05:37 PM
OK. I'll try to replicate this tomorrow. (We're off today.)
Since I put a 4965 card in my GazV5, I've not had this problem. But if the aforementioned fix does not help, I'm gonna have to do some testing on it.
Can you shoot me an email reminder?