PDA

View Full Version : [ubuntu] [SOLVED] Windows Share With Space In Name



eeboy
May 15th, 2008, 11:22 PM
I am trying to mount a windows share with a space in the share name. I tried quotes and that doesn't work. Here's what I have added to /etc/fstab:


"//Server01/shared files" /mnt/win cifs exec,credentials=/etc/cifspw 0 0

Further complicating things my username has a space in it as well so I made my credentials file as follows:


username="user name"
password=pass

/mnt/win does exist as well.

Any suggestions?

dmizer
May 16th, 2008, 01:57 AM
use \040 for your space:

//Server01/shared\040files /mnt/win cifs exec,credentials=/etc/cifspw 0 0

as for the space in your user name, there's no way around it that i'm aware of. best bet is to change it to a username without a space. if this is not an option, you may not be able to use a credentials file.

eeboy
May 16th, 2008, 04:02 AM
'\040' works in the /etc/fstab file
'\ ' works on the command line

Changing the username was easy enough and so that's what I did.