PDA

View Full Version : [ubuntu] No wireless after update



yssida
May 15th, 2008, 12:34 PM
Before I updated last night, my wireless was working fine, after an update I had difficulty connecting, and finally gave up. What should I do? My network adapter is an Intel PRO/Wireless 3945ABG, it has an open source driver.

Regards,
yssida

ADD: Actually, it wasn't fine, I couldn't connect to many public access areas (airports,etc), but it worked fine at home.

chili555
May 15th, 2008, 01:03 PM
There is evidently a better iwl3945 in here:
sudo apt-get install linux-backports-modules-hardy-genericPlease let us know.

yssida
May 15th, 2008, 01:39 PM
I plugged in the ethernet wire and installed it. Removed the wire, and it worked.

I'll keep you posted. Thanks!

yssida
May 21st, 2008, 12:15 PM
Hmmm, it didn't work again. Required me to change wireless security for my router to 'none'. And then set it again to WPA Personal, and reentered the password. I don't exactly know what the problem is either.

chili555
May 21st, 2008, 02:19 PM
This is a great tutorial on WPA: http://ubuntuforums.org/showthread.php?t=318539

yssida
May 22nd, 2008, 03:54 AM
Does that let me connect to WPA network? Or is it for setting up WPA network?

Anyway, what if iwlist scan says


lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

wmaster0 Interface doesn't support scanning.

wlan0 No scan results