View Full Version : [kubuntu] [SOLVED] screen regularly flashing

May 15th, 2008, 06:32 AM

I'm using Hardy (KDE4). When in X, the screen infrequently flashes for a split second. It happens regularly though infrequently. It can not occur for minutes and then occur a couple of times in a minute.

I'm using a Dell XPS M1710 with the proprietary nvidia driver. I've never experienced this problem on Windows so I doubt it would be the card.

My xorg.conf is:

# xorg.conf (X.Org X Window System server configuration file)
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbVariant" "altgr-intl"
Option "XkbOptions" "lv3:ralt_switch"

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizEdgeScroll" "0"

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"

Section "Monitor"
Identifier "Configured Monitor"

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Defaultdepth 24

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
Inputdevice "Synaptics Touchpad"
Section "Module"
Load "glx"

Has anyone experienced this before?

Any help would be appreciated!


Xiong Chiamiov
May 15th, 2008, 06:38 AM
This would probably be better suited in the Multimedia Section, since I'm pretty sure it's not a KDE problem.

Which version of the NVIDIA driver are you using? Do you have compiz (advanced desktop effects) enabled?

May 15th, 2008, 09:05 AM
After hours of trial and error it looks like I've found the fix (fingers crossed).

It's detailed in http://www.nvnews.net/vbulletin/showthread.php?t=83340&page=2

Basically, you need to edit /etc/modprobe.d/options and add:

options nvidia NVreg_RegistryDwords="PerfLevelSrc=0x2222"

I've no idea why it fixes it but so far so good!