PDA

View Full Version : [ubuntu] Internet Problem



kinuser
May 13th, 2008, 03:30 AM
Hey, I am a newbie to linux and trying to get my new ubuntu box to connect to the internet. I have cable internet and have the ethernet from the cable box going to a five port switch, from there I plugged it into my linux box and a windows XP box which I am using now, the internet is working fine on it.

I have already tried taking the switch out and plugging the ubuntu box directly to the cable modem and it still didn't work, I tried running the ping program and it didn't return any packets so I don't think it is connecting. Any suggestions on my next step of troubleshooting? I am pretty novice when it comes to routing in general so any help would be welcomed.

Iowan
May 13th, 2008, 04:22 AM
Some cable modems reportedly (I don't have one) lock onto a MAC address. You might try resetting the modem with only Ubuntu connected to see if it helps.

kinuser
May 13th, 2008, 04:57 AM
Iowan, hey thanks for the tip I did that wish just the ubuntu box hooked up and now the internet works the linux box and not windows. Since it seems that only one at a time can be connected, is there a easy way or some kind of tutorial for connecting internet through either one to the other. I am not sure which is better for the hosting of the network, I do have virus protection already for my windows box but I am not sure about needed virus protection for ubuntu. Is one way easier then the other??

superprash2003
May 13th, 2008, 12:35 PM
you could enable Internet Connection Sharing in the Windows pc