View Full Version : [xubuntu] Xubuntu, Verizon DSL, netgear router and no connection

May 13th, 2008, 02:50 AM
I'm having trouble getting my linux box to connect to the internet even though windows machines can.

Here's my setup - please ask for more info if needed:

- Verizon DSL which uses PPPoE.

- A westell versalink 327W dsl modem set to bridge mode and no dhcp assignment (so it should be just a modem, not a router).

- A MR814v2 Netgear router is connected to the dsl modem (WAN port of the router to port 1 on the modem). The router is taking care of logging into my ISP and DHCP since the modem is just a bridge.

- A windows box is connected to one of the ports on the router and my linux machine is connected to another - both wired connections.

- Assigned IP addresses based on MAC addresses for both the windows and linux machines.

- I am running Xubuntu 7.04. I downloaded the network manager applet (nm-applet) and used it to assign a static IP to the linux machine using the router's ip as the gateway.

I can connect to the router's configuration pages, but I can't connect to the internet.

Any help would be greatly appreciated. Thanks.

May 13th, 2008, 12:37 PM
in the terminal type ping google.com and post output here

May 13th, 2008, 11:19 PM
$ ping google.com
ping: unknown host google.com

May 14th, 2008, 02:14 AM
are you able to open .

May 14th, 2008, 05:18 AM
aha...very interesting...

yes i can open it if i put in the numbers. i take it that means that the DNS server for machine is not configured correctly...

May 14th, 2008, 05:44 AM
So feeling optimistic, I tried disabling ipv6 as suggested in this link (https://help.ubuntu.com/community/WifiDocs/WirelessTroubleShootingGuide#head-1b12c0a8c765a0d0d623e3ee60daf197a5bf2b59-2), but it didn't work.

Here's the DNS configuration from 'ipconfig /all' from my windows machine:
DNS Suffix search list verizon.net
DNS servers

and here's what /etc/resolv.conf looks like on linux:
$ less resolv.conf
search verizon.net

in case that's helpful.

May 14th, 2008, 12:42 PM
it would be better to change your DNS servers to opendns .. try this http://prash-babu.blogspot.com/2008/04/how-to-configure-dns-servers-in-linux.html

May 14th, 2008, 02:10 PM
didn't work - i also tried changing my /etc/resolv.conf file to have:


as well, but that didn't work.

i would think that if the opendns would work, so would the verizon one (even if, as i saw from the link, it's loads slower).