View Full Version : [ubuntu] [SOLVED] Firefox 3 + Hardy no bookmarks, no nav buttons, can't uninstall

May 12th, 2008, 11:10 AM
I upgraded to Hardy a couple of weeks ago and despite a few minor problems all has been fine since then. I shut down my PC on Friday and today (Mon) Firefox 3 is a complete mess? (I'm running a Dell Dimension 5150 2.8GHz DC)

The bookmarks toolbar has completely vanished
the forward an back nav buttons no longer function
I cannot import the bookmarks file as Firefox doesn't even see the .mozilla folder
I installed Firefox 2 via Synaptic, it wouldn't run at all.
I removed all traces of FF2 and FF3 via synaptic then reinstalled FF3, same problems
I have searched the forums and there seems to be a lot of people advocating removal of FF3 and going back to FF2 but as you can see I tried this and got nowhere.

Grateful for any ideas.

May 12th, 2008, 11:20 AM
To get back the bookmark tool bar have you tried right clicking some where on the blank space above the address bar and making sure "bookmark toolbar" is ticked?
Also try selecting "customise" then remove and then re add the forward and back nav buttons and see if that works.
When you tried to remove firefox did you purge or choose the "compete reinstall" option in synaptic?

May 12th, 2008, 11:32 AM
Yes the toolbar is selected but not showing. The back/forward bottons are there in the toolbar, they just don't do anything at all. I didn't try the "compete reinstall" option in synaptic, I'll give it a go.

Another weird thing, I thought I'd install another browser till I get this fixed, I installed Amaya but it too will not run just like FF2.

May 12th, 2008, 11:42 AM
using "compete reinstall" will remove all config files for firefox3 maybe backup your bookmarks just in case you loose them.

May 12th, 2008, 03:27 PM
RESOLVED: Thanks for all the advice but after numerous un-installs and re-installs of FF I finally tracked the problem. Believe it or not I had virtually run out of disk space on my Ubuntu partition which caused problems for FF and Evolution not to mention numerous other odd system behaviours, such as no menu when I clicked Shut Down button.

I managed to free up some space and low and behold FF sprang back into life, all I had to do was import my bookmarks from the backup.

What is more worrying is that at no time were any warnings generated by the system to warn of a lack of space.