PDA

View Full Version : HOWTO: PulseAudio Fixes & System-Wide Equalizer Support



Pages : 1 [2] 3 4 5 6 7

starnerd67
June 20th, 2008, 08:52 PM
HI im following the instructions to get flash to play sounds.

But still i get no sound from pulse audio.

After going through troubleshoot i realize that its because PulseAudio is outputting sound on the wrong device.

My Juli@ sound card can output on Analog and Digital (i only have Digital working)

right now in the PulseAudio Volume Control -> Output Devices it says this:

ALSA PCM on front:0 (ICE1724) via DMA

Sound for my card only works on s/pdif output on IEC1724 IEC958 (so its IEC not ICE) Also audio only works after downloading gnome-alsamixer

do you guys know how i can change output to make it output on the correct deivce ????

psyke83
June 20th, 2008, 08:59 PM
HI im following the instructions to get flash to play sounds.

But still i get no sound from pulse audio.

After going through troubleshoot i realize that its because PulseAudio is outputting sound on the wrong device.

My Juli@ sound card can output on Analog and Digital (i only have Digital working)

right now in the PulseAudio Volume Control -> Output Devices it says this:

ALSA PCM on front:0 (ICE1724) via DMA

Sound for my card only works on s/pdif output on IEC1724 IEC958 (so its IEC not ICE) Also audio only works after downloading gnome-alsamixer

do you guys know how i can change output to make it output on the correct deivce ????

Hi, thanks for answering.

1. When you first installed Hardy, was PulseAudio playing sound on the right device?

2. Did you follow Part D of this guide (to enable the equalizer)?

If you followed Part D, disable the equalizer (I mentioned how to do that a few posts back).

If you didn't follow part D and PulseAudio never used the correct device (even before this guide), use the PulseAudio Device Chooser to change the default sink.

starnerd67
June 20th, 2008, 09:13 PM
I didn't follow Part D.
I don't think pulse audio ever played sound on the correct device

hmmmm
in the Device Chooser it says either Default or Other (when i click other... it says enter sink name)... there is also a grey'd out portion that says no network devices found

psyke83
June 20th, 2008, 09:23 PM
I didn't follow Part D.
I don't think pulse audio ever played sound on the correct device

hmmmm
in the Device Chooser it says either Default or Other (when i click other... it says enter sink name)... there is also a grey'd out portion that says no network devices found

Go to the PulseAudio Manager, and look at the Server Information tab. The default sink will tell you what sound card PulseAudio is currently using as default. Now, go to the Sample Cache tab. Click the dropdown box beside "Playback on", and try to find the correct device. Select the proper device, click on "pulse-hotplug" and click the Play button.

If that works for you, I'm not entirely sure of what the "easiest" way is to fix the problem. For example, you may be able to go to PulseAudio Device Chooser, click Default Sink -> Other, and enter the exact name of the correct device, as listed in the "Playback on" dropdown box.

Or, you can edit /etc/pulse/default.pa and define the default device there. So, change this:

#load-module module-alsa-sink
To this (where xyz is the proper name for your sound card):

load-module module-alsa-sink device=xyz

Try changing it via the Device Chooser first, though.

starnerd67
June 20th, 2008, 10:09 PM
default sink is currently:
alsa_output.pci_1412_1724_sound_card_0_alsa_playba ck_0

i tried manually typing device in to the "other" sink but............. the exact name of the device is something i don't know...........
i just know its not: Monitor Source of ALSA PCM on front:0 (ICE1724) via DMA
should be somehtign like: Monitor Source of ALSA PCM on s/pdifout:1 (IEC1724 IEC958) via DMA

but the exact name... im not sure where to find that.....

in Sample Cache dropdown it only gives me:
alsa_output.pci_1412_1724_sound_card_0_alsa_playba ck_0
combined
both of which don't work........

hmmmmmmmmmmm
i think the problem maybe in ALSA itself outputting on the wrong device.... cause under my System -> Preferences -> Sound PReferences sound playback is on IEC1724 IEC958 not ALSA (if i change it to ALSA i can't here any sounds ... normnally mp3's work)

is there any way to find out what audio devices there are to work with ?????

psyke83
June 20th, 2008, 10:30 PM
is there any way to find out what audio devices there are to work with ?????

EDIT: PulseAudio Volume Control, Output Devices. You can right-click on a device to make it the default. Also on the Playback tab, you can right-click and move streams to other devices. That may be a better solution than the below advice.

Ok, here's what you can do.

Take a look at the playback devices with this command:

aplay -l

To illustrate, here's my output:

**** List of PLAYBACK Hardware Devices ****
card 0: I82801DBICH4 [Intel 82801DB-ICH4], device 0: Intel ICH [Intel 82801DB-ICH4]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: I82801DBICH4 [Intel 82801DB-ICH4], device 4: Intel ICH - IEC958 [Intel 82801DB-ICH4 - IEC958]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: pcsp [pcsp], device 0: pcspeaker [pcsp]
Subdevices: 1/1
Subdevice #0: subdevice #0


In my case, the sound card is card 0, and there are two devices for playback - device 0 and device 4. As you can see, device 4 is the IEC958 output.

PulseAudio most likely selects the default playback device - in my case, device 0 of card 0. If I want to change it to the IEC958 output, here's what I would do:

Edit /etc/pulse/default.pa

Change this line:

#load-module module-alsa-sink
To this:

load-module module-alsa-sink device=hw:0,4

You just need to find the correct hardware definition for your desired output. Logging out and back in (to restart PulseAudio) will make this setting take effect.

NOTE: There may be an easier way to change the device, perhaps via the PulseAudio Device Chooser. And if this doesn't help, make sure to have a backup of your /etc/pulse/default.pa file.

starnerd67
June 20th, 2008, 11:20 PM
Aww man you rock

that did the trick...... music videos and flash work great now ^__^

thanks so much

there is one more minor thing though.........
System -> preferences -> sound preferences -> sounds
the Log Out / Log in test play's make no sound....

so when i login or logout, no sound comes out (more asethetical preference really) but would u have any idea why those don't work ????

psyke83
June 20th, 2008, 11:31 PM
there is one more minor thing though.........
System -> preferences -> sound preferences -> sounds
the Log Out / Log in test play's make no sound....

so when i login or logout, no sound comes out (more asethetical preference really) but would u have any idea why those don't work ????

That's to be expected. You see, PulseAudio is configured to launch per-user, not system-wide. That means the GDM greeter does not use PulseAudio, but plays directly through ALSA (and it's playing on the wrong device again).

You can try creating /etc/asound.conf and pasting the following:

pcm.!default {
type hw
card 0
device 4
}

Of course, you may need to change the card/device number to match the same you used for PulseAudio. That should hopefully direct GDM's output to the right device.

Let me warn you that this *may* cause problems with some applications in PulseAudio (I tested and it seems ok, but I thought I'd warn you). If you have problems after trying this, just delete the /etc/asound.conf file.

starnerd67
June 20th, 2008, 11:54 PM
hmmmmm that didn't work...........

is there anything i can check ??

psyke83
June 21st, 2008, 12:01 AM
hmmmmm that didn't work...........

is there anything i can check ??

I'm not sure, sorry. It may not take effect until you restart the computer.

starnerd67
June 21st, 2008, 12:11 AM
meh nothing to problematic that i hafta waste another day on.......

but thanks for all your help ^__^

now i can have some real linux fun

myromance123
June 21st, 2008, 02:57 AM
Create a new "/etc/libao.conf" file and change the default driver to "pulse"

How do I do this?? Where do i do this??

psyke83
June 21st, 2008, 03:04 AM
Create a new "/etc/libao.conf" file and change the default driver to "pulse"

How do I do this?? Where do i do this??

The text in the code box directly underneath does that...

If you're not sure how to use the command line, be careful with this guide as a lot can go wrong due to user error. Here's a guide that that describes the fundamentals, including how to use the command line: http://ubuntuguide.org/wiki/Ubuntu:Hardy

myromance123
June 21st, 2008, 03:10 AM
Thanks so much (dang youre fast to reply :D )
Means a lot, thought I might screw up and ruin my pc :P

myromance123
June 21st, 2008, 03:19 AM
I was trying to do appendix B and I cant get my pulseaudio from the applications bar to open. It just wont run. What could be wrong?

psyke83
June 21st, 2008, 03:22 AM
I was trying to do appendix B and I cant get my pulseaudio from the applications bar to open. It just wont run. What could be wrong?

Try opening it from the terminal:
$ padevchooser
If it doesn't work, paste the output here.

Did you make sure to log out and back in before trying?

ShirishAg75
June 21st, 2008, 05:10 PM
Hi pyske83,
Finally with the new kernel I'm able to run padevchooser. Now it shows the following menu

Default Server
Default Sink
Default Source

----------------

Manager
Volume Control
Volume Meter (Playback)
Volume Meter (Recording)
Configure Local Sound Server

--------------------------------

Preferences

---------------------------------

Quit

Now nothing is selected either in the Default Server, Sink or Source. Can you tell me what is to be done now?

psyke83
June 21st, 2008, 06:14 PM
Now nothing is selected either in the Default Server, Sink or Source. Can you tell me what is to be done now?

This guide is not really supposed to be for the development version of Ubuntu, as many things are in flux. The 2.6.26 kernel now considers the pc speaker as a pcm device, and PulseAudio may be picking that as the default ALSA sink.

This thread contains two possible answers: http://ubuntuforums.org/showthread.php?t=833825

Try to keep Intrepid discussion to the proper forum.

eryksun
June 23rd, 2008, 06:53 PM
Killing the PulseAudio server with 'pulseaudio -k' and reloading ALSA doesn't restore ALSA properly (e.g. alsamixer's default master still controls the PulseAudio master) because of the settings in .asoundrc. So I moved the equalizer settings to .asoundrc.equalizer and let asoundconf manage the PulseAudio settings. Now all I have to do is run 3 commands without having to edit any files.

Disable PulseAudio:


pulseaudio -k
asoundconf unset-pulseaudio
sudo alsa reload

Enable PulseAudio:


asoundconf set-pulseaudio
sudo alsa reload
pulseaudio &

Setup modifications I made:

.asoundrc:


# ALSA library configuration file

# Include settings that are under the control of asoundconf(1).
# (To disable these settings, comment out this line.)
</home/USER_NAME/.asoundrc.asoundconf>

# System-wide equalizer settings
</home/USER_NAME/.asoundrc.equalizer>

I changed the equalizer plugin setup to use the !default device rather than 'equalized' so the EQ works with or without PulseAudio given the way asoundconf manages the configuration.

.asoundrc.equalizer:


pcm.!default {
type plug
slave.pcm "equalizer"
}

pcm.equalizer {
type ladspa

#output to either hardware or software mixers
#slave.pcm "plug:dmix"
slave.pcm "plughw"

# plugin path
path "/usr/lib/ladspa"

plugins [
{
label mbeq
id 1197
input {
# Frequency Bands (kHz)
# 0.050, 0.100, 0.156, 0.220, 0.311, 0.440, 0.622, 0.880,
# 1.250, 1.750, 2.500, 3.500, 5.000, 10.00, 20.00
controls [0 -1 -3 -5 -5 -5 -5 -8 -8 -5 -5 -5 -5 -5 -5]
}
}
]
}

Changing the equalizer plugin device requires a similar change to PulseAudio's driver config.

/etc/pulse/default.pa, the following line:


load-module module-alsa-sink device=equalized

becomes


load-module module-alsa-sink device=default

So, psyke83, everything seems to be working ok, but does this config mess something up that I haven't considered?

psyke83
June 23rd, 2008, 07:15 PM
So, psyke83, everything seems to be working ok, but does this config mess something up that I haven't considered?

Unfortunately this won't work properly. Defining "equalizer" as the default ALSA virtual device means that all ALSA applications will output audio directly to the "equalized" device, completely bypassing PulseAudio.

On top of that, your configuration defines two default ALSA devices (in .asoundrc.asoundconf and .asoundrc.equalized) - this causes a conflict and PulseAudio doesn't pick up the equalizer at all.

Using your configuration, applications with native PulseAudio support continue to output sound to PulseAudio, but the equalizer doesn't work, and ALSA applications bypass PulseAudio.

If you don't believe me, open the PulseAudio Volume Control and then try the following:
1. mplayer /usr/share/sounds/startup.wav -ao pulse
2. mplayer /usr/share/sounds/startup.wav -ao alsa

The latter won't display an entry in the Volume Control list, as it's not getting directed to PulseAudio.

Edit: I also forgot to mention that your configuration will break Skype - you need to create a unique definition (called "pulse" in my guide), because Skype won't work with the "default" device properly.

eryksun
June 23rd, 2008, 09:21 PM
Unfortunately this won't work properly. Defining "equalizer" as the default ALSA virtual device means that all ALSA applications will output audio directly to the "equalized" device, completely bypassing PulseAudio.

First of all, thank you for the quick feedback.

I didn't test for PulseAudio not picking up ALSA apps. I would have discovered this eventually with games (I just modified the config this morning).


On top of that, your configuration defines two default ALSA devices (in .asoundrc.asoundconf and .asoundrc.equalized) - this causes a conflict and PulseAudio doesn't pick up the equalizer at all.

Using your configuration, applications with native PulseAudio support continue to output sound to PulseAudio, but the equalizer doesn't work, and ALSA applications bypass PulseAudio.

I think you're right that this should be a conflict. Does it make a difference that one default is of type 'plug' and the other is of type 'pulse'? All I know is that the equalizer works fine for both PulseAudio and ALSA apps. I tested with extreme settings on the EQ to make sure it was engaged. If things were as bad as you say, I never would have posted anything at all, or my post would have been more like "Help! I can't make this work".


Edit: I also forgot to mention that your configuration will break Skype - you need to create a unique definition (called "pulse" in my guide), because Skype won't work with the "default" device properly.

I wouldn't have noticed this since I don't use Skype. But I just checked and oddly enough it works for a test call. It's set up to use the device 'equalizer' for 'Sound Out' and 'Ringing'.

My only goal in changing the EQ to the default device was to keep the EQ active after killing PulseAudio without having to re-edit files. But I overlooked that it would cause ALSA streams to bypass PulseAudio. As I'm still learning, can you suggest a command that will make ALSA use the equalized device as the default? Or does it require editing .asoundrc to make the equalizer the default device every time?

I'm in the process of digesting this page on ALSA (http://www.sabi.co.uk/Notes/linuxSoundALSA.html) to get a deeper understanding.

P.S. I lose the EQ in PulseAudio if I comment out the following line in /etc/pulse/default.pa:


load-module module-alsa-sink device=default

And the EQ also works if I change the line to just:


load-module module-alsa-sink

psyke83
June 23rd, 2008, 09:59 PM
I think you're right that this should be a conflict. Does it make a difference that one default is of type 'plug' and the other is of type 'pulse'? All I know is that the equalizer works fine for both PulseAudio and ALSA apps. I tested with extreme settings on the EQ to make sure it was engaged. If things were as bad as you say, I never would have posted anything at all, or my post would have been more like "Help! I can't make this work".
No, it doesn't make any difference. You simply cannot define the same ALSA virtual device twice - it won't work.


I wouldn't have noticed this since I don't use Skype. But I just checked and oddly enough it works for a test call. It's set up to use the device 'equalizer' for 'Sound Out' and 'Ringing'.
Yes, it will work if you set it to that device. My point is that it won't work with PulseAudio.


My only goal in changing the EQ to the default device was to keep the EQ active after killing PulseAudio without having to re-edit files. But I overlooked that it would cause ALSA streams to bypass PulseAudio. As I'm still learning, can you suggest a command that will make ALSA use the equalized device as the default? Or does it require editing .asoundrc to make the equalizer the default device every time?
Why would you want to kill PulseAudio anyway?


I'm in the process of digesting this page on ALSA (http://www.sabi.co.uk/Notes/linuxSoundALSA.html) to get a deeper understanding.
Unfortunately, that page won't tell you anything about .asoundrc files or PulseAudio's ALSA pcm plugins. These pages are better:
http://alsa.opensrc.org/.asoundrc
http://www.pulseaudio.org/wiki/PerfectSetup


P.S. I lose the EQ in PulseAudio if I comment out the following line in /etc/pulse/default.pa:


#load-module module-alsa-sink device=default
If you comment that line, then HAL will select the sink automatically, using the raw device strings (hw:0,0 for a system with just one sound card, for example).

Just because your application plays sound while PulseAudio is running does not mean it is really using PulseAudio. In PulseAudio, there is a module called "module-suspend-on-idle" that suspends the PulseAudio server when there is no current activity, allowing other applications to access the sound card directly via ALSA or OSS. However, if an application is using the sound card directly, then PulseAudio will no longer function, causing a mixing error. I strongly recommend you do some experiments with Appendix B of the guide to get a better understanding.

Why do you want to kill the PulseAudio server anyway? Using the proper configuration in my guide, sound works correctly in 99% of cases, and I doubt you need the 1% case that warrants PulseAudio to get killed.

eryksun
June 23rd, 2008, 10:35 PM
If you comment that page, then the sink will be selected by HAL, using the raw device strings (hw:0,0 for a system with just one sound card, for example).

Just because your application plays sound while PulseAudio is running does not mean it is really using PulseAudio.

I meant that the Equalizer works for PulseAudio clients when I include that line. I know these are PulseAudio clients since when I run 'pulseaudio -C' and use the 'info' command they show up as clients there. So, as long as PulseAudio has an ALSA sink selected (as opposed to hw:0,0) its audio is going through the equalizer.


I think however, a better question is why you'd want to kill the PulseAudio server at all? Using the proper configuration in my guide, sound works correctly in 99% of cases, and I doubt you need the 1% case without PulseAudio.

You may recall that my PulseAudio has a strange bug: whenever the PulseAudio master volume and the per application volume sum to less than 100%, my audio completely cuts out. I'm experimenting and reading to learn more about how the system works. In so doing I have to kill PulseAudio a lot, but I like to keep my music going, and nicely equalized...

P.S. I'm going to switch to using two different .asoundrc files, as you suggested, switching the equalizer to 'default' when PulseAudio isn't running.

psyke83
June 23rd, 2008, 10:57 PM
You may recall that my PulseAudio has a strange bug: whenever the PulseAudio master volume and the per application volume sum to less than 100%, my audio completely cuts out. I'm experimenting and reading to learn more about how the system works. In so doing I have to kill PulseAudio a lot, but I like to keep my music going, and nicely equalized...

P.S. I'm going to switch to using two different .asoundrc files, as you suggested, switching the equalizer to 'default' when PulseAudio isn't running.

Ah yes, the volume bug.

There is another way to enable LADSPA support in PulseAudio, but I did not choose to use it for this guide as it has a disadvantage. Basically, there is a "module-ladspa-sink" plugin in PulseAudio, but it doesn't work with "module-suspend-on-idle". Disabling "module-suspend-on-idle" means that PulseAudio (and thus the sound card) is always active, causing battery drain on on laptops.

If you're willing to put up with this, here is how to use it:

A. Ensure you have followed Part A of this guide.

B. Edit ~/.pulse/default.pa, and make the following changes:

1. If you followed Part D already, comment (prefix with #) the line you edited previously:

load-module module-alsa-sink device=equalized

2. Comment (prefix with #) the following line:

load-module module-suspend-on-idle

3. Add the following lines to the end (you can use customized settings if you want, of course):

load-module module-ladspa-sink sink_name=ladspa_out plugin=mbeq_1197 label=mbeq control=-1,-1,-1,-1,-5,-10,-18,-15,-10,-5,-5,-5,-5,0,0
set-default-sink ladspa_out

C. Delete your PulseAudio user settings (otherwise saved applications will use the wrong sink):

$ rm ~/.pulse/volume_restore.table ~/.pulse/default-sink ~/.pulse/default-source

Now log out and back in, and try using PulseAudio. To verify the equalizer is working, PulseAudio Manager should display the default sink as "ladspa_out", and you can right-click on clients listed in PulseAudio Volume Control and "Move Stream" to see the current stream.

Using this configuration, alsamixer's master control will be the real ALSA master control.

daverave999
June 25th, 2008, 01:13 AM
Appears to have sorted me-thanks greatly!

Masoris
June 25th, 2008, 01:29 PM
It's doesn't work for me. My firefox sometimes randomly crash with flash video :(
One way to prevent this is stop flash video before close the tab.

psyke83
June 25th, 2008, 01:59 PM
It's doesn't work for me. My firefox sometimes randomly crash with flash video :(
One way to prevent this is stop flash video before close the tab.

Disable any composite managers (compiz, xcompmgr, etc.) and see if it helps.

I[AM]SMRT
June 25th, 2008, 08:54 PM
$ sudo apt-get install libasound2 libasound2-plugins libasound2-dev padevchooser swh-plugins libao-pulse libsdl1.2debian-pulseaudio ladspa-sdk

When I put that into Terminal, it tells me:


The following packages have unmet dependencies:
libasound2-plugins: Depends: libasound2 (> 1.0.16) but 1.0.15-3ubuntu4 is to be installed
E: Broken packages

I've enabled the "hardy-proposed" repository and everything ;(. What should I be doing?

psyke83
June 25th, 2008, 09:27 PM
SMRT;5260879']I've enabled the "hardy-proposed" repository and everything ;(. What should I be doing?

You need to update the repository lists:

$ sudo apt-get update

Edit: Hmm. It seems that libasound2 and libasound2-plugins have been removed from the hardy-proposed repository. You'll have to get them from Intrepid's repository until this matter is clarified.

http://packages.ubuntu.com/intrepid/libasound2
http://packages.ubuntu.com/intrepid/libasound2-plugins

cherva
June 25th, 2008, 09:40 PM
Anyone have an idea how to make skype ( linux native ) and wine work at the same time and both to play sound ... The guide at the first post doesn't work, after I made all the changes wine didn't play sound at all... even when wine was the only app that used the sound card...

psyke83
June 25th, 2008, 09:41 PM
Anyone have an idea how to make skype ( linux native ) and wine work at the same time and both to play sound ...

Read Appendix A, it explains how to get both applications working.

I[AM]SMRT
June 25th, 2008, 10:22 PM
You need to update the repository lists:

$ sudo apt-get update

Edit: Hmm. It seems that libasound2 and libasound2-plugins have been removed from the hardy-proposed repository. You'll have to get them from Intrepid's repository until this matter is clarified.

http://packages.ubuntu.com/intrepid/libasound2
http://packages.ubuntu.com/intrepid/libasound2-plugins
Thanks that worked and everything's working fantastically :).

EDIT: Apparently it fixed my Banshee/m4a problem somehow too! I'm so happy now.

dogscoff
June 26th, 2008, 12:50 PM
Will following these instructions fix the issue I am having, where my laptop has no sound after resuming from suspend?

cherva
June 26th, 2008, 01:57 PM
Read Appendix A, it explains how to get both applications working.
As I wrote ...
The guide at the first post doesn't work

psyke83
June 26th, 2008, 02:05 PM
Will following these instructions fix the issue I am having, where my laptop has no sound after resuming from suspend?

No.

psyke83
June 26th, 2008, 02:08 PM
As I wrote ...

You're not giving me enough information. Does PulseAudio work for other applications such as Totem? To check if applications work, use Appendix B.

As for WINE, it needs special configuration, explained in Appendix A. As long as other applications are working with PulseAudio, WINE will work after you configure it properly.

eryksun
June 26th, 2008, 09:20 PM
I copied /etc/pulse/default.pa to ~/.pulse/default.pa and added the equalized device there, rather than system wide, to mirror the fact that I create the device per user in .asoundrc. In keeping with UNIX principles, should daemon.conf be modified locally as well? That's where I change the buffering from 100ms in 4 segments to 40ms in 8 segments. I can't really think of a use case where that needs to be changed, so the mod should probably stay in /etc, IMO. But if an upgrade for PulseAudio gets pushed through, will it overwrite my custom settings?

psyke83
June 26th, 2008, 09:33 PM
I copied /etc/pulse/default.pa to ~/.pulse/default.pa and added the equalized device there, rather than system wide, to mirror the fact that I create the device per user in .asoundrc. In keeping with UNIX principles, should daemon.conf be modified locally as well? That's where I change the buffering from 100ms in 4 segments to 40ms in 8 segments. I can't really think of a use case where that needs to be changed, so the mod should probably stay in /etc, IMO. But if an upgrade for PulseAudio gets pushed through, will it overwrite my custom settings?

That's a good idea, I'm going to update the guide with that information in mind (and add some more tweaks I've been experimenting with). As you suspected, if pulseaudio gets upgraded it will indeed try to overwrite any changes to configuration files in /etc/pulse/ - although you're given the choice to keep the current version.

Did you get equalized sound working using the "module-ladspa-sink" method?

psyke83
June 26th, 2008, 10:42 PM
I've posted a new update to the guide (v2.9). There's three main changes -

Configuration files are now modified for local users and not system-wide, as suggested by eryksun.

I've updated Part C to give some extra tweaks to reduce stuttering - it's recommended you try these updates, especially if you have a slow CPU.

Finally, the Flash beta plugin is now only available for i386 users, as the required ALSA updates have been removed from the hardy-proposed repository and it's too messy to upgrade the 64bit version.

If anyone sees a problem with anything in the guide, let me know.

2-bits
June 27th, 2008, 12:49 AM
Psyke, i see that the note about hardy-proposed is gone... does that mean those packages have been moved into the standard repos?

psyke83
June 27th, 2008, 12:54 AM
Psyke, i see that the note about hardy-proposed is gone... does that mean those packages have been moved into the standard repos?

Unfortunately, no. It seems that the updated packages were rejected for 8.04.1 due to possible ABI breakage with certain sound cards (a rare case, but too risky to push into hardy main).

The instructions should grab the Intrepid version of the packages (they are necessary for Flash v10, Skype and some ALSA apps), until this matter is clarified.

ubrox
June 27th, 2008, 06:22 AM
Everything worked just fine ... however, I had to comment

load-module module-alsa-sink device=equalized

or else pulse will start and die with a segfault.

My original prob remians ... low sound volume on laptop speakers and now even the headphones are lower voloume.

any suggestions?

Thanks,
Kalyan

timzak
June 27th, 2008, 01:29 PM
psyke83,

Once I install the updates from Hardy Proposed, can I then untick the Hardy Proposed checkbox in Software Sources->Updates tab? I don't want to continue updating all my other software from Proposed, but am concerned if I untick this box, it will remove the Pulseaudio updates I installed. I now see some xorg updates from Proposed and don't want to install them, but don't want to be continually reminded of them from Update Manager.

EDIT: Also, I just noticed the comment about removing the hardy-proposed and repointing to Intrepid. I am afraid I might have installed some other updates (besides the ones you require for your howto) from Proposed without realizing it. Is there a way to find out if I did? Also, because I am using the Pulseaudio updates from Hardy Proposed, will something break down the line when it is eventually released to the main repositories? I am a little concerned about having installed some packages from Proposed now that you mentioned the part about them removing a package because of potential problems.

Thanks.

psyke83
June 27th, 2008, 01:56 PM
psyke83,

Once I install the updates from Hardy Proposed, can I then untick the Hardy Proposed checkbox in Software Sources->Updates tab? I don't want to continue updating all my other software from Proposed, but am concerned if I untick this box, it will remove the Pulseaudio updates I installed. I now see some xorg updates from Proposed and don't want to install them, but don't want to be continually reminded of them from Update Manager.

Thanks.

You don't need to enable the hardy-proposed repository anymore, so you can disable it - check the guide again.

psyke83
June 27th, 2008, 02:01 PM
psyke83,

EDIT: Also, I just noticed the comment about removing the hardy-proposed and repointing to Intrepid. I am afraid I might have installed some other updates (besides the ones you require for your howto) from Proposed without realizing it. Is there a way to find out if I did? Also, because I am using the Pulseaudio updates from Hardy Proposed, will something break down the line when it is eventually released to the main repositories? I am a little concerned about having installed some packages from Proposed now that you mentioned the part about them removing a package because of potential problems.

Thanks.

Do this:
1. Disable the hardy-proposed repository and update the repository lists
2. In Synaptic, click the "Status" button and click "Installed (local or obsolete)". That will show any packages that are not available in the repositories (3rd party packages and also from the proposed repository).

You can use Synaptic to downgrade these packages if you wish - but I don't recommend that yet. Most of these updates will become official when 8.04.1 is released, so I recommend you keep the newer versions for the time being.

psyke83
June 27th, 2008, 02:09 PM
Everything worked just fine ... however, I had to comment

load-module module-alsa-sink device=equalized

or else pulse will start and die with a segfault.

My original prob remians ... low sound volume on laptop speakers and now even the headphones are lower voloume.

any suggestions?

Thanks,
Kalyan

Open the terminal and use "alsamixer", and experiment with all the controls. If your low volume problem is because of ALSA, then PulseAudio can't help (remember, it works on top of ALSA, not as a replacement).

Having said that, it is possible to "overdrive" the volume in PulseAudio, I only recommend this in case you're desperate, but you *will* experience distortion - so consider yourself warned ;).

Open PulseAudio Manager, click the Devices tab, double-click on the ALSA sink listed, and move the volume slider to a value >0.0db (or >100%).

You are guaranteed to hear sound clipping using this method so it's not really worthwhile - try to solve the volume problem in ALSA instead.

I[AM]SMRT
June 27th, 2008, 04:38 PM
I followed this guide and it was working perfectly the other day but now, when I click on my PulseAudio Applet, it can't find an audio device. My sound in Flash/VLC/Amarok still work but I can't get anything to play in Rhythmbox/Banshee. Any ideas?

http://ubuntuforums.org/showthread.php?t=841868

psyke83
June 27th, 2008, 05:02 PM
SMRT;5273525']I followed this guide and it was working perfectly the other day but now, when I click on my PulseAudio Applet, it can't find an audio device. My sound in Flash/VLC/Amarok still work but I can't get anything to play in Rhythmbox/Banshee. Any ideas?

http://ubuntuforums.org/showthread.php?t=841868

1. Go To Preferences/Sound and set everything to "Autodetect"
2. Paste PulseAudio's log here:

$ pkill pulseaudio
$ pulseaudio -vv

I[AM]SMRT
June 27th, 2008, 05:10 PM
I: main.c: We're in the group 'pulse-rt', allowing real-time and high-priority scheduling.
I: core-util.c: Successfully gained nice level -11.
I: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
I: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
I: main.c: This is PulseAudio 0.9.10
I: main.c: Page size is 4096 bytes
I: main.c: Fresh high-resolution timers available! Bon appetit!
ALSA lib pcm_ladspa.c:1502:(snd_pcm_ladspa_add_plugin) Unable to find or load plugin 'mbeq' ID 1197, path '/usr/lib/ladspa'
E: alsa-util.c: Error opening PCM device equalized: No such file or directory
E: module.c: Failed to load module "module-alsa-sink" (argument: "device=equalized"): initialization failed.
E: main.c: Module load failed.
E: main.c: Failed to initialize daemon.
I: main.c: Daemon terminated.


That's what it gave me.

psyke83
June 27th, 2008, 05:14 PM
SMRT;5273721']That's what it gave me.

You must not have followed the guide properly - you're missing the proper .asoundrc configuration that defines the "equalized" virtual device. You can either follow the guide completely again, or undo the change you made in Part D (i.e. disable the equalizer).

I[AM]SMRT
June 27th, 2008, 05:15 PM
You must not have followed the guide properly - you're missing the proper .asoundrc configuration that defines the "equalized" virtual device. You can either follow the guide completely again, or undo the change you made in Part D (i.e. disable the equalizer).
Ok thanks, I'll give it another go.

EDIT: When I try to install the libasound2 stuff, it gives me this:


The following packages have unmet dependencies:
libasound2-dev: Depends: libasound2 (= 1.0.15-3ubuntu4) but 1.0.16-2ubuntu1 is to be installed


How can I revert to the previous version of libasound2? Or is that unnecessary?

EDIT #2: Note to self: Do not uninstall libasound2 again. Oh god.

EDIT #3: Haha, reinstalled Ubuntu, that was actually kinda funny.

abuakel
June 28th, 2008, 06:53 PM
Thanks.. this has been driving me crazy! :)

Doughsay
June 28th, 2008, 09:37 PM
Hi, thanks for the guide, but it didn't really work for me. I'm hoping someone can help me further?

2.6.24-18-rt
2.6.24-18-generic
x86_64

Skipping audio under both kernels before AND after following the guide. Seems no different actually. Strangely, killing the pulseaudio daemon has no effect as well. Still skips.

Now this isn't THAT bad, the skipping is not constant, and I can mostly listen to music fine, but it's prevalent enough to be annoying and I really want to fix it

I notice that daemon.conf sets pulse's priority to 5 and nice to -11. Checking top shows the nice at -11 but priority at 9 not 5. Not a big difference. But if i change the priority to say 50 or something, it doesn't have an effect, top still shows 9.

What could the issue be? I guess it seems like it's not necessarily related to pulse, since it happens even after I kill the daemon.

psyke83
June 28th, 2008, 09:51 PM
Hi, thanks for the guide, but it didn't really work for me. I'm hoping someone can help me further?

2.6.24-18-rt
2.6.24-18-generic
x86_64

Skipping audio under both kernels before AND after following the guide. Seems no different actually. Strangely, killing the pulseaudio daemon has no effect as well. Still skips.

Now this isn't THAT bad, the skipping is not constant, and I can mostly listen to music fine, but it's prevalent enough to be annoying and I really want to fix it

I notice that daemon.conf sets pulse's priority to 5 and nice to -11. Checking top shows the nice at -11 but priority at 9 not 5. Not a big difference. But if i change the priority to say 50 or something, it doesn't have an effect, top still shows 9.

What could the issue be? I guess it seems like it's not necessarily related to pulse, since it happens even after I kill the daemon.

If audio skips without PulseAudio, then you're suffering a kernel/ALSA problem. This guide can't help, unfortunately.

tsger
June 29th, 2008, 11:08 PM
Thank you for this post. VERY helpful! Especially the equalizer fixes...now the speakers in my Dell laptop sound fantastic!

Tavathlon
June 30th, 2008, 04:13 PM
I followed the guide, and sound in flash works perfectly now. =)

However, I first had problems with sound in Skype. After reading a little bit in this thread, I tried to set 'pulse' as my sound device for in, out and ringing in different combinations in Skype, but there was a very poor sound-quality all the time - stuttering. Instead of fiddling around with part C of the guide (don't really have time right now - I just need to have skype working for thesis work), I just put them all directly to the device. So far, it seems to work very fine, and gives me very good sound quality. However, if I play any other music, skype won't work. And if it is sound from the browser, it won't work even if I close the website. Doesn't matter to me right now, though - I guess it will be fixed if I follow part C, I just don't bother right now. Thesis first... =P
Just wanted to tell how it worked. =)

Thanks for a very useful guide! =)

psyke83
June 30th, 2008, 04:22 PM
I followed the guide, and sound in flash works perfectly now. =)

However, I first had problems with sound in Skype. After reading a little bit in this thread, I tried to set 'pulse' as my sound device for in, out and ringing in different combinations in Skype, but there was a very poor sound-quality all the time - stuttering. Instead of fiddling around with part C of the guide (don't really have time right now - I just need to have skype working for thesis work), I just put them all directly to the device. So far, it seems to work very fine, and gives me very good sound quality.

Thanks for a very useful guide! =)

Due to some bugs in Skype and/or Pulse's pcm_pulse ALSA plugins, following Part C should be considered a mandatory step to avoid stuttering in Skype - specifically the fragment size/amount.

Although your solution probably works on a superficial level, it will completely break sound mixing on your system. With your configuration, Skype will only work if PulseAudio has no active clients at the exact moment that Skype opens the sound device. Try making a test call and simultaneously playing sound in another application - it won't work. Using the steps of Appendix B can help you understand what I mean.

Tavathlon
June 30th, 2008, 04:28 PM
Due to some bugs in Skype and/or Pulse's pcm_pulse ALSA plugins, following Part C should be considered a mandatory step to avoid stuttering in Skype - specifically the fragment size/amount.

Although your solution probably works on a superficial level, it will completely break sound mixing on your system. With your configuration, Skype will only work if PulseAudio has no active clients at the exact moment that Skype opens the sound device. Try making a test call and simultaneously playing sound in another application - it won't work. Using the steps of Appendix B can help you understand what I mean.


Yes, I figured that out and edited my post already while you were answering. I will do part C and the rest when I feel for doing it - for now this will have to work. Thanks! =)

Tavathlon
July 1st, 2008, 11:27 AM
Hm, now I have a serious problem though. I tried to do one of my interviews via skype this morning, but I forgot to first test whether the recording program would work after the changes (SCX recorder). It did, in a way. It recorded everything, but didn't let me hear what my interviewee said until after one minute after he/she said it. Quite difficult to perform interviews that way...

So I did what part C says, and I also checked through appendix B, but no luck. So I thought I'd go back to my old sound settings, and followed the removal guide in the first post in this thread. First step went fine, but the others did not. It said that it could not remove some of those files such as asound.conf, since they did not exist, and the backup-files did not exist either (there is a backup folder, although it had a different name and most importantly did not have any asound.conf in it, only libao.conf...).

So now, I have sound in for example youtube, and I have sound in skype. I do not have sound in any mediaplayer such as totem or rythmbox, and the recording of skype calls still doesn't work.

Help? =S

psyke83
July 1st, 2008, 03:35 PM
Help? =S

Yes, there was a mistake in the guide and the backup folder had the wrong name in Part A - however, that isn't a vital step and those "file not found" errors are to be expected.

Run the following commands and paste the output here:

$ pulseaudio -k
$ pulseaudio -vv

Tavathlon
July 1st, 2008, 04:10 PM
Alright, sounds reassuring. =)

I have a feeling that it might be difficult to get the skype recording to work, since it probably depends pretty much on the SCX recorder as well, a program that doesn't seem to be quite stable itself. So I guess I should go back to my original settings until thesis is over, and then install pulseaudio again after that ('cause everything else worked really nice with pulseaudio, so I was very content with it apart from the recording issue). The problem is just that I don't know how to get my old settings back...

pulseaudio -k gives nothing, but pulseaudio -vv gives the following:


I: main.c: We're in the group 'pulse-rt', allowing real-time and high-priority scheduling.
I: core-util.c: Successfully gained nice level -11.
I: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
I: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
I: main.c: This is PulseAudio 0.9.10
I: main.c: Page size is 4096 bytes
I: main.c: Fresh high-resolution timers available! Bon appetit!
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-hal-detect.so': success
I: module-hal-detect.c: Trying capability alsa
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/computer_alsa_timer
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/computer_alsa_sequencer
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_8086_284b_sound_card_0_alsa_playback_6
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_8086_284b_sound_card_0_alsa_capture_6
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_8086_284b_sound_card_0_alsa_playback_1
D: module-hal-detect.c: Loading module-alsa-sink with arguments 'device_id=0 sink_name=alsa_output.pci_8086_284b_sound_card_0_a lsa_playback_0'
D: alsa-util.c: Trying front:0...
I: module-alsa-sink.c: Successfully opened device front:0.
I: module-alsa-sink.c: Successfully enabled mmap() mode.
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
I: alsa-util.c: Unable to attach to mixer front:0: No such file or directory
I: alsa-util.c: Successfully attached to mixer 'hw:0'
I: alsa-util.c: Using mixer control "Master".
I: sink.c: Created sink 0 "alsa_output.pci_8086_284b_sound_card_0_alsa_playba ck_0" with sample spec "s16le 2ch 44100Hz"
I: source.c: Created source 0 "alsa_output.pci_8086_284b_sound_card_0_alsa_playba ck_0.monitor" with sample spec "s16le 2ch 44100Hz"
I: module-alsa-sink.c: Using 4 fragments of size 4352 bytes.
I: alsa-util.c: ALSA device lacks independant volume controls for each channel, falling back to software volume control.
D: module-alsa-sink.c: Thread starting up
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+29
I: module-alsa-sink.c: Starting playback.
I: module.c: Loaded "module-alsa-sink" (index: #0; argument: "device_id=0 sink_name=alsa_output.pci_8086_284b_sound_card_0_a lsa_playback_0").
D: module-hal-detect.c: Loading module-alsa-source with arguments 'device_id=0 source_name=alsa_input.pci_8086_284b_sound_card_0_ alsa_capture_0'
D: alsa-util.c: Trying front:0...
I: module-alsa-source.c: Successfully opened device front:0.
I: module-alsa-source.c: Successfully enabled mmap() mode.
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
I: alsa-util.c: Unable to attach to mixer front:0: No such file or directory
I: alsa-util.c: Successfully attached to mixer 'hw:0'
I: alsa-util.c: Using mixer control "Capture".
I: source.c: Created source 1 "alsa_input.pci_8086_284b_sound_card_0_alsa_capture _0" with sample spec "s16le 2ch 44100Hz"
I: module-alsa-source.c: Using 4 fragments of size 4352 bytes.
I: alsa-util.c: All 2 channels can be mapped to mixer channels. Using hardware volume control.
D: module-alsa-source.c: Thread starting up
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+28
I: module.c: Loaded "module-alsa-source" (index: #1; argument: "device_id=0 source_name=alsa_input.pci_8086_284b_sound_card_0_ alsa_capture_0").
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_8086_284b_sound_card_0_alsa_hw_specific_1
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_8086_284b_sound_card_0_alsa_hw_specific_0
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_8086_284b_sound_card_0_alsa_control__1
I: module-hal-detect.c: Loaded 2 modules.
I: module.c: Loaded "module-hal-detect" (index: #2; argument: "").
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-esound-protocol-unix.so': success
I: module.c: Loaded "module-esound-protocol-unix" (index: #3; argument: "").
I: protocol-native.c: loading cookie from disk.
I: module.c: Loaded "module-native-protocol-unix" (index: #4; argument: "").
I: module.c: Loaded "module-volume-restore" (index: #5; argument: "").
D: module-default-device-restore.c: Restored default sink 'alsa_output.pci_8086_284b_sound_card_0_alsa_playb ack_0'.
D: core-subscribe.c: dropped redundant event.
D: module-default-device-restore.c: Restored default source 'alsa_input.pci_8086_284b_sound_card_0_alsa_captur e_0'.
I: module.c: Loaded "module-default-device-restore" (index: #6; argument: "").
I: module.c: Loaded "module-rescue-streams" (index: #7; argument: "").
D: module-suspend-on-idle.c: Sink alsa_output.pci_8086_284b_sound_card_0_alsa_playba ck_0 becomes idle.
D: module-suspend-on-idle.c: Source alsa_output.pci_8086_284b_sound_card_0_alsa_playba ck_0.monitor becomes idle.
D: module-suspend-on-idle.c: Source alsa_input.pci_8086_284b_sound_card_0_alsa_capture _0 becomes idle.
I: module.c: Loaded "module-suspend-on-idle" (index: #8; argument: "").
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-gconf.so': success
I: module.c: Loaded "module-gconf" (index: #9; argument: "").
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-x11-publish.so': success
D: module-x11-publish.c: using already loaded auth cookie.
I: module.c: Loaded "module-x11-publish" (index: #10; argument: "").
I: main.c: Daemon startup complete.
D: module-hal-detect.c: dbus: interface=org.freedesktop.DBus, path=/org/freedesktop/DBus, member=NameAcquired
I: module-suspend-on-idle.c: Source alsa_input.pci_8086_284b_sound_card_0_alsa_capture _0 idle for too long, suspending ...
I: module-alsa-source.c: Device suspended...
I: module-suspend-on-idle.c: Source alsa_output.pci_8086_284b_sound_card_0_alsa_playba ck_0.monitor idle for too long, suspending ...
I: module-suspend-on-idle.c: Sink alsa_output.pci_8086_284b_sound_card_0_alsa_playba ck_0 idle for too long, suspending ...
I: module-alsa-sink.c: Device suspended...
D: module-hal-detect.c: dbus: interface=org.freedesktop.Hal.Device, path=/org/freedesktop/Hal/devices/computer_power_supply_battery_BAT0, member=PropertyModified
D: module-hal-detect.c: dbus: interface=org.freedesktop.Hal.Device, path=/org/freedesktop/Hal/devices/computer_power_supply_battery_BAT0, member=PropertyModified
D: module-hal-detect.c: dbus: interface=org.freedesktop.Hal.Device, path=/org/freedesktop/Hal/devices/computer_power_supply_battery_BAT0, member=PropertyModified
D: module-hal-detect.c: dbus: interface=org.freedesktop.Hal.Device, path=/org/freedesktop/Hal/devices/computer_power_supply_battery_BAT0, member=PropertyModified
D: module-hal-detect.c: dbus: interface=org.freedesktop.Hal.Device, path=/org/freedesktop/Hal/devices/computer_power_supply_battery_BAT0, member=PropertyModified
D: module-hal-detect.c: dbus: interface=org.freedesktop.Hal.Device, path=/org/freedesktop/Hal/devices/computer_power_supply_battery_BAT0, member=PropertyModified
D: module-hal-detect.c: dbus: interface=org.freedesktop.Hal.Device, path=/org/freedesktop/Hal/devices/computer_power_supply_battery_BAT0, member=PropertyModified
D: module-hal-detect.c: dbus: interface=org.freedesktop.Hal.Device, path=/org/freedesktop/Hal/devices/computer_power_supply_battery_BAT0, member=PropertyModified
D: module-hal-detect.c: dbus: interface=org.freedesktop.Hal.Device, path=/org/freedesktop/Hal/devices/computer_power_supply_battery_BAT0, member=PropertyModified
D: module-hal-detect.c: dbus: interface=org.freedesktop.Hal.Device, path=/org/freedesktop/Hal/devices/computer_power_supply_battery_BAT0, member=PropertyModified
D: module-hal-detect.c: dbus: interface=org.freedesktop.Hal.Device, path=/org/freedesktop/Hal/devices/computer_power_supply_battery_BAT0, member=PropertyModified
D: module-hal-detect.c: dbus: interface=org.freedesktop.Hal.Device, path=/org/freedesktop/Hal/devices/computer_power_supply_battery_BAT0, member=PropertyModified
D: module-hal-detect.c: dbus: interface=org.freedesktop.Hal.Device, path=/org/freedesktop/Hal/devices/computer_power_supply_battery_BAT0, member=PropertyModified
D: module-hal-detect.c: dbus: interface=org.freedesktop.Hal.Device, path=/org/freedesktop/Hal/devices/computer_power_supply_battery_BAT0, member=PropertyModified
D: module-hal-detect.c: dbus: interface=org.freedesktop.Hal.Device, path=/org/freedesktop/Hal/devices/computer_power_supply_battery_BAT0, member=PropertyModified
D: module-hal-detect.c: dbus: interface=org.freedesktop.Hal.Device, path=/org/freedesktop/Hal/devices/computer_power_supply_battery_BAT0, member=PropertyModified
D: module-hal-detect.c: dbus: interface=org.freedesktop.Hal.Device, path=/org/freedesktop/Hal/devices/computer_power_supply_battery_BAT0, member=PropertyModified

psyke83
July 1st, 2008, 04:17 PM
pulseaudio -k gives nothing, but pulseaudio -vv gives the following:

Ok, I don't see any problems with PulseAudio. Try using the troubleshooting steps of Appendix B for the applications that won't play sound, and let me know the result.

Also, go to System/Preferences/Sound and make sure everything is set to Autodetect.

Tavathlon
July 1st, 2008, 07:53 PM
Well, as I said; no real luck. SCX Recorder do get an entry in the playback tab, and there is sound going through - but the sound is delayed too much for me to have a conversation during the interviews. In the playback tab, everything looks normal. And yes, everything is on autodetect. =S

psyke83
July 1st, 2008, 08:14 PM
Well, as I said; no real luck. SCX Recorder do get an entry in the playback tab, and there is sound going through - but the sound is delayed too much for me to have a conversation during the interviews. In the playback tab, everything looks normal. And yes, everything is on autodetect. =S

Make sure you followed the Appendix C uninstall instructions (although I think you have).

I've never used SCX Recorder, but if it interfaces using the Skype API, then you need to make sure that Skype is *not* using the pulse devices in the Sound Options (yep, that's right - you need to bypass PulseAudio).

Of course, this will break sound mixing for applications, but if you're forced to use this application then I see no other alternative for the moment.

rohandhruva
July 1st, 2008, 09:40 PM
Thanks for the tutorial. I am having problems with mplayer. On a stock install, mplayer just wouldn't work, due to some pulseaudio connection refused problem. I solved it by using -ao alsa. Now after using your tutorial, none of the methods seems to work :( I get proper sound in firefox/flash, but now mplayer is borked :( I can't use amarok either, it says - "xine: unable to initialize any audio drivers".

Here is the (relevant) mplayer output:

rohan@ubuntu:/media/sda6/Fav_songs/Hindi$ mplayer Saher/Palkein\ Jhukaao\ Na.mp3 -ao pulse
AO: [pulse] Failed to connect to server: Connection refused
Could not open/initialize audio device -> no sound.
Audio: no sound
Video: no video

rohan@ubuntu:/media/sda6/Fav_songs/Hindi$ mplayer Saher/Palkein\ Jhukaao\ Na.mp3 -ao alsa
*** PULSEAUDIO: Unable to connect: Connection refused
[AO_ALSA] Playback open error: Connection refused
Could not open/initialize audio device -> no sound.
Audio: no sound
Video: no video

rohan@ubuntu:/media/sda6/Fav_songs/Hindi$ mplayer Saher/Palkein\ Jhukaao\ Na.mp3 -ao oss
[AO OSS] audio_setup: Can't open audio device /dev/dsp: Device or resource busy
Could not open/initialize audio device -> no sound.
Audio: no sound
Video: no video

I am using Kubuntu, and not Ubuntu, does that make any difference? I know I can roll back all the changes, but somehow what you've done seems correct, so I don't want to roll back. Is this a problem specific to my system?

psyke83
July 1st, 2008, 10:21 PM
Thanks for the tutorial. I am having problems with mplayer. On a stock install, mplayer just wouldn't work, due to some pulseaudio connection refused problem. I solved it by using -ao alsa. Now after using your tutorial, none of the methods seems to work :( I get proper sound in firefox/flash, but now mplayer is borked :( I can't use amarok either, it says - "xine: unable to initialize any audio drivers".

Yep, don't worry about that. In Part A when you set up the ".asoundrc", that set the default ALSA device to PulseAudio. It appears that PulseAudio isn't running on your system, and since ALSA applications are trying to access a PulseAudio server that's not running, no audio will play.


Here is the (relevant) mplayer output:

rohan@ubuntu:/media/sda6/Fav_songs/Hindi$ mplayer Saher/Palkein\ Jhukaao\ Na.mp3 -ao pulse
AO: [pulse] Failed to connect to server: Connection refused
Could not open/initialize audio device -> no sound.
Audio: no sound
Video: no video

This indicates that PulseAudio isn't running (from the "Connection refused" message).


rohan@ubuntu:/media/sda6/Fav_songs/Hindi$ mplayer Saher/Palkein\ Jhukaao\ Na.mp3 -ao alsa
*** PULSEAUDIO: Unable to connect: Connection refused
[AO_ALSA] Playback open error: Connection refused
Could not open/initialize audio device -> no sound.
Audio: no sound
Video: no video

Even though you're asking mplayer to use ALSA, it's still trying to access the PulseAudio server. This is caused by the configuration in your ".asoundrc".


rohan@ubuntu:/media/sda6/Fav_songs/Hindi$ mplayer Saher/Palkein\ Jhukaao\ Na.mp3 -ao oss
[AO OSS] audio_setup: Can't open audio device /dev/dsp: Device or resource busy
Could not open/initialize audio device -> no sound.
Audio: no sound
Video: no video

Hmm, this is suspicious. OSS output should have worked.


I am using Kubuntu, and not Ubuntu, does that make any difference? I know I can roll back all the changes, but somehow what you've done seems correct, so I don't want to roll back. Is this a problem specific to my system?

Nope, it shouldn't make a difference :).

Here's what I need you to run in a terminal:


$ pulseaudio -k
$ pulseaudio -vv

Please post the output of the second command here, so we can see what's the problem.

rohandhruva
July 1st, 2008, 10:28 PM
Here's what I need you to run in a terminal:


$ pulseaudio -k
$ pulseaudio -vv

Please post the output of the second command here, so we can see what's the problem.

Wow, something is REALLY wrong. Here is the output:

rohan@ubuntu:/media/sda6/Fav_songs/Hindi$ pulseaudio -k
The program 'pulseaudio' is currently not installed. You can install it by typing:

How come this program is not installed? :O I don't remember removing that package, and I have the metapackage "kubuntu-desktop" installed too. Maybe Kubuntu doesn't use pulseaudio?

EDIT: I asked around a bit on IRC too, it seems that the package "pulseaudio" is not installed by default on Kubuntu. Am I missing something here?

psyke83
July 1st, 2008, 10:41 PM
EDIT: I asked around a bit on IRC too, it seems that the package "pulseaudio" is not installed by default on Kubuntu. Am I missing something here?

Wow, I wasn't aware of that... and you're running the Hardy release (8.04)? If so, you can simply follow the Appendix C (however, be cautious and *don't* let apt-get uninstall packages if it asks for your permission).

rohandhruva
July 1st, 2008, 11:20 PM
Wow, I wasn't aware of that... and you're running the Hardy release (8.04)? If so, you can simply follow the Appendix C (however, be cautious and *don't* let apt-get uninstall packages if it asks for your permission).

Same here. It's surprising that Ubuntu uses PulseAudio and Kubuntu ALSA. Yes, I'm running the 8.04 release. I have reverted, and now everything is back to normal. That explains why mplayer gives connection refused error on a "stock" install - there is no pulseaudio installed! And that also explains why firefox crashes after installing libflashsupport - there is no pulseaudio to support flash ;)

I think you should add a note in the original tutorial that it is not meant for Kubuntu users.

Tavathlon
July 2nd, 2008, 10:17 AM
Make sure you followed the Appendix C uninstall instructions (although I think you have).

I've never used SCX Recorder, but if it interfaces using the Skype API, then you need to make sure that Skype is *not* using the pulse devices in the Sound Options (yep, that's right - you need to bypass PulseAudio).

Of course, this will break sound mixing for applications, but if you're forced to use this application then I see no other alternative for the moment.

Yes, I did follow the Appendix C, but since that didn't work, I reinstalled pulseaudio by following the whole procedure again. Now, I just tried to do what you suggested here, i.e. to let skype bypass pulseaudio while letting SCX recorder use it. Skype did of course not get any entry in the playback tab, while SCX did - the delay of sound was still there, though. =/

Btw, I guess you changed the backup folders in the guide? 'Cause now I have two backup folders, one pulseaudio-backup and one pulse-backup. The new one is completely empty, though. And since the backup folders does not (by some unknown reason) contain what they should contain, how can I get my old settings back? Is it enough by just reinstalling alsa?

Edit: I just realized that SCX recorder requires ALSA with asoundlib.h header file installed - a file that I cannot find on my system.

psyke83
July 3rd, 2008, 01:19 AM
Yes, I did follow the Appendix C, but since that didn't work, I reinstalled pulseaudio by following the whole procedure again. Now, I just tried to do what you suggested here, i.e. to let skype bypass pulseaudio while letting SCX recorder use it. Skype did of course not get any entry in the playback tab, while SCX did - the delay of sound was still there, though. =/

Btw, I guess you changed the backup folders in the guide? 'Cause now I have two backup folders, one pulseaudio-backup and one pulse-backup. The new one is completely empty, though. And since the backup folders does not (by some unknown reason) contain what they should contain, how can I get my old settings back? Is it enough by just reinstalling alsa?

Edit: I just realized that SCX recorder requires ALSA with asoundlib.h header file installed - a file that I cannot find on my system.

If you need to use SCX recorder, you must follow the *uninstall* instructions (Appendix C), and ensure Skype doesn't use PulseAudio. Finally, "asoundlib.h" is part of the "libasound2-dev" package.

Tavathlon
July 3rd, 2008, 11:44 AM
I did follow appendix C, but it did not work, since there were no files in the backup folders. I managed to uninstall anyway, by doing the first step in appendix C, and then manually editing libao.conf from 'default_driver=pulse' to 'default_driver=alsa', while also changing back devices in skype from pulse or directly to the device, to default.

As it is now, everything works more or less as it did before. =)
Once I'm done with my thesis, I will go through this guide again, since it would be really nice to be able to view flash movies etc.

psyke83
July 3rd, 2008, 04:42 PM
Hi,

Anyone who previously installed Flash v10 using this guide may want to follow Part B again - there was a new release of the Flash plugin.

adlin5000
July 3rd, 2008, 09:29 PM
Well I have been trying to get Zsnes to run on hardy. I followed all the steps in you guide(except the equalizer) and still nothing. I followed your trouble shooting guide and I came up with result "D". Zsnes shows up in the playback tab, but no sound. Here is the output of pulse audio:


I: main.c: We're in the group 'pulse-rt', allowing real-time and high-priority scheduling.
I: core-util.c: Successfully gained nice level -11.
I: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
W: main.c: RLIMIT_RTPRIO failed: Operation not permitted
I: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
I: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
I: main.c: This is PulseAudio 0.9.10
I: main.c: Page size is 4096 bytes
I: main.c: Fresh high-resolution timers available! Bon appetit!
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-hal-detect.so': success
I: module-hal-detect.c: Trying capability alsa
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/computer_alsa_timer
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/computer_alsa_sequencer
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_10de_371_sound_card_0_alsa_capture_2
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_10de_371_sound_card_0_alsa_playback_1
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_10de_371_sound_card_0_alsa_capture_1
D: module-hal-detect.c: Loading module-alsa-sink with arguments 'device_id=0 sink_name=alsa_output.pci_10de_371_sound_card_0_al sa_playback_0'
D: alsa-util.c: Trying front:0...
I: module-alsa-sink.c: Successfully opened device front:0.
I: module-alsa-sink.c: Successfully enabled mmap() mode.
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
I: alsa-util.c: Unable to attach to mixer front:0: No such file or directory
I: alsa-util.c: Successfully attached to mixer 'hw:0'
I: alsa-util.c: Using mixer control "Master".
I: sink.c: Created sink 0 "alsa_output.pci_10de_371_sound_card_0_alsa_playbac k_0" with sample spec "s16le 2ch 44100Hz"
I: source.c: Created source 0 "alsa_output.pci_10de_371_sound_card_0_alsa_playbac k_0.monitor" with sample spec "s16le 2ch 44100Hz"
I: module-alsa-sink.c: Using 8 fragments of size 896 bytes.
I: alsa-util.c: ALSA device lacks independant volume controls for each channel, falling back to software volume control.
D: module-alsa-sink.c: Thread starting up
I: core-util.c: Successfully enabled SCHED_FIFO scheduling for thread, with priority 5.
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+29
I: module-alsa-sink.c: Starting playback.
I: module.c: Loaded "module-alsa-sink" (index: #0; argument: "device_id=0 sink_name=alsa_output.pci_10de_371_sound_card_0_al sa_playback_0").
D: module-hal-detect.c: Loading module-alsa-source with arguments 'device_id=0 source_name=alsa_input.pci_10de_371_sound_card_0_a lsa_capture_0'
D: alsa-util.c: Trying front:0...
I: module-alsa-source.c: Successfully opened device front:0.
I: module-alsa-source.c: Successfully enabled mmap() mode.
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
I: alsa-util.c: Unable to attach to mixer front:0: No such file or directory
I: alsa-util.c: Successfully attached to mixer 'hw:0'
I: alsa-util.c: Using mixer control "Capture".
I: source.c: Created source 1 "alsa_input.pci_10de_371_sound_card_0_alsa_capture_ 0" with sample spec "s16le 2ch 44100Hz"
I: module-alsa-source.c: Using 8 fragments of size 896 bytes.
I: alsa-util.c: All 2 channels can be mapped to mixer channels. Using hardware volume control.
D: module-alsa-source.c: Thread starting up
I: core-util.c: Successfully enabled SCHED_FIFO scheduling for thread, with priority 5.
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+28
I: module.c: Loaded "module-alsa-source" (index: #1; argument: "device_id=0 source_name=alsa_input.pci_10de_371_sound_card_0_a lsa_capture_0").
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_10de_371_sound_card_0_alsa_hw_specific_0
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_10de_371_sound_card_0_alsa_control__1
I: module-hal-detect.c: Loaded 2 modules.
I: module.c: Loaded "module-hal-detect" (index: #2; argument: "").
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-esound-protocol-unix.so': success
I: module.c: Loaded "module-esound-protocol-unix" (index: #3; argument: "").
I: protocol-native.c: loading cookie from disk.
I: module.c: Loaded "module-native-protocol-unix" (index: #4; argument: "").
I: module.c: Loaded "module-volume-restore" (index: #5; argument: "").
D: module-default-device-restore.c: Restored default sink 'alsa_output.pci_10de_371_sound_card_0_alsa_playba ck_0'.
D: core-subscribe.c: dropped redundant event.
D: module-default-device-restore.c: Restored default source 'alsa_input.pci_10de_371_sound_card_0_alsa_capture _0'.
I: module.c: Loaded "module-default-device-restore" (index: #6; argument: "").
I: module.c: Loaded "module-rescue-streams" (index: #7; argument: "").
D: module-suspend-on-idle.c: Sink alsa_output.pci_10de_371_sound_card_0_alsa_playbac k_0 becomes idle.
D: module-suspend-on-idle.c: Source alsa_output.pci_10de_371_sound_card_0_alsa_playbac k_0.monitor becomes idle.
D: module-suspend-on-idle.c: Source alsa_input.pci_10de_371_sound_card_0_alsa_capture_ 0 becomes idle.
I: module.c: Loaded "module-suspend-on-idle" (index: #8; argument: "").
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-gconf.so': success
D: module-gconf.c: Loading module 'module-combine' with args '' due to GConf configuration.
I: sink.c: Created sink 1 "combined" with sample spec "s16le 2ch 44100Hz"
I: source.c: Created source 2 "combined.monitor" with sample spec "s16le 2ch 44100Hz"
D: memblockq.c: memblockq requested: maxlength=174080, tlength=174080, base=4, prebuf=1, minreq=0
D: memblockq.c: memblockq sanitized: maxlength=174080, tlength=174080, base=4, prebuf=4, minreq=4
D: module-suspend-on-idle.c: Sink alsa_output.pci_10de_371_sound_card_0_alsa_playbac k_0 becomes busy.
I: resampler.c: Using resampler 'trivial'
I: resampler.c: Using s16le as working format.
I: sink-input.c: Created input 0 "Simultaneous output on ALSA PCM on front:0 (ALC882 Analog) via DMA" on alsa_output.pci_10de_371_sound_card_0_alsa_playbac k_0 with sample spec s16le 2ch 44100Hz and channel map front-left,front-right
I: module-combine.c: Master sink is now 'alsa_output.pci_10de_371_sound_card_0_alsa_playba ck_0'
D: module-combine.c: Thread starting up
I: core-util.c: Successfully enabled SCHED_FIFO scheduling for thread, with priority 6.
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+27
D: module-suspend-on-idle.c: Source combined.monitor becomes idle.
D: module-suspend-on-idle.c: Sink combined becomes idle.
I: module.c: Loaded "module-combine" (index: #9; argument: "").
D: module-gconf.c: Loading module 'module-native-protocol-tcp' with args 'auth-anonymous=1' due to GConf configuration.
I: protocol-native.c: using already loaded auth cookie.
I: protocol-native.c: using already loaded auth cookie.
I: module.c: Loaded "module-native-protocol-tcp" (index: #10; argument: "auth-anonymous=1").
D: module-gconf.c: Loading module 'module-esound-protocol-tcp' with args 'auth-anonymous=1' due to GConf configuration.
I: module.c: Loaded "module-esound-protocol-tcp" (index: #11; argument: "auth-anonymous=1").
D: module-gconf.c: Loading module 'module-zeroconf-publish' with args '' due to GConf configuration.
D: module-zeroconf-publish.c: Publishing services in Zeroconf
D: module-zeroconf-publish.c: Successfully created entry group for adlin5000@Mine: ALSA PCM on front:0 (ALC882 Analog) via DMA.
D: module-zeroconf-publish.c: Successfully created entry group for adlin5000@Mine: Simultaneous output to ALSA PCM on front:0 (ALC.
D: module-zeroconf-publish.c: Successfully created entry group for adlin5000@Mine: ALSA PCM on front:0 (ALC882 Analog) via DMA.
I: module.c: Loaded "module-zeroconf-publish" (index: #12; argument: "").
D: module-gconf.c: Loading module 'module-zeroconf-discover' with args '' due to GConf configuration.
I: module.c: Loaded "module-zeroconf-discover" (index: #13; argument: "").
I: module.c: Loaded "module-gconf" (index: #14; argument: "").
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-x11-publish.so': success
D: module-x11-publish.c: using already loaded auth cookie.
I: module.c: Loaded "module-x11-publish" (index: #15; argument: "").
I: main.c: Daemon startup complete.
D: module-hal-detect.c: dbus: interface=org.freedesktop.DBus, path=/org/freedesktop/DBus, member=NameAcquired
I: module-zeroconf-publish.c: Successfully established service adlin5000@Mine: ALSA PCM on front:0 (ALC882 Analog) via DMA.
I: module-zeroconf-publish.c: Successfully established service adlin5000@Mine: Simultaneous output to ALSA PCM on front:0 (ALC.
I: module-zeroconf-publish.c: Successfully established service adlin5000@Mine: ALSA PCM on front:0 (ALC882 Analog) via DMA.
I: module-zeroconf-publish.c: Successfully established main service.
I: module-suspend-on-idle.c: Source alsa_input.pci_10de_371_sound_card_0_alsa_capture_ 0 idle for too long, suspending ...
I: module-alsa-source.c: Device suspended...
I: module-suspend-on-idle.c: Source alsa_output.pci_10de_371_sound_card_0_alsa_playbac k_0.monitor idle for too long, suspending ...
I: module-suspend-on-idle.c: Sink combined idle for too long, suspending ...
D: module-suspend-on-idle.c: Sink alsa_output.pci_10de_371_sound_card_0_alsa_playbac k_0 becomes idle.
D: module-suspend-on-idle.c: Sink alsa_output.pci_10de_371_sound_card_0_alsa_playbac k_0 becomes idle.
I: sink-input.c: Freeing output 0 "Simultaneous output on ALSA PCM on front:0 (ALC882 Analog) via DMA"
I: module-combine.c: No master selected, lacking suitable outputs.
I: module-combine.c: Device suspended...
I: module-suspend-on-idle.c: Source combined.monitor idle for too long, suspending ...
I: module-suspend-on-idle.c: Sink alsa_output.pci_10de_371_sound_card_0_alsa_playbac k_0 idle for too long, suspending ...
I: module-alsa-sink.c: Device suspended...


at that point it stalled out and I had to close the terminal.

I know there has been a lot of problems with zsnes, but I was hoping to find a way to get Zsnes and Pulse to play nice without having to do a lot of tweaking with the Zsnes source code to get it to work.

If there is nothing I can do on the pulse side let me know and I'll go ahead and start playing on the Zsnes side.

Thanks

psyke83
July 3rd, 2008, 10:09 PM
If there is nothing I can do on the pulse side let me know and I'll go ahead and start playing on the Zsnes side.

Thanks

I believe this is a bug in zsnes - fortunately, there's an easy fix.

Simply launch zsnes from the terminal using the following parameters:

$ zsnes -ad sdl

You only need to use those parameters once, as the setting will be saved and used by default on subsequent runs. As long as you followed at least Part A of this guide, sound will work perfectly with PulseAudio.

Fix found on this bug report by Jeremy LaCroix: https://bugs.launchpad.net/ubuntu/+source/zsnes/+bug/188567

adlin5000
July 4th, 2008, 08:52 AM
Thanks psyke83. I could have sworn that I had tried SDL before and it did not work. I guess I did not retry it after I ran through this setup. It works now.

Maybe now I'll try and get Gens to work also.....

rklk
July 4th, 2008, 10:03 AM
Hi,

Anyone who previously installed Flash v10 using this guide may want to follow Part B again - there was a new release of the Flash plugin.

As the new release may bring some new functionality I wouldn't recommend it to anyone who followed this guide to get rid of Firefox crashes. This Astro release crashes Firefox every time I visit sites like last.fm.
I would downgrade to previous beta but forgot to backup it somewhere.

psyke83
July 6th, 2008, 04:33 PM
As the new release may bring some new functionality I wouldn't recommend it to anyone who followed this guide to get rid of Firefox crashes. This Astro release crashes Firefox every time I visit sites like last.fm.
I would downgrade to previous beta but forgot to backup it somewhere.

Thanks for the heads-up - I noticed regressions in beta 2 as well. I've updated the guide to provide the choice of installing beta 1 or beta 2.

mattkoehn
July 7th, 2008, 04:56 AM
When I start pulseaudio with the "load-module module-alsa-sink device=equalized" uncommented then I get the error below. If I comment it, puleaudio loads. There was earlier in the thread about incorrectly setting up a virtual interface for an error that was similar. I followed the guide and didn't see that part, but may have missed it. Any help would be appreciated.

W: main.c: RLIMIT_RTPRIO failed: Operation not permitted
E: alsa-util.c: Error opening PCM device equalized: No such file or directory
E: module.c: Failed to load module "module-alsa-sink" (argument: "device=equalized"): initialization failed.
E: main.c: Module load failed.
E: main.c: Failed to initialize daemon.

quanumphaze
July 7th, 2008, 07:08 AM
The Flash 10 beta 1 installer no longer works. It seems that the files are no longer available for download from download.macromedia.com


Setting up flashplugin-nonfree (10.0.1.218ubuntu1) ...
Downloading...
--16:01:19-- http://download.macromedia.com/pub/labs/flashplayer10/flashplayer10_install_linux_051508.tar.gz
=> `./flashplayer10_install_linux_051508.tar.gz'
Resolving download.macromedia.com... 122.252.43.191
Connecting to download.macromedia.com|122.252.43.191|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
16:01:19 ERROR 404: Not Found.

download failed
The Flash plugin is NOT installed.
Unfortunately the installer script doesn't keep the tar.gz file around from the first time I used it, so I'm stuck with beta 2's regressions.

mattkoehn
July 7th, 2008, 07:18 AM
For anyone following my post, I'm still trying to get clean audio. When I start without the device=equalized, everything plays but sounds horrible. I've been messing around with the daemon.conf settings for fragments and the resample method but none seem to make a difference. I was thinking that if I could get the equalized output to work it would fix this. Again, any help would be appreciated.

mattkoehn
July 7th, 2008, 08:44 AM
Ok. Got the audio clean but no equalizer. For some reason, deselecting 'mic front input' from the alsa mixer cleaned up my audio. Now I'm curious why that was happening, if anyone cares to explain. I didn't even have a mic plugged in this whole time. I was ignoring alsa settings as I thought they wouldn't be used, or at best or worse, would be fine in the same config that was working before forcing everything to use pulse. For instance, Amarok using Xine-pulse audio plugin shouldn't be effected by alsa mixer settings, right?

Well, that bit and my original question about getting the mixer to work. Thanks

psyke83
July 7th, 2008, 12:28 PM
Ok. Got the audio clean but no equalizer. For some reason, deselecting 'mic front input' from the alsa mixer cleaned up my audio. Now I'm curious why that was happening, if anyone cares to explain. I didn't even have a mic plugged in this whole time. I was ignoring alsa settings as I thought they wouldn't be used, or at best or worse, would be fine in the same config that was working before forcing everything to use pulse. For instance, Amarok using Xine-pulse audio plugin shouldn't be effected by alsa mixer settings, right?

Well, that bit and my original question about getting the mixer to work. Thanks

PulseAudio runs on top of ALSA and not as a substitute for it, so yes, every ALSA mixer setting can affect PulseAudio. It's well-known that the MIC input can cause interference (even if there's no microphone attached).

Also, it appears that you didn't follow Part A of the guide correctly, so you're missing the "equalized" virtual device in your ".asoundrc" file. I don't recommend you use the equalizer if the source of your problem was the MIC, unless you're using a laptop.

psyke83
July 7th, 2008, 12:30 PM
The Flash 10 beta 1 installer no longer works. It seems that the files are no longer available for download from download.macromedia.com


Setting up flashplugin-nonfree (10.0.1.218ubuntu1) ...
Downloading...
--16:01:19-- http://download.macromedia.com/pub/labs/flashplayer10/flashplayer10_install_linux_051508.tar.gz
=> `./flashplayer10_install_linux_051508.tar.gz'
Resolving download.macromedia.com... 122.252.43.191
Connecting to download.macromedia.com|122.252.43.191|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
16:01:19 ERROR 404: Not Found.

download failed
The Flash plugin is NOT installed.
Unfortunately the installer script doesn't keep the tar.gz file around from the first time I used it, so I'm stuck with beta 2's regressions.

I'm finding your post a little puzzling because a) the tar.gz for beta 1 is still available for me (I tried just this minute), and b) the deb package should have kept a backup of beta 1, even if you upgraded to beta 2.

twinklellon
July 9th, 2008, 09:48 AM
Actually, I have a much much easier but better way to deal with the PulseAudio problem.

SEE:
http://ubuntuforums.org/showthread.php?t=852822

psyke83
July 9th, 2008, 01:02 PM
Actually, I have a much much easier but better way to deal with the PulseAudio problem.

SEE:
http://ubuntuforums.org/showthread.php?t=852822

Sorry, but this is not an optimal solution. The only advantage of configuring PulseAudio to use dmix is that sound mixing will work without extra effort. There are many disadvantages, however: many applications will skip PulseAudio entirely, and applications that do use PulseAudio will have increased latency and CPU usage.

I would argue this is the worst way to configure PulseAudio - in fact it's better to remove PulseAudio entirely than use it this way.

BGFG
July 10th, 2008, 04:49 AM
I just stumbled across this post. Before this i honestly thought that only one program could run audio at a time :) due to my understanding of linux and how information had to be written to the sound file.
I just thought that was how ubuntu sound worked. (sad i know) Anyway, i've only executed step 'a' as it was all i really needed and it went without a hitch. I tested playing a song in audacious and running a movie in vlc and both streams were audible. Now my system is complete. thanks for all your hard work.
I look forward to future HOWTO's from psyke83

NTolerance
July 10th, 2008, 05:09 AM
The Flash 10 beta 1 installer no longer works. It seems that the files are no longer available for download from download.macromedia.com


Setting up flashplugin-nonfree (10.0.1.218ubuntu1) ...
Downloading...
--16:01:19-- http://download.macromedia.com/pub/labs/flashplayer10/flashplayer10_install_linux_051508.tar.gz
=> `./flashplayer10_install_linux_051508.tar.gz'
Resolving download.macromedia.com... 122.252.43.191
Connecting to download.macromedia.com|122.252.43.191|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
16:01:19 ERROR 404: Not Found.

download failed
The Flash plugin is NOT installed.
Unfortunately the installer script doesn't keep the tar.gz file around from the first time I used it, so I'm stuck with beta 2's regressions.

I'm getting this problem too. Unfortunately every script/howto out there links to the macromedia site which is no longer hosting beta 1.

psyke83
July 10th, 2008, 05:28 AM
I'm getting this problem too. Unfortunately every script/howto out there links to the macromedia site which is no longer hosting beta 1.

Here you go (I'm not sure of the legality of such redistribution, let me know if the link needs to be deleted): http://www.megaupload.com/?d=6EXVWL10

You can manually copy the archive to /var/cache/flashplugin-nonfree/ and try (re)installing the deb, it should work. Although downloading from random sites on the internet is usually an unsafe practice, bear in mind that the flashplugin-nonfree script does an md5sum check of the archive, so it should be safe.

mghambunan
July 11th, 2008, 11:17 AM
@ psyke83: Thanks a lot for this useful HOWTO. It resolves my crashing problem with firefox.

I just have some questions regarding this HOWTO. After following the steps from Part A to Part C, I notice that when running alsamixer from terminal the Card and Chip has changed to PulseAudio and there are only 2 volume controls left which are the Master and Capture. Does this mean that the alsamixer volume control found in the taskbar can't be use except for the Master and Capture controls?
I also have problem with my microphone. I can't record any audio using Sound Recorder. I can't figure out how to fix this problem and where to start. Any help is highly appreciated.

I'm new to ubuntu and linux in general so please bear with me.

BTW I'm using Ubuntu Hardy i386

psyke83
July 11th, 2008, 02:10 PM
I just have some questions regarding this HOWTO. After following the steps from Part A to Part C, I notice that when running alsamixer from terminal the Card and Chip has changed to PulseAudio and there are only 2 volume controls left which are the Master and Capture. Does this mean that the alsamixer volume control found in the taskbar can't be use except for the Master and Capture controls?
I also have problem with my microphone. I can't record any audio using Sound Recorder. I can't figure out how to fix this problem and where to start. Any help is highly appreciated.

Your alsamixer problem is an expected result of using the pulse_ctl ALSA plugin. You have two choices to work around this behaviour (this is to fix alsamixer only, as the Volume Control applet should be unaffected).

1. You can comment or delete this section of your .asoundrc (though I'm not sure if this will have negative repercussions elsewhere):

ctl.!default {
type pulse
}

OR

2. you can specify your sound card explicitly when running alsamixer:

$ alsamixer -c <your_card_number>

Sound Recorder uses the GStreamer framework, so you need to go to System/Preferences/Sound and set the "Capture" device to your microphone's hardware device. Did your microphone work before you followed this guide? PulseAudio shouldn't interfere.

tneo
July 11th, 2008, 07:21 PM
Thanks !!
With some different settings for my .asoundrc file I got this working now under openSUSE 11.

Nexusx6
July 12th, 2008, 08:05 PM
Argh! Every time I try to use the Flash v10 package it breaks firefox. FF3 can't play any video's at Youtube, saying that I either have Java off (I don't) or that I'm using an old version of flash (false). FF isn't detecting Flash v10 for some reason, is there a way to solve this?

Craig73
July 13th, 2008, 05:33 AM
I have applied the settings and I'm not entired sure (a little tired) at this point if the sound improved or not.

Do I have to keep logging off and on between changing settings for them to take effect? Is there not some GUI app (sorry - but like on Windows) that presents me with a list of 20 different speaker setups that take effect immediately?

There are suggestions here (http://gentoo-wiki.com/HOWTO_Set_up_a_system-wide_equaliser_with_ALSA_and_LADSPA) that I should have determined my equalizer settings before hand using an audio program that does support this plugin and has a graphical tool.

My other more general question is - I only want the system wide equalizer as I don't percieve any other issues (except perhaps flash audio blocking which took one package to resolve) so why are there so many packages to install when other setups guides (not Ubuntu 8.04 specific) suggest only two packages (ladspa-sdk swh-plugins)?

psyke83
July 13th, 2008, 02:00 PM
I have applied the settings and I'm not entired sure (a little tired) at this point if the sound improved or not.

Do I have to keep logging off and on between changing settings for them to take effect? Is there not some GUI app (sorry - but like on Windows) that presents me with a list of 20 different speaker setups that take effect immediately?

There are suggestions here (http://gentoo-wiki.com/HOWTO_Set_up_a_system-wide_equaliser_with_ALSA_and_LADSPA) that I should have determined my equalizer settings before hand using an audio program that does support this plugin and has a graphical tool.

There's no easy way to change the equalizer settings in realtime. What you can do, however, is this: disable the equalizer (follow Part D backwards), and then (after logging out and back in) use Audacious as described in the Gentoo guide. When you've gotten the ideal equalizer settings, edit your .asoundrc file with the new values from Audacious. Finally, re-enable the equalizer.


My other more general question is - I only want the system wide equalizer as I don't percieve any other issues (except perhaps flash audio blocking which took one package to resolve) so why are there so many packages to install when other setups guides (not Ubuntu 8.04 specific) suggest only two packages (ladspa-sdk swh-plugins)?

PulseAudio in Hardy was not configured properly, quite simply. Most applications that came with the CD (Totem, Rhythmbox, etc.) use the GStreamer framework, and that has native PulseAudio support. Some high-profile applications also have PulseAudio support (VLC, mplayer). Most other programs have no PulseAudio support at all.

As an experiment you can try this:
1. Temporarily move or delete your .asoundrc file, install "libsdl1.2debian-alsa", then log out and back in.
2. Open Rhythmbox, begin playback of a radio station and leave it running
3. (Install and) run Skype, OR Neverball.

In this situation Rhythmbox will work correctly and using PulseAudio support, but Neverball tries to use ALSA directly, and fails. If PulseAudio is active, then it has exclusive access to the sound card and no other applications can get direct access to the card. Appendix B explains this in detail.

As for the extra packages: "libasound2-plugins" has the PCM pulse plugins that are necessary to make ALSA applications work correctly (like Skype/Neverball in the example above), "padevchooser" is the PulseAudio Device Chooser (which also grabs the manager and volume control, for troubleshooting), and the rest are PulseAudio support libraries that should have been installed by default, but weren't. You were obviously following the wrong guides in the past, because the only guides you can really trust are the ones that follow the steps here: http://www.pulseaudio.org/wiki/PerfectSetup

Craig73
July 13th, 2008, 03:06 PM
PulseAudio in Hardy was not configured properly, quite simply. [...lots of great clarifications...] You were obviously following the wrong guides [...]

I wasn't necessarily following the other guides - I'm just newly back to Linux and I wasn't as confident if I was over solving my problem or not so was seeking other perspectives. Unfortunately there is a wealth of information out there and it sometimes isn't obvious what is relevant to this release of this distribution and I wasn't looking to head down a long road :-)

I do very much appreciate this guide you put together. It was targeted at exactly this release and issues I didn't know I had.

[It's too bad it couldn't be repackaged as a set of scripts to automatically run as the new 'ideal' setup... save for perhaps the beta software]

psyke83
July 13th, 2008, 03:19 PM
[It's too bad it couldn't be repackaged as a set of scripts to automatically run as the new 'ideal' setup... save for perhaps the beta software]

Yes, it would be more convenient to automate this process. Unfortunately I'm afraid that could reduce the possibility of getting these problems fixed officially. Having everything explicitly outlined as it is now can help the Ubuntu packagers see the entire picture and get all these issues sorted together, rather than in a piecemeal fashion.

Besides, sometimes it's better to get your hands dirty, to get a better understanding of how something works ;).

Craig73
July 13th, 2008, 03:28 PM
Besides, sometimes it's better to get your hands dirty, to get a better understanding of how something works ;).

Ha ha... true enough. I was just browsing about seeing if it was possible to externally (ie from another utility) send a signal to get the equalizer to reload the values, or to the sound system to reload the equalizer. Assuming that, then I could just grab the code for an equalizer dialog and hack together graphical tool (change value, click apply, update file, force plug-in refresh, hear effect). [This is probably not the right place to discuss this]

psyke83
July 13th, 2008, 04:08 PM
Ha ha... true enough. I was just browsing about seeing if it was possible to externally (ie from another utility) send a signal to get the equalizer to reload the values, or to the sound system to reload the equalizer. Assuming that, then I could just grab the code for an equalizer dialog and hack together graphical tool (change value, click apply, update file, force plug-in refresh, hear effect). [This is probably not the right place to discuss this]

Well, someone else already beat you to that idea ;). It's possible to adjust a LADSPA plugin in "realtime" (using a different LADSPA plugin than what I use in my guide), by chaining PulseAudio through the ALSAEQUAL (http://www.thedigitalmachine.net/alsaequal.html) plugin. I experimented with this idea before (without success), but I intend to give it another try soon...

ikarusX3
July 13th, 2008, 05:38 PM
Hi,

after following this guide and finally getting some kind of decent sound on my SigmaTel Audio, i have a problem with random hangs, like im listening to music, and from time to time the system just hangs in intervals of about 2 seconds for a total time of about 10 seconds. it is not possible to force this, it appears from time to time.

also, i get a short hang of about one second when starting music playback.

while the second problem is not that annoying, the other one really is. there are no errors in syslog, just the following on each system boot:

Jul 13 18:00:13 ikarus pulseaudio[5812]: main.c: RLIMIT_RTPRIO failed: Operation not permitted
Jul 13 18:00:14 ikarus pulseaudio[5812]: alsa-util.c: Error opening PCM device hw:0: Device or resource busy
Jul 13 18:00:14 ikarus pulseaudio[5812]: module.c: Failed to load module "module-alsa-sink" (argument: "device_id=0 sink_name=alsa_output.pci_8086_24c5_sound_card_0_a lsa_playback_0"): initialization failed.

dont know if this could cause the problem.

i would really like to keep the equalized output, because sound is really crappy without it.

any suggestions?

greetings

psyke83
July 13th, 2008, 05:42 PM
Hi,

after following this guide and finally getting some kind of decent sound on my SigmaTel Audio, i have a problem with random hangs, like im listening to music, and from time to time the system just hangs in intervals of about 2 seconds for a total time of about 10 seconds. it is not possible to force this, it appears from time to time.

By any chance, is this a problem in Rhythmbox? Anyway, try going to System/Preferences/Sound and set all the "Sound Playback" options to "ALSA", then see if these hangs stop.


also, i get a short hang of about one second when starting music playback.
This is a problem with the equalizer, I assume there is a small initialization delay when loading the LADSPA plugin. It can't be avoided until a certain bug in PulseAudio is fixed (though it probably won't see an update in Hardy).

Finally, the error in the PulseAudio log is to be expected when using equalized output, and doesn't indicate a problem.

Roasted
July 14th, 2008, 01:08 AM
So, I followed this guide. I was skeptical due to the lack of good things I've heard about the Pulse installation process.

I ran into several problems.

When I am under system-preferences-sounds, everything is selected to Pulse. When I hit test, I get this error.

audiotestsrc wave=sine freq512 ! audioconvert ! audioresample ! gconfaudiosink profile=music: Failed to connect: Connection refused.

To top it off, when I tried to revert everything back to normal:

jason@jason-hardy:~$ sudo rm ~/.asoundrc* /etc/asound.conf ~/.libao ~/.pulse/daemon.conf ~/.pulse/default.pa
rm: cannot remove `/etc/asound.conf': No such file or directory
jason@jason-hardy:~$ sudo cp ~/pulse-backup/asound.conf /etc/
cp: cannot stat `/home/jason/pulse-backup/asound.conf': No such file or directory
jason@jason-hardy:~$ cp ~/pulse-backup/.asoundrc* ~/
cp: cannot stat `/home/jason/pulse-backup/.asoundrc*': No such file or directory
jason@jason-hardy:~$


You could say I'm in a good mood now. :) Any clue what happened?

psyke83
July 14th, 2008, 01:15 AM
So, I followed this guide. I was skeptical due to the lack of good things I've heard about the Pulse installation process.

I ran into several problems.

When I am under system-preferences-sounds, everything is selected to Pulse. When I hit test, I get this error.

audiotestsrc wave=sine freq512 ! audioconvert ! audioresample ! gconfaudiosink profile=music: Failed to connect: Connection refused.

You don't need to explicitly set output to "Pulse" in System/Preferences/Sound, Autodetect will automatically choose the correct output in the order Pulse -> ALSA -> OSS. PulseAudio is obviously not working for you, as "Connection refused" means the PulseAudio server isn't running.


To top it off, when I tried to revert everything back to normal:

jason@jason-hardy:~$ sudo rm ~/.asoundrc* /etc/asound.conf ~/.libao ~/.pulse/daemon.conf ~/.pulse/default.pa
rm: cannot remove `/etc/asound.conf': No such file or directory
jason@jason-hardy:~$ sudo cp ~/pulse-backup/asound.conf /etc/
cp: cannot stat `/home/jason/pulse-backup/asound.conf': No such file or directory
jason@jason-hardy:~$ cp ~/pulse-backup/.asoundrc* ~/
cp: cannot stat `/home/jason/pulse-backup/.asoundrc*': No such file or directory
jason@jason-hardy:~$

That's perfectly normal. The "no such file or directory" errors only indicate that you never had a custom .asoundrc or asound.conf file before following this guide, so there were no backups to restore.

If you follow the guide again, let me know which parts you followed and give me the verbose output of PulseAudio (see Appendix B), otherwise I can't help.

Roasted
July 14th, 2008, 01:33 AM
You don't need to explicitly set output to "Pulse" in System/Preferences/Sound, Autodetect will automatically choose the correct output in the order Pulse -> ALSA -> OSS. PulseAudio is obviously not working for you, as "Connection refused" means the PulseAudio server isn't running.



That's perfectly normal. The "no such file or directory" errors only indicate that you never had a custom .asoundrc or asound.conf file before following this guide, so there were no backups to restore.

If you follow the guide again, let me know which parts you followed and give me the verbose output of PulseAudio (see Appendix B), otherwise I can't help.

Uh, I followed the entire thing with the exception of the i386 stuff since I run 64 bit.

I definitely did do the backup command... And if these commands worked, which I followed exactly, why do I not have sound AT ALL now? Even with Alsa?

Cancel that. Just for Alsa working. Now, how can I fix up pulse? :(

psyke83
July 14th, 2008, 01:40 AM
Uh, I followed the entire thing with the exception of the i386 stuff since I run 64 bit.

I definitely did do the backup command... And if these commands worked, which I followed exactly, why do I not have sound AT ALL now? Even with Alsa?

I explained it to you already. PulseAudio is broken on your system. You are forcing Pulse output via System/Preferences/Sound, and thus audio is failing. You need to:

a) set everything back to "Autodetect" to make sounds work (so that applications will fall back to ALSA output when PulseAudio fails), and;
b) give me the PulseAudio verbose output so I can help you get PulseAudio fixed.

Your sound didn't return probably because you didn't log out and back in, after you followed the section to revert changes.

Roasted
July 14th, 2008, 02:04 AM
jason@jason-hardy:~$ pulseaudio -k; sleep 4; pulseaudio -vv
E: main.c: Failed to kill daemon.
I: main.c: We're in the group 'pulse-rt', allowing real-time and high-priority scheduling.
I: core-util.c: Successfully gained nice level -11.
I: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
W: main.c: RLIMIT_RTPRIO failed: Operation not permitted
W: pid.c: Stale PID file, overwriting.
I: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
I: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
I: main.c: This is PulseAudio 0.9.10
I: main.c: Page size is 4096 bytes
I: main.c: Fresh high-resolution timers available! Bon appetit!
I: module-alsa-sink.c: Successfully opened device equalized.
I: module-alsa-sink.c: Successfully enabled mmap() mode.
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL equalized
I: alsa-util.c: Unable to attach to mixer equalized: No such file or directory
I: alsa-util.c: Unable to attach to mixer hw:(null): No such device
I: sink.c: Created sink 0 "alsa_output.equalized" with sample spec "s16le 2ch 44100Hz"
I: source.c: Created source 0 "alsa_output.equalized.monitor" with sample spec "s16le 2ch 44100Hz"
I: module-alsa-sink.c: Using 8 fragments of size 880 bytes.
D: module-alsa-sink.c: Thread starting up
I: core-util.c: Successfully enabled SCHED_FIFO scheduling for thread, with priority 5.
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+29
I: module-alsa-sink.c: Starting playback.
I: module.c: Loaded "module-alsa-sink" (index: #0; argument: "device=equalized").
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-hal-detect.so': success
I: module-hal-detect.c: Trying capability alsa
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/computer_alsa_timer
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/computer_alsa_sequencer
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_10de_59_sound_card_0_alsa_playback_2
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_10de_59_sound_card_0_alsa_capture_1
D: module-hal-detect.c: Loading module-alsa-sink with arguments 'device_id=0 sink_name=alsa_output.pci_10de_59_sound_card_0_als a_playback_0'
D: alsa-util.c: Trying front:0...
Segmentation fault
jason@jason-hardy:~$


Tried it again. Didn't work.

In time, can we expect an apt-get package for this pulse setup? :(

psyke83
July 14th, 2008, 02:12 AM
Tried it again. Didn't work.

In time, can we expect an apt-get package for this pulse setup? :(

Disable the equalizer (follow Part C backwards), then log out and back in. PulseAudio should then work.

Roasted
July 14th, 2008, 02:30 AM
Would I have to undo the adduser thing? If so, how?

Note - If it's just un-editing the config file... I logged out, back in, sys-pref-sounds are on auto detect, audacious is on pulse... no audio.

psyke83
July 14th, 2008, 02:33 AM
Would I have to undo the adduser thing? If so, how?

Note - If it's just un-editing the config file... I logged out, back in, sys-pref-sounds are on auto detect, audacious is on pulse... no audio.

Oops, I'm sorry, I mixed up sections. I meant for you to undo Part D (i.e. to disable the equalizer). You can re-do Part C.

Roasted
July 14th, 2008, 02:59 AM
Damn. You're good. Pulse works now. How'd you know to do that?

The reason I wanted to try pulse is, ever since the introduction of Hardy, if my PCM is 100%, it distorts VERY badly. I have to have PCM at 75% or lower in order to keep the distortion at a minimal.

I figured it was due to alsa, since Hardy was designed for pulse.

Pulse, in all honesty, yields the EXACT SAME results as alsa did. I still get distortion (if not, worse distortion) at 100% PCM.

Is there more configurations I should do?

sys-pref-sounds = auto detect
vlc + audacious = pulse
vlc is what distorts INCREDIBLY bad with 100% PCM. Audacious doesn't seem as bad, though.

psyke83
July 14th, 2008, 03:13 AM
Damn. You're good. Pulse works now. How'd you know to do that?

The reason I wanted to try pulse is, ever since the introduction of Hardy, if my PCM is 100%, it distorts VERY badly. I have to have PCM at 75% or lower in order to keep the distortion at a minimal.

I figured it was due to alsa, since Hardy was designed for pulse.

Pulse, in all honesty, yields the EXACT SAME results as alsa did. I still get distortion (if not, worse distortion) at 100% PCM.

Is there more configurations I should do?

sys-pref-sounds = auto detect
vlc + audacious = pulse
vlc is what distorts INCREDIBLY bad with 100% PCM. Audacious doesn't seem as bad, though.

That's really unfortunate. I'm sure you're aware of the "workaround" to keep PCM volume at 75%. Using the equalized output probably would have helped, but I'm afraid it was the equalizer (or in other words, the LADSPA plugin) causing the segmentation fault on your system. This issue seems to affect 64bit users, and I'm running 32bit myself so I'm unsure of how to get equalized output working for you.

However... there is another way to get equalized sound in PulseAudio, but it has a drawback (the PulseAudio server never suspends, so it can waste battery on a laptop). This is it: http://ubuntuforums.org/showpost.php?p=5247472&postcount=274

The method in that post is the ideal way to use LADSPA plugins with PulseAudio; unfortunately there's a bug with the suspend-on-idle module that causes PulseAudio to segfault. However, if suspend-on-idle is disabled (as explained in the post), everything works fine, as long as you take into account the drawback of battery life for laptops.

Roasted
July 14th, 2008, 03:17 AM
Wow. I appreciate your help and all, but pulse can take a back seat. This is too crazy to get 0% upgrade over what alsa can already do.

The day pulse comes with an apt-get package, I'll be game for it.

psyke83
July 14th, 2008, 03:24 AM
Wow. I appreciate your help and all, but pulse can take a back seat. This is too crazy to get 0% upgrade over what alsa can already do.

The day pulse comes with an apt-get package, I'll be game for it.

PulseAudio should be working for you already. I'm pointing you to the alternate method to get the equalized sound in PulseAudio, just in case you really, really want to fix your distorted sound ;). This equalizer will *never* be included in a package, I can (unfortunately) guarantee you of that fact.

Did you check other obvious causes of distortion (unrelated to PulseAudio)? For example, you should always mute the Microphone and all other capture mixers, as they often cause interference on some cards.

Roasted
July 14th, 2008, 03:54 AM
Oh, I really want to get my sound fixed up a bit. My sound, as I recall, used to seem a little louder. I don't know if that's because PCM was always maxed, or what... and then with this distro, if the high PCM just resulted in the static. I don't know... but it's just what I've experienced.

The other thing is, I'm also running an onboard realtek... so it's not top notch. My options were to try pulse, or try a new sound card. I recall my old sound card working fine, which lead me to believe that pulse would fix my issues. Pulse did not fix my issues, so now what? New sound card? Yet the current one worked perfect in gutsy... perhaps a more powerful card (PCI) would be enough to give some extra oomph (clarity plus higher volume levels)??

What do you think?

psyke83
July 14th, 2008, 05:15 AM
Oh, I really want to get my sound fixed up a bit. My sound, as I recall, used to seem a little louder. I don't know if that's because PCM was always maxed, or what... and then with this distro, if the high PCM just resulted in the static. I don't know... but it's just what I've experienced.

The other thing is, I'm also running an onboard realtek... so it's not top notch. My options were to try pulse, or try a new sound card. I recall my old sound card working fine, which lead me to believe that pulse would fix my issues. Pulse did not fix my issues, so now what? New sound card? Yet the current one worked perfect in gutsy... perhaps a more powerful card (PCI) would be enough to give some extra oomph (clarity plus higher volume levels)??

What do you think?

Be sure to check PulseAudio Volume Control (via PulseAudio Device Chooser) and make sure all the mixers are at 100%. It's also possible to over-drive the volume beyond 100% (in PulseAudio Manager), but you'll experience distortion.

As for a new sound card... I think you're better off trying to get your current (onboard) sound working correctly. Search the forums for your card's model and see if there's any insights.

Roasted
July 14th, 2008, 05:42 AM
Be sure to check PulseAudio Volume Control (via PulseAudio Device Chooser) and make sure all the mixers are at 100%. It's also possible to over-drive the volume beyond 100% (in PulseAudio Manager), but you'll experience distortion.

As for a new sound card... I think you're better off trying to get your current (onboard) sound working correctly. Search the forums for your card's model and see if there's any insights.

Where is the pulse audio device chooser? Is that what's under sys-pref-pulseaudio preferences?

estyles
July 14th, 2008, 02:31 PM
Thanks for the tutorial - definitely helped. Now I have sound in most apps, and can have 2 apps using sound concurrently, but I have no sound at all in firefox - have tested flash and youtube videos so far - dead silence. Is there a setting in firefox somewhere to choose where it sends sounds, or is it controlled by the plugins individually, and if so, is there a place to set that?

I have to mention that installing Flash 10 broke Flash entirely for me, so I had to revert back to version 9. Could this be causing the sound problem for videos as well as for flash?

psyke83
July 14th, 2008, 04:32 PM
Where is the pulse audio device chooser? Is that what's under sys-pref-pulseaudio preferences?

If you check Appendix B, you'll see how to get to it.

psyke83
July 14th, 2008, 04:34 PM
Thanks for the tutorial - definitely helped. Now I have sound in most apps, and can have 2 apps using sound concurrently, but I have no sound at all in firefox - have tested flash and youtube videos so far - dead silence. Is there a setting in firefox somewhere to choose where it sends sounds, or is it controlled by the plugins individually, and if so, is there a place to set that?

I have to mention that installing Flash 10 broke Flash entirely for me, so I had to revert back to version 9. Could this be causing the sound problem for videos as well as for flash?

Flash 9 needs to have the "libflashsupport" package installed to work correctly with PulseAudio. Unfortunately, that can also cause system instability. There's no proper fix yet.

mriedel
July 14th, 2008, 04:55 PM
First of all thanks for that great howto.

I followed parts A and C of your instructions and actually got skype playback to run. There's a new problem now though and if I remember correctly it didn't exist before:

Recording volume in skype and other apps (like Sound Recorder) is very low. If I raise input device volume above 60% in PA Volume Control, it distorts really hard so that my recorded voice sounds unbearably bad and the "Right" bar in PA Input Volume Meter goes crazy while the left one does nothing.

Even if I choose lower input volumes, I sound crappy, just a little better.

Recorded sound seems to be crappier in Skype than in Sound Recorder. Skype sounds even crappier when I select "pulse" instead of my hardware input device.

Also, there's still a little playback stuttering left in Skype, although I did follow Part C of your howto.

psyke83
July 14th, 2008, 05:42 PM
First of all thanks for that great howto.

I followed parts A and C of your instructions and actually got skype playback to run. There's a new problem now though and if I remember correctly it didn't exist before:

Recording volume in skype and other apps (like Sound Recorder) is very low. If I raise input device volume above 60% in PA Volume Control, it distorts really hard so that my recorded voice sounds unbearably bad and the "Right" bar in PA Input Volume Meter goes crazy while the left one does nothing.

Even if I choose lower input volumes, I sound crappy, just a little better.

Recorded sound seems to be crappier in Skype than in Sound Recorder. Skype sounds even crappier when I select "pulse" instead of my hardware input device.

Also, there's still a little playback stuttering left in Skype, although I did follow Part C of your howto.

Look at Appendix A, it tells you how to configure Skype correctly. As for stuttering playback, try adjusting the fragment sizes/amounts. Each time you make adjustments, kill pulseaudio and restart it, i.e.:

pulseaudio -k; sleep 3; pulseaudio

estyles
July 14th, 2008, 06:03 PM
Flash 9 needs to have the "libflashsupport" package installed to work correctly with PulseAudio. Unfortunately, that can also cause system instability. There's no proper fix yet.

Fair enough. Thanks. I'm pretty sure I can live with no sound in Firefox until Flash 10 is released. Hopefully that will fix my problem. It's enough that I can play music that doesn't sound like it's being played out of a helicopter.

mriedel
July 14th, 2008, 06:09 PM
Look at Appendix A, it tells you how to configure Skype correctly. As for stuttering playback, try adjusting the fragment sizes/amounts. Each time you make adjustments, kill pulseaudio and restart it, i.e.:

pulseaudio -k; sleep 3; pulseaudio

Forgot to say I had followed the instructions in Appendix A too. I did say, though, that the problem persists whichever input device I choose in Skype and which devices to select is pretty much all you say about skype in the appendix.

smokiemac
July 16th, 2008, 01:18 AM
great thread thanks to all of u who took the time to help here and be so specific so that even newbies could follow

jaklumen
July 17th, 2008, 12:47 AM
Pulling my hair out on this one!

Audacity: Result B
Everything else will not play audio, but will register an entry.
Things go back to "normal" when I set up everything as OSS in System -> Preferences -> Sound. Alsa settings do not work.

jaklumen@jaklumen-ubuntu:~$ pulseaudio -k; sleep 4; pulseaudio -vv
I: main.c: We're in the group 'pulse-rt', allowing real-time and high-priority scheduling.
I: core-util.c: Successfully gained nice level -11.
I: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
I: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
I: main.c: This is PulseAudio 0.9.10
I: main.c: Page size is 4096 bytes
I: main.c: Fresh high-resolution timers available! Bon appetit!
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-hal-detect.so': success
I: module-hal-detect.c: Trying capability alsa
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/computer_alsa_timer
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/computer_alsa_sequencer
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_10b9_5455_sound_card_0_alsa_playback_2
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_10b9_5455_sound_card_0_alsa_capture_1
D: module-hal-detect.c: Loading module-alsa-sink with arguments 'device_id=1 sink_name=alsa_output.pci_10b9_5455_sound_card_0_a lsa_playback_0'
D: alsa-util.c: Trying front:1...
W: alsa-util.c: Device front:1 doesn't support 44100 Hz, changed to 48000 Hz.
I: module-alsa-sink.c: Successfully opened device front:1.
I: module-alsa-sink.c: Successfully enabled mmap() mode.
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:1
I: alsa-util.c: Unable to attach to mixer front:1: No such file or directory
I: alsa-util.c: Successfully attached to mixer 'hw:1'
I: alsa-util.c: Using mixer control "Master".
I: sink.c: Created sink 0 "alsa_output.pci_10b9_5455_sound_card_0_alsa_playba ck_0" with sample spec "s16le 2ch 48000Hz"
I: source.c: Created source 0 "alsa_output.pci_10b9_5455_sound_card_0_alsa_playba ck_0.monitor" with sample spec "s16le 2ch 48000Hz"
I: module-alsa-sink.c: Using 4 fragments of size 4408 bytes.
I: alsa-util.c: All 2 channels can be mapped to mixer channels. Using hardware volume control.
D: module-alsa-sink.c: Thread starting up
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+29
I: module-alsa-sink.c: Starting playback.
I: module.c: Loaded "module-alsa-sink" (index: #0; argument: "device_id=1 sink_name=alsa_output.pci_10b9_5455_sound_card_0_a lsa_playback_0").
D: module-hal-detect.c: Loading module-alsa-source with arguments 'device_id=1 source_name=alsa_input.pci_10b9_5455_sound_card_0_ alsa_capture_0'
D: alsa-util.c: Trying front:1...
W: alsa-util.c: Device front:1 doesn't support 44100 Hz, changed to 48000 Hz.
I: module-alsa-source.c: Successfully opened device front:1.
I: module-alsa-source.c: Successfully enabled mmap() mode.
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:1
I: alsa-util.c: Unable to attach to mixer front:1: No such file or directory
I: alsa-util.c: Successfully attached to mixer 'hw:1'
I: alsa-util.c: Using mixer control "Capture".
I: source.c: Created source 1 "alsa_input.pci_10b9_5455_sound_card_0_alsa_capture _0" with sample spec "s16le 2ch 48000Hz"
I: module-alsa-source.c: Using 4 fragments of size 4408 bytes.
I: alsa-util.c: All 2 channels can be mapped to mixer channels. Using hardware volume control.
D: module-alsa-source.c: Thread starting up
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+28
I: module.c: Loaded "module-alsa-source" (index: #1; argument: "device_id=1 source_name=alsa_input.pci_10b9_5455_sound_card_0_ alsa_capture_0").
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_10b9_5455_sound_card_0_alsa_control__1
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_1102_7_sound_card_0_alsa_playback_3
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_1102_7_sound_card_0_alsa_capture_3
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_1102_7_sound_card_0_alsa_playback_2
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_1102_7_sound_card_0_alsa_capture_2
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_1102_7_sound_card_0_alsa_playback_1
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_1102_7_sound_card_0_alsa_capture_1
D: module-hal-detect.c: Loading module-alsa-sink with arguments 'device_id=0 sink_name=alsa_output.pci_1102_7_sound_card_0_alsa _playback_0'
D: alsa-util.c: Trying front:0...
W: alsa-util.c: Device front:0 doesn't support 44100 Hz, changed to 48000 Hz.
I: module-alsa-sink.c: Successfully opened device front:0.
I: module-alsa-sink.c: Successfully enabled mmap() mode.
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
I: alsa-util.c: Unable to attach to mixer front:0: No such file or directory
I: alsa-util.c: Successfully attached to mixer 'hw:0'
I: alsa-util.c: Cannot find mixer control "Master".
W: alsa-util.c: Cannot find fallback mixer control "PCM".
I: sink.c: Created sink 1 "alsa_output.pci_1102_7_sound_card_0_alsa_playback_ 0" with sample spec "s16le 2ch 48000Hz"
I: source.c: Created source 2 "alsa_output.pci_1102_7_sound_card_0_alsa_playback_ 0.monitor" with sample spec "s16le 2ch 48000Hz"
I: module-alsa-sink.c: Using 4 fragments of size 4416 bytes.
D: module-alsa-sink.c: Thread starting up
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+27
I: module-alsa-sink.c: Starting playback.
I: module.c: Loaded "module-alsa-sink" (index: #2; argument: "device_id=0 sink_name=alsa_output.pci_1102_7_sound_card_0_alsa _playback_0").
D: module-hal-detect.c: Loading module-alsa-source with arguments 'device_id=0 source_name=alsa_input.pci_1102_7_sound_card_0_als a_capture_0'
D: alsa-util.c: Trying front:0...
I: module-alsa-source.c: Successfully opened device front:0.
I: module-alsa-source.c: Successfully enabled mmap() mode.
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
I: alsa-util.c: Unable to attach to mixer front:0: No such file or directory
I: alsa-util.c: Successfully attached to mixer 'hw:0'
I: alsa-util.c: Cannot find mixer control "Capture".
I: alsa-util.c: Using mixer control "Mic".
I: source.c: Created source 3 "alsa_input.pci_1102_7_sound_card_0_alsa_capture_0" with sample spec "s16le 2ch 44100Hz"
I: module-alsa-source.c: Using 2 fragments of size 4416 bytes.
I: alsa-util.c: All 2 channels can be mapped to mixer channels. Using hardware volume control.
D: module-alsa-source.c: Thread starting up
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+26
I: module.c: Loaded "module-alsa-source" (index: #3; argument: "device_id=0 source_name=alsa_input.pci_1102_7_sound_card_0_als a_capture_0").
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_1102_7_sound_card_0_alsa_midi_0
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_1102_7_sound_card_0_alsa_control__1
I: module-hal-detect.c: Loaded 4 modules.
I: module.c: Loaded "module-hal-detect" (index: #4; argument: "").
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-esound-protocol-unix.so': success
I: module.c: Loaded "module-esound-protocol-unix" (index: #5; argument: "").
I: protocol-native.c: loading cookie from disk.
I: module.c: Loaded "module-native-protocol-unix" (index: #6; argument: "").
I: module.c: Loaded "module-volume-restore" (index: #7; argument: "").
D: module-default-device-restore.c: Restored default sink 'alsa_output.pci_10b9_5455_sound_card_0_alsa_playb ack_0'.
D: core-subscribe.c: dropped redundant event.
D: module-default-device-restore.c: Restored default source 'alsa_input.pci_10b9_5455_sound_card_0_alsa_captur e_0'.
I: module.c: Loaded "module-default-device-restore" (index: #8; argument: "").
I: module.c: Loaded "module-rescue-streams" (index: #9; argument: "").
D: module-suspend-on-idle.c: Sink alsa_output.pci_10b9_5455_sound_card_0_alsa_playba ck_0 becomes idle.
D: module-suspend-on-idle.c: Sink alsa_output.pci_1102_7_sound_card_0_alsa_playback_ 0 becomes idle.
D: module-suspend-on-idle.c: Source alsa_output.pci_10b9_5455_sound_card_0_alsa_playba ck_0.monitor becomes idle.
D: module-suspend-on-idle.c: Source alsa_input.pci_10b9_5455_sound_card_0_alsa_capture _0 becomes idle.
D: module-suspend-on-idle.c: Source alsa_output.pci_1102_7_sound_card_0_alsa_playback_ 0.monitor becomes idle.
D: module-suspend-on-idle.c: Source alsa_input.pci_1102_7_sound_card_0_alsa_capture_0 becomes idle.
I: module.c: Loaded "module-suspend-on-idle" (index: #10; argument: "").
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-gconf.so': success
D: module-gconf.c: Loading module 'module-null-sink' with args 'sink_name=rtp format=s16be channels=2 rate=44100 description="RTP Multicast Sink"' due to GConf configuration.
I: sink.c: Created sink 2 "rtp" with sample spec "s16be 2ch 44100Hz"
I: source.c: Created source 4 "rtp.monitor" with sample spec "s16be 2ch 44100Hz"
D: module-null-sink.c: Thread starting up
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+25
D: module-suspend-on-idle.c: Source rtp.monitor becomes idle.
D: module-suspend-on-idle.c: Sink rtp becomes idle.
I: module.c: Loaded "module-null-sink" (index: #11; argument: "sink_name=rtp format=s16be channels=2 rate=44100 description="RTP Multicast Sink"").
D: module-gconf.c: Loading module 'module-rtp-send' with args 'source=rtp.monitor loop=0' due to GConf configuration.
D: module-suspend-on-idle.c: Source rtp.monitor becomes busy.
I: source-output.c: Created output 0 "RTP Monitor Stream" on rtp.monitor with sample spec s16be 2ch 44100Hz and channel map front-left,front-right
D: memblockq.c: memblockq requested: maxlength=174080, tlength=174080, base=4, prebuf=1, minreq=0
D: memblockq.c: memblockq sanitized: maxlength=174080, tlength=174080, base=4, prebuf=4, minreq=4
I: module-rtp-send.c: RTP stream initialized with mtu 1280 on 224.0.0.56:46290, SSRC=0xce7e3e18, payload=10, initial sequence #59648
I: module-rtp-send.c: SDP-Data:
I: module-rtp-send.c: v=0
I: module-rtp-send.c: o=jaklumen 3425240663 0 IN IP4 192.168.2.100
I: module-rtp-send.c: s=PulseAudio RTP Stream on jaklumen-ubuntu.myhome.westell.com
I: module-rtp-send.c: c=IN IP4 224.0.0.56
I: module-rtp-send.c: t=3425240663 0
I: module-rtp-send.c: a=recvonly
I: module-rtp-send.c: m=audio 46290 RTP/AVP 10
I: module-rtp-send.c: a=rtpmap:10 L16/44100/2
I: module-rtp-send.c: a=type:broadcast
I: module-rtp-send.c: EOF
I: module.c: Loaded "module-rtp-send" (index: #12; argument: "source=rtp.monitor loop=0").
D: module-gconf.c: Loading module 'module-rtp-recv' with args '' due to GConf configuration.
I: module.c: Loaded "module-rtp-recv" (index: #13; argument: "").
D: module-gconf.c: Loading module 'module-native-protocol-tcp' with args 'auth-anonymous=1' due to GConf configuration.
I: protocol-native.c: using already loaded auth cookie.
I: protocol-native.c: using already loaded auth cookie.
I: module.c: Loaded "module-native-protocol-tcp" (index: #14; argument: "auth-anonymous=1").
D: module-gconf.c: Loading module 'module-esound-protocol-tcp' with args 'auth-anonymous=1' due to GConf configuration.
I: module.c: Loaded "module-esound-protocol-tcp" (index: #15; argument: "auth-anonymous=1").
D: module-gconf.c: Loading module 'module-zeroconf-publish' with args '' due to GConf configuration.
D: module-zeroconf-publish.c: Publishing services in Zeroconf
D: module-zeroconf-publish.c: Successfully created entry group for jaklumen@jaklumen-ubuntu: ALSA PCM on front:1 (ALi M5455) via D.
D: module-zeroconf-publish.c: Successfully created entry group for jaklumen@jaklumen-ubuntu: ALSA PCM on front:0 (CA0106) via DMA.
D: module-zeroconf-publish.c: Successfully created entry group for jaklumen@jaklumen-ubuntu: RTP Multicast Sink.
D: module-zeroconf-publish.c: Successfully created entry group for jaklumen@jaklumen-ubuntu: ALSA PCM on front:1 (ALi M5455) via D.
D: module-zeroconf-publish.c: Successfully created entry group for jaklumen@jaklumen-ubuntu: ALSA PCM on front:0 (CA0106) via DMA.
I: module.c: Loaded "module-zeroconf-publish" (index: #16; argument: "").
D: module-gconf.c: Loading module 'module-zeroconf-discover' with args '' due to GConf configuration.
I: module.c: Loaded "module-zeroconf-discover" (index: #17; argument: "").
I: module.c: Loaded "module-gconf" (index: #18; argument: "").
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-x11-publish.so': success
D: module-x11-publish.c: using already loaded auth cookie.
I: module.c: Loaded "module-x11-publish" (index: #19; argument: "").
I: main.c: Daemon startup complete.
D: module-hal-detect.c: dbus: interface=org.freedesktop.DBus, path=/org/freedesktop/DBus, member=NameAcquired
I: module-zeroconf-publish.c: Successfully established service jaklumen@jaklumen-ubuntu: ALSA PCM on front:1 (ALi M5455) via D.
I: module-zeroconf-publish.c: Successfully established service jaklumen@jaklumen-ubuntu: ALSA PCM on front:0 (CA0106) via DMA.
I: module-zeroconf-publish.c: Successfully established service jaklumen@jaklumen-ubuntu: RTP Multicast Sink.
I: module-zeroconf-publish.c: Successfully established service jaklumen@jaklumen-ubuntu: ALSA PCM on front:1 (ALi M5455) via D.
I: module-zeroconf-publish.c: Successfully established service jaklumen@jaklumen-ubuntu: ALSA PCM on front:0 (CA0106) via DMA.
I: module-zeroconf-publish.c: Successfully established main service.
I: module-suspend-on-idle.c: Sink alsa_output.pci_10b9_5455_sound_card_0_alsa_playba ck_0 idle for too long, suspending ...
I: module-alsa-sink.c: Device suspended...
I: module-suspend-on-idle.c: Source alsa_output.pci_1102_7_sound_card_0_alsa_playback_ 0.monitor idle for too long, suspending ...
I: module-suspend-on-idle.c: Source alsa_input.pci_10b9_5455_sound_card_0_alsa_capture _0 idle for too long, suspending ...
I: module-alsa-source.c: Device suspended...
I: module-suspend-on-idle.c: Source alsa_output.pci_10b9_5455_sound_card_0_alsa_playba ck_0.monitor idle for too long, suspending ...
I: module-suspend-on-idle.c: Sink alsa_output.pci_1102_7_sound_card_0_alsa_playback_ 0 idle for too long, suspending ...
I: module-alsa-sink.c: Device suspended...
I: module-suspend-on-idle.c: Source alsa_input.pci_1102_7_sound_card_0_alsa_capture_0 idle for too long, suspending ...
I: module-alsa-source.c: Device suspended...
I: module-suspend-on-idle.c: Sink rtp idle for too long, suspending ...
D: module-rtp-recv.c: Checking for dead streams ...
(and so on)

psyke83
July 17th, 2008, 01:12 AM
Pulling my hair out on this one!

Audacity: Result B
Everything else will not play audio, but will register an entry.
Things go back to "normal" when I set up everything as OSS in System -> Preferences -> Sound. Alsa settings do not work.

Can you clarify something for me, please? When you say "everything else will not play audio", do you mean that everything else will not play audio only when Audacious is running?

Anyway, I have some bad news. Audacity doesn't support PulseAudio properly. You can still use it if you use "pasuspender" (PulseAudio suspender). Set everything in System/Preferences/Sound back to Autodetect, and run Audacity like so:


$ pasuspender audacity

Audacity will work only if no other applications are playing sound, unfortunately.

This is the bug you should subscribe to: https://bugs.launchpad.net/ubuntu/+source/audacity/+bug/178895

sancho panza
July 17th, 2008, 03:40 PM
This was a really useful post and worked well for me. But I finally had to undo everything because the version(s) of flash till date have issues with quite a few of the websites, probably because its beta flash. On many websites, the images in the graphics are very noisy/dirty, while some others dont work at all, and some others have flash unresponsive to keyboard inputs.

It would be helpful if you can include update(s) on the status of this problem in the Howto so that we can know when these issues have been fixed and can have a fully functional setup.

satet
July 18th, 2008, 12:17 AM
I followed all four steps to get PulseAudio working (even Skype) and was very pleased with the results - until I was prompted by Ubuntu (Hardy) that an update to Flash was available (Flash 10). After the update, flash no longer has sound, but other applications still seem to work as before with PulseAudio. Any suggestions? Is there, for example, a setting in FireFox that must be set to enable sound through PulseAudio? I apologize if this question has already been answered, I couldn't find it.

psyke83
July 18th, 2008, 12:22 AM
This was a really useful post and worked well for me. But I finally had to undo everything because the version(s) of flash till date have issues with quite a few of the websites, probably because its beta flash. On many websites, the images in the graphics are very noisy/dirty, while some others dont work at all, and some others have flash unresponsive to keyboard inputs.

It would be helpful if you can include update(s) on the status of this problem in the Howto so that we can know when these issues have been fixed and can have a fully functional setup.

I assume you're using 32bit Ubuntu, right? Here's my current thoughts on Flash:


Flash 10 beta 2 is fairly buggy, causing Firefox to crash on many common sites - although for once it's caused by a bug in Firefox, and the problem exists irrespective of PulseAudio. It's a problem with Firefox's "windowless mode" support, and it causes problems with Flash and the newest versions of swfdec (that has also implemented wmode). Once the appropriate fix makes it into Firefox (possibly 3.0.2), this version of Flash will work better. This is the bug to watch: https://bugs.launchpad.net/ubuntu/+source/firefox-3.0/+bug/239182
Flash 10 beta 1 is pretty stable and works perfectly with PulseAudio, though some websites use faulty heuristics to detect the correct Flash version. You will encounter sites that refuse to play Flash, warning that your version of Flash is "outdated" - pretty annoying.
Flash 9 has PulseAudio issues. It does not work properly with the pcm_pulse ALSA plugins (the bug is mentioned in the guide), so you are required to install the package "libflashsupport". Unfortunately, using this support library introduces instability, causing Firefox to crash regularly when closing/reloading pages with Flash content.


One solution to the last point is to use Flash 9 + libflashsupport + nspluginwrapper (yes, for the 32bit version of Ubuntu - you can find the deb I built attached to the relevant bug on Launchpad). Unfortunately that does not prevent Flash from crashing; Firefox remains running, but Flash content becomes "greyed out" and you need to restart Firefox to get Flash working again.

However, I noticed on the nspluginwrapper site there is a new version with support for auto-restarting of crashed plugins - this may be the solution we need. I'm going to try to package the latest version for 32bit systems, and if it works well, I'll include it here in my guide.

onero
July 18th, 2008, 12:29 AM
I followed all four steps to get PulseAudio working (even Skype) and was very pleased with the results - until I was prompted by Ubuntu (Hardy) that an update to Flash was available (Flash 10). After the update, flash no longer has sound, but other applications still seem to work as before with PulseAudio. Any suggestions? Is there, for example, a setting in FireFox that must be set to enable sound through PulseAudio? I apologize if this question has already been answered, I couldn't find it.

Just reinstall the Flash 10 Beta, et. al. I think the Ubuntu backport installs Flash 9 even if the package says its a higher version. Just ignore any upgrades to flashplugin-nonfree until they package flash 10 final.

psyke83
July 18th, 2008, 12:40 AM
I followed all four steps to get PulseAudio working (even Skype) and was very pleased with the results - until I was prompted by Ubuntu (Hardy) that an update to Flash was available (Flash 10). After the update, flash no longer has sound, but other applications still seem to work as before with PulseAudio. Any suggestions? Is there, for example, a setting in FireFox that must be set to enable sound through PulseAudio? I apologize if this question has already been answered, I couldn't find it.

My previous response to sancho panza can be helpful to you too ;). Yes, Flash 10 was added to hardy-backports and then it was reverted to 9 (due to the instability mentioned), so it's probably marked as a later version than the Intrepid package (in my guide). My advice to you for the moment is to keep Flash 9, then install libflashsupport and nspluginwrapper, and Flash 9 will work. Sometimes Flash content will "cut out", but you can restart Firefox to make it work again. I know it's not perfect, but at least with this setup, *you* decide when to close Firefox (in all other cases, Firefox crashes completely when Flash fails).

psyke83
July 18th, 2008, 02:28 AM
Hi,

An update to my previous post: I have successfully built, installed and tested the latest nspluginwrapper package. Although Flash 9 still crashes sporadically (without killing the Firefox process), it is now possible to get Flash working with a page reload! This is the best workaround we have for the time being, until Flash 10 becomes final *and* a serious bug in Firefox 3 is resolved. I have updated Part B as of v3.3 of this guide.

You can also read my (hastily typed) entry on the bug report, here: https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/192888/comments/269

Theo148
July 18th, 2008, 04:34 AM
Unfortunately when I try to install nspluginwrapper from the .deb linked to in the tutorial, it throws dependency errors at me.


Selecting previously deselected package nspluginwrapper.
(Reading database ... 151449 files and directories currently installed.)
Unpacking nspluginwrapper (from nspluginwrapper_1.1.0-0conn1_i386.deb) ...
dpkg: dependency problems prevent configuration of nspluginwrapper:
nspluginwrapper depends on libgtk2.0-0 (>= 2.13.3); however:
Version of libgtk2.0-0 on system is 2.12.9-3ubuntu4.
nspluginwrapper depends on libpango1.0-0 (>= 1.21.3); however:
Version of libpango1.0-0 on system is 1.20.5-0ubuntu1.
dpkg: error processing nspluginwrapper (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
nspluginwrapper

Any idea where I can get the updated libgtk and libpango packages?

psyke83
July 18th, 2008, 04:47 AM
Unfortunately when I try to install nspluginwrapper from the .deb linked to in the tutorial, it throws dependency errors at me.


Selecting previously deselected package nspluginwrapper.
(Reading database ... 151449 files and directories currently installed.)
Unpacking nspluginwrapper (from nspluginwrapper_1.1.0-0conn1_i386.deb) ...
dpkg: dependency problems prevent configuration of nspluginwrapper:
nspluginwrapper depends on libgtk2.0-0 (>= 2.13.3); however:
Version of libgtk2.0-0 on system is 2.12.9-3ubuntu4.
nspluginwrapper depends on libpango1.0-0 (>= 1.21.3); however:
Version of libpango1.0-0 on system is 1.20.5-0ubuntu1.
dpkg: error processing nspluginwrapper (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
nspluginwrapper

Any idea where I can get the updated libgtk and libpango packages?

Thanks for testing. The problem is that I built the package on Intrepid. If you can wait, tomorrow I'll post the deb built for Hardy.

Theo148
July 18th, 2008, 05:02 AM
Thanks for testing. The problem is that I built the package on Intrepid. If you can wait, tomorrow I'll post the deb built for Hardy.
No problem. Thanks for the great tutorial by the way. :)

Plasma_NZ
July 18th, 2008, 11:41 AM
ok, call me noob, i want to undo Part-A - how do i put everything back to how it was before i followed your guide..??

Theo148
July 18th, 2008, 12:40 PM
ok, call me noob, i want to undo Part-A - how do i put everything back to how it was before i followed your guide..??
Appendix C (at the bottom of the tutorial) has instructions on how to revert the changes to PulseAudio. :)

psyke83
July 18th, 2008, 02:04 PM
Unfortunately when I try to install nspluginwrapper from the .deb linked to in the tutorial, it throws dependency errors at me.

I built the nspluginwrapper package for Hardy and updated the guide. If you follow Part B again, it should work.

Theo148
July 18th, 2008, 02:21 PM
All the packages install fine for me now, and Flash player seems to be working fine with PulseAudio, so I'd have to say that it worked. :)

satet
July 18th, 2008, 08:25 PM
I had a small hiccup trying to download from launchpad, but the second attempt worked. No idea what the problem was. In any event after completing all the steps in the new Part B, I now have sound back, through PulseAudio, for flash. Many thanks.

zozio32
July 19th, 2008, 11:04 AM
I think I followed exactly part A, but my rythmbox is still stuck: it won't play if I have lunch Firefox before...
Do I need to run part C also to get it run (I have just check the list of plugins in firefox, and FlashPlayer does not seems to be there)

go_beep_yourself
July 20th, 2008, 07:37 AM
Am I the only one who has this problem? When I use Skype, sound will not work in other applications. For example, if I am in a Skype call, and I try to play Amarok, Amarok will freeze. If I am playing Amarok, and I try to make a Skype call, Skype will say "problems with audio device". I don't see anything in this guide about it. Anybody else have these issues???

psyke83
July 20th, 2008, 01:48 PM
Am I the only one who has this problem? When I use Skype, sound will not work in other applications. For example, if I am in a Skype call, and I try to play Amarok, Amarok will freeze. If I am playing Amarok, and I try to make a Skype call, Skype will say "problems with audio device". I don't see anything in this guide about it. Anybody else have these issues???

Look harder ;). Appendix A. Make sure you have also followed Part C, as Skype *will* stutter otherwise. And if you're using Kubuntu, you weren't supposed to follow this guide at all.

psyke83
July 20th, 2008, 01:54 PM
I think I followed exactly part A, but my rythmbox is still stuck: it won't play if I have lunch Firefox before...
Do I need to run part C also to get it run (I have just check the list of plugins in firefox, and FlashPlayer does not seems to be there)

Please, read the guide properly before posting. Part B will install and configure Flash properly.

zozio32
July 20th, 2008, 08:16 PM
ok, well, seems to be fine now. I didn't realise I had to follow part B also as I didn't now that the flashplugin was installed.

sistoviejo
July 20th, 2008, 10:21 PM
Is there a GUI for the equalizer suggested in the first post (ladspa)?
If not, how do I modify gains for each frequency?
thx

psyke83
July 20th, 2008, 10:27 PM
Is there a GUI for the equalizer suggested in the first post (ladspa)?
If not, how do I modify gains for each frequency?
thx

Please, read the guide entirely before asking questions. The description of Part D explains how to find out (and thus change) the gains.

Unfortunately there's no direct GUI to do this. You can indirectly use Audacious, though. See this post: http://ubuntuforums.org/showpost.php?p=5376745&postcount=345

sistoviejo
July 20th, 2008, 10:42 PM
Please, read the guide entirely before asking questions. The description of Part D explains how to find out (and thus change) the gains.

Unfortunately there's no direct GUI to do this. You can indirectly use Audacious, though. See this post: http://ubuntuforums.org/showpost.php?p=5376745&postcount=345

ok thanks!
I ran analyseplugin /usr/lib/ladspa/mbeq_1197.so and got this output:


Plugin Name: "Multiband EQ"
Plugin Label: "mbeq"
Plugin Unique ID: 1197
Maker: "Steve Harris <email address removed>"
Copyright: "GPL"
Must Run Real-Time: No
Has activate() Function: Yes
Has deativate() Function: No
Has run_adding() Function: Yes
Environment: Normal or Hard Real-Time
Ports: "50Hz gain (low shelving)" input, control, -70 to 30, default 0
"100Hz gain" input, control, -70 to 30, default 0
"156Hz gain" input, control, -70 to 30, default 0
"220Hz gain" input, control, -70 to 30, default 0
"311Hz gain" input, control, -70 to 30, default 0
"440Hz gain" input, control, -70 to 30, default 0
"622Hz gain" input, control, -70 to 30, default 0
"880Hz gain" input, control, -70 to 30, default 0
"1250Hz gain" input, control, -70 to 30, default 0
"1750Hz gain" input, control, -70 to 30, default 0
"2500Hz gain" input, control, -70 to 30, default 0
"3500Hz gain" input, control, -70 to 30, default 0
"5000Hz gain" input, control, -70 to 30, default 0
"10000Hz gain" input, control, -70 to 30, default 0
"20000Hz gain" input, control, -70 to 30, default 0
"Input" input, audio
"Output" output, audio
"latency" output, control

what do I do now?
I want to change the parameters.

sistoviejo
July 20th, 2008, 10:46 PM
Nevermind... It seems to be too awkward. I thought it could be changed on the fly. I find no practical use for this. Thanks anyway.

keiichidono
July 20th, 2008, 11:27 PM
I want to ask before I do anything, can this guide fix my problem in Flash/Firefox where I cannot play music and have a flash object with sound open at the same time? What about the problem I have where if I play any flash object with sound and close it and try to open a movie or play some music the sound will not work?

psyke83
July 20th, 2008, 11:33 PM
I want to ask before I do anything, can this guide fix my problem in Flash/Firefox where I cannot play music and have a flash object with sound open at the same time? What about the problem I have where if I play any flash object with sound and close it and try to open a movie or play some music the sound will not work?

Are you using Ubuntu 64bit? The simple answer to your question is "yes" with a caveat.

Flash 9 needs the support library "libflashsupport" to enable PulseAudio support (to allow Flash and other applications to play sounds simultaneously), but it can introduce instability - you will notice Flash content "cutting out" randomly on websites.

Flash 10 works with PulseAudio, but there is a critical bug in Firefox exposed in this version of Flash, causing many websites to crash (unrelated to PulseAudio). There's no easy solution that works 100% reliably, until Firefox 3.0.2 is released.

keiichidono
July 21st, 2008, 12:04 AM
Well as he said in the OP I can always just reload the page if flash doesn't load, right? I can do that until Firefox 3.0.2 is released. As long as my main problem with playing flash with sound and then closing Firefox and trying to open music or a movie will not have sound therefore requiring me to restart if I want to play my media is fixed I am good.

psyke83
July 21st, 2008, 12:08 AM
Well as he said in the OP I can always just reload the page if flash doesn't load, right? I can do that until Firefox 3.0.2 is released.

That's why I asked if you're using 64bit Ubuntu (I can only tell that your CPU is 64bit from your signature). If you're using 32bit, then yes, a page reload will work. If you're using 64 bit, a page reload won't work (you'll need to restart Firefox). Only the newest development build of nspluginwrapper (1.1.0) supports plugin auto-restart, and nobody has built a 64bit package yet. No, I can't do it.

sistoviejo
July 21st, 2008, 01:51 AM
When I played music over MPD I couldn't play music on Rhythmbox or Firefox and vice versa.
I decided to remove pulseaudio but that didn't solve the problem.
Maybe I haven't completely removed pulseaudio and that's why I still have this problem?
I only uninstalled the packages.

psyke83
July 21st, 2008, 02:06 AM
When I played music over MPD I couldn't play music on Rhythmbox or Firefox and vice versa.
I decided to remove pulseaudio but that didn't solve the problem.
Maybe I haven't completely removed pulseaudio and that's why I still have this problem?
I only uninstalled the packages.

PulseAudio is integrated into the Hardy release, so you can't remove it without losing some functionality. I can't and won't support that kind of action, so you're on your own ;).

If you do decide to install PulseAudio again, you need to configure MPD properly. See here: http://mpd.wikia.com/wiki/PulseAudio

sistoviejo
July 21st, 2008, 02:28 AM
If you do decide to install PulseAudio again, you need to configure MPD properly.

No way!! I'm happier with ALSA.

keiichidono
July 21st, 2008, 03:53 AM
That's why I asked if you're using 64bit Ubuntu (I can only tell that your CPU is 64bit from your signature). If you're using 32bit, then yes, a page reload will work. If you're using 64 bit, a page reload won't work (you'll need to restart Firefox). Only the newest development build of nspluginwrapper (1.1.0) supports plugin auto-restart, and nobody has built a 64bit package yet. No, I can't do it.
Sorry I didn't answer that before, I use 32bit. So I can use the new nspluginwrapper and use autorestart, right? Thank you for the help.

keiichidono
July 21st, 2008, 06:00 AM
I have to give you a big thanks for this guide, Flash now seems to work without any problems and I can play more than one audio source at once. I followed to Multimedia Guide before to install Flash 10 but now Flash 9 is working even better than ever for me. One of my big complaints when using Ubuntu is gone. :D Now I can also safely recommend it to a friend.

keiichidono
July 21st, 2008, 10:16 AM
Ok, I met my first problem. Whenever a flash object can't run it restarts, all good. But it restarts the entire Firefox. I keep loosing all the tabs I have open to this. I think it may be because of the dev release of nspluginwrapper. I'll check it out, if anyone has any info on this I'll be very glad. EDIT: I can't seem to find/install an older version of nspluginwrapper. I'll reinstall it and see what happens. Hopefully I might be able to do something right this time. EDIT: I seem to have messed up my flash plugin somehow, no matter how many times i reinstall and uninstall it doesn't work. If I can get it back to the way it was before I started I'll be good to go. EDIT: I kinda have it half working now. BTW, if anyone references the xkcd comic I will kill them.

AmbroseBierce
July 22nd, 2008, 01:23 PM
Hey,
I tried this "HOW-TO" and it only partly works. Sound works but my internal mic ins`t working anymore. But some how it also works when i use the skype-static-oss version. If i try to record via the ubuntu recording tool it says "Internal Error with Dataflow"(free translated from German^^) and also "subclass did not specify output size". Does anybody else have this problem? How to solve it?
Im using a Sony Vaio VGN SZ61 MN/b with Ubuntu Hardy 8.04 64-bit

psyke83
July 22nd, 2008, 02:00 PM
Hey,
I tried this "HOW-TO" and it only partly works. Sound works but my internal mic ins`t working anymore. But some how it also works when i use the skype-static-oss version. If i try to record via the ubuntu recording tool it says "Internal Error with Dataflow"(free translated from German^^) and also "subclass did not specify output size". Does anybody else have this problem? How to solve it?
Im using a Sony Vaio VGN SZ61 MN/b with Ubuntu Hardy 8.04 64-bit

In System->Preferences->Sound, set all the "Sound playback" options to "Autodetect" and "Sound capture" to "ALSA".

Also, make sure you use the ALSA version of Skype and read Appendix A (there's instructions specifically for Skype).

AmbroseBierce
July 22nd, 2008, 04:04 PM
Now it works. thx alot now everything really:) works.

lamborghiniwang
July 22nd, 2008, 04:31 PM
I followed the guide, everything seems to be working well, but Skype now crashes constantly if I choose pulse as the sound out and ringing device for Skype. Skype works well if I choose HDA Intel (hw:intel.0) as sound out and ringing device except that only one of the speakers have audio output in that case.
Does anyone have the same problem?
I am running 64 bit Hardy on a Thinkpad T61p.(Santa Rosa platform with integrated Intel 82801H ICH8 sound card )

zozio32
July 22nd, 2008, 11:01 PM
Skype issues

Hi again,
well, I've got everything working now, but skype.
I guess I have the "shuttering" problem, even if I am not sure what the word means.
I've followed Part A, B and C and I've try to apply the setting you recommend for Skype. After all that, if I press the "test call" button in Skype, I get a Problem with Audio Playback

I've tried to blindly fiddle a bit with the parameter of part C

default-fragments = 8
default-fragment-size-msec = 5
but without success.

I have also check in the pulse audio applet and Skype is not listed...

There is one stuff: how do I find what's the name of what I should choose for "Sound in". Anyway, I've tried with the 4 options I have, without success.

psyke83
July 22nd, 2008, 11:35 PM
I followed the guide, everything seems to be working well, but Skype now crashes constantly if I choose pulse as the sound out and ringing device for Skype. Skype works well if I choose HDA Intel (hw:intel.0) as sound out and ringing device except that only one of the speakers have audio output in that case.
Does anyone have the same problem?
I am running 64 bit Hardy on a Thinkpad T61p.(Santa Rosa platform with integrated Intel 82801H ICH8 sound card )

The first thing you can try is to disable the equalizer, if you enabled it already (follow Part D in reverse).

If it's not the equalizer giving trouble, I'm pretty sure I know the problem you're having, but the fix is a little complicated and risky. You need to update the "libasound2" packages to the newest version (from Intrepid) to make the PulseAudio ALSA plugin work correctly with Skype. These updated packages were once uploaded to "hardy-proposed" but were pulled from the repository soon after.

Download these packages:

$ wget -c http://archive.ubuntu.com/ubuntu/pool/main/a/alsa-lib/libasound2-dev_1.0.16-2ubuntu1_amd64.deb http://archive.ubuntu.com/ubuntu/pool/main/a/alsa-lib/libasound2_1.0.16-2ubuntu1_amd64.deb http://archive.ubuntu.com/ubuntu/pool/main/a/alsa-plugins/libasound2-plugins_1.0.16-1ubuntu1_amd64.deb http://archive.ubuntu.com/ubuntu/pool/main/a/alsa-lib/lib32asound2_1.0.16-2ubuntu1_amd64.deb

Now, try to install via dpkg:

$ sudo dpkg -i wget -c libasound2-dev_1.0.16-2ubuntu1_amd64.deb libasound2_1.0.16-2ubuntu1_amd64.deb libasound2-plugins_1.0.16-1ubuntu1_amd64.deb lib32asound2_1.0.16-2ubuntu1_amd64.deb

Please, please, please check the output of dpkg and ensure there were no errors - I'm not using 64bit Ubuntu so I can't determine if these packages will install without requiring others.

If you receive errors, please post the output of dpkg above so I can try to find out the problem, then also give me the output of the following:
$ sudo apt-get install --dry-run -f

If you did get errors, this will revert packages to the Hardy versions:

$ sudo apt-get install libasound2-dev_1.0.16-2ubuntu1_amd64.deb/hardy libasound2_1.0.16-2ubuntu1_amd64.deb/hardy libasound2-plugins_1.0.16-1ubuntu1_amd64.deb/hardy lib32asound2_1.0.16-2ubuntu1_amd64.deb/hardy

If you received no errors, then reboot your machine and try Skype again. Let me know if it helps, I'm sure a lot of 64bit users will thank you if it does!

psyke83
July 22nd, 2008, 11:40 PM
Hi again,
well, I've got everything working now, but skype.
I guess I have the "shuttering" problem, even if I am not sure what the word means.
I've followed Part A, B and C and I've try to apply the setting you recommend for Skype. After all that, if I press the "test call" button in Skype, I get a Problem with Audio Playback


Are you using 64bit Ubuntu? If so, check my previous post as well. The word "stuttering" means that audio plays, but it seems to skip like a scratched CD (or broken record). I don't think stuttering is your problem.

If you're using 32bit Ubuntu, you may need to upgrade the "libasound2" packages as well.

Download the packages:

$ wget -c http://archive.ubuntu.com/ubuntu/pool/main/a/alsa-plugins/libasound2-plugins_1.0.16-1ubuntu1_i386.deb http://archive.ubuntu.com/ubuntu/pool/main/a/alsa-lib/libasound2-dev_1.0.16-2ubuntu1_i386.deb http://archive.ubuntu.com/ubuntu/pool/main/a/alsa-plugins/libasound2-plugins_1.0.16-1ubuntu1_i386.deb

Install the packages:

$ sudo dpkg -i libasound2-plugins_1.0.16-1ubuntu1_i386.deb libasound2-dev_1.0.16-2ubuntu1_i386.deb libasound2-plugins_1.0.16-1ubuntu1_i386.deb

If there are errors, post the errors here and you can downgrade the packages by doing this:
$ sudo apt-get install libasound2-plugins/hardy libasound2-dev/hardy libasound2-plugins/hardy

If there are no errors, reboot and try Skype (just make sure you set the "pulse" device in the Skype Options, as Appendix A says).

AmbroseBierce
July 24th, 2008, 03:41 PM
Here I am again^^
everything worked fine with skype...but now again i have problems. If i start skype and test call the sound breaks after a few seconds and i also can#t terminate skype any more...but still can use it menus...the rest of the sound works fine, also recoriding...skype-static-oss works...don know if this is a bug of skype or of pulse
hope you can help me again^

NTolerance
July 24th, 2008, 04:01 PM
I followed a previous version of this how-to that used Flash 10 beta 2. Beta 2 is a real mess so I'd like to try the latest edit in the how-to. I assume that going back to Flash 9 by installing flashplugin-nonfree will automatically remove Flash 10 from my system?

Bios Element
July 27th, 2008, 11:22 AM
Thank you SO MUCH for this! I spent DAYS trying to get my mic to work trying way after way and FINALLY I have it. :D

DiCon
July 29th, 2008, 06:09 PM
For some reason it seems like I am unable to get RTP for pulseaudio since I get this in my syslog:


Jul 29 19:02:23 atlantis pulseaudio[15531]: main.c: RLIMIT_RTPRIO failed: Operation not permitted

I tried to google and search this thread and noticed the same or similar lines in many posts, but nobody seems to notice. But this is not supposed to be right after following this HOWTO, is it?

I tried this on two machines - my notebook, which I updated from older Ubuntu versions (and which does not really need RTP-support) and on my "TV"-barebone, which really needs the RTP and got a fresh 8.04 last weekend. On both the user is in the groups "pulse-access pulse-rt" (I copied this directly from the output of "groups") and both still have the "RLIMIT_RTPRIO failed" message in their syslog.

Any suggestions?

billybag
July 30th, 2008, 04:15 AM
My sound no longer works. I am not sure what happened. The volume Monitor acts as though everything is fine, but no sound. I get system beeps sometimes.

I am sure this issue has come up before so if someone could just point me to a previous post at least, that would be wonderful.

this happened a while ago before, but i forget how i fixed it

psyke83
July 30th, 2008, 04:20 AM
My sound no longer works. I am not sure what happened. The volume Monitor acts as though everything is fine, but no sound. I get system beeps sometimes.

I am sure this issue has come up before so if someone could just point me to a previous post at least, that would be wonderful.

this happened a while ago before, but i forget how i fixed it

Please, read the entire guide before asking questions. In Appendix B I give you the precise information to give in order to help troubleshooting. If no applications play sound correctly, you can skip the application tests and simply give the verbose output of PulseAudio (see the guide).

I also noticed from your earlier posts that you use Linux Mint. I can't really support that configuration as I don't even know if it's supposed to use PulseAudio by default. At the moment, only Ubuntu 8.04 uses PulseAudio to my knowledge.

billybag
July 30th, 2008, 04:35 AM
Linux mint is based on Ubuntu 8. it uses the same repos and pulseaudio out of the box...


pulseaudio -k; sleep 4; pulseaudio -vv
I: main.c: Called SUID root and real-time/high-priority scheduling was requested in the configuration. However, we lack the necessary priviliges:
I: main.c: We are not in group 'pulse-rt' and PolicyKit refuse to grant us priviliges. Dropping SUID again.
I: main.c: For enabling real-time scheduling please acquire the appropriate PolicyKit priviliges, or become a member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.
I: main.c: Note that real-time/high-priority scheduling is NOT normally required. If you experience crackling or other sound anomalies, consider one or more of the above solutions.
I: main.c: High-priority scheduling enabled in configuration but now allowed by policy. Disabling forcibly.
I: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
I: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
I: main.c: This is PulseAudio 0.9.10
I: main.c: Page size is 4096 bytes
I: main.c: Fresh high-resolution timers available! Bon appetit!
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-hal-detect.so': success
I: module-hal-detect.c: Trying capability alsa
I: module-hal-detect.c: Trying capability oss
I: module-hal-detect.c: Loaded 0 modules.
I: module.c: Loaded "module-hal-detect" (index: #0; argument: "").
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-esound-protocol-unix.so': success
I: module.c: Loaded "module-esound-protocol-unix" (index: #1; argument: "").
I: protocol-native.c: loading cookie from disk.
I: module.c: Loaded "module-native-protocol-unix" (index: #2; argument: "").
I: module.c: Loaded "module-volume-restore" (index: #3; argument: "").
I: module-default-device-restore.c: Saved default sink 'combined' not existant, not restoring default sink setting.
I: module-default-device-restore.c: Saved default source 'combined.monitor' not existant, not restoring default source setting.
I: module.c: Loaded "module-default-device-restore" (index: #4; argument: "").
I: module.c: Loaded "module-rescue-streams" (index: #5; argument: "").
I: module.c: Loaded "module-suspend-on-idle" (index: #6; argument: "").
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-gconf.so': success
D: module-gconf.c: Loading module 'module-combine' with args '' due to GConf configuration.
I: sink.c: Created sink 0 "combined" with sample spec "s16le 2ch 44100Hz"
I: source.c: Created source 0 "combined.monitor" with sample spec "s16le 2ch 44100Hz"
D: module-combine.c: Thread starting up
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+29
D: module-suspend-on-idle.c: Source combined.monitor becomes idle.
D: module-suspend-on-idle.c: Sink combined becomes idle.
I: module.c: Loaded "module-combine" (index: #7; argument: "").
I: module.c: Loaded "module-gconf" (index: #8; argument: "").
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-x11-publish.so': success
D: module-x11-publish.c: using already loaded auth cookie.
I: module.c: Loaded "module-x11-publish" (index: #9; argument: "").
I: main.c: Daemon startup complete.
D: module-hal-detect.c: dbus: interface=org.freedesktop.DBus, path=/org/freedesktop/DBus, member=NameAcquired
I: module-suspend-on-idle.c: Sink combined idle for too long, suspending ...
I: module-combine.c: Device suspended...
I: module-suspend-on-idle.c: Source combined.monitor idle for too long, suspending ...
D: module-hal-detect.c: dbus: interface=org.freedesktop.Hal.Device, path=/org/freedesktop/Hal/devices/computer_power_supply_battery_BAT0, member=PropertyModified
D: module-hal-detect.c: dbus: interface=org.freedesktop.Hal.Device, path=/org/freedesktop/Hal/devices/computer_power_supply_battery_BAT0, member=PropertyModified

psyke83
July 30th, 2008, 01:06 PM
Linux mint is based on Ubuntu 8. it uses the same repos and pulseaudio out of the box...

You seem to be using a combined sink which would suggest you're using a custom configuration not part of my guide. If you changed something yourself, I can't really help troubleshoot easily, sorry. Try to undo the changes to your PulseAudio configuration.

Toshibawarrior
July 31st, 2008, 03:20 AM
I bow to thee (psyke83)...You truly are a wise one!

This fix worked absolutely and completely GREAT!!!...At long last I fixed my Toshiba's audio to a 100%...I used almost every fix and workaround out there, and NOTHING worked completely...This EQ really made a difference on my sound! Since music is a very important part of my life i need my audio to be crisp and clear...and not tinny and stuttery...:)

I just have one question...How can I change the EQ's settings?...Is there a way to do so?...

Thanks again man, and keep up the great work! ;)

InfinityCircuit
August 1st, 2008, 04:08 AM
I have the same card you do. If I follow all the tips in this guide, I get this message:


dmoerner@skynet:~$ pulseaudio -k; sleep 4; pulseaudio
W: main.c: RLIMIT_RTPRIO failed: Operation not permitted
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0


If I revert all the steps per your directions, I get:


pulseaudio -k; sleep 4; pulseaudio
E: main.c: Failed to kill daemon.
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0

InfinityCircuit
August 1st, 2008, 08:34 AM
I fixed my problem by reverting everything the guide did and then rebooting. Any attempts to re-follow part A kill my sound and require a reboot + removal of changes to work.

InfinityCircuit
August 2nd, 2008, 01:29 AM
I compiled a new Ubuntu kernel using the sources from the repository, with phc and hdaps patches. I didn't change anything in the core config other than removing SMP support. Now, pulseaudio finds zero soundcards. Any ideas?


dmoerner@skynet:/lib/modules/2.6.24-19-generic/kernel$ pulseaudio -vv
I: main.c: We're in the group 'pulse-rt', allowing real-time and high-priority scheduling.
I: core-util.c: Successfully gained nice level -11.
I: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
I: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
I: main.c: This is PulseAudio 0.9.10
I: main.c: Page size is 4096 bytes
I: main.c: Fresh high-resolution timers available! Bon appetit!
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-hal-detect.so': success
I: module-hal-detect.c: Trying capability alsa
I: module-hal-detect.c: Trying capability oss
I: module-hal-detect.c: Loaded 0 modules.
I: module.c: Loaded "module-hal-detect" (index: #0; argument: "").
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-esound-protocol-unix.so': success
I: module.c: Loaded "module-esound-protocol-unix" (index: #1; argument: "").
I: protocol-native.c: loading cookie from disk.
I: module.c: Loaded "module-native-protocol-unix" (index: #2; argument: "").
I: module.c: Loaded "module-volume-restore" (index: #3; argument: "").
D: module-default-device-restore.c: No previous default sink setting, ignoring.
D: module-default-device-restore.c: No previous default source setting, ignoring.
I: module.c: Loaded "module-default-device-restore" (index: #4; argument: "").
I: module.c: Loaded "module-rescue-streams" (index: #5; argument: "").
I: module.c: Loaded "module-suspend-on-idle" (index: #6; argument: "").
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-gconf.so': success
I: module.c: Loaded "module-gconf" (index: #7; argument: "").
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-x11-publish.so': success
D: module-x11-publish.c: using already loaded auth cookie.
I: module.c: Loaded "module-x11-publish" (index: #8; argument: "").
I: main.c: Daemon startup complete.
D: module-hal-detect.c: dbus: interface=org.freedesktop.DBus, path=/org/freedesktop/DBus, member=NameAcquired

psyke83
August 2nd, 2008, 02:43 AM
I compiled a new Ubuntu kernel using the sources from the repository, with phc and hdaps patches. I didn't change anything in the core config other than removing SMP support. Now, pulseaudio finds zero soundcards. Any ideas?

You're looking in the wrong thread. Forget about PulseAudio entirely and troubleshoot *ALSA*. More than likely you need to recompile the ALSA kernel modules. Again though, wrong thread.

BTW, your previous posts didn't give the required information as you forgot to enable verbose logging.

psyke83
August 2nd, 2008, 02:48 AM
I just have one question...How can I change the EQ's settings?...Is there a way to do so?...

Thanks again man, and keep up the great work! ;)

It's possible to change the EQ settings, but not in real-time. It's explained in the italics of Part D.

kofshower
August 3rd, 2008, 04:31 AM
How I can start pulseaudio server when I login?
I use hardy and kde.
Pulseaudio cannot start normally,and phonon try to use another sound driver.
But wait for a moment,I can start it manually,just need to type "pulseaudio &".

edmondt
August 3rd, 2008, 12:05 PM
I have a problem, I have got sound working... But only when I issue the
sudo alsa force-reload command. It will when play the sound that was queued to play, like the login sound.

Everytime when I restart, I have to do
sudo alsa force-reload in order for sound to work.

Under Sound Preference, when I test sound it will always give me:


audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink: no element "gconfaudiosink"

I am also missing autodetect in the sound selection, only ALSA is available.

aplay -l gives:

**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: ALC861VD Analog [ALC861VD Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 1: ALC861VD Digital [ALC861VD Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 6: Si3054 Modem [Si3054 Modem]
Subdevices: 1/1
Subdevice #0: subdevice #0


Is there a way to get sound working properly without reinstalling ubuntu?


lspci -v | grep -i audio
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)

digitalbenji
August 3rd, 2008, 01:36 PM
I'm also having this issue on my friends laptop (I fix everything, c'est la vis). After issuing a sudo alsa force-reload sound works, but even adding that to a login script for Gnome, it still needs to be manually done. I may try adding a wait to the beginning of the script of 30 seconds first. He seems to have a strange revision of his audio card, since we have nearly the same laptop, and I've never had any non default audio issues. Here's some info

lspci -v | grep -i audio
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC861 Analog [ALC861 Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC861 Digital [ALC861 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 6: Si3054 Modem [Si3054 Modem]
Subdevices: 1/1
Subdevice #0: subdevice #0

I also had to modify the /etc/modprobe.d/alsa-base file to even get any sound working on this laptop, and add this line to the end:

options snd-hda-intel model=asus-laptop

psyke83
August 3rd, 2008, 02:46 PM
edmondt & digitalbenji,

This guide is *not* supposed to fix problems with ALSA. Read the guide in its entirety and give the requested output for troubleshooting.

garloosh
August 4th, 2008, 10:23 PM
Is there a way to increase the volume coming through the headphones? it says the main output is at 100% but headphones dont sound nearly at their capacity.

loboc
August 4th, 2008, 10:30 PM
How I can start pulseaudio server when I login?
I use hardy and kde.
Pulseaudio cannot start normally,and phonon try to use another sound driver.
But wait for a moment,I can start it manually,just need to type "pulseaudio &".

In your preferences there is a module to control start up programs,

You can run the gnome one it without diving into menus by executing it in a terminal



gnome-session-properties &


add /usr/bin/pulseaudio to the start up list

KDE is supposed to save the session when you logout for the next session by default.

try closing the terminal you started it inn and logging out.


If that doesnt work Look in the kde system setting manager for a session or start up option to add it manualy

ypatis
August 5th, 2008, 10:09 PM
i'm in part B of the procedure and i'm writing in terminal

$ wget -c http://launchpadlibrarian.net/16150887/nspluginwrapper_1.1.0-0conn2_i386.deb

the message that i get is

... http://:8080/: Invalid host name.

what can i do?

haxwithaxe
August 6th, 2008, 08:56 PM
Hey very nice guide.
My issue is stuttering. It seems to me that the higher the numbers for the fragment rate and size in daemon.conf are the better my audio sounds. With lower numbers the audio is nothing but stuttering (with rate=2 and size=1 it sounds like just a high pitch tone, with rate=40000 and size=250000 it stutters intermitently, although the best it's been is rate=8 and size =28 but that still has intermitent stutering).
Also I get result A fromtrouble shooting.
soundcard spec
$ cat /proc/asound/cards
1 [NVidia ]: HDA-Intel - HDA NVidia
HDA NVidia at 0xfcf78000 irq 21

$ cat /proc/asound/card1/codec#0 | grep Codec
Codec: Realtek ALC662 rev1

$ cat /proc/asound/card1/codec#0
see attachments

$ pactl list
see attachments

$ pulseaudio -vv
see attachments

Thanks

manlypain
August 11th, 2008, 01:58 AM
Great guide,

I have performed all the steps in section A. I have sound from multiple sources but eventually it crashes. i have to run "pulseaudio &"

W: pid.c: Stale PID file, overwriting.
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0

then "control c" so i get the prompt back then run "pulseaudio &" again. It comes back fine. I can run rythembox and flash or anything else but then it just dies. Some times it will die while i am listening to music. It just crashes the program. I use the pulse audio applet to see if ts still running and it can't connect. When i run the first "pulseaudio &" it says i have a stale PID and that its replacing it. When i run the command the second time it just gives me a number in brackets. I don't know if it matters but when i run cedega i can pass both the oss and the alsa test but if anything else is using sound when i actually try to play a game the audio does not work for the game. If you need any other files let me know. I have been trying to figure this out for weeks.

here is my verbose pulse audio command. after it crashed again today. and then the quote after is what showed before it crashed again


rklinkefus@linuxcore2:~$ pulseaudio -k; sleep 4; pulseaudio -vv
E: main.c: Failed to kill daemon.
I: main.c: Called SUID root and real-time/high-priority scheduling was requested in the configuration. However, we lack the necessary priviliges:
I: main.c: We are not in group 'pulse-rt' and PolicyKit refuse to grant us priviliges. Dropping SUID again.
I: main.c: For enabling real-time scheduling please acquire the appropriate PolicyKit priviliges, or become a member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.
I: main.c: Note that real-time/high-priority scheduling is NOT normally required. If you experience crackling or other sound anomalies, consider one or more of the above solutions.
I: main.c: High-priority scheduling enabled in configuration but now allowed by policy. Disabling forcibly.
W: pid.c: Stale PID file, overwriting.
I: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
I: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
I: main.c: This is PulseAudio 0.9.10
I: main.c: Page size is 4096 bytes
I: main.c: Fresh high-resolution timers available! Bon appetit!
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-hal-detect.so': success
I: module-hal-detect.c: Trying capability alsa
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/computer_alsa_timer
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/computer_alsa_sequencer
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_8086_293e_sound_card_0_alsa_capture_2
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_8086_293e_sound_card_0_alsa_playback_1
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_8086_293e_sound_card_0_alsa_capture_1
D: module-hal-detect.c: Loading module-alsa-sink with arguments 'device_id=0 sink_name=alsa_output.pci_8086_293e_sound_card_0_a lsa_playback_0'
D: alsa-util.c: Trying front:0...
I: module-alsa-sink.c: Successfully opened device front:0.
I: module-alsa-sink.c: Successfully enabled mmap() mode.
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
I: alsa-util.c: Unable to attach to mixer front:0: No such file or directory
I: alsa-util.c: Successfully attached to mixer 'hw:0'
I: alsa-util.c: Using mixer control "Master".
I: sink.c: Created sink 0 "alsa_output.pci_8086_293e_sound_card_0_alsa_playba ck_0" with sample spec "s16le 2ch 44100Hz"
I: source.c: Created source 0 "alsa_output.pci_8086_293e_sound_card_0_alsa_playba ck_0.monitor" with sample spec "s16le 2ch 44100Hz"
I: module-alsa-sink.c: Using 4 fragments of size 4352 bytes.
I: alsa-util.c: ALSA device lacks independant volume controls for each channel, falling back to software volume control.
D: module-alsa-sink.c: Thread starting up
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+29
I: module-alsa-sink.c: Starting playback.
I: module.c: Loaded "module-alsa-sink" (index: #0; argument: "device_id=0 sink_name=alsa_output.pci_8086_293e_sound_card_0_a lsa_playback_0").
D: module-hal-detect.c: Loading module-alsa-source with arguments 'device_id=0 source_name=alsa_input.pci_8086_293e_sound_card_0_ alsa_capture_0'
D: alsa-util.c: Trying front:0...
I: module-alsa-source.c: Successfully opened device front:0.
I: module-alsa-source.c: Successfully enabled mmap() mode.
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
I: alsa-util.c: Unable to attach to mixer front:0: No such file or directory
I: alsa-util.c: Successfully attached to mixer 'hw:0'
I: alsa-util.c: Using mixer control "Capture".
I: source.c: Created source 1 "alsa_input.pci_8086_293e_sound_card_0_alsa_capture _0" with sample spec "s16le 2ch 44100Hz"
I: module-alsa-source.c: Using 4 fragments of size 4352 bytes.
I: alsa-util.c: All 2 channels can be mapped to mixer channels. Using hardware volume control.
D: module-alsa-source.c: Thread starting up
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+28
I: module.c: Loaded "module-alsa-source" (index: #1; argument: "device_id=0 source_name=alsa_input.pci_8086_293e_sound_card_0_ alsa_capture_0").
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_8086_293e_sound_card_0_alsa_hw_specific_2
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_8086_293e_sound_card_0_alsa_control__1
I: module-hal-detect.c: Loaded 2 modules.
I: module.c: Loaded "module-hal-detect" (index: #2; argument: "").
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-esound-protocol-unix.so': success
I: module.c: Loaded "module-esound-protocol-unix" (index: #3; argument: "").
I: protocol-native.c: loading cookie from disk.
I: module.c: Loaded "module-native-protocol-unix" (index: #4; argument: "").
I: module.c: Loaded "module-volume-restore" (index: #5; argument: "").
I: module-default-device-restore.c: Saved default sink 'Intel' not existant, not restoring default sink setting.
I: module-default-device-restore.c: Saved default source 'alsa_input.hw_Intel' not existant, not restoring default source setting.
I: module.c: Loaded "module-default-device-restore" (index: #6; argument: "").
I: module.c: Loaded "module-rescue-streams" (index: #7; argument: "").
D: module-suspend-on-idle.c: Sink alsa_output.pci_8086_293e_sound_card_0_alsa_playba ck_0 becomes idle.
D: module-suspend-on-idle.c: Source alsa_output.pci_8086_293e_sound_card_0_alsa_playba ck_0.monitor becomes idle.
D: module-suspend-on-idle.c: Source alsa_input.pci_8086_293e_sound_card_0_alsa_capture _0 becomes idle.
I: module.c: Loaded "module-suspend-on-idle" (index: #8; argument: "").
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-gconf.so': success
D: module-gconf.c: Loading module 'module-combine' with args '' due to GConf configuration.
I: sink.c: Created sink 1 "combined" with sample spec "s16le 2ch 44100Hz"
I: source.c: Created source 2 "combined.monitor" with sample spec "s16le 2ch 44100Hz"
D: memblockq.c: memblockq requested: maxlength=174080, tlength=174080, base=4, prebuf=1, minreq=0
D: memblockq.c: memblockq sanitized: maxlength=174080, tlength=174080, base=4, prebuf=4, minreq=4
D: module-suspend-on-idle.c: Sink alsa_output.pci_8086_293e_sound_card_0_alsa_playba ck_0 becomes busy.
I: resampler.c: Using resampler 'trivial'
I: resampler.c: Using s16le as working format.
I: sink-input.c: Created input 0 "Simultaneous output on ALSA PCM on front:0 (ALC882 Analog) via DMA" on alsa_output.pci_8086_293e_sound_card_0_alsa_playba ck_0 with sample spec s16le 2ch 44100Hz and channel map front-left,front-right
I: module-combine.c: Master sink is now 'alsa_output.pci_8086_293e_sound_card_0_alsa_playb ack_0'
D: module-combine.c: Thread starting up
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+27
D: module-suspend-on-idle.c: Source combined.monitor becomes idle.
D: module-suspend-on-idle.c: Sink combined becomes idle.
I: module.c: Loaded "module-combine" (index: #9; argument: "").
I: module.c: Loaded "module-gconf" (index: #10; argument: "").
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-x11-publish.so': success
D: module-x11-publish.c: using already loaded auth cookie.
I: module.c: Loaded "module-x11-publish" (index: #11; argument: "").
I: main.c: Daemon startup complete.
D: module-hal-detect.c: dbus: interface=org.freedesktop.DBus, path=/org/freedesktop/DBus, member=NameAcquired
I: module-suspend-on-idle.c: Source alsa_input.pci_8086_293e_sound_card_0_alsa_capture _0 idle for too long, suspending ...
I: module-alsa-source.c: Device suspended...
I: module-suspend-on-idle.c: Source alsa_output.pci_8086_293e_sound_card_0_alsa_playba ck_0.monitor idle for too long, suspending ...
I: module-suspend-on-idle.c: Sink combined idle for too long, suspending ...
D: module-suspend-on-idle.c: Sink alsa_output.pci_8086_293e_sound_card_0_alsa_playba ck_0 becomes idle.
D: module-suspend-on-idle.c: Sink alsa_output.pci_8086_293e_sound_card_0_alsa_playba ck_0 becomes idle.
I: sink-input.c: Freeing output 0 "Simultaneous output on ALSA PCM on front:0 (ALC882 Analog) via DMA"
I: module-combine.c: No master selected, lacking suitable outputs.
I: module-combine.c: Device suspended...
I: module-suspend-on-idle.c: Source combined.monitor idle for too long, suspending ...
I: module-suspend-on-idle.c: Sink alsa_output.pci_8086_293e_sound_card_0_alsa_playba ck_0 idle for too long, suspending ...
I: module-alsa-sink.c: Device suspended...
I: client.c: Created 0 "Native client (UNIX socket client)"
I: protocol-native.c: Got credentials: uid=1000 gid=1000 success=1
I: protocol-native.c: Enabled SHM for new connection
I: client.c: Client 0 changed name from "Native client (UNIX socket client)" to "PulseAudio Manager"
D: core-subscribe.c: dropped redundant event.
I: client.c: Freed 0 "PulseAudio Manager"
I: protocol-native.c: connection died.
I: client.c: Created 1 "EsounD client (UNIX socket client)"
I: client.c: Created 2 "EsounD client (UNIX socket client)"




Soft CPU time limit exhausted, terminating.
Hard CPU time limit exhausted, terminating forcibly.
Aborted

cool_penguin
August 11th, 2008, 02:12 PM
Thanks a lot for the tutorial. I tried it but then realized that Skype was being a bit irresponsive and the CPU usage due to skype had shot up to 100 %.

I hence had to revert back to my previous setting. Do you have any suggestions to get things working properly?

rubberd91
August 11th, 2008, 09:32 PM
Thanks very much for the tutorial!
It works perfectly in fixing the Flash audio problem!

cool_penguin
August 12th, 2008, 02:23 PM
Does your Skype work properly with the above fix? The tutorial helped resolve my Pulseaudio issues. But now when I use Skype, the CPU usage shoots up to 100 % and later Skype almost freezes.

hyperair
August 12th, 2008, 06:01 PM
On my desktop, the problem with Skype was fixed by installing libasound2-plugins version 1.0.16 and setting the "Sound Out" and "Ringing" devices to "pulse". That computer uses a SiS chip with AC97 codec.

On my notebook, Lenovo Y410 (using HDA Intel), this was not necessary, but then again, I had already compiled and installed the drivers for 1.0.17 in order for sound to work. libasound2-plugins remained at 1.0.15 though.

cool_penguin
August 12th, 2008, 08:18 PM
Thanks Hyperair. I shall try it for sure. I too have SiS chipset. If it worked in your case, I am guess it should work for me too since I too have a SiS chipset.

I shall try it and give my feedback soon.

Thanks a lot.

Cheers,
Harish

hyperair
August 12th, 2008, 09:31 PM
Good luck. By the way, the pulse devices come from a customized ~/.asoundrc:


pcm.pulse { type pulse }
ctl.pulse { type pulse }

cool_penguin
August 13th, 2008, 05:02 PM
Nothing seems to work. When I tried to install libsound2-plugin (same as what you mentioned), i got a dependency error.

Looks like i gotta wait until 8.10 is out.

Cheers,
Harry

kieonsegg
August 13th, 2008, 05:27 PM
Hey this helpped amarok from stuttering and firefox video viewing, BUT now when im not playing anything i can here a soft buzzing sound. I have an eee pc 4gb i did all the steps accept d i think. Im not even sure if this pc is i386 or not but im pretty sure it is. Any ideas?????

dansan
August 13th, 2008, 06:34 PM
Thanks for the tutorial, psyke83.

Until I found it, I could only get sound to work inside VirtualBox (on an XP host), but after following Part A, the sound worked perfectly in Hardy. What a relief!

hyperair
August 13th, 2008, 06:50 PM
Nothing seems to work. When I tried to install libsound2-plugin (same as what you mentioned), i got a dependency error.

Looks like i gotta wait until 8.10 is out.

Cheers,
Harry
What dependencies are missing? I didn't have problems installing it on my Ubuntu Hardy system. Make sure you have hardy-updates, hardy-backports and hardy-security enabled.

psyke83
August 13th, 2008, 06:54 PM
here is my verbose pulse audio command. after it crashed again today. and then the quote after is what showed before it crashed again

It's possible that too many client connection are being made, which overloads PulseAudio. There seems to be a bug filed that deals with your issue: https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/237443

I would suggest you try using the libasound2 and libasound2-plugins packages from Intrepid's repository to see if it helps at all.

psyke83
August 13th, 2008, 07:05 PM
i'm in part B of the procedure and i'm writing in terminal

$ wget -c http://launchpadlibrarian.net/16150887/nspluginwrapper_1.1.0-0conn2_i386.deb

the message that i get is

... http://:8080/: Invalid host name.

what can i do?

That's a weird error that suggests your system is using some kind of proxy server that's incorrectly configured, perhaps.

This week I'm going to (finally) set up a PPA containing updated ALSA and Flash components to finally make things work smoothly. Perhaps you can hold off until then.

psyke83
August 13th, 2008, 07:10 PM
Hey very nice guide.
My issue is stuttering. It seems to me that the higher the numbers for the fragment rate and size in daemon.conf are the better my audio sounds. With lower numbers the audio is nothing but stuttering (with rate=2 and size=1 it sounds like just a high pitch tone, with rate=40000 and size=250000 it stutters intermitently, although the best it's been is rate=8 and size =28 but that still has intermitent stutering).

I'm a little confused. Which parameter are you referring to by "rate"? There are only two exposed settings for fragments, and they are:


default-fragments = 4
default-fragment-size-msec = 25

If you were referring to "default-sample-rate" when you mention "rate", you shouldn't change that value: it has nothing to do with fragments or buffers, but it is the default sample rate in which PulseAudio uses. This should be left alone in most circumstances.

psyke83
August 13th, 2008, 07:12 PM
Thanks a lot for the tutorial. I tried it but then realized that Skype was being a bit irresponsive and the CPU usage due to skype had shot up to 100 %.

I hence had to revert back to my previous setting. Do you have any suggestions to get things working properly?

You should try the libasound2 and libasound-plugins packages from Intrepid. Hardy's version does not work well with Skype. I'm going to set up a PPA to make this process more painless in the future (since the bugs seem to be getting fixed at a glacial pace).

psyke83
August 13th, 2008, 07:18 PM
Hey this helpped amarok from stuttering and firefox video viewing, BUT now when im not playing anything i can here a soft buzzing sound. I have an eee pc 4gb i did all the steps accept d i think. Im not even sure if this pc is i386 or not but im pretty sure it is. Any ideas?????

I want you to try two steps, and please log out and back in between the first and second step:

1. When you hear the buzzing sound, kill the pulseaudio server:

$ pulseaudio -k

Verify that pulseaudio has stopped (paste the output here if you're unsure), then listen to see if the buzzing continues to occur, or not.

2. When you hear the buzzing sound, open the GNOME Volume Control applet and mute *all* the entries on the playback tab. You may need to enable hidden entries via the Preferences button in order to test this fully.

Let me know the results. If the second step worked, then progressively unmute each entry until you find the offending item. Otherwise, unmute everything to avoid losing sound entirely.

dansan
August 13th, 2008, 07:23 PM
Hi psyke83,

Just after posting my thank-you note a few minutes ago, which I stick by, I discovered that sound in Hardy only comes through the earpiece of my CS-60 mic.

I've tried looking at System -> Preferences -> Default Sound Card, but this does not work after doing the changes in your tutorial. My System -> Preferences -> Sound settings are shown in the attached screen shot.

Generally, I want sound through my speakers. How do I direct it there?

kieonsegg
August 13th, 2008, 07:32 PM
SWEEET. Got a buzzing sound, tried to remove alltheprograms you told e to install, then it stared to delete firefox, amarok,pidgin, basket, cheese. Now my system dosent boot and i have to doeverything oer again. WHY THE HELL DO PEOPLE LIKE LINUX?!?!? Wats so special about it??? Its ike windows but confusing

psyke83
August 13th, 2008, 07:34 PM
Hi psyke83,

Just after posting my thank-you note a few minutes ago, which I stick by, I discovered that sound in Hardy only comes through the earpiece of my CS-60 mic.

I've tried looking at System -> Preferences -> Default Sound Card, but this does not work after doing the changes in your tutorial. My System -> Preferences -> Sound settings are shown in the attached screen shot.

Generally, I want sound through my speakers. How do I direct it there?

Unfortunately the System/Preferences/Sound application does not control PulseAudio directly. It's possible you're experiencing this "problem" as PulseAudio allows hotplugging of audio devices (which ALSA never did before). For example, when I insert my USB Skype phone, PulseAudio selects that as the default PCM device.

Open the PulseAudio Device Chooser (from Applications/Sound & Video), then click on the applet in the notification tray and choose "Manager..."

Look on the Server Information tab and see what is defined for the "Default Sink" (probably the CS-60).

Try this: play some content in e.g. Totem, and launch the PulseAudio Volume Control applet (again from the PulseAudio Device Chooser). On the Playback tab, you should see an entry for Totem. Right click on the Totem entry, select "Move stream" and try to change the stream from the CS-60 to your desired output device.

Let me know if it worked, and I'll tell you how to set the default device without having to manually move streams like the above ;).

psyke83
August 13th, 2008, 07:39 PM
SWEEET. Got a buzzing sound, tried to remove alltheprograms you told e to install, then it stared to delete firefox, amarok,pidgin, basket, cheese. Now my system dosent boot and i have to doeverything oer again. WHY THE HELL DO PEOPLE LIKE LINUX?!?!? Wats so special about it??? Its ike windows but confusing

I didn't ask you to uninstall any packages (in fact, I replied with troubleshooting steps for your issue just a few minutes ago). It's unfortunate that you tried removing obviously vital packages - let it be a lesson for you to never blindly remove packages ;).

Also, there's no need to troll. You may have been able to restore your system if you tried reinstalling the "ubuntu-desktop" metapackage from the console (if you had a working network connection). Too bad.

kieonsegg
August 13th, 2008, 07:40 PM
I didn't ask you to uninstall any packages (in fact, I replied with troubleshooting steps for your issue just a few minutes ago). It's unfortunate that you tried removing obviously vital packages - let it be a lesson for you to never blindly remove packages ;).

Also, there's no need to troll. You may have been able to restore your system if you tried reinstalling the "ubuntu-desktop" metapackage from the console (if you had a working network connection). Too bad.

Yea tahnks for your help. I thought i could undo the changes lol
Well ill be back to normal in about 5 hours once m done installing it from a usb :)

manlypain
August 13th, 2008, 08:03 PM
It's possible that too many client connection are being made, which overloads PulseAudio. There seems to be a bug filed that deals with your issue: https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/237443

I would suggest you try using the libasound2 and libasound2-plugins packages from Intrepid's repository to see if it helps at all.

Thanks for the idea. I am a noob so it might take me a day to be able to test this out. Do the connections have to be all at once to do this or is it a max number over time thing? I had a hard time understanding the bug report page. When i first start the machine an check the "Clients" tab in the PA Manager i have 8 or 9 EsoundD clients attached. After it crashes only 1 shows up after i restart the service. PA will still crash after that anyways though

dansan
August 13th, 2008, 08:07 PM
Thanks for the help getting me started.


...

Open the PulseAudio Device Chooser (from Applications/Sound & Video), then click on the applet in the notification tray and choose "Manager..."

Look on the Server Information tab and see what is defined for the "Default Sink" (probably the CS-60).

As you see from the screenshot, two sinks are shown, both USB devices. The Server tab shows the top one as Default. My speakers plug into the MB, so they aren't a USB device.


Try this: play some content in e.g. Totem, and launch the PulseAudio Volume Control applet (again from the PulseAudio Device Chooser). On the Playback tab, you should see an entry for Totem. Right click on the Totem entry, select "Move stream" and try to change the stream from the CS-60 to your desired output device.

Yes, this all checks, except there was only one choice.

ALSA PCM on front: 2 (USB Audio) via DCM (the Default) or
ALSA PCM on front: 0 (USB Audio) via DCM

Switching the stream to the latter did not get sound to the speakers.

I hope the screenshot gives you useful information.

psyke83
August 13th, 2008, 08:11 PM
Thanks for the idea. I am a noob so it might take me a day to be able to test this out. Do the connections have to be all at once to do this or is it a max number over time thing? I had a hard time understanding the bug report page. When i first start the machine an check the "Clients" tab in the PA Manager i have 8 or 9 EsoundD clients attached. After it crashes only 1 shows up after i restart the service. PA will still crash after that anyways though

The connection limit may be reached due to bugs in ALSA, so you don't need to do anything more than update the offending ALSA components.


Assuming you're using 32bit Ubuntu, download and install the Intrepid packages, i.e.:

$ wget -c http://archive.ubuntu.com/ubuntu/pool/main/a/alsa-lib/libasound2_1.0.16-2ubuntu1_i386.deb http://archive.ubuntu.com/ubuntu/pool/main/a/alsa-plugins/libasound2-plugins_1.0.16-1ubuntu1_i386.deb http://archive.ubuntu.com/ubuntu/pool/main/a/alsa-lib/libasound2-dev_1.0.16-2ubuntu1_i386.deb
$ sudo dpkg -i libasound2_1.0.16-2ubuntu1_i386.deb libasound2-plugins_1.0.16-1ubuntu1_i386.deb libasound2-dev_1.0.16-2ubuntu1_i386.deb

Please be careful with these commands and do not allow packages to be uninstalled. If in doubt, post a log here.

psyke83
August 13th, 2008, 08:17 PM
As you see from the screenshot, two sinks are shown, both USB devices. The Server tab shows the top one as Default. My speakers plug into the MB, so they aren't a USB device.

Ok, so judging from that screenshot it appears that your built-in sound card has "disappeared", right? Please post the verbose log of PulseAudio (see Appendix B) and also the listing of /proc/asound/pcm (and any other sound logs you can think may be helpful). This may be an ALSA bug.

manlypain
August 13th, 2008, 09:08 PM
The connection limit may be reached due to bugs in ALSA, so you don't need to do anything more than update the offending ALSA components.


Assuming you're using 32bit Ubuntu, download and install the Intrepid packages, i.e.:

$ wget -c http://archive.ubuntu.com/ubuntu/pool/main/a/alsa-lib/libasound2_1.0.16-2ubuntu1_i386.deb http://archive.ubuntu.com/ubuntu/pool/main/a/alsa-plugins/libasound2-plugins_1.0.16-1ubuntu1_i386.deb http://archive.ubuntu.com/ubuntu/pool/main/a/alsa-lib/libasound2-dev_1.0.16-2ubuntu1_i386.deb
$ sudo dpkg -i libasound2_1.0.16-2ubuntu1_i386.deb libasound2-plugins_1.0.16-1ubuntu1_i386.deb libasound2-dev_1.0.16-2ubuntu1_i386.deb

Please be careful with these commands and do not allow packages to be uninstalled. If in doubt, post a log here.

I am using 64bit. i already found the packages. I downloaded them individually. I also downloaded the ones i currently have installed to i can force them back if it dies. Thanks for all the help. I will try this tonight.

psyke83
August 13th, 2008, 09:16 PM
I am using 64bit. i already found the packages. I downloaded them individually. I also downloaded the ones i currently have installed to i can force them back if it dies. Thanks for all the help. I will try this tonight.

Alright. Just remember that you may need the package lib32asound2 if you're on 64bit. Make sure you're not using the equalizer in this guide (to help isolate your problem).

Also, you can revert packages using apt-get this way:


$ sudo apt-get install libasound2/hardy libasound2-plugins/hardy lib32asound2/hardy libasound2-dev/hardy

Toshibawarrior
August 13th, 2008, 11:04 PM
Ok, this fixes have worked great for me until today. Audacity doesn't seem to work with any audio configuration...it worked before following this tutorial.

So if anyone can help me, I'll appreciate it! :)...

Apparently Audacity is not friendly with Pulseaudio...I've tried almost every driver on audacity and none of them work...:(

:popcorn: Please help!

Toshibawarrior
August 13th, 2008, 11:18 PM
Ok, apparently Hydrogen doesn't work either! I didn't try these programs after doing the fixes, and now I know they don't work...Hydrogen sounds trembly and choppy, and I don't know what else to do to configure it with PulseAudio...:(...

Someone please help!

manlypain
August 14th, 2008, 12:32 AM
Alright. Just remember that you may need the package lib32asound2 if you're on 64bit. Make sure you're not using the equalizer in this guide (to help isolate your problem).

Also, you can revert packages using apt-get this way:


$ sudo apt-get install libasound2/hardy libasound2-plugins/hardy lib32asound2/hardy libasound2-dev/hardy

I went to install libasound2 using the deb file and it went ok then errored out after the install and game me this "Processing triggers for libc6 failed". Your uninstall command fixed everything. Can you give me the command to install the 64bit packages like you did for the 32. i will try to run it that way and see if i have better luck.

Julianito
August 14th, 2008, 12:44 AM
Hi,

Thanks for this useful guide :)
Though I still have some issues:
- I couldn't get mbeq_1197 ; is it only available from Intrepide Ubuntu ?
- I have very bad sound capture with teamspeak when using pulseaudio (was ok with aoss and is fine but unsharable with no wrapper).

I'm on Hardy 64 bits. Using X-Fi Extreme Audio creative card (CA0106)

I tried to managed with this :
default-fragments = 8
default-fragment-size-msec = 5
but no success

I run "padsp teamspeak" as if I don't, I can't share the sound with wine programs (ran with "padsp wine wineprg")
Running Teamspeak without padsp, I have good sound capture from the microphone but cannot share sound with wine programs (even or not via padsp).
If I increase the sound quality in Teamspeak options, I have too big latency. So I set it on low (don't have to do this using aoss and not pulseaudio).
The "bad" sound capture is saccaded, my voice's heard as if I was a robot.

So, I disabled load-module module-alsa-sink device=equalized
Here is my .asoundrc

#pcm.card0 {
# type hw
# card 0
#}

pcm.dmixer {
type dmix
ipc_key 1025
slave {
pcm "hw:0,0"
period_time 0
#period_size 1024
#buffer_size 8192
period_size 2048
buffer_size 32768
rate 48000
}
# bindings {
# 0 0
# 1 1
# }
}

pcm.dsp0 {
type plug
slave.pcm "dmixer"
}

# This following device can fool some applications into using pulseaudio
pcm.dsp1 {
type plug
slave.pcm "pulse"
}

ctl.mixer0 {
type hw
card 0
}

#pcm.css {
# type asym
# playback.pcm "hw:0"
#}

pcm.pulse {
type pulse
}

ctl.pulse {
type pulse
}

# Optional, set defaults
pcm.!default {
type pulse
}

ctl.!default {
type pulse
}

pcm.equalized {
type plug
slave.pcm "equalizer";
}

pcm.equalizer {
type ladspa

# The output from the EQ can either go direct to a hardware device
# (if you have a hardware mixer, e.g. SBLive/Audigy) or it can go
# to the software mixer shown here.
#slave.pcm "plughw:0,0"
slave.pcm "plug:dmix"

# Sometimes you may need to specify the path to the plugins,
# especially if you've just installed them. Once you've logged
# out/restarted this shouldn't be necessary, but if you get errors
# about being unable to find plugins, try uncommenting this.
path "/usr/lib/ladspa:/usr/lib64/ladspa:/usr/lib32/ladspa"

plugins [
{
label mbeq
id 1197
input {
#this setting is here by example, edit to your own taste
#bands: 50hz, 100hz, 156hz, 220hz, 311hz, 440hz, 622hz, 880hz,
# 1250hz, 1750hz, 25000hz, 50000hz, 10000hz, 20000hz
#range: -70 to 30
controls [ -1 -1 -1 -1 -5 -10 -20 -17 -12 -7 -6 -5 -5 0 0 ]
}
}
]
}

pulseaudio starting output :

I: main.c: We're in the group 'pulse-rt', allowing real-time and high-priority scheduling.
I: core-util.c: Successfully gained nice level -11.
I: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Opération non permise
I: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Opération non permise
I: main.c: This is PulseAudio 0.9.10
I: main.c: Page size is 4096 bytes
I: main.c: Fresh high-resolution timers available! Bon appetit!
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-hal-detect.so': success
I: module-hal-detect.c: Trying capability alsa
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/computer_alsa_timer
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/computer_alsa_sequencer
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_1102_7_sound_card_0_alsa_playback_3
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_1102_7_sound_card_0_alsa_capture_3
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_1102_7_sound_card_0_alsa_playback_2
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_1102_7_sound_card_0_alsa_capture_2
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_1102_7_sound_card_0_alsa_playback_1
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_1102_7_sound_card_0_alsa_capture_1
D: module-hal-detect.c: Loading module-alsa-sink with arguments 'device_id=0 sink_name=alsa_output.pci_1102_7_sound_card_0_alsa _playback_0'
D: alsa-util.c: Trying front:0...
W: alsa-util.c: Device front:0 doesn't support 44100 Hz, changed to 48000 Hz.
I: module-alsa-sink.c: Successfully opened device front:0.
I: module-alsa-sink.c: Successfully enabled mmap() mode.
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
I: alsa-util.c: Unable to attach to mixer front:0: Aucun fichier ou dossier de ce type
I: alsa-util.c: Successfully attached to mixer 'hw:0'
I: alsa-util.c: Cannot find mixer control "Master".
W: alsa-util.c: Cannot find fallback mixer control "PCM".
I: sink.c: Created sink 0 "alsa_output.pci_1102_7_sound_card_0_alsa_playback_ 0" with sample spec "s16le 2ch 48000Hz"
I: source.c: Created source 0 "alsa_output.pci_1102_7_sound_card_0_alsa_playback_ 0.monitor" with sample spec "s16le 2ch 48000Hz"
I: module-alsa-sink.c: Using 4 fragments of size 4416 bytes.
D: module-alsa-sink.c: Thread starting up
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+29
I: module-alsa-sink.c: Starting playback.
I: module.c: Loaded "module-alsa-sink" (index: #0; argument: "device_id=0 sink_name=alsa_output.pci_1102_7_sound_card_0_alsa _playback_0").
D: module-hal-detect.c: Loading module-alsa-source with arguments 'device_id=0 source_name=alsa_input.pci_1102_7_sound_card_0_als a_capture_0'
D: alsa-util.c: Trying front:0...
I: module-alsa-source.c: Successfully opened device front:0.
I: module-alsa-source.c: Successfully enabled mmap() mode.
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
I: alsa-util.c: Unable to attach to mixer front:0: Aucun fichier ou dossier de ce type
I: alsa-util.c: Successfully attached to mixer 'hw:0'
I: alsa-util.c: Cannot find mixer control "Capture".
I: alsa-util.c: Using mixer control "Mic".
I: source.c: Created source 1 "alsa_input.pci_1102_7_sound_card_0_alsa_capture_0" with sample spec "s16le 2ch 44100Hz"
I: module-alsa-source.c: Using 2 fragments of size 4416 bytes.
I: alsa-util.c: All 2 channels can be mapped to mixer channels. Using hardware volume control.
D: module-alsa-source.c: Thread starting up
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+28
I: module.c: Loaded "module-alsa-source" (index: #1; argument: "device_id=0 source_name=alsa_input.pci_1102_7_sound_card_0_als a_capture_0").
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_1102_7_sound_card_0_alsa_midi_0
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_1102_7_sound_card_0_alsa_control__1
I: module-hal-detect.c: Loaded 2 modules.
I: module.c: Loaded "module-hal-detect" (index: #2; argument: "").
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-esound-protocol-unix.so': success
I: module.c: Loaded "module-esound-protocol-unix" (index: #3; argument: "").
I: protocol-native.c: loading cookie from disk.
I: module.c: Loaded "module-native-protocol-unix" (index: #4; argument: "").
I: module.c: Loaded "module-volume-restore" (index: #5; argument: "").
D: module-default-device-restore.c: Restored default sink 'alsa_output.pci_1102_7_sound_card_0_alsa_playback _0'.
D: core-subscribe.c: dropped redundant event.
D: module-default-device-restore.c: Restored default source 'alsa_input.pci_1102_7_sound_card_0_alsa_capture_0 '.
I: module.c: Loaded "module-default-device-restore" (index: #6; argument: "").
I: module.c: Loaded "module-rescue-streams" (index: #7; argument: "").
D: module-suspend-on-idle.c: Sink alsa_output.pci_1102_7_sound_card_0_alsa_playback_ 0 becomes idle.
D: module-suspend-on-idle.c: Source alsa_output.pci_1102_7_sound_card_0_alsa_playback_ 0.monitor becomes idle.
D: module-suspend-on-idle.c: Source alsa_input.pci_1102_7_sound_card_0_alsa_capture_0 becomes idle.
I: module.c: Loaded "module-suspend-on-idle" (index: #8; argument: "").
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-gconf.so': success
D: module-gconf.c: Loading module 'module-native-protocol-tcp' with args '' due to GConf configuration.
I: protocol-native.c: using already loaded auth cookie.
I: protocol-native.c: using already loaded auth cookie.
I: module.c: Loaded "module-native-protocol-tcp" (index: #9; argument: "").
D: module-gconf.c: Loading module 'module-esound-protocol-tcp' with args '' due to GConf configuration.
I: module.c: Loaded "module-esound-protocol-tcp" (index: #10; argument: "").
D: module-gconf.c: Loading module 'module-zeroconf-discover' with args '' due to GConf configuration.
I: module.c: Loaded "module-zeroconf-discover" (index: #11; argument: "").
I: module.c: Loaded "module-gconf" (index: #12; argument: "").
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-x11-publish.so': success
D: module-x11-publish.c: using already loaded auth cookie.
I: module.c: Loaded "module-x11-publish" (index: #13; argument: "").
I: main.c: Daemon startup complete.
D: module-hal-detect.c: dbus: interface=org.freedesktop.DBus, path=/org/freedesktop/DBus, member=NameAcquired
I: module-suspend-on-idle.c: Source alsa_input.pci_1102_7_sound_card_0_alsa_capture_0 idle for too long, suspending ...
I: module-alsa-source.c: Device suspended...
I: module-suspend-on-idle.c: Source alsa_output.pci_1102_7_sound_card_0_alsa_playback_ 0.monitor idle for too long, suspending ...
I: module-suspend-on-idle.c: Sink alsa_output.pci_1102_7_sound_card_0_alsa_playback_ 0 idle for too long, suspending ...
I: module-alsa-sink.c: Device suspended...


Running teamspeak (see memory message at the end)
with high latency and default fragments options in pulseaudio daemon.conf

I: client.c: Created 0 "Native client (UNIX socket client)"
I: protocol-native.c: Got credentials: uid=1000 gid=1000 success=1
I: protocol-native.c: Enabled SHM for new connection
I: client.c: Client 0 changed name from "Native client (UNIX socket client)" to "OSS Emulation[teamspeak.real]"
I: module-volume-restore.c: Restoring source for <pulsecore/protocol-native.c$OSS Emulation[teamspeak.real]>
I: module-alsa-source.c: Trying resume...
I: module-alsa-source.c: Resumed successfully...
D: module-suspend-on-idle.c: Source alsa_input.pci_1102_7_sound_card_0_alsa_capture_0 becomes idle.
D: module-suspend-on-idle.c: Source alsa_input.pci_1102_7_sound_card_0_alsa_capture_0 becomes busy.
D: resampler.c: Channel matrix:
D: resampler.c: I00 I01
D: resampler.c: +------------
D: resampler.c: O00 | 1,000 1,000
I: resampler.c: Using resampler 'speex-float-3'
I: resampler.c: Using float32le as working format.
I: resampler.c: Choosing speex quality setting 3.
I: source-output.c: Created output 0 "Audio Stream" on alsa_input.pci_1102_7_sound_card_0_alsa_capture_0 with sample spec u8 1ch 8000Hz and channel map mono
D: memblockq.c: memblockq requested: maxlength=13312, tlength=0, base=1, prebuf=1, minreq=0
D: memblockq.c: memblockq sanitized: maxlength=13312, tlength=13312, base=1, prebuf=1, minreq=1
D: module-suspend-on-idle.c: Source alsa_input.pci_1102_7_sound_card_0_alsa_capture_0 becomes idle.
D: module-suspend-on-idle.c: Source alsa_input.pci_1102_7_sound_card_0_alsa_capture_0 becomes idle.
I: source-output.c: Freeing output 0 "Audio Stream"
I: module-volume-restore.c: Restoring source for <pulsecore/protocol-native.c$OSS Emulation[teamspeak.real]>
D: module-suspend-on-idle.c: Source alsa_input.pci_1102_7_sound_card_0_alsa_capture_0 becomes busy.
D: resampler.c: Channel matrix:
D: resampler.c: I00 I01
D: resampler.c: +------------
D: resampler.c: O00 | 1,000 1,000
I: resampler.c: Using resampler 'speex-float-3'
I: resampler.c: Using float32le as working format.
I: resampler.c: Choosing speex quality setting 3.
I: source-output.c: Created output 1 "Audio Stream" on alsa_input.pci_1102_7_sound_card_0_alsa_capture_0 with sample spec u8 1ch 8000Hz and channel map mono
D: memblockq.c: memblockq requested: maxlength=13312, tlength=0, base=1, prebuf=1, minreq=0
D: memblockq.c: memblockq sanitized: maxlength=13312, tlength=13312, base=1, prebuf=1, minreq=1
D: module-suspend-on-idle.c: Source alsa_input.pci_1102_7_sound_card_0_alsa_capture_0 becomes idle.
D: module-suspend-on-idle.c: Source alsa_input.pci_1102_7_sound_card_0_alsa_capture_0 becomes idle.
I: source-output.c: Freeing output 1 "Audio Stream"
I: module-volume-restore.c: Restoring source for <pulsecore/protocol-native.c$OSS Emulation[teamspeak.real]>
D: module-suspend-on-idle.c: Source alsa_input.pci_1102_7_sound_card_0_alsa_capture_0 becomes busy.
D: resampler.c: Channel matrix:
D: resampler.c: I00 I01
D: resampler.c: +------------
D: resampler.c: O00 | 1,000 1,000
I: resampler.c: Using resampler 'speex-float-3'
I: resampler.c: Using float32le as working format.
I: resampler.c: Choosing speex quality setting 3.
I: source-output.c: Created output 2 "Audio Stream" on alsa_input.pci_1102_7_sound_card_0_alsa_capture_0 with sample spec u8 1ch 8000Hz and channel map mono
D: memblockq.c: memblockq requested: maxlength=16384, tlength=0, base=1, prebuf=1, minreq=0
D: memblockq.c: memblockq sanitized: maxlength=16384, tlength=16384, base=1, prebuf=1, minreq=1
D: module-suspend-on-idle.c: Source alsa_input.pci_1102_7_sound_card_0_alsa_capture_0 becomes idle.
D: module-suspend-on-idle.c: Source alsa_input.pci_1102_7_sound_card_0_alsa_capture_0 becomes idle.
I: source-output.c: Freeing output 2 "Audio Stream"
I: module-volume-restore.c: Restoring source for <pulsecore/protocol-native.c$OSS Emulation[teamspeak.real]>
D: module-suspend-on-idle.c: Source alsa_input.pci_1102_7_sound_card_0_alsa_capture_0 becomes busy.
D: resampler.c: Channel matrix:
D: resampler.c: I00 I01
D: resampler.c: +------------
D: resampler.c: O00 | 1,000 1,000
I: resampler.c: Using resampler 'speex-float-3'
I: resampler.c: Using float32le as working format.
I: resampler.c: Choosing speex quality setting 3.
I: source-output.c: Created output 3 "Audio Stream" on alsa_input.pci_1102_7_sound_card_0_alsa_capture_0 with sample spec s16le 1ch 8000Hz and channel map mono
D: memblockq.c: memblockq requested: maxlength=16384, tlength=0, base=2, prebuf=1, minreq=0
D: memblockq.c: memblockq sanitized: maxlength=16384, tlength=16384, base=2, prebuf=2, minreq=2
D: module-suspend-on-idle.c: Source alsa_input.pci_1102_7_sound_card_0_alsa_capture_0 becomes idle.
D: module-suspend-on-idle.c: Source alsa_input.pci_1102_7_sound_card_0_alsa_capture_0 becomes idle.
I: source-output.c: Freeing output 3 "Audio Stream"
I: module-volume-restore.c: Restoring source for <pulsecore/protocol-native.c$OSS Emulation[teamspeak.real]>
D: module-suspend-on-idle.c: Source alsa_input.pci_1102_7_sound_card_0_alsa_capture_0 becomes busy.
D: resampler.c: Channel matrix:
D: resampler.c: I00 I01
D: resampler.c: +------------
D: resampler.c: O00 | 1,000 1,000
I: resampler.c: Using resampler 'speex-float-3'
I: resampler.c: Using float32le as working format.
I: resampler.c: Choosing speex quality setting 3.
I: source-output.c: Created output 4 "Audio Stream" on alsa_input.pci_1102_7_sound_card_0_alsa_capture_0 with sample spec s16le 1ch 8000Hz and channel map mono
D: memblockq.c: memblockq requested: maxlength=16384, tlength=0, base=2, prebuf=1, minreq=0
D: memblockq.c: memblockq sanitized: maxlength=16384, tlength=16384, base=2, prebuf=2, minreq=2
D: module-suspend-on-idle.c: Source alsa_input.pci_1102_7_sound_card_0_alsa_capture_0 becomes idle.
D: module-suspend-on-idle.c: Source alsa_input.pci_1102_7_sound_card_0_alsa_capture_0 becomes idle.
I: source-output.c: Freeing output 4 "Audio Stream"
I: module-volume-restore.c: Restoring source for <pulsecore/protocol-native.c$OSS Emulation[teamspeak.real]>
D: module-suspend-on-idle.c: Source alsa_input.pci_1102_7_sound_card_0_alsa_capture_0 becomes busy.
D: resampler.c: Channel matrix:
D: resampler.c: I00 I01
D: resampler.c: +------------
D: resampler.c: O00 | 1,000 1,000
I: resampler.c: Using resampler 'speex-float-3'
I: resampler.c: Using float32le as working format.
I: resampler.c: Choosing speex quality setting 3.
I: source-output.c: Created output 5 "Audio Stream" on alsa_input.pci_1102_7_sound_card_0_alsa_capture_0 with sample spec s16le 1ch 22050Hz and channel map mono
D: memblockq.c: memblockq requested: maxlength=16384, tlength=0, base=2, prebuf=1, minreq=0
D: memblockq.c: memblockq sanitized: maxlength=16384, tlength=16384, base=2, prebuf=2, minreq=2
I: module-volume-restore.c: Restoring sink for <pulsecore/protocol-native.c$OSS Emulation[teamspeak.real]>
I: module-volume-restore.c: Restoring volume for <pulsecore/protocol-native.c$OSS Emulation[teamspeak.real]>
I: module-alsa-sink.c: Trying resume...
I: module-alsa-sink.c: Resumed successfully...
I: module-alsa-sink.c: Starting playback.
D: module-suspend-on-idle.c: Sink alsa_output.pci_1102_7_sound_card_0_alsa_playback_ 0 becomes idle.
D: module-suspend-on-idle.c: Sink alsa_output.pci_1102_7_sound_card_0_alsa_playback_ 0 becomes busy.
D: resampler.c: Channel matrix:
D: resampler.c: I00
D: resampler.c: +------
D: resampler.c: O00 | 1,000
D: resampler.c: O01 | 1,000
I: resampler.c: Using resampler 'speex-float-3'
I: resampler.c: Using float32le as working format.
I: resampler.c: Choosing speex quality setting 3.
I: sink-input.c: Created input 0 "Audio Stream" on alsa_output.pci_1102_7_sound_card_0_alsa_playback_ 0 with sample spec s16le 1ch 22050Hz and channel map mono
D: memblockq.c: memblockq requested: maxlength=16384, tlength=12288, base=2, prebuf=4096, minreq=4096
D: memblockq.c: memblockq sanitized: maxlength=16384, tlength=12288, base=2, prebuf=4096, minreq=4096
D: memblock.c: Memory block too large for pool: 18344 > 16368
D: memblock.c: Memory block too large for pool: 16896 > 16368
D: memblock.c: Memory block too large for pool: 16960 > 16368
D: memblock.c: Memory block too large for pool: 17024 > 16368
D: memblock.c: Memory block too large for pool: 17088 > 16368
D: memblock.c: Memory block too large for pool: 17536 > 16368


I also got unlimited:

D: memblock.c: Pool full

How to configure this in order not to have memory filled ? How to improve my sound capture quality ?

Setting the output to max makes the sound crashing. But setting it at the middle and increasing the output on the speakers, sound is fine.
Input has to be set to max to be quite audible. Don't know if that helps.

What can I do ?

ethos_dacapo
August 14th, 2008, 04:29 AM
My little laptop speakers are still being shredded by the lack of eq lol
After i set everything up i didn't notice any difference so i tried adjusting the eq killed pulse and restarted this is what i get:


$ pulseaudio
W: main.c: RLIMIT_RTPRIO failed: Operation not permitted
ALSA lib pcm_ladspa.c:1275:(snd_pcm_ladspa_parse_controls) Control port 2 has not an float or integer value
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL equalized
ALSA lib conf.c:3952:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM surround71:0
E: alsa-util.c: Error opening PCM device hw:0: Device or resource busy
E: module.c: Failed to load module "module-alsa-sink" (argument: "device_id=0 sink_name=alsa_output.pci_8086_2485_sound_card_0_a lsa_playback_0"): initialization failed.
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
ALSA lib pcm_ladspa.c:1275:(snd_pcm_ladspa_parse_controls) Control port 2 has not an float or integer value
ALSA lib pcm_ladspa.c:1275:(snd_pcm_ladspa_parse_controls) Control port 2 has not an float or integer value
ALSA lib pcm_ladspa.c:1275:(snd_pcm_ladspa_parse_controls) Control port 2 has not an float or integer value


now what?

helps if you type this in the right box: btw i just noticed flash is no longer working!!! What went wrong??

edit: oops! i already had flash installed and when i added the nonfree from synaptic it confused the heck out of firefox. Doh!

Still wondering whats up with these error messages from pulse....

dansan
August 14th, 2008, 09:41 AM
Thanks for the fast response. Mine had to wait as I am based in Iceland (GMT), so I didn't see your post till I got home (computer involved is my office desktop). Here is the output you requested.


...Please post the verbose log of PulseAudio (see Appendix B)

$ pulseaudio -k; sleep 4; pulseaudio -vv

I: main.c: Called SUID root and real-time/high-priority scheduling was requested in the configuration. However, we lack the necessary priviliges:
I: main.c: We are not in group 'pulse-rt' and PolicyKit refuse to grant us priviliges. Dropping SUID again.
I: main.c: For enabling real-time scheduling please acquire the appropriate PolicyKit priviliges, or become a member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.
I: main.c: Note that real-time/high-priority scheduling is NOT normally required. If you experience crackling or other sound anomalies, consider one or more of the above solutions.
I: main.c: High-priority scheduling enabled in configuration but now allowed by policy. Disabling forcibly.
I: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
I: main.c: This is PulseAudio 0.9.10
I: main.c: Page size is 4096 bytes
I: main.c: Fresh high-resolution timers available! Bon appetit!
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-hal-detect.so': success
I: module-hal-detect.c: Trying capability alsa
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/computer_alsa_timer
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/computer_alsa_sequencer
D: module-hal-detect.c: Loading module-alsa-sink with arguments 'device_id=2 sink_name=alsa_output.usb_device_47f_410_noserial_ if0_sound_card_0_alsa_playback_0'
D: alsa-util.c: Trying front:2...
I: module-alsa-sink.c: Successfully opened device front:2.
I: module-alsa-sink.c: Successfully enabled mmap() mode.
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:2
I: alsa-util.c: Unable to attach to mixer front:2: No such file or directory
I: alsa-util.c: Successfully attached to mixer 'hw:2'
I: alsa-util.c: Cannot find mixer control "Master".
I: alsa-util.c: Using mixer control "PCM".
I: sink.c: Created sink 0 "alsa_output.usb_device_47f_410_noserial_if0_sound_ card_0_alsa_playback_0" with sample spec "s16le 2ch 44100Hz"
I: source.c: Created source 0 "alsa_output.usb_device_47f_410_noserial_if0_sound_ card_0_alsa_playback_0.monitor" with sample spec "s16le 2ch 44100Hz"
I: module-alsa-sink.c: Using 4 fragments of size 4408 bytes.
I: alsa-util.c: All 2 channels can be mapped to mixer channels. Using hardware volume control.
D: module-alsa-sink.c: Thread starting up
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+29
I: module-alsa-sink.c: Starting playback.
I: module.c: Loaded "module-alsa-sink" (index: #0; argument: "device_id=2 sink_name=alsa_output.usb_device_47f_410_noserial_ if0_sound_card_0_alsa_playback_0").
D: module-hal-detect.c: Loading module-alsa-source with arguments 'device_id=2 source_name=alsa_input.usb_device_47f_410_noserial _if0_sound_card_0_alsa_capture_0'
D: alsa-util.c: Trying front:2...
I: module-alsa-source.c: Successfully opened device front:2.
I: module-alsa-source.c: Successfully enabled mmap() mode.
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:2
I: alsa-util.c: Unable to attach to mixer front:2: No such file or directory
I: alsa-util.c: Successfully attached to mixer 'hw:2'
I: alsa-util.c: Cannot find mixer control "Capture".
I: alsa-util.c: Using mixer control "Mic".
I: source.c: Created source 1 "alsa_input.usb_device_47f_410_noserial_if0_sound_c ard_0_alsa_capture_0" with sample spec "s16le 2ch 44100Hz"
I: module-alsa-source.c: Using 4 fragments of size 4408 bytes.
I: alsa-util.c: ALSA device lacks separate volumes control for channel 'front-right', falling back to software volume control.
D: module-alsa-source.c: Thread starting up
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+28
I: module.c: Loaded "module-alsa-source" (index: #1; argument: "device_id=2 source_name=alsa_input.usb_device_47f_410_noserial _if0_sound_card_0_alsa_capture_0").
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/usb_device_47f_410_noserial_if0_sound_card_0_alsa_ control__1
D: module-hal-detect.c: Loading module-alsa-sink with arguments 'device_id=0 sink_name=alsa_output.usb_device_556_4_noserial_if 0_sound_card_0_alsa_playback_0'
D: alsa-util.c: Trying front:0...
I: module-alsa-sink.c: Successfully opened device front:0.
I: module-alsa-sink.c: Successfully enabled mmap() mode.
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
I: alsa-util.c: Unable to attach to mixer front:0: No such file or directory
I: alsa-util.c: Successfully attached to mixer 'hw:0'
I: alsa-util.c: Cannot find mixer control "Master".
I: alsa-util.c: Using mixer control "PCM".
I: sink.c: Created sink 1 "alsa_output.usb_device_556_4_noserial_if0_sound_ca rd_0_alsa_playback_0" with sample spec "s16le 2ch 44100Hz"
I: source.c: Created source 2 "alsa_output.usb_device_556_4_noserial_if0_sound_ca rd_0_alsa_playback_0.monitor" with sample spec "s16le 2ch 44100Hz"
I: module-alsa-sink.c: Using 4 fragments of size 4408 bytes.
D: module-alsa-sink.c: Thread starting up
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+27
I: module-alsa-sink.c: Starting playback.
I: module.c: Loaded "module-alsa-sink" (index: #2; argument: "device_id=0 sink_name=alsa_output.usb_device_556_4_noserial_if 0_sound_card_0_alsa_playback_0").
D: module-hal-detect.c: Loading module-alsa-source with arguments 'device_id=0 source_name=alsa_input.usb_device_556_4_noserial_i f0_sound_card_0_alsa_capture_0'
D: alsa-util.c: Trying front:0...
I: alsa-util.c: PCM device front:0 refused our hw parameters: Invalid argument
D: alsa-util.c: Trying surround40:0...
I: alsa-util.c: PCM device surround40:0 refused our hw parameters: Invalid argument
D: alsa-util.c: Trying surround41:0...
I: alsa-util.c: PCM device surround41:0 refused our hw parameters: Invalid argument
D: alsa-util.c: Trying surround50:0...
I: alsa-util.c: PCM device surround50:0 refused our hw parameters: Invalid argument
D: alsa-util.c: Trying surround51:0...
I: alsa-util.c: PCM device surround51:0 refused our hw parameters: Invalid argument
D: alsa-util.c: Trying surround71:0...
I: alsa-util.c: PCM device surround71:0 refused our hw parameters: Invalid argument
D: alsa-util.c: Trying hw:0 as last resort...
W: alsa-util.c: Device hw:0 doesn't support 2 channels, changed to 1.
I: module-alsa-source.c: Successfully opened device hw:0.
I: module-alsa-source.c: Successfully enabled mmap() mode.
I: alsa-util.c: Successfully attached to mixer 'hw:0'
I: alsa-util.c: Cannot find mixer control "Capture".
I: alsa-util.c: Using mixer control "Mic".
I: source.c: Created source 3 "alsa_input.usb_device_556_4_noserial_if0_sound_car d_0_alsa_capture_0" with sample spec "s16le 1ch 44100Hz"
I: module-alsa-source.c: Using 4 fragments of size 2204 bytes.
D: module-alsa-source.c: Thread starting up
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+26
I: module.c: Loaded "module-alsa-source" (index: #3; argument: "device_id=0 source_name=alsa_input.usb_device_556_4_noserial_i f0_sound_card_0_alsa_capture_0").
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/usb_device_556_4_noserial_if0_sound_card_0_alsa_co ntrol__1
D: module-hal-detect.c: Loading module-alsa-source with arguments 'device_id=1 source_name=alsa_input.usb_device_556_1_noserial_i f0_sound_card_0_alsa_capture_0'
D: alsa-util.c: Trying front:1...
I: alsa-util.c: PCM device front:1 refused our hw parameters: Invalid argument
D: alsa-util.c: Trying surround40:1...
I: alsa-util.c: PCM device surround40:1 refused our hw parameters: Invalid argument
D: alsa-util.c: Trying surround41:1...
I: alsa-util.c: PCM device surround41:1 refused our hw parameters: Invalid argument
D: alsa-util.c: Trying surround50:1...
I: alsa-util.c: PCM device surround50:1 refused our hw parameters: Invalid argument
D: alsa-util.c: Trying surround51:1...
I: alsa-util.c: PCM device surround51:1 refused our hw parameters: Invalid argument
D: alsa-util.c: Trying surround71:1...
I: alsa-util.c: PCM device surround71:1 refused our hw parameters: Invalid argument
D: alsa-util.c: Trying hw:1 as last resort...
W: alsa-util.c: Device hw:1 doesn't support 2 channels, changed to 1.
I: module-alsa-source.c: Successfully opened device hw:1.
I: module-alsa-source.c: Successfully enabled mmap() mode.
I: alsa-util.c: Successfully attached to mixer 'hw:1'
I: alsa-util.c: Cannot find mixer control "Capture".
I: alsa-util.c: Using mixer control "Mic".
I: source.c: Created source 4 "alsa_input.usb_device_556_1_noserial_if0_sound_car d_0_alsa_capture_0" with sample spec "s16le 1ch 44100Hz"
I: module-alsa-source.c: Using 4 fragments of size 2204 bytes.
I: alsa-util.c: All 1 channels can be mapped to mixer channels. Using hardware volume control.
D: module-alsa-source.c: Thread starting up
D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+25
I: module.c: Loaded "module-alsa-source" (index: #4; argument: "device_id=1 source_name=alsa_input.usb_device_556_1_noserial_i f0_sound_card_0_alsa_capture_0").
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/usb_device_556_1_noserial_if0_sound_card_0_alsa_co ntrol__1
I: module-hal-detect.c: Loaded 5 modules.
I: module.c: Loaded "module-hal-detect" (index: #5; argument: "").
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-esound-protocol-unix.so': success
I: module.c: Loaded "module-esound-protocol-unix" (index: #6; argument: "").
I: protocol-native.c: loading cookie from disk.
I: module.c: Loaded "module-native-protocol-unix" (index: #7; argument: "").
I: module.c: Loaded "module-volume-restore" (index: #8; argument: "").
D: module-default-device-restore.c: Restored default sink 'alsa_output.usb_device_47f_410_noserial_if0_sound _card_0_alsa_playback_0'.
D: core-subscribe.c: dropped redundant event.
D: module-default-device-restore.c: Restored default source 'alsa_input.usb_device_47f_410_noserial_if0_sound_ card_0_alsa_capture_0'.
I: module.c: Loaded "module-default-device-restore" (index: #9; argument: "").
I: module.c: Loaded "module-rescue-streams" (index: #10; argument: "").
D: module-suspend-on-idle.c: Sink alsa_output.usb_device_47f_410_noserial_if0_sound_ card_0_alsa_playback_0 becomes idle.
D: module-suspend-on-idle.c: Sink alsa_output.usb_device_556_4_noserial_if0_sound_ca rd_0_alsa_playback_0 becomes idle.
D: module-suspend-on-idle.c: Source alsa_output.usb_device_47f_410_noserial_if0_sound_ card_0_alsa_playback_0.monitor becomes idle.
D: module-suspend-on-idle.c: Source alsa_input.usb_device_47f_410_noserial_if0_sound_c ard_0_alsa_capture_0 becomes idle.
D: module-suspend-on-idle.c: Source alsa_output.usb_device_556_4_noserial_if0_sound_ca rd_0_alsa_playback_0.monitor becomes idle.
D: module-suspend-on-idle.c: Source alsa_input.usb_device_556_4_noserial_if0_sound_car d_0_alsa_capture_0 becomes idle.
D: module-suspend-on-idle.c: Source alsa_input.usb_device_556_1_noserial_if0_sound_car d_0_alsa_capture_0 becomes idle.
I: module.c: Loaded "module-suspend-on-idle" (index: #11; argument: "").
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-gconf.so': success
I: module.c: Loaded "module-gconf" (index: #12; argument: "").
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-x11-publish.so': success
D: module-x11-publish.c: using already loaded auth cookie.
I: module.c: Loaded "module-x11-publish" (index: #13; argument: "").
I: main.c: Daemon startup complete.
D: module-hal-detect.c: dbus: interface=org.freedesktop.DBus, path=/org/freedesktop/DBus, member=NameAcquired
I: module-suspend-on-idle.c: Source alsa_input.usb_device_556_1_noserial_if0_sound_car d_0_alsa_capture_0 idle for too long, suspending ...
I: module-alsa-source.c: Device suspended...
I: module-suspend-on-idle.c: Source alsa_input.usb_device_556_4_noserial_if0_sound_car d_0_alsa_capture_0 idle for too long, suspending ...
I: module-alsa-source.c: Device suspended...
I: module-suspend-on-idle.c: Source alsa_output.usb_device_556_4_noserial_if0_sound_ca rd_0_alsa_playback_0.monitor idle for too long, suspending ...
I: module-suspend-on-idle.c: Source alsa_input.usb_device_47f_410_noserial_if0_sound_c ard_0_alsa_capture_0 idle for too long, suspending ...
I: module-alsa-source.c: Device suspended...
I: module-suspend-on-idle.c: Source alsa_output.usb_device_47f_410_noserial_if0_sound_ card_0_alsa_playback_0.monitor idle for too long, suspending ...
I: module-suspend-on-idle.c: Sink alsa_output.usb_device_556_4_noserial_if0_sound_ca rd_0_alsa_playback_0 idle for too long, suspending ...
I: module-alsa-sink.c: Device suspended...
I: module-suspend-on-idle.c: Sink alsa_output.usb_device_47f_410_noserial_if0_sound_ card_0_alsa_playback_0 idle for too long, suspending ...
I: module-alsa-sink.c: Device suspended...


and also the listing of /proc/asound/pcm (and any other sound logs you can think may be helpful). This may be an ALSA bug.

$ cat /proc/asound/pcm

01-00: USB Audio : USB Audio : capture 1
00-00: USB Audio : USB Audio : playback 1 : capture 1
02-00: USB Audio : USB Audio : playback 1 : capture 1

After reading through pulseaudio.log, I added my user and root to the pulse-rt group, restarted and rechecked the log output:


I: main.c: We're in the group 'pulse-rt', allowing real-time and high-priority scheduling.

I: core-util.c: Successfully gained nice level -11.

I: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted

I: main.c: This is PulseAudio 0.9.10

I: main.c: Page size is 4096 bytes

I: main.c: Fresh high-resolution timers available! Bon appetit!

D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-hal-detect.so': success

I: module-hal-detect.c: Trying capability alsa

D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/computer_alsa_timer

D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/computer_alsa_sequencer

D: module-hal-detect.c: Loading module-alsa-sink with arguments 'device_id=2 sink_name=alsa_output.usb_device_47f_410_noserial_ if0_sound_card_0_alsa_playback_0'

D: alsa-util.c: Trying front:2...

I: module-alsa-sink.c: Successfully opened device front:2.

I: module-alsa-sink.c: Successfully enabled mmap() mode.

ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:2

I: alsa-util.c: Unable to attach to mixer front:2: No such file or directory

I: alsa-util.c: Successfully attached to mixer 'hw:2'

I: alsa-util.c: Cannot find mixer control "Master".

I: alsa-util.c: Using mixer control "PCM".

I: sink.c: Created sink 0 "alsa_output.usb_device_47f_410_noserial_if0_sound_ card_0_alsa_playback_0" with sample spec "s16le 2ch 44100Hz"

I: source.c: Created source 0 "alsa_output.usb_device_47f_410_noserial_if0_sound_ card_0_alsa_playback_0.monitor" with sample spec "s16le 2ch 44100Hz"

I: module-alsa-sink.c: Using 4 fragments of size 4408 bytes.

I: alsa-util.c: All 2 channels can be mapped to mixer channels. Using hardware volume control.

D: module-alsa-sink.c: Thread starting up

D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+29

I: module-alsa-sink.c: Starting playback.

I: module.c: Loaded "module-alsa-sink" (index: #0; argument: "device_id=2 sink_name=alsa_output.usb_device_47f_410_noserial_ if0_sound_card_0_alsa_playback_0").

D: module-hal-detect.c: Loading module-alsa-source with arguments 'device_id=2 source_name=alsa_input.usb_device_47f_410_noserial _if0_sound_card_0_alsa_capture_0'

D: alsa-util.c: Trying front:2...

I: module-alsa-source.c: Successfully opened device front:2.

I: module-alsa-source.c: Successfully enabled mmap() mode.

ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:2

I: alsa-util.c: Unable to attach to mixer front:2: No such file or directory

I: alsa-util.c: Successfully attached to mixer 'hw:2'

I: alsa-util.c: Cannot find mixer control "Capture".

I: alsa-util.c: Using mixer control "Mic".

I: source.c: Created source 1 "alsa_input.usb_device_47f_410_noserial_if0_sound_c ard_0_alsa_capture_0" with sample spec "s16le 2ch 44100Hz"

I: module-alsa-source.c: Using 4 fragments of size 4408 bytes.

I: alsa-util.c: ALSA device lacks separate volumes control for channel 'front-right', falling back to software volume control.

D: module-alsa-source.c: Thread starting up

D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+28

I: module.c: Loaded "module-alsa-source" (index: #1; argument: "device_id=2 source_name=alsa_input.usb_device_47f_410_noserial _if0_sound_card_0_alsa_capture_0").

D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/usb_device_47f_410_noserial_if0_sound_card_0_alsa_ control__1

D: module-hal-detect.c: Loading module-alsa-sink with arguments 'device_id=0 sink_name=alsa_output.usb_device_556_4_noserial_if 0_sound_card_0_alsa_playback_0'

D: alsa-util.c: Trying front:0...

I: module-alsa-sink.c: Successfully opened device front:0.

I: module-alsa-sink.c: Successfully enabled mmap() mode.

ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0

I: alsa-util.c: Unable to attach to mixer front:0: No such file or directory

I: alsa-util.c: Successfully attached to mixer 'hw:0'

I: alsa-util.c: Cannot find mixer control "Master".

I: alsa-util.c: Using mixer control "PCM".

I: sink.c: Created sink 1 "alsa_output.usb_device_556_4_noserial_if0_sound_ca rd_0_alsa_playback_0" with sample spec "s16le 2ch 44100Hz"

I: source.c: Created source 2 "alsa_output.usb_device_556_4_noserial_if0_sound_ca rd_0_alsa_playback_0.monitor" with sample spec "s16le 2ch 44100Hz"

I: module-alsa-sink.c: Using 4 fragments of size 4408 bytes.

D: module-alsa-sink.c: Thread starting up

D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+27

I: module-alsa-sink.c: Starting playback.

I: module.c: Loaded "module-alsa-sink" (index: #2; argument: "device_id=0 sink_name=alsa_output.usb_device_556_4_noserial_if 0_sound_card_0_alsa_playback_0").

D: module-hal-detect.c: Loading module-alsa-source with arguments 'device_id=0 source_name=alsa_input.usb_device_556_4_noserial_i f0_sound_card_0_alsa_capture_0'

D: alsa-util.c: Trying front:0...

I: alsa-util.c: PCM device front:0 refused our hw parameters: Invalid argument

D: alsa-util.c: Trying surround40:0...

I: alsa-util.c: PCM device surround40:0 refused our hw parameters: Invalid argument

D: alsa-util.c: Trying surround41:0...

I: alsa-util.c: PCM device surround41:0 refused our hw parameters: Invalid argument

D: alsa-util.c: Trying surround50:0...

I: alsa-util.c: PCM device surround50:0 refused our hw parameters: Invalid argument

D: alsa-util.c: Trying surround51:0...

I: alsa-util.c: PCM device surround51:0 refused our hw parameters: Invalid argument

D: alsa-util.c: Trying surround71:0...

I: alsa-util.c: PCM device surround71:0 refused our hw parameters: Invalid argument

D: alsa-util.c: Trying hw:0 as last resort...

W: alsa-util.c: Device hw:0 doesn't support 2 channels, changed to 1.

I: module-alsa-source.c: Successfully opened device hw:0.

I: module-alsa-source.c: Successfully enabled mmap() mode.

I: alsa-util.c: Successfully attached to mixer 'hw:0'

I: alsa-util.c: Cannot find mixer control "Capture".

I: alsa-util.c: Using mixer control "Mic".

I: source.c: Created source 3 "alsa_input.usb_device_556_4_noserial_if0_sound_car d_0_alsa_capture_0" with sample spec "s16le 1ch 44100Hz"

I: module-alsa-source.c: Using 4 fragments of size 2204 bytes.

D: module-alsa-source.c: Thread starting up

D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+26

I: module.c: Loaded "module-alsa-source" (index: #3; argument: "device_id=0 source_name=alsa_input.usb_device_556_4_noserial_i f0_sound_card_0_alsa_capture_0").

D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/usb_device_556_4_noserial_if0_sound_card_0_alsa_co ntrol__1

D: module-hal-detect.c: Loading module-alsa-source with arguments 'device_id=1 source_name=alsa_input.usb_device_556_1_noserial_i f0_sound_card_0_alsa_capture_0'

D: alsa-util.c: Trying front:1...

I: alsa-util.c: PCM device front:1 refused our hw parameters: Invalid argument

D: alsa-util.c: Trying surround40:1...

I: alsa-util.c: PCM device surround40:1 refused our hw parameters: Invalid argument

D: alsa-util.c: Trying surround41:1...

I: alsa-util.c: PCM device surround41:1 refused our hw parameters: Invalid argument

D: alsa-util.c: Trying surround50:1...

I: alsa-util.c: PCM device surround50:1 refused our hw parameters: Invalid argument

D: alsa-util.c: Trying surround51:1...

I: alsa-util.c: PCM device surround51:1 refused our hw parameters: Invalid argument

D: alsa-util.c: Trying surround71:1...

I: alsa-util.c: PCM device surround71:1 refused our hw parameters: Invalid argument

D: alsa-util.c: Trying hw:1 as last resort...

W: alsa-util.c: Device hw:1 doesn't support 2 channels, changed to 1.

I: module-alsa-source.c: Successfully opened device hw:1.

I: module-alsa-source.c: Successfully enabled mmap() mode.

I: alsa-util.c: Successfully attached to mixer 'hw:1'

I: alsa-util.c: Cannot find mixer control "Capture".

I: alsa-util.c: Using mixer control "Mic".

I: source.c: Created source 4 "alsa_input.usb_device_556_1_noserial_if0_sound_car d_0_alsa_capture_0" with sample spec "s16le 1ch 44100Hz"

I: module-alsa-source.c: Using 4 fragments of size 2204 bytes.

I: alsa-util.c: All 1 channels can be mapped to mixer channels. Using hardware volume control.

D: module-alsa-source.c: Thread starting up

D: rtpoll.c: Acquired POSIX realtime signal SIGRTMIN+25

I: module.c: Loaded "module-alsa-source" (index: #4; argument: "device_id=1 source_name=alsa_input.usb_device_556_1_noserial_i f0_sound_card_0_alsa_capture_0").

D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/usb_device_556_1_noserial_if0_sound_card_0_alsa_co ntrol__1

I: module-hal-detect.c: Loaded 5 modules.

I: module.c: Loaded "module-hal-detect" (index: #5; argument: "").

D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-esound-protocol-unix.so': success

I: module.c: Loaded "module-esound-protocol-unix" (index: #6; argument: "").

I: protocol-native.c: loading cookie from disk.

I: module.c: Loaded "module-native-protocol-unix" (index: #7; argument: "").

I: module.c: Loaded "module-volume-restore" (index: #8; argument: "").

D: module-default-device-restore.c: Restored default sink 'alsa_output.usb_device_47f_410_noserial_if0_sound _card_0_alsa_playback_0'.

D: core-subscribe.c: dropped redundant event.

D: module-default-device-restore.c: Restored default source 'alsa_input.usb_device_47f_410_noserial_if0_sound_ card_0_alsa_capture_0'.

I: module.c: Loaded "module-default-device-restore" (index: #9; argument: "").

I: module.c: Loaded "module-rescue-streams" (index: #10; argument: "").

D: module-suspend-on-idle.c: Sink alsa_output.usb_device_47f_410_noserial_if0_sound_ card_0_alsa_playback_0 becomes idle.

D: module-suspend-on-idle.c: Sink alsa_output.usb_device_556_4_noserial_if0_sound_ca rd_0_alsa_playback_0 becomes idle.

D: module-suspend-on-idle.c: Source alsa_output.usb_device_47f_410_noserial_if0_sound_ card_0_alsa_playback_0.monitor becomes idle.

D: module-suspend-on-idle.c: Source alsa_input.usb_device_47f_410_noserial_if0_sound_c ard_0_alsa_capture_0 becomes idle.

D: module-suspend-on-idle.c: Source alsa_output.usb_device_556_4_noserial_if0_sound_ca rd_0_alsa_playback_0.monitor becomes idle.

D: module-suspend-on-idle.c: Source alsa_input.usb_device_556_4_noserial_if0_sound_car d_0_alsa_capture_0 becomes idle.

D: module-suspend-on-idle.c: Source alsa_input.usb_device_556_1_noserial_if0_sound_car d_0_alsa_capture_0 becomes idle.

I: module.c: Loaded "module-suspend-on-idle" (index: #11; argument: "").

D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-gconf.so': success

I: module.c: Loaded "module-gconf" (index: #12; argument: "").

D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules/module-x11-publish.so': success

D: module-x11-publish.c: using already loaded auth cookie.

I: module.c: Loaded "module-x11-publish" (index: #13; argument: "").

I: main.c: Daemon startup complete.

D: module-hal-detect.c: dbus: interface=org.freedesktop.DBus, path=/org/freedesktop/DBus, member=NameAcquired

I: module-suspend-on-idle.c: Sink alsa_output.usb_device_47f_410_noserial_if0_sound_ card_0_alsa_playback_0 idle for too long, suspending ...

I: module-alsa-sink.c: Device suspended...

I: module-suspend-on-idle.c: Source alsa_input.usb_device_556_1_noserial_if0_sound_car d_0_alsa_capture_0 idle for too long, suspending ...

I: module-alsa-source.c: Device suspended...

I: module-suspend-on-idle.c: Source alsa_input.usb_device_556_4_noserial_if0_sound_car d_0_alsa_capture_0 idle for too long, suspending ...

I: module-alsa-source.c: Device suspended...

I: module-suspend-on-idle.c: Source alsa_output.usb_device_556_4_noserial_if0_sound_ca rd_0_alsa_playback_0.monitor idle for too long, suspending ...

I: module-suspend-on-idle.c: Source alsa_input.usb_device_47f_410_noserial_if0_sound_c ard_0_alsa_capture_0 idle for too long, suspending ...

I: module-alsa-source.c: Device suspended...

I: module-suspend-on-idle.c: Source alsa_output.usb_device_47f_410_noserial_if0_sound_ card_0_alsa_playback_0.monitor idle for too long, suspending ...

I: module-suspend-on-idle.c: Sink alsa_output.usb_device_556_4_noserial_if0_sound_ca rd_0_alsa_playback_0 idle for too long, suspending ...

I: module-alsa-sink.c: Device suspended...

I: client.c: Created 0 "EsounD client (UNIX socket client)"

But these changes still didn't change the Pulse Audio Volume Control to give me an option to output through my speakers.

psyke83
August 14th, 2008, 03:59 PM
Edit: this temporary version of the PulseAudio Fixes guide has been removed. Please look to the original location (http://ubuntuforums.org/showthread.php?t=789578) of the guide for the latest instructions.

Thanks!

dansan
August 14th, 2008, 04:42 PM
Wow! I think your forum name should be psyke83_MAGICIAN. This worked like magic. It got my onboard sound card registerered with Pulse Audio Volume Control, enabling me to set it as default. Now I can listen to sound on my speakers. What a relief!


(it's my first attempt, so there could be issues)

It looks and feels like top professional work, but if anything comes up, I'll be sure to drop you a line.

Many thanks!

shantzg001
August 14th, 2008, 06:24 PM
psyke: Thanks, now my pulse audio setup works fine after adding your PPA. However, installing flash plugin through your PPA throws an error:

*** NSPlugin Viewer *** ERROR: libcurl.so.3: cannot open shared object file: No such file or directory
nspluginwrapper: no appropriate viewer found for /usr/lib/flashplugin-nonfree/libflashplayer.so
dpkg: error processing flashplugin-nonfree (--configure):
subprocess post-installation script returned error exit status 1


I'm using 64 bit Hardy Heron, BTW

psyke83
August 14th, 2008, 06:57 PM
psyke: Thanks, now my pulse audio setup works fine after adding your PPA. However, installing flash plugin through your PPA throws an error:


I'm using 64 bit Hardy Heron, BTW

Flash has a couple of new dependencies, and libcurl3 is one of them - but the new package should have installed the new dependencies. Can you verify if it's installed on your system?


$ sudo dpkg -l | grep libcurl3

I suspect that nspluginwrapper tried to "wrap" the libflashplayer.so library before libcurl3 was successfully installed, but I can't be sure.

manlypain
August 14th, 2008, 07:01 PM
psyke: Thanks, now my pulse audio setup works fine after adding your PPA. However, installing flash plugin through your PPA throws an error:


I'm using 64 bit Hardy Heron, BTW

i got this

Setting up pulseaudio-module-zeroconf (0.9.10-2ubuntu4~ppa3) ...
Processing triggers for libc6 ...
ldconfig deferred processing now taking place
Errors were encountered while processing:
flashplugin-nonfree
Updating Debian Packages of System Configurations (dpsyco).
E: Sub-process /usr/bin/dpkg returned an error code (1)


I am also using 64bit

psyke83
August 14th, 2008, 07:02 PM
i got this

Can you post the complete apt-get log, please? I can't tell the problem from the excerpt you posted.

manlypain
August 14th, 2008, 07:05 PM
Flash has a couple of new dependencies, and libcurl3 is one of them - but the new package should have installed the new dependencies. Can you verify if it's installed on your system?


$ sudo dpkg -l | grep libcurl3

I suspect that nspluginwrapper tried to "wrap" the libflashplayer.so library before libcurl3 was successfully installed, but I can't be sure.

here is what i got


ii libcurl3 7.18.0-1ubuntu2 Multi-protocol file transfer library (OpenSS
ii libcurl3-gnutls 7.18.0-1ubuntu2 Multi-protocol file transfer library (GnuTLS

psyke83
August 14th, 2008, 07:07 PM
here is what i got

What happens if you try to reinstall the plugin?


$ sudo apt-get install flashplugin-nonfree

manlypain
August 14th, 2008, 07:07 PM
Can you post the complete apt-get log, please? I can't tell the problem from the excerpt you posted.



rklinkefus@linuxcore2:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be upgraded:
alsa-utils flashplugin-nonfree lib32asound2 libasound2 libasound2-dev
libasound2-plugins libpulse-browse0 libpulse-mainloop-glib0 libpulse0
libpulsecore5 pulseaudio pulseaudio-esound-compat pulseaudio-module-gconf
pulseaudio-module-hal pulseaudio-module-x11 pulseaudio-module-zeroconf
pulseaudio-utils
17 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 3496kB of archives.
After this operation, 81.9kB disk space will be freed.
Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
libasound2-dev lib32asound2 libasound2 alsa-utils flashplugin-nonfree
libpulse0 libasound2-plugins libpulse-browse0 libpulse-mainloop-glib0
libpulsecore5 pulseaudio pulseaudio-esound-compat pulseaudio-module-gconf
pulseaudio-module-hal pulseaudio-utils pulseaudio-module-x11
pulseaudio-module-zeroconf
Install these packages without verification [y/N]? y
Get:1 http://ppa.launchpad.net hardy/main libasound2-dev 1.0.16-2ubuntu2~ppa1 [549kB]
Get:2 http://ppa.launchpad.net hardy/main lib32asound2 1.0.16-2ubuntu2~ppa1 [311kB]
Get:3 http://ppa.launchpad.net hardy/main libasound2 1.0.16-2ubuntu2~ppa1 [397kB]
Get:4 http://ppa.launchpad.net hardy/main alsa-utils 1.0.16-1ubuntu3~ppa1 [1076kB]
Get:5 http://ppa.launchpad.net hardy/main flashplugin-nonfree 10.0.1.218+10.0.0.569ubuntu1~ppa2 [19.2kB]
Get:6 http://ppa.launchpad.net hardy/main libpulse0 0.9.10-2ubuntu4~ppa3 [165kB]
Get:7 http://ppa.launchpad.net hardy/main libasound2-plugins 1.0.16-1ubuntu2~ppa1 [136kB]
Get:8 http://ppa.launchpad.net hardy/main libpulse-browse0 0.9.10-2ubuntu4~ppa3 [27.7kB]
Get:9 http://ppa.launchpad.net hardy/main libpulse-mainloop-glib0 0.9.10-2ubuntu4~ppa3 [27.2kB]
Get:10 http://ppa.launchpad.net hardy/main libpulsecore5 0.9.10-2ubuntu4~ppa3 [212kB]
Get:11 http://ppa.launchpad.net hardy/main pulseaudio 0.9.10-2ubuntu4~ppa3 [340kB]
Get:12 http://ppa.launchpad.net hardy/main pulseaudio-esound-compat 0.9.10-2ubuntu4~ppa3 [31.3kB]
Get:13 http://ppa.launchpad.net hardy/main pulseaudio-module-gconf 0.9.10-2ubuntu4~ppa3 [10.8kB]
Get:14 http://ppa.launchpad.net hardy/main pulseaudio-module-hal 0.9.10-2ubuntu4~ppa3 [17.2kB]
Get:15 http://ppa.launchpad.net hardy/main pulseaudio-utils 0.9.10-2ubuntu4~ppa3 [137kB]
Get:16 http://ppa.launchpad.net hardy/main pulseaudio-module-x11 0.9.10-2ubuntu4~ppa3 [18.8kB]
Get:17 http://ppa.launchpad.net hardy/main pulseaudio-module-zeroconf 0.9.10-2ubuntu4~ppa3 [19.5kB]
Fetched 3496kB in 5s (632kB/s)
Preconfiguring packages ...
(Reading database ... 151166 files and directories currently installed.)
Preparing to replace libasound2-dev 1.0.15-3ubuntu4 (using .../libasound2-dev_1.0.16-2ubuntu2~ppa1_amd64.deb) ...
Unpacking replacement libasound2-dev ...
Preparing to replace lib32asound2 1.0.15-3ubuntu4 (using .../lib32asound2_1.0.16-2ubuntu2~ppa1_amd64.deb) ...
Unpacking replacement lib32asound2 ...
Preparing to replace libasound2 1.0.15-3ubuntu4 (using .../libasound2_1.0.16-2ubuntu2~ppa1_amd64.deb) ...
Unpacking replacement libasound2 ...
Preparing to replace alsa-utils 1.0.15-3ubuntu2 (using .../alsa-utils_1.0.16-1ubuntu3~ppa1_amd64.deb) ...
Unpacking replacement alsa-utils ...
Preparing to replace flashplugin-nonfree 9.0.124.0ubuntu2 (using .../flashplugin-nonfree_10.0.1.218+10.0.0.569ubuntu1~ppa2_amd64.de b) ...
Unpacking replacement flashplugin-nonfree ...
Preparing to replace libpulse0 0.9.10-1ubuntu1 (using .../libpulse0_0.9.10-2ubuntu4~ppa3_amd64.deb) ...
Unpacking replacement libpulse0 ...
Preparing to replace libasound2-plugins 1.0.15-1ubuntu3 (using .../libasound2-plugins_1.0.16-1ubuntu2~ppa1_amd64.deb) ...
Unpacking replacement libasound2-plugins ...
Preparing to replace libpulse-browse0 0.9.10-1ubuntu1 (using .../libpulse-browse0_0.9.10-2ubuntu4~ppa3_amd64.deb) ...
Unpacking replacement libpulse-browse0 ...
Preparing to replace libpulse-mainloop-glib0 0.9.10-1ubuntu1 (using .../libpulse-mainloop-glib0_0.9.10-2ubuntu4~ppa3_amd64.deb) ...
Unpacking replacement libpulse-mainloop-glib0 ...
Preparing to replace libpulsecore5 0.9.10-1ubuntu1 (using .../libpulsecore5_0.9.10-2ubuntu4~ppa3_amd64.deb) ...
Unpacking replacement libpulsecore5 ...
Preparing to replace pulseaudio 0.9.10-1ubuntu1 (using .../pulseaudio_0.9.10-2ubuntu4~ppa3_amd64.deb) ...
Unpacking replacement pulseaudio ...
Preparing to replace pulseaudio-esound-compat 0.9.10-1ubuntu1 (using .../pulseaudio-esound-compat_0.9.10-2ubuntu4~ppa3_amd64.deb) ...
Unpacking replacement pulseaudio-esound-compat ...
Preparing to replace pulseaudio-module-gconf 0.9.10-1ubuntu1 (using .../pulseaudio-module-gconf_0.9.10-2ubuntu4~ppa3_amd64.deb) ...
Unpacking replacement pulseaudio-module-gconf ...
Preparing to replace pulseaudio-module-hal 0.9.10-1ubuntu1 (using .../pulseaudio-module-hal_0.9.10-2ubuntu4~ppa3_amd64.deb) ...
Unpacking replacement pulseaudio-module-hal ...
Preparing to replace pulseaudio-utils 0.9.10-1ubuntu1 (using .../pulseaudio-utils_0.9.10-2ubuntu4~ppa3_amd64.deb) ...
Unpacking replacement pulseaudio-utils ...
Preparing to replace pulseaudio-module-x11 0.9.10-1ubuntu1 (using .../pulseaudio-module-x11_0.9.10-2ubuntu4~ppa3_amd64.deb) ...
Unpacking replacement pulseaudio-module-x11 ...
Preparing to replace pulseaudio-module-zeroconf 0.9.10-1ubuntu1 (using .../pulseaudio-module-zeroconf_0.9.10-2ubuntu4~ppa3_amd64.deb) ...
Unpacking replacement pulseaudio-module-zeroconf ...
Setting up libasound2 (1.0.16-2ubuntu2~ppa1) ...

Setting up libasound2-dev (1.0.16-2ubuntu2~ppa1) ...

Setting up lib32asound2 (1.0.16-2ubuntu2~ppa1) ...

Setting up alsa-utils (1.0.16-1ubuntu3~ppa1) ...
Installing new version of config file /etc/init.d/alsa-utils ...

Setting up flashplugin-nonfree (10.0.1.218+10.0.0.569ubuntu1~ppa2) ...
Downloading...
--10:56:49-- http://download.macromedia.com/pub/labs/flashplayer10/flashplayer10_install_linux_081108.tar.gz
=> `./flashplayer10_install_linux_081108.tar.gz'
Resolving download.macromedia.com... 72.246.87.191
Connecting to download.macromedia.com|72.246.87.191|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 4,035,433 (3.8M) [application/x-gzip]

0K .......... .......... .......... .......... .......... 1% 351.83 KB/s
50K .......... .......... .......... .......... .......... 2% 867.76 KB/s
100K .......... .......... .......... .......... .......... 3% 882.31 KB/s
150K .......... .......... .......... .......... .......... 5% 984.01 KB/s
200K .......... .......... .......... .......... .......... 6% 850.47 KB/s
250K .......... .......... .......... .......... .......... 7% 804.49 KB/s
300K .......... .......... .......... .......... .......... 8% 2.57 MB/s
350K .......... .......... .......... .......... .......... 10% 792.20 KB/s
400K .......... .......... .......... .......... .......... 11% 697.35 KB/s
450K .......... .......... .......... .......... .......... 12% 1.46 MB/s
500K .......... .......... .......... .......... .......... 13% 1003.14 KB/s
550K .......... .......... .......... .......... .......... 15% 776.63 KB/s
600K .......... .......... .......... .......... .......... 16% 743.97 KB/s
650K .......... .......... .......... .......... .......... 17% 2.59 MB/s
700K .......... .......... .......... .......... .......... 19% 771.49 KB/s
750K .......... .......... .......... .......... .......... 20% 2.40 MB/s
800K .......... .......... .......... .......... .......... 21% 672.75 KB/s
850K .......... .......... .......... .......... .......... 22% 1023.18 KB/s
900K .......... .......... .......... .......... .......... 24% 2.48 MB/s
950K .......... .......... .......... .......... .......... 25% 789.23 KB/s
1000K .......... .......... .......... .......... .......... 26% 2.43 MB/s
1050K .......... .......... .......... .......... .......... 27% 789.98 KB/s
1100K .......... .......... .......... .......... .......... 29% 2.74 MB/s
1150K .......... .......... .......... .......... .......... 30% 750.62 KB/s
1200K .......... .......... .......... .......... .......... 31% 724.30 KB/s
1250K .......... .......... .......... .......... .......... 32% 2.47 MB/s
1300K .......... .......... .......... .......... .......... 34% 724.55 KB/s
1350K .......... .......... .......... .......... .......... 35% 2.04 MB/s
1400K .......... .......... .......... .......... .......... 36% 700.09 KB/s
1450K .......... .......... .......... .......... .......... 38% 2.55 MB/s
1500K .......... .......... .......... .......... .......... 39% 784.04 KB/s
1550K .......... .......... .......... .......... .......... 40% 745.81 KB/s
1600K .......... .......... .......... .......... .......... 41% 2.36 MB/s
1650K .......... .......... .......... .......... .......... 43% 837.57 KB/s
1700K .......... .......... .......... .......... .......... 44% 532.35 KB/s
1750K .......... .......... .......... .......... .......... 45% 4.27 MB/s
1800K .......... .......... .......... .......... .......... 46% 260.80 KB/s
1850K .......... .......... .......... .......... .......... 48% 542.44 KB/s
1900K .......... .......... .......... .......... .......... 49% 845.32 KB/s
1950K .......... .......... .......... .......... .......... 50% 534.20 KB/s
2000K .......... .......... .......... .......... .......... 52% 937.27 KB/s
2050K .......... .......... .......... .......... .......... 53% 892.18 KB/s
2100K .......... .......... .......... .......... .......... 54% 876.11 KB/s
2150K .......... .......... .......... .......... .......... 55% 891.52 KB/s
2200K .......... .......... .......... .......... .......... 57% 716.13 KB/s
2250K .......... .......... .......... .......... .......... 58% 779.62 KB/s
2300K .......... .......... .......... .......... .......... 59% 842.43 KB/s
2350K .......... .......... .......... .......... .......... 60% 1018.24 KB/s
2400K .......... .......... .......... .......... .......... 62% 1019.80 KB/s
2450K .......... .......... .......... .......... .......... 63% 820.41 KB/s
2500K .......... .......... .......... .......... .......... 64% 901.59 KB/s
2550K .......... .......... .......... .......... .......... 65% 726.36 KB/s
2600K .......... .......... .......... .......... .......... 67% 699.71 KB/s
2650K .......... .......... .......... .......... .......... 68% 709.76 KB/s
2700K .......... .......... .......... .......... .......... 69% 767.96 KB/s
2750K .......... .......... .......... .......... .......... 71% 836.89 KB/s
2800K .......... .......... .......... .......... .......... 72% 1.04 MB/s
2850K .......... .......... .......... .......... .......... 73% 974.55 KB/s
2900K .......... .......... .......... .......... .......... 74% 947.03 KB/s
2950K .......... .......... .......... .......... .......... 76% 863.63 KB/s
3000K .......... .......... .......... .......... .......... 77% 760.78 KB/s
3050K .......... .......... .......... .......... .......... 78% 663.06 KB/s
3100K .......... .......... .......... .......... .......... 79% 682.87 KB/s
3150K .......... .......... .......... .......... .......... 81% 1.55 MB/s
3200K .......... .......... .......... .......... .......... 82% 934.50 KB/s
3250K .......... .......... .......... .......... .......... 83% 806.11 KB/s
3300K .......... .......... .......... .......... .......... 85% 742.24 KB/s
3350K .......... .......... .......... .......... .......... 86% 848.06 KB/s
3400K .......... .......... .......... .......... .......... 87% 978.12 KB/s
3450K .......... .......... .......... .......... .......... 88% 1.07 MB/s
3500K .......... .......... .......... .......... .......... 90% 1.31 MB/s
3550K .......... .......... .......... .......... .......... 91% 645.87 KB/s
3600K .......... .......... .......... .......... .......... 92% 1.07 MB/s
3650K .......... .......... .......... .......... .......... 93% 1.08 MB/s
3700K .......... .......... .......... .......... .......... 95% 1008.09 KB/s
3750K .......... .......... .......... .......... .......... 96% 990.79 KB/s
3800K .......... .......... .......... .......... .......... 97% 1.09 MB/s
3850K .......... .......... .......... .......... .......... 98% 1.35 MB/s
3900K .......... .......... .......... .......... 100% 894.83 KB/s

10:56:54 (877.34 KB/s) - `./flashplayer10_install_linux_081108.tar.gz' saved [4035433/4035433]

Download done.
Flash Plugin installed.
*** NSPlugin Viewer *** ERROR: libcurl.so.3: cannot open shared object file: No such file or directory
nspluginwrapper: no appropriate viewer found for /usr/lib/flashplugin-nonfree/libflashplayer.so
dpkg: error processing flashplugin-nonfree (--configure):
subprocess post-installation script returned error exit status 1
Setting up libpulse0 (0.9.10-2ubuntu4~ppa3) ...

Setting up libasound2-plugins (1.0.16-1ubuntu2~ppa1) ...
Setting up libpulse-browse0 (0.9.10-2ubuntu4~ppa3) ...

Setting up libpulse-mainloop-glib0 (0.9.10-2ubuntu4~ppa3) ...

Setting up libpulsecore5 (0.9.10-2ubuntu4~ppa3) ...

Setting up pulseaudio (0.9.10-2ubuntu4~ppa3) ...
Installing new version of config file /etc/pulse/default.pa ...
Installing new version of config file /etc/pulse/daemon.conf ...

Setting up pulseaudio-esound-compat (0.9.10-2ubuntu4~ppa3) ...
Setting up pulseaudio-module-gconf (0.9.10-2ubuntu4~ppa3) ...
Setting up pulseaudio-module-hal (0.9.10-2ubuntu4~ppa3) ...
Setting up pulseaudio-utils (0.9.10-2ubuntu4~ppa3) ...
Setting up pulseaudio-module-x11 (0.9.10-2ubuntu4~ppa3) ...
Setting up pulseaudio-module-zeroconf (0.9.10-2ubuntu4~ppa3) ...
Processing triggers for libc6 ...
ldconfig deferred processing now taking place
Errors were encountered while processing:
flashplugin-nonfree
Updating Debian Packages of System Configurations (dpsyco).
E: Sub-process /usr/bin/dpkg returned an error code (1)
rklinkefus@linuxcore2:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Do you want to continue [Y/n]? y
Setting up flashplugin-nonfree (10.0.1.218+10.0.0.569ubuntu1~ppa2) ...
Installing from local file /var/cache/flashplugin-nonfree/flashplayer10_install_linux_081108.tar.gz
Flash Plugin installed.
*** NSPlugin Viewer *** ERROR: libcurl.so.3: cannot open shared object file: No such file or directory
nspluginwrapper: no appropriate viewer found for /usr/lib/flashplugin-nonfree/libflashplayer.so
dpkg: error processing flashplugin-nonfree (--configure):
subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
flashplugin-nonfree
Updating Debian Packages of System Configurations (dpsyco).
E: Sub-process /usr/bin/dpkg returned an error code (1)
rklinkefus@linuxcore2:~$ sudo dpkg -l | grep libcurl3
ii libcurl3 7.18.0-1ubuntu2 Multi-protocol file transfer library (OpenSS
ii libcurl3-gnutls 7.18.0-1ubuntu2 Multi-protocol file transfer library (GnuTLS


here you go

manlypain
August 14th, 2008, 07:09 PM
What happens if you try to reinstall the plugin?


$ sudo apt-get install flashplugin-nonfree

here you go

sudo apt-get install flashplugin-nonfree
Reading package lists... Done
Building dependency tree
Reading state information... Done
flashplugin-nonfree is already the newest version.
The following packages were automatically installed and are no longer required:
libcommons-lang-java libswt3.2-gtk-jni
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Setting up flashplugin-nonfree (10.0.1.218+10.0.0.569ubuntu1~ppa2) ...
Installing from local file /var/cache/flashplugin-nonfree/flashplayer10_install_linux_081108.tar.gz
Flash Plugin installed.
*** NSPlugin Viewer *** ERROR: libcurl.so.3: cannot open shared object file: No such file or directory
nspluginwrapper: no appropriate viewer found for /usr/lib/flashplugin-nonfree/libflashplayer.so
dpkg: error processing flashplugin-nonfree (--configure):
subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
flashplugin-nonfree
Updating Debian Packages of System Configurations (dpsyco).
E: Sub-process /usr/bin/dpkg returned an error code (1)

psyke83
August 14th, 2008, 07:15 PM
here you go

Ok, thanks for the output. I think I know the problem - give me a little while to sort it out. The ia32-libs needs to be updated with the new dependencies.

manlypain
August 14th, 2008, 07:22 PM
Take all the time you need. Thanks for all the hard work.

ethos_dacapo
August 14th, 2008, 08:15 PM
Please have a look at this if you will...


$ pkill pulseaudio
$ pulseaudio
W: main.c: RLIMIT_RTPRIO failed: Operation not permitted
ALSA lib pcm_ladspa.c:1275:(snd_pcm_ladspa_parse_controls) Control port 2 has not an float or integer value
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL equalized
ALSA lib conf.c:3952:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM surround71:0
E: alsa-util.c: Error opening PCM device hw:0: Device or resource busy
E: module.c: Failed to load module "module-alsa-sink" (argument: "device_id=0 sink_name=alsa_output.pci_8086_2485_sound_card_0_a lsa_playback_0"): initialization failed.
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0

I was hoping to get the eq working on my laptop speakers. My sound is the same as before except now sometimes there is a delay in sounds like when someone IMs me. Thanks for your help

haxwithaxe
August 14th, 2008, 09:22 PM
I'm a little confused. Which parameter are you referring to by "rate"? There are only two exposed settings for fragments, and they are:


default-fragments = 4
default-fragment-size-msec = 25

If you were referring to "default-sample-rate" when you mention "rate", you shouldn't change that value: it has nothing to do with fragments or buffers, but it is the default sample rate in which PulseAudio uses. This should be left alone in most circumstances.
Sorry,
Late night that night. By rate I mean "default-fragment".

Toshibawarrior
August 14th, 2008, 09:49 PM
Hmmm...I still need help with Audacity and Hydrogen...read my posts above for details!...

Please help me!

jacobmh
August 14th, 2008, 11:53 PM
I still have the same problem, even after trying the fix. Of course, my terminal did say that I did not have the asound directories, so do I need to get those for this to work?

psyke83
August 14th, 2008, 11:58 PM
I still have the same problem, even after trying the fix. Of course, my terminal did say that I did not have the asound directories, so do I need to get those for this to work?

What asound directories? Please be more specific. Post logs of apt-get when you performed the upgrade and let me know your basic system specs (32bit or 64bit).

psyke83
August 15th, 2008, 12:10 AM
Hmmm...I still need help with Audacity and Hydrogen...read my posts above for details!...

Please help me!

Audacity and Hydrogen are not PulseAudio compatible. Until those application fix their ALSA implementation, they can't cooperate with PulseAudio.

To use those applications, you'll need to either a) ensure you run Audacity or Hydrogen without other applications on your system accessing the sound card, or b) temporarily disable PulseAudio while using those applications:


$ pulseaudio -k
mv ~/.asoundrc ~/.asoundrc.disabled

To re-enable:

$ pulseaudio
mv ~/.asoundrc.disabled ~/.asoundrc

Toshibawarrior
August 15th, 2008, 12:27 AM
Audacity and Hydrogen are not PulseAudio compatible. Until those application fix their ALSA implementation, they can't cooperate with PulseAudio.

To use those applications, you'll need to either a) ensure you run Audacity or Hydrogen without other applications on your system accessing the sound card, or b) temporarily disable PulseAudio while using those applications:


$ pulseaudio -k
mv ~/.asoundrc ~/.asoundrc.disabled

To re-enable:

$ pulseaudio
mv ~/.asoundrc.disabled ~/.asoundrc

Thanks a lot!

manlypain
August 15th, 2008, 12:59 AM
Ok, thanks for the output. I think I know the problem - give me a little while to sort it out. The ia32-libs needs to be updated with the new dependencies.

Just to make sure i know what happened:
-i am without flash basically until you are able to figure it out

i am kinda scared to reboot because i can deal with loss of flash for a while but not sound altogether. Thanks for trying to figure this out

nick623
August 15th, 2008, 02:41 AM
Hi I tried your amendment http://ubuntuforums.org/showpost.php?p=5587712&postcount=472
to your how to.

And now I have flash video but no sound. My setup was according to your latest how to. I'm using 32 bit Hardy.

Actually, I have no sound.

Is there a way to revert.

And if so. How?

Thanks.

psyke83
August 15th, 2008, 02:54 AM
Just to make sure i know what happened:
-i am without flash basically until you are able to figure it out

i am kinda scared to reboot because i can deal with loss of flash for a while but not sound altogether. Thanks for trying to figure this out

Try:

$ sudo apt-get install flashplugin-nonfree/hardy

That will downgrade to the version in the official repositories. Hold off on upgrading until you see that I've fixed the 64bit issues (which I'll post in this thread).

Theo148
August 15th, 2008, 02:58 AM
The PPA works like a charm! :D (It went flawlessly for me at least)

psyke83
August 15th, 2008, 02:59 AM
Hi I tried your amendment http://ubuntuforums.org/showpost.php?p=5587712&postcount=472
to your how to.

And now I have flash video but no sound. My setup was according to your latest how to. I'm using 32 bit Hardy.

Actually, I have no sound.

Is there a way to revert.

And if so. How?

Thanks.

Before you downgrade, can you help out a bit?

1. Post the verbose log of PulseAudio:


$ pulseaudio -k && pulseaudio -vv

2. Try to temporarily disable PulseAudio:

$ pulseaudio -k && asoundconf unset-pulseaudio

Then, try launching an application and playing sound (you will need to restart any open applications).

Let me know if you can get sound after following step 2.

psyke83
August 15th, 2008, 03:52 AM
Thanks for the fast response. Mine had to wait as I am based in Iceland (GMT), so I didn't see your post till I got home (computer involved is my office desktop). Here is the output you requested.

Unfortunately it seems that ALSA isn't detecting your sound card at all - the log suggests that only the USB device/devices were detected. PulseAudio is not to blame here (as PulseAudio itself is an ALSA client, and if your ALSA drivers aren't working, then neither will PulseAudio).

Perhaps look around the Multimedia & Video section: http://ubuntuforums.org/forumdisplay.php?f=334 -once ALSA detects your motherboard's audio chipset (and loads the drivers properly), PulseAudio should also pick it up properly. I can only give you generic advice like "check your dmesg log" and "try disabling PulseAudio" (see my other post above this reply), but I suspect PulseAudio has nothing to do with your problem.

Edit: aaargh! I forgot your later reply where you confirmed the issue was fixed ;). Glad to hear it's working now.

psyke83
August 15th, 2008, 04:04 AM
Please have a look at this if you will...


$ pkill pulseaudio
$ pulseaudio
W: main.c: RLIMIT_RTPRIO failed: Operation not permitted
ALSA lib pcm_ladspa.c:1275:(snd_pcm_ladspa_parse_controls) Control port 2 has not an float or integer value
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL equalized
ALSA lib conf.c:3952:(snd_config_expand) Unknown parameters 0
ALSA lib pcm.c:2145:(snd_pcm_open_noupdate) Unknown PCM surround71:0
E: alsa-util.c: Error opening PCM device hw:0: Device or resource busy
E: module.c: Failed to load module "module-alsa-sink" (argument: "device_id=0 sink_name=alsa_output.pci_8086_2485_sound_card_0_a lsa_playback_0"): initialization failed.
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0

I was hoping to get the eq working on my laptop speakers. My sound is the same as before except now sometimes there is a delay in sounds like when someone IMs me. Thanks for your help

Are you sure the equalizer isn't working? Edit ~/.asoundrc and change the band settings to something ridiculous, e.g.:


controls [ 10 10 10 10 10 10 10 10 10 10 10 10 10 10 10 ]

If your speakers sound "blown out" after logging out and back in, the equalizer was always working, but the presets in my guide didn't make your sound better ;). If it worked, try tweaking the settings to something more reasonable (the 10's above are just to test). Also, there tends to be a slight delay when playing audio streams because of the equalizer, so that's probably normal.

You're on 64bit, and unfortunately I'm not sure if the equalizer works correctly on that architecture.

psyke83
August 15th, 2008, 04:09 AM
Sorry,
Late night that night. By rate I mean "default-fragment".

Unfortunately there may be no ideal settings until we get PulseAudio 0.9.11 (in Intrepid or Intrepid+1, as it has "glitch-free" playback). All I know is that the fragment settings in the guide minimized ~99% of stutters on my system.

ethos_dacapo
August 15th, 2008, 04:24 AM
Are you sure the equalizer isn't working? Edit ~/.asoundrc and change the band settings to something ridiculous, e.g.:


controls [ 10 10 10 10 10 10 10 10 10 10 10 10 10 10 10 ]

If your speakers sound "blown out" after logging out and back in, the equalizer was always working, but the presets in my guide didn't make your sound better ;). If it worked, try tweaking the settings to something more reasonable (the 10's above are just to test). Also, there tends to be a slight delay when playing audio streams because of the equalizer, so that's probably normal.

You're on 64bit, and unfortunately I'm not sure if the equalizer works correctly on that architecture.

I'm not running 64bit actually. This is a dell latitude c610 1ghz processor. I tried adjusting the eq before because it was set to all 0's by default but even after that it still sounded exactly the same. I uninstalled it and applied the updated you just posted to upgrade to the flash 10 candidate and fix the stuttering so i think i'll try the eq again. When i attempted to unistall everything before as you describe it kept saying none of the files existed so maybe something just went wrong initially. I'll let you know whats up as soon as i know whats up. Thanks for taking the time and effort to do this stuff

edit: how do i enable the equalizer now after following your most recent post http://ubuntuforums.org/showpost.php?p=5587712&postcount=472
when i try to edit the ~/.pulse/default.pa file there isn't anything there probably because this file is long gone now....

psyke83
August 15th, 2008, 04:33 AM
I'm not running 64bit actually. This is a dell latitude c610 1ghz processor. I tried adjusting the eq before because it was set to all 0's by default but even after that it still sounded exactly the same. I uninstalled it and applied the updated you just posted to upgrade to the flash 10 candidate and fix the stuttering so i think i'll try the eq again. When i attempted to unistall everything before as you describe it kept saying none of the files existed so maybe something just went wrong initially. I'll let you know whats up as soon as i know whats up. Thanks for taking the time and effort to do this stuff

Ok, let me clear something up: the testing packages in my PPA (and the included instructions) do *not* configure the equalizer (for the sake of simplicity). In order to get the equalizer working, you need to ensure your ~/.asoundrc matches the one posted in the guide on the first page, and that you also follow Part D.

In other words, follow Part A & D of the guide again.