PDA

View Full Version : [ubuntu] no hdd boot after clean install of 8.04



brijam
May 10th, 2008, 07:36 PM
Twice through the GNOME 8.04 live CD install today, both times letting it configure everything on its own, including partitioning.

"Operating System not found".

Both times, the hdd won't boot. It appears GRUB isn't being installed at all. /dev/sda is flagged as boot when I look at it from the live CD's gparted.

Also, Ubuntu is the only Linux I've installed that always finds my Hitachi laptop drive as being SCSI instead of IDE.

Is there a guide somewhere to getting an auto-configured GRUB going?

Pumalite
May 10th, 2008, 07:47 PM
Are you running Vista?

brijam
May 10th, 2008, 07:48 PM
Good lord, no.

100% clean hdd to start.

Pumalite
May 10th, 2008, 07:51 PM
Boot your Live CD and post:
sudo fdisk -l

brijam
May 10th, 2008, 08:12 PM
ubuntu@ubuntu:~$ sudo fdisk -l

Disk /dev/sda: 100.0 GB, 100030242816 bytes
255 heads, 63 sectors/track, 12161 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xcccdcccd

Device Boot Start End Blocks Id System
/dev/sda1 * 1 11661 93666951 83 Linux
/dev/sda2 11662 12161 4016250 5 Extended
/dev/sda5 11662 12161 4016218+ 82 Linux swap / Solaris
ubuntu@ubuntu:~$

Pumalite
May 10th, 2008, 08:20 PM
How did you partition?

brijam
May 10th, 2008, 08:25 PM
Guided - entire disk.

I was never offered any options for anything at all, partitioning, packages, or otherwise.

Also:

ubuntu@ubuntu:/boot$ ls
abi-2.6.24-16-generic memtest86+.bin
config-2.6.24-16-generic System.map-2.6.24-16-generic
initrd.img-2.6.24-16-generic.bak vmlinuz-2.6.24-16-generic
ubuntu@ubuntu:/boot$

Unless I'm mistaken, grub wasn't installed at all. Shouldn't there be a /grub directory there?

brijam
May 10th, 2008, 09:00 PM
Anyone?

Pumalite
May 10th, 2008, 09:02 PM
Reinstall Grub:
http://ubuntuforums.org/showthread.php?t=224351

brijam
May 10th, 2008, 09:13 PM
No effect.

From what I can tell, there's nothing to get from /boot/grub/stage1 -- /boot/grub doesn't exist, and that's what find returns.

Screw it, I'll just go back to Gutsy and upgrade.

Pumalite
May 10th, 2008, 09:15 PM
Good luck.

brijam
May 10th, 2008, 09:21 PM
Thanks. Sorry if that sounded directed at you -- it certainly wasn't. Thanks for your help.

Pumalite
May 10th, 2008, 09:24 PM
No offense taken. You are welcome.