View Full Version : [ubuntu] 8.04 but can't use Firefox 3

May 9th, 2008, 11:08 PM

I upgraded from 7.10 to 8.04 but have noticed when I try to use Firefox it still opens version
I have used locate to find firefox-3.0 in usr/bin and run directly from there but when it oens up it is still v

Any ideas?

thanks in advance

May 9th, 2008, 11:21 PM
Thats very odd, try reinstalling?

May 10th, 2008, 12:11 AM
Thanks. You mean remove firefox 3 from repos and then reinstall or download source and try to install over the top?

May 10th, 2008, 12:22 AM
Can you paste these commands in the terminal (http://www.psychocats.net/ubuntu/terminal) and post the output back here?
cd /opt

May 10th, 2008, 01:14 AM
yes, thanks :


Adobe firefox



May 10th, 2008, 01:23 AM
I think I see the problem. At one point, you installed Firefox manually (not from the repositories).

Let's do one last test to be sure, though. Can you run the command
firefox.ubuntu and see if it launches Firefox 3?

If it does, try pasting these commands in the terminal:
sudo rm /usr/bin/firefox
sudo dpkg-divert --rename --remove /usr/bin/firefox
sudo rm /usr/bin/mozilla-firefox
sudo dpkg-divert --rename --remove /usr/bin/mozilla-firefox
firefox & if that last command launches Firefox 3, then you're good and can paste this last command
sudo rm -r /opt/firefox If it doesn't, then let us know, and we'll go from there.

May 10th, 2008, 01:31 AM
Thanks again aysiu but no luck.
firefox.ubuntu still launches


May 10th, 2008, 01:34 AM
I'm stumped then.

Can you try pasting these commands into the terminal?
sudo apt-get update
sudo apt-get remove firefox-2
sudo apt-get install --reinstall firefox-3.0
firefox.ubuntu &

May 10th, 2008, 01:49 AM
got to the second line and:

Package firefox-2 is not installed, so not removed

I do recall installing firefox manually a little while ago.

May 10th, 2008, 01:52 AM
That's fine. Can you still try that third command?

May 10th, 2008, 02:00 AM
That did the trick.
Thanks very much for your help and prompt responses! I appreciate it.


May 10th, 2008, 01:44 PM
Sorry I did think this was solved but it is ongoing.
After a reboot when trying to open Firefox I get again.

Typing firefox.ubuntu into the terminal also brings up the older version.
I go through the apt-get reinstall method for v3beta5 again and it works again using the firefox.ubuntu commands. But if all firefox instances are closed I am back in the same situation with opening again no matter how I try to access it.

In my /usr/lib folder I had both 'firefox' and 'firefox-3.0b5' so i moved the firefox folder to another location thinking it would result in shortcuts not finding but this made no difference.

Very strange!

Sorry, any more thoughts?


May 10th, 2008, 03:02 PM
I'm not really sure what next to try. Anyone else have some suggestions?

May 11th, 2008, 01:37 AM
I'm thinking my next option (in the absence of any more ideas) is to completely remove v3, backup my personal settings and then find everything 'firefox' and remove it (maybe quarantine it first)
Then re-install v3 and see how it goes?

A couple of questions:
1. is this likely to have any adverse impacts?
2. how do i locate my personal settings? (passwords, bookmarks, cookies etc.)

thanks again

May 11th, 2008, 01:56 AM
Are you clicking the icon in the panel? if so make a new panel icon for firefox 3.

May 11th, 2008, 01:58 AM
I've tried all different ways of launching it.
Mysteriously, even going into the Firefox3 folder in /usr/bin and running the shell launch script in there still manages to open up