View Full Version : [ubuntu] SHIFT key not working - not VMWare related

May 7th, 2008, 06:44 AM
hi there,

i upgraded from ubuntu 7.10 to 8.04 today. since the upgrade, i cannot use either of the two SHIFT keys on my keyboard any more - with the exception of a few applications. here are some more details

- my previous ubuntu 7.10 installation was a full installation and not an upgrade

- i'm running ubuntu on a lenovo x61 laptop

- ubuntu start-up runs fine and i can still use the SHIFT key in the login screen

- once logged on, pressing the SHIFT key and any other key results in no output in a terminal, firefox, thunderbird, editors etc. however, when i invoke one of the admin functions that prompts for a password - via a pop-up window - the SHIFT key works but in that window only. the same isn't true for pop-up windows produced by firefox, thunderbird or in the terminal

- in addition, switching to the console - via ctrl, alt, f1 - results in the SHIFT key to work until i go back to gnome

- i tried to find similar report online but didn't find any. posts related to keyboard issues and vmware are not related to my problem here

- all other keys on my keyboard work without any issues - including caps lock. i played a bit with keyboard setting but no improvement.

any ideas, suggestions etc. are much appreciated.


May 7th, 2008, 07:24 AM
Solved it ...

The problem disappears when I switch the setting under

System -> Preferences -> Appearance

from Normal to None.



August 20th, 2008, 10:52 PM

Did you solved it within the normal appearance ?


August 20th, 2008, 10:58 PM
He probably disabled the Visual effects (compiz) - set it to none

August 21st, 2008, 12:28 AM
Yes, I only solved it by switching from normal appearance to none.



August 21st, 2008, 01:36 PM
Yes, it is what I also made, because I have the same problem.
But, did you manage (or looked) to make it work in normal mode?
I have a complete installation of ubuntu 8.04. During some weeks that worked with the normal appearance. But since yesterday (after an update?), I have to switch from normal appearance to none to make it work.


August 21st, 2008, 04:44 PM
Thanks because of you I was able to fix it as I had the same problem.

System>Preferances> Advanced Desktop Settings

Click on General Options
click commands tab extend key bindings

Run Command 0 will say Shift+F19 in my case.

Change it to shift+ alt or just disable it.

Mine was caused because I installed grandr. I removed it because I couldn't get it to work and if it works for you it may render the shift + f7 shortcut useless.

August 21st, 2008, 07:44 PM
Thank you very much, that works again.

As for you, grandr did not work and I also removed it.


August 22nd, 2008, 01:10 AM
Hi Yel,

I never investigated the problem in normal mode. However, I also had the problem reappearing (in none mode) earlier this week (I think on Monday) when I installed an update. I had to reboot my machine to fix it.

Btw, I'm using xrandr and a customised script based on that from http://www.kelvinism.com/tech-blog/zenity-gui-shell-script/ in order to enable Fn-F7. Works very well for me.



December 18th, 2008, 09:20 PM
I have experienced the same problem

Has anyone filed a bug report?

Is compiz the same as file>preferences>appearance>visual affects?

December 19th, 2008, 12:54 AM
No, I didn't file a bug report.

March 13th, 2009, 09:41 AM
Post #7 worked for me fine!!!!

Thanks a lot!!!!


April 24th, 2009, 10:02 PM
Post #7 worked for me fine!!!!

Thanks a lot!!!!


Ditto! I had opened grandr and checked the box to use Shift+F7 as a Hotkey. Boy that was a mistake!

September 20th, 2010, 12:35 PM
using ububtu 9.10

number 7 didn't work for me. i had everything blank over there in compiz settings. furthermore i disabled the whole 'commands' section. still no shift-key.

December 29th, 2010, 02:15 AM
Just try to uninstall grandr if you have it and don't need it. Worked fine for me.

You might want to check out this: http://ubuntu-ky.ubuntuforums.org/showthread.php?t=1442132&page=2. It seems like the same thing.

If you don't have compizconfig, here is a url to a page on how to install it: http://www.tech-recipes.com/rx/2756/ubuntu_install_compiz_config_settings_manager_conf igure_desktop_effects/.

April 28th, 2011, 09:47 PM
Had the same problem after some rather heinous issues with compiz ( not toolbars on start up, etc. ) Turning off the visual appearance fixed my shift key also. I couldn't find a bug entry for this specific issue, but since my problem started with other issues, I won't start a new bug report.