PDA

View Full Version : [ubuntu] 8.04 Resticted Nvidia Driver White Screen



sparkerjc
May 7th, 2008, 06:07 AM
Hello,

I am giving 8.04 a try and there was a thread during the beta stages describing my problem, but it was closed when Hardy was launched. My machine is an Inspiron 1520 with a GeForce 8400m.

As soon as I enable the restricted driver and reboot my machine the screen looks like the abominable snowman threw-up all over it. I have tried every suggestion in the old thread, including downloading beta driver directly from nvidia. The beta driver worked, allowing 32 bit color and desktop effects, but my touchpad would become inoperable and any change to xorg.conf for the touchpad would completely disable the video driver, reverting to "low graphics mode"

What changed from 7.1 to 8.04 that this driver doesn't work now? I had huge issues in 7.1 with sound that forced me back to windows, and I really want to give 8.04 a shot.

Does anybody know if there are new drivers in development or if this issues has even been acknowledged?

thanks.

edit: even if I could get the free driver to display full color to tide me over until proper drivers are developed I would appreciate that!!

sparkerjc
May 8th, 2008, 02:26 AM
I'm not usually one to do this but....



Bump!

gkrules
May 8th, 2008, 02:29 AM
use envy [http://albertomilone.com/nvidia_scripts1.html]
it worked perfectly on my 8400M

put this in terminal to download envy



sudo apt-get install envyng-gtk


after its finished just go to applications>systemtools>envyng
and run it

sparkerjc
May 8th, 2008, 04:36 AM
Envy automatic settings gives me same white screen, if I manually choose driver 96.xx.xx I can get in with 24 bit depth, but only 800x600 resolution.

The main thing I care about is having more than 8 colors and 1280x800 resolution.

I found some workaround on the nv forums and it looks like an nvidia driver issue and I guess you can patch together some edid file, but my machine wouldn't do it....

here is my xorg with 96.xx at 800x600:




# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by failsafeDexconf, using
# values from the debconf database and some overrides to use vesa mode.
#
# You should use dexconf or another such tool for creating a "real" xorg.conf
# For example:
# sudo dpkg-reconfigure -phigh xserver-xorg
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
EndSection


Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizEdgeScroll" "0"
EndSection
Section "Device"
Identifier "Configured Video Device"
Boardname "vesa"
Busid "PCI:1:0:0"
Driver "nvidia"
Screen 0
EndSection

Section "Monitor"
Identifier "Configured Monitor"
Vendorname "Generic LCD Display"
Modelname "LCD Panel 1280x800"
Horizsync 31.5-50.0
Vertrefresh 56.0 - 65.0
modeline "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
modeline "1280x768@60" 80.14 1280 1344 1480 1680 768 769 772 795 -hsync +vsync
modeline "1280x720@60" 74.48 1280 1336 1472 1664 720 721 724 746 -hsync +vsync
modeline "1280x800@60" 83.46 1280 1344 1480 1680 800 801 804 828 -hsync +vsync
Gamma 1.0
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
Defaultdepth 24
SubSection "Display"
Depth 24
Virtual 1280 800
Modes "1280x800@60" "1280x720@60" "1280x768@60" "800x600@60" "800x600@56"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen 0 "Default Screen" 0 0
Inputdevice "Synaptics Touchpad"
EndSection
Section "Module"
Load "glx"
Load "v4l"
EndSection
Section "device" #
Identifier "device1"
Boardname "vesa"
Busid "PCI:1:0:0"
Driver "nvidia"
Screen 1
EndSection
Section "screen" #
Identifier "screen1"
Device "device1"
Defaultdepth 24
Monitor "monitor1"
EndSection
Section "monitor" #
Identifier "monitor1"
Gamma 1.0
EndSection
Section "ServerFlags"
EndSection

gkrules
May 8th, 2008, 09:38 PM
hmm im running fine with 1280x800


did u try disables the restricted nvidia driver and then installing envy?

and if that doesnt work... start up envy and manually set ur display

sailor2001
May 8th, 2008, 09:42 PM
go to: /usr/share/applications/screen & graffics and set your monitor # and resolution recomended

sparkerjc
May 8th, 2008, 11:28 PM
hmm im running fine with 1280x800


did u try disables the restricted nvidia driver and then installing envy?

and if that doesnt work... start up envy and manually set ur display

I uninstalled completely Nvidia drivers, and then used Envy... no luck, Other with this issue have also reported no luck with Envy.

What do you mean set up display manually? When the Nvidia drivers are installed the only resolution I can get is 640 x 480 no matter what.

sparkerjc
May 8th, 2008, 11:51 PM
go to: /usr/share/applications/screen & graffics and set your monitor # and resolution recomended

Thanks fo rthe link, although I can still not get the desired results with 3d and all that, I at last have 24 bit color now. I resorted to the vesa driver. The Nvidia GLX-new driver is completely crap. I will wait for the driver to be updated. There are several user with similar issues. It is beyond dell and ubuntu.... there are posts from fedora and suse users on the nvidia forum with the same issue.

ameanjoe
May 9th, 2008, 02:56 AM
I'm starting to think nVidia sucks...I recently upgraded to 8.04 from 7.10 and immediately started having problems. Booting was dificult and when it did boot the best res. I could get was 640X480 (I'm not kidding..) Try working with that res....Tried a multitude of fixes offered on this forum (responses to my posts) and the best I could come up with was to hit escape when grub first comes up and to select kernel "22" and it would boot.. Then terminal and : gksu dpkg-reconfigure -plow xserver-xorg, then Ctrl/Alt/Backspace to re-boot and the display would come up 1280X1024 with the option to change. If I went to the hardware driver list (System/Admin) and tried to enable nVidia to get the 3-D acceleration...disaster.
So I tried to re-install 8.04 (won't do it), went back to my "Live disk" for 7.10, did the install and at the end when the machine asks if one wants to get any updates...there was an offering to up-grade to 8.04! I went for it1...8.04 runs fine with the "native graphics driver" and disabled nVidia, I have a full selection of resolutions, just don't have the acceleration. Screen saver runs way slow, but that seems to be the only negative effect. I'm not a "gamer" or "developer", I just want a computer that reliably starts and runs, and will provide the software needed for office work, browsing, and email...I'm not interested in shooting Bad Guys or blowing anything up...Sometimes the simple path works best.
Aloha, ameanjoe

hariprs
May 9th, 2008, 03:17 AM
Hi,

This is bug and reported in lanchpad. I dont remember the ID. Wait for the fix.

emakarov
May 10th, 2008, 04:54 AM
I had the exact same problem: NVIDIA GeForce 8400M GS and dirty-white screen, sometimes with moiré pattern or a gray band in the middle. I found a solution that worked for me on NVIDIA forums in this thread (http://www.nvnews.net/vbulletin/showthread.php?t=107138), post #14.

The short story is to add a line to xorg.conf, section "Device" that has 'Driver "nvidia"' line. This line says to use something which is called EDID file. This EDID file can be obtained in one of two ways: one is to use Phoenix EDID free program under Windows (I have not tried this), the other is to install the older version of NVIDIA driver (100.14.19) and use nvidia-settings to get this file.

Now synaptic has an older version on NVIDIA: nvidia-glx 96.43.05, and since it is easier to install than using envy or NVIDIA installer, I thought that those instructions to get EDID file would work for it. However after I installed it, I could not reboot so that the driver actually started. I got a low-resolution window with "Configure", "Continue" (and "Turn off"?) buttons, and even when I selected nvidia card, nvidia-settings reported that the driver was not running after login. When I followed all the instructions in the NVIDIA forum thread (this included installing 100.14.19 driver using the installer from NVIDIA), it worked for me.

Feel free to ask if some of the steps are not clear.

Evgeny

sparkerjc
May 14th, 2008, 01:06 AM
I had the exact same problem: NVIDIA GeForce 8400M GS and dirty-white screen, sometimes with moiré pattern or a gray band in the middle. I found a solution that worked for me on NVIDIA forums in this thread (http://www.nvnews.net/vbulletin/showthread.php?t=107138), post #14.

The short story is to add a line to xorg.conf, section "Device" that has 'Driver "nvidia"' line. This line says to use something which is called EDID file. This EDID file can be obtained in one of two ways: one is to use Phoenix EDID free program under Windows (I have not tried this), the other is to install the older version of NVIDIA driver (100.14.19) and use nvidia-settings to get this file.

Now synaptic has an older version on NVIDIA: nvidia-glx 96.43.05, and since it is easier to install than using envy or NVIDIA installer, I thought that those instructions to get EDID file would work for it. However after I installed it, I could not reboot so that the driver actually started. I got a low-resolution window with "Configure", "Continue" (and "Turn off"?) buttons, and even when I selected nvidia card, nvidia-settings reported that the driver was not running after login. When I followed all the instructions in the NVIDIA forum thread (this included installing 100.14.19 driver using the installer from NVIDIA), it worked for me.

Feel free to ask if some of the steps are not clear.

Evgeny

Would you please post the edid file since we have the same card? I cannot get phoenix to capture mine. Also it would be cool to take a peek at your xorg.conf

thedevnull
May 14th, 2008, 01:09 AM
Yes, its a known bug. I have it on one of my machines. God forbid I have to go without games for a few days. :lolflag:

https://bugs.edge.launchpad.net/ubuntu/+source/xorg/+bug/173418

emakarov
May 14th, 2008, 03:19 AM
Would you please post the edid file since we have the same card? I cannot get phoenix to capture mine. Also it would be cool to take a peek at your xorg.conf
See attachments (I had to gzip them because the original file extensions were not allowed).

I noticed one problem with the custom edid file, though: sometimes every window is surrounded by thin reddish fringe. It dissappears, though when I open System | Appearance and change the theme back and forth.

sparkerjc
May 15th, 2008, 01:19 AM
Thanks for the EDID, but after 3-4 tries I got the beta driver working without messing up my touchpad. for some reason it would revert to vesa if I put my touch pad into the xorg.conf.

from the beta driver page:

"Fixed a regression that caused invalid EDIDs to be detected for the internal display device on some notebooks."

emakarov
May 15th, 2008, 01:21 AM
Could you post the link to the beta driver?

Evgeny

emakarov
May 17th, 2008, 01:51 AM
Never mind, I found it using Advanced Search (http://www.nvidia.com/Download/Find.aspx?lang=en-us) on NVIDIA site. It fixed the white screen problem for me, and effects work too. Now it seems, though, that scrolling is slow, or maybe I am being paranoid...

sparkerjc
May 17th, 2008, 09:33 PM
No,

You're right. The beta driver wreaked havoc on my touch pad & mouse scrolling. After a couple re-installs of the beta driver, it seems to be better, although the scrolling can still be odd.

They'll fix it soon.

sparkerjc
May 31st, 2008, 07:58 PM
NVidia's new driver was released on 5-28, you can get it at their website.

http://www.nvidia.com/object/linux_display_ia32_173.14.05.html

emakarov
June 1st, 2008, 04:06 AM
Thanks for letting know. The new driver seems to make things faster than the beta driver; e.g., I do not need to wait a second while switching tabs in Firefox.

dslax27
June 4th, 2008, 04:37 AM
Hello,
Absolute supernoob here. I'm getting the exact white screen error described above and I need to ask a very simple (and probably stupid) question. I apologize, but my only computer credentials are a hatred for Microsoft and a curiosity to try a linux.

I have a GForce video card from Nvidia and I attempted to install the 8.04 i386 version from a boot cd. I got as far as the screen asking what kind of install I want. I hit install, the program went through the motions and I get the crazy white screen described above. I suspect its the same error everyone is getting.

I see that I need to install this nvidia linux driver (http://www.nvnews.net/vbulletin/showthread.php?t=102509), right? If so, answer this: how do I install the correcting Nvidia driver without first having an operating system (my machine is completely bare)?

sparkerjc
June 6th, 2008, 04:06 AM
Hello,
Absolute supernoob here. I'm getting the exact white screen error described above and I need to ask a very simple (and probably stupid) question. I apologize, but my only computer credentials are a hatred for Microsoft and a curiosity to try a linux.

I have a GForce video card from Nvidia and I attempted to install the 8.04 i386 version from a boot cd. I got as far as the screen asking what kind of install I want. I hit install, the program went through the motions and I get the crazy white screen described above. I suspect its the same error everyone is getting.

I see that I need to install this nvidia linux driver (http://www.nvnews.net/vbulletin/showthread.php?t=102509), right? If so, answer this: how do I install the correcting Nvidia driver without first having an operating system (my machine is completely bare)?

What boot cd?
Once you install ubuntu (You may need the alternate cd which is text based if your video card doesn't work on the normal cd...), download the driver link I posted, and follow the instructions on their site.

emakarov
June 6th, 2008, 04:41 AM
Sorry for the delay. Of course, you need to install Ubuntu first, which it seems that you have done, since you got to the white screen. This screen is in fact a login screen. I am surprised, though, that the problem occurs right after installation. If it is indeed NVIDIA driver that causes it, then Ubuntu has activated it by default. In my case, I had to tell it to use it in something like System | Administration | Hardware Drivers. It is surprising if Ubuntu activated it since it is not a free software.

However, if the problem is due to the driver, there are two possible ways to log in and do something. You can boot in safe mode. If you have a Grub screen when you reboot, there should be an option for safe mode. During the boot process, Ubuntu may ask you some questions and you can experiment with different answers, but in my case I managed to log in with 800x600 resolution only. Another alternative is to press Ctrl-Alt-F1 at the white screen. This should get you a text-only login screen.

Once you log in using either method, there are again two options. One is to disable NVIDIA driver altogether. For this, you may modify /etc/X11/xorg.conf file, e.g., in nano or pico editors (make a backup copy of it). You need to edit it as a superuser. Find the line 'Section "Screen"'. Withing this section, find the line 'Device "The-name-of-your-device"' where The-name-of-your-device may vary. Finally, find two lines

Section "Device"
Identifier "The-name-of-your-device"

Within this section, if there is a line 'Driver "nvidia"', put a # in front of it (in the first character of the line). In fact, you may comment out all lines in this section except for Identifier. Now save (remember to make a backup copy) and reboot.

The other option is to download the new driver (the right version is 173.14.05) and save it somewhere. Next, press Ctrl-Alt-F1 at the login screen, login and say "sudo /etc/init.d/gdm stop" (I don't know if this is really needed but I saw it somewhere). Then uninstall the current NVIDIA driver by saying "nvidia-installer --uninstall" (probably need to be superuser). Finally, install the downloaded driver by saying "sh NVIDIA-Linux-x86-version.run" or whatever the name is.

Hope this helps. I am not an expert either, so corrections are welcome.