PDA

View Full Version : [ubuntu] Error Message while shutdown about NetworkManager



adnansanni
May 7th, 2008, 02:51 AM
from today I have got a error message while shutdown my laptop. Anybody has idea to solve it? Here is the code that I have. I'm using hadry heron.

* Starting periodic command scheduler crond [OK]
* Checking batterystate... [OK]
* Running local boot scripts (/etc/rc.local) [OK]
NetwokManager: <WARN> nm_signal_handler(): Caught signal 15, shutting down normally.
NetwokManager: <info> Caught terminiation signal
NetwokManager: <debug>[1210091816.740501] nm_print_open_socks(): Open Sockets List:
NetwokManager: <debug>[1210091816.740687] nm_print_open_socks(): Open Sockets List:
NetwokManager: <info> Deactivating device eth0.
NetwokManager: <WARN> nm_hal_deinit(): libhal shutdown failed - Connection is closed
NetwokManager: <WARN> nm_dbus_init(): nm_dbus_init() could not get the system bus. Make sure the message bus deamon is running!
NetworkManager: nm_dbus_signal_device_status_change: assertion 'cb-data->data->dbus_connection' failed

macaholic
May 7th, 2008, 02:53 AM
I get similar stuff on shutdown from network manager, if it isn't causing issues with your system, I wouldn't worry about it too much, my guess is the dbus daemon is shutting down before Network manager and it's gettings angry because of that.

VoodooLoveDog
May 7th, 2008, 03:23 AM
Same thing happens to my laptop. It doesn't seem to be a problem.

sujoy
May 7th, 2008, 03:25 AM
but it ought to be resolved though, i had similar issues in gutsy also

adnansanni
May 7th, 2008, 07:52 AM
So are there no ways to solve that?

kpkeerthi
May 7th, 2008, 08:31 AM
https://bugs.launchpad.net/ubuntu/+source/dbus/+bug/138691

tedrogers
May 8th, 2008, 06:36 PM
I've got this too on an IBM T42 running Hardy on a USB drive (just testing you see!).

Couldn't see a definite solution on the bug report.

I don't feel right with a screen full of errors - even though it doesn't make that much difference for me as it shuts down ok.

Might try and see if the proposed updates on the bug report fix it. Hoping I can just enable the proposed updates in SOURCES and let it do the work.

If you don't hear from me again then you can assume it didn't work....I will be back to explain otherwise.

sujoy
May 10th, 2008, 03:44 AM
and becuase of it, it takes ages to shutdown my laptop, it just waits till that message finally comes, after which its just a matter of seconds before the computer shutdowns.

tedrogers
May 11th, 2008, 06:59 PM
I thought I'd post anyway...and those proposed updates made naff all difference here! Oh well. No solution then?

prinknash
May 11th, 2008, 07:03 PM
So are there no ways to solve that?

You might want to try this:

1. Go to System - Administration - Login Window.

2. Under 'General', press "Edit commands ...'

3. Select 'Halt command' - in 'Path' box, cut the text in quotes (I.e. "Shut down via gdm") - press "Apply command change" - paste the text back - press 'Apply command change'

4. Select 'Reboot command' and do as for 3. above

Try restarting a couple of times and see if this has fixed the problem. It seems to have done so for a number of people, including me - although I wouldn't care to have to explain exactly how it's fixed the problem!

p

nick_h
May 12th, 2008, 11:58 PM
This is the same problem described in this (http://ubuntuforums.org/showthread.php?t=772733) thread.

maramot
May 13th, 2008, 12:12 AM
I have the same problem since I installed ubuntu 8.04, only that since yesterday I also lost my wireless. The driver is installed, the device is listed in the ifconfig/iwconfig, lspci, I even get to choose from wireless networks, only that I can't ping even my router and the network always stays at 0%.

I haven't changed anything manually so I suspect I've downloaded some update which "upgraded" me from "waiting a bit until wireless starts after login" to "no wireless at all". Boy, I should never have updated to this messed up release!

It says something about disabling wlan0 but I can't read it fast enough. Can anyone tell me how can I see this output when I'm shutting down? Save it somewhere to read it perhaps?

zvonkojaz
June 3rd, 2008, 07:57 AM
Hi!

I got the same error...but its not that easy to deal with...because it caouses my internet connection to fail ...it apears that after the latest update the system doesnt recognize my network connection device..eth0? any ideas...help?..pls...because without any connection to internet i cannot download any repairs.

tnx

XMAG
June 17th, 2008, 11:02 PM
I had the same error here. Here's how I solved it:

I removed packages network-manager and network-manager-gnome and installed them again. Be sure to download the 2 .deb files before removing the packages since it will disable your network connectivity.

You can find both packages at packages.ubuntu.com . Search for them, select your distro and download the package for your CPU architecture (link at the bottom of the page).

After you have them


sudo apt-get remove network-manager network-manager-gnome

reboot, then


sudo dpkg -i package_name_here for each package

reboot and see if the problem goes away. Mine seems to be gone!

happyisland
July 13th, 2008, 06:04 PM
You might want to try this:

1. Go to System - Administration - Login Window.

2. Under 'General', press "Edit commands ...'

3. Select 'Halt command' - in 'Path' box, cut the text in quotes (I.e. "Shut down via gdm") - press "Apply command change" - paste the text back - press 'Apply command change'

4. Select 'Reboot command' and do as for 3. above

Try restarting a couple of times and see if this has fixed the problem. It seems to have done so for a number of people, including me - although I wouldn't care to have to explain exactly how it's fixed the problem!

p

This solution worked for me. Thanks for the fix!

fletch31337
August 9th, 2008, 05:15 PM
I get similar stuff on shutdown from network manager, if it isn't causing issues with your system, I wouldn't worry about it too much, my guess is the dbus daemon is shutting down before Network manager and it's gettings angry because of that.

I have a dirty hack to fix this. In the /etc/init.d/dhcdbd file, add the following line straight under the "stop)" line:

killall NetworkManager # Dirty hack to avoid nasty error messages!

Nasty I know, but until it is fixed, this will terminate the daemon BEFORE D-BUS terminates.

oyvindaa
August 9th, 2008, 06:09 PM
You might want to try this:

1. Go to System - Administration - Login Window.

2. Under 'General', press "Edit commands ...'

3. Select 'Halt command' - in 'Path' box, cut the text in quotes (I.e. "Shut down via gdm") - press "Apply command change" - paste the text back - press 'Apply command change'

4. Select 'Reboot command' and do as for 3. above

Try restarting a couple of times and see if this has fixed the problem. It seems to have done so for a number of people, including me - although I wouldn't care to have to explain exactly how it's fixed the problem!

p

That fixed the problem on my computer. Thank you prinknash!