PDA

View Full Version : [other] DeVeDe preview issue



DestroyMicroshaft
May 7th, 2008, 02:23 AM
Ok heres the problem, I use devede regularly, I just put a fresh install of hardy on my pc, and when I go to preview a movie before I make it mplayer doesnt start to actually the movie. I can here the movie previewing, but no video nothing opens up. Any ideas here?

macaholic
May 7th, 2008, 02:27 AM
Do any other videos work in mplayer? What is the command line output if you manually play the temporary file in mplayer? Probably a codec issue. Have you installed ubuntu-restricted-extras?

tjwoosta
May 7th, 2008, 02:29 AM
i had the same problem with gutsy

it turned out that i cant use mplayer on my computer (dunno why)

the only movie player that i can get to work with my laptop is

GNOME Mplayer

i dont know what the difference is between gnome mplyaer and regular mplayer but everything works now

the only thing is devede always tries to open previews with the regular mplayer Which doesnt work for me so i have to save previews to desktop and click the icon to make them open with the correct movie player

DestroyMicroshaft
May 7th, 2008, 02:31 AM
I just tried two movies, one in avi, and one in mp4 format, and neither of the videos started, I got a message that says fatal error error opening/initializing the selected video_out (-vo) device. Once I hit ok, the audio window disappears but the audio begins playing.

macaholic
May 7th, 2008, 02:33 AM
i had the same problem with gutsy

it turned out that i cant use mplayer on my computer (dunno why)

the only movie player that i can get to work with my laptop is

GNOME Mplayer

i dont know what the difference is between gnome mplyaer and regular mplayer but everything works now

the only thing is devede always tries to open previews with the regular mplayer Which doesnt work for me so i have to save previews to desktop and click the icon to make them open with the correct movie player
Gnome-mplayer is just a GUI frontend for mplayer, it uses the mplayer backend and controls it via Dbus calls if I remember correctly. I'm not sure why mplayer would not work for you yet gnome-mplayer would, perhaps a settings issue of some sort?

DestroyMicroshaft
May 7th, 2008, 02:34 AM
i had the same problem with gutsy

it turned out that i cant use mplayer on my computer (dunno why)

the only movie player that i can get to work with my laptop is

GNOME Mplayer

i dont know what the difference is between gnome mplyaer and regular mplayer but everything works now

the only thing is devede always tries to open previews with the regular mplayer Which doesnt work for me so i have to save previews to desktop and click the icon to make them open with the correct movie player

Sorry bout the double post, but mplayer has always worked on my pc, this is the fourth Ubuntu version, and only on this one am I having the problem.

macaholic
May 7th, 2008, 02:51 AM
I just tried two movies, one in avi, and one in mp4 format, and neither of the videos started, I got a message that says fatal error error opening/initializing the selected video_out (-vo) device. Once I hit ok, the audio window disappears but the audio begins playing.
Try switching video devices/outputs in the mplayer settings.

DestroyMicroshaft
May 7th, 2008, 03:32 AM
Ok I solved the problem, and Im going to post the solution, incase someone else has this problem. All I did was change the default video out driver in mplayer.conf to xll, and bam video preview in devede again. Thanx to those who tried to help.

tjwoosta
May 7th, 2008, 04:20 AM
ha.. you know what

after you posted that i just remembered why GNOME Mplayer works for me and regular MPlayer dont

im not smart enough to find the mplayer.conf file to change the video output in Mplayer, but with GNOME Mplayer i was able to go to the preferences menu and change the video output to x11.

i wish i had remembered this in time to help


if you dont mind could you tell me where i could find the mplayer.conf file and how to change the output?

EDIT: nevermind i found it /etc/mplayer/mplayer.conf

macaholic
May 7th, 2008, 09:52 PM
Ok I solved the problem, and Im going to post the solution, incase someone else has this problem. All I did was change the default video out driver in mplayer.conf to xll, and bam video preview in devede again. Thanx to those who tried to help.
Don't take this the wrong way, but I think that's exactly what I told you to do is it not?