PDA

View Full Version : [ubuntu] Mouse failure when WD Mybook is attached



megale
May 4th, 2008, 11:55 PM
Just upgraded to Ubuntu Hardy from Gutsy with a USB attached Microsoft Intellimouse Explorer 4.0A on a dual boot (XP, Ubuntu) Dell Optiplex GX270. Also just bought a WD 500 GB MyBook for backups.

When I boot without Mybook attached, the mouse works correctly.
When Mybook is attached at boot time, the mouse is completely non-functional (though the red power indicator light on the mouse is lit).
When I boot without Mybook attached, and then plug in Mybook USB connection after log in, both the mouse and Mybook work correctly.

Tried switching the mouse to the PS2 port with an adapter to see if that might help, but Ubuntu didn't recognize that the mouse was present either (even without the MyBook disconnected).

Tried tinkering with xorg.conf file, but only succeeded in temporarily ruining my screen resolution...

Anyone have any idea how to fix the apparent conflict between the mouse and MyBook during boot without using the 'climb under the desk and unplugging and replugging' workaround?

Thanks in advance!