View Full Version : Can not update

October 18th, 2005, 02:53 AM
When ever I try and update I get this error message

Unable to get exclusive lock and something about apt-get is running.

I tired restarting the computer and I got the same thing what is up. I just did in install of Easy Ubuntu if that helps

October 18th, 2005, 02:56 AM
Only one installer program can be running at any given time--apt-get, Synaptic, KPackage, Adept, etc. Maybe try
sudo killall apt-get

October 18th, 2005, 04:09 AM
I did the
sudo killall apt-get

dj@dhcppc4:~$ sudo killall apt-get
apt-get: no process killed

I still get the same error message
This usually means that another package management application (like apt-get or aptitude) already running. Please close that application first

I also tired
sudo killall aptitude

October 18th, 2005, 10:58 AM
run this command in terminal
sudo rm /var/lib/apt/lists/lock
and try updating after running that command


ad noiseam
October 19th, 2005, 01:07 PM
I have the exact same problem as the original poster, and none of these solutions worked. However, typing "sudo synaptic" in a terminal did the spell.

Br... another thing that was working well in Hoary and is broken in Breezy. :-(

November 1st, 2005, 09:07 PM
In terminal type..

sudo dpkg --configure -a

And don't go blaming Breezy again ;)

January 7th, 2006, 08:43 PM
Thanks for sudo dpkg --configure -a
Thsi did the job after trying to complete a failed real player install and lots of clicking of OK to the Exclusive lock message.
However I still don't have a working Real player (I want to listen to the BBC)!