View Full Version : [ubuntu] ICH8 sound card not working in 8.04 LTS

May 4th, 2008, 12:03 AM
Recently installed 8.04 LTS and my sound card isn't working!

In sound settings when I try to test any devices I get the following error message

audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink: Failed to connect stream: Invalid argument

And when I try to adjust the volume I get the following error message

No volume control GStreamer plugins and/or devices found

(running 64bit by the way)...

Thanks for any help :)

May 4th, 2008, 11:10 AM
See if anything over at http://ubuntuforums.org/showthread.php?p=4869649#post4869649 applies. That is, if you have an Intel HDA chipset.

May 5th, 2008, 05:19 PM
Nope didn't work
I tried changing the model in alsa-utils to no avail

aplay -l shows no soundcards found

lspci shows my audio device as "Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)"

Any other ideas?

May 10th, 2008, 02:47 PM
Is the driver assigned to the device and is the module loaded? Post the output of the following commands.

$ lshw -C multimedia
$ lsmod | grep snd

May 15th, 2008, 08:16 PM
I just upgraded from 7.10 to 8.04 and have a similar problem. My laptop computer came with ubuntu 7.10. I have an IHDA Sound card. I'm pretty new to ubuntu. How can I configure my soundcard to work with 8.04?

How do I assign the driver to the device or load the module? I don't see how I can access that. How would I post output of the commands you laid out? Do I have to enter the terminal?

May 15th, 2008, 08:45 PM
Yes, pop up a terminal and enter those commands.

Omit the dollarsigns though, they're syntax convention to show they should be entered in a terminal.

May 15th, 2008, 09:11 PM
Should I use a backslash if I don't have a vertical line key? Are those lower case L's or upper case i's?

May 15th, 2008, 09:27 PM
Just copy/paste in to terminal

May 15th, 2008, 10:45 PM
The following is what it showed me:

lsmod | grep snd
snd_pcm_oss 42144 0
snd_mixer_oss 17920 1 snd_pcm_oss
snd_pcm 78596 1 snd_pcm_oss
snd_seq_dummy 4868 0
snd_seq_oss 35584 0
snd_seq_midi 9376 0
snd_rawmidi 25760 1 snd_seq_midi
snd_seq_midi_event 8320 2 snd_seq_oss,snd_seq_midi
snd_seq 54224 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_mid i_event
snd_timer 24836 2 snd_pcm,snd_seq
snd_seq_device 9612 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi ,snd_seq
snd 56996 9 snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_dummy,sn d_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_de vice
soundcore 8800 1 snd
snd_page_alloc 11400 1 snd_pcm


lshw -C multimedia
WARNING: you should run this program as super-user.
*-multimedia UNCLAIMED
description: Audio device
product: 82801H (ICH8 Family) HD Audio Controller
vendor: Intel Corporation
physical id: 1b
bus info: pci@0000:00:1b.0
version: 02
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list
configuration: latency=0

It's still not working. And I don't know what the following things are:
changing the model in alsa-utils
aplay -l

What can be done next?