PDA

View Full Version : [ubuntu] compiz on intel graphics



Kenn
May 3rd, 2008, 11:13 PM
before hardy heron gusty ran nice and smooth on intel chipset. Now after hardy installed firefox scrolling is choppy and stuttery + games run at a snails pace.

damis648
May 3rd, 2008, 11:15 PM
Have you tried installing the restricted drivers? (if there are any?)

PS: does the scrolling look like waves just moving up the window? if it does that means a wrong driver

Kenn
May 3rd, 2008, 11:24 PM
yep so where do i get these restricted drivers

damis648
May 3rd, 2008, 11:27 PM
Try System>Administration>Hardware Drivers in the panel and click the check box on your graphics card (if it is in there)

EDIT: WHOA that had to be the longest string of two letter words starting with I in history

Kenn
May 3rd, 2008, 11:30 PM
"No proprietary drivers....."
there's nothing there

damis648
May 3rd, 2008, 11:31 PM
Hm... what is the model of your card?

Kenn
May 3rd, 2008, 11:33 PM
i think its 945gm intel family chipset thing

Helios38
May 3rd, 2008, 11:37 PM
thats a bit weak 4 compiz.


go into preferences > appearance > visual effects


and click none


some stuff will happen, your desktop will dissapear for a few secs

and compiz will be off. things should speed up.

damis648
May 3rd, 2008, 11:37 PM
ok try going into terminal and typing

gedit /ext/X11/xorg.conf
and find the section that starts like this:

Section "Device"
Identifier "Intel Corporation Mobile 945GM"

and tell me what the next line down says, the line that says "driver"

EDIT: it is a bit weak, however we should not see this scrolling issue if it using the correct driver, however i have never used this specific card so i am not positive.

Whiffle
May 3rd, 2008, 11:42 PM
Do

"glxinfo | grep direct"

If it replies something about Direct Rendering: Yes, then you're pretty much set to have compiz work. I have it working on my 915GM and its not too shabby.

m_ad
May 3rd, 2008, 11:52 PM
How did you get your intel graphics to work with compiz in Gutsy? I have..

Intel Corporation Mobile GM965/GL960 Integrated Graphics

and I can't get compiz to work with it. Says I'm blacklisted.

adult swim
May 4th, 2008, 12:36 AM
to the OP, i have the same intel card and was having this problem. by adding a couple things to my xorg.conf it worked itself out.
if you hit alt-f2 and then type in gksudo gedit /etc/X11/xorg.conf and press enter, go down to where it says section "Device" and at the end of that section, add the following
Option "AccelMethod" "EXA"
Option "MigrationHeuristic" "greedy" then save the file, log out of ubuntu and then log back in. things should go alot smoother!

Kenn
May 4th, 2008, 12:15 PM
tried what you said adult swim no change at all

@damis648

Section "Device"
Identifier "Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller"
Driver "intel"
BusID "PCI:0:2:0"
Option "AccelMethod" "EXA"
Option "MigrationHeuristic" "greedy"
EndSection