PDA

View Full Version : [ubuntu] screen resolution (guess it's my turn?)



jayceekayy
May 3rd, 2008, 11:09 PM
hello all. i recently installed ubuntu on my machine which has a geforce4 ti4400 and a philips 109s. the monitor is capable of doing 1600x1200 @ 75 which can be seen in its manual (pdf) here (http://www.p4c.philips.com/files/1/19c2502e11/19c2502e11_dfu_aen.pdf). (i'm almost certain i never had problems with this rate at this res. in windows xp.)

no matter how i've tried setting it up in ubuntu whether using the nvidia x server settings or editing xorg.conf manually, i can't get the settings to stick. depending on what i try sometimes it will reject my resolution and size back down to 1280x1024, and others it will revert in to "low graphics mode" forcing me to reconfigure the graphics driver settings all together.

below is my current xorg.conf file which was recreated after a reboot in which my display settings were overridden:


# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Defaultdepth 24
Option "AddARGBGLXVisuals" "True"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
EndSection
Section "Module"
Load "glx"
EndSection

here is "xorg.conf.good" which i generated by using the "nvidia x server settings" and then merged with my existing xorg.conf. when i tried to use it by restarting gnome, it too did not stick.


# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce4 Ti 4400"
EndSection

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "PHILIPS 109S2"
HorizSync 31.0 - 92.0
VertRefresh 50.0 - 160.0
Option "DPMS"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "1600x1200_70 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection


any help is appreciated. thanks all.

Cap'n Redbeard
May 4th, 2008, 02:45 AM
Hi jayceekayy,

Have you tried


sudo displayconfig-gtk

from the display line ?

It worked for this machine.

"displayconfig-gtk" gives more options than system/preferences/Screen Resolution.

Please read the "ATTENTION ALL USERS: Malicious Commands" post before trying this :)

imasickboy
May 4th, 2008, 03:22 AM
Use sudo to open nvidia-settings, otherwise the changes it makes cannot be saved to xorg.conf, since it's in a protected directory.

bsharp
May 4th, 2008, 03:25 AM
I had this problem, try adding these inside the quotes on the DISABLED_MODULES line in /etc/default/linux-restricted-modules-common:

nvidia nvidia_legacy

(I may be wrong on the nvidia one, if so try "nv" instead)

jayceekayy
May 4th, 2008, 03:00 PM
sudo nvidia-settings did the trick. thanks!

imasickboy
May 5th, 2008, 03:32 AM
You're welcome. Glad I could help.