View Full Version : [ubuntu] VLC Player no sound in Hardy Heron

May 3rd, 2008, 05:14 PM
Hi have spent the last couple of days trying to get sound in my VLC player in Hardy Heron. Judging by other forum postings there does seem to be a lot of people with the same problem as me. At last, I found a solution that worked for me. I hope by my sharing it now it will help others.

I followed the guide at link:


The Pulse audio I could never get working in vlc. In the end I added the following package which I found in the Synaptic package manager:


I then pointed in the vlc preferences to: ALSA audio output
instead of Pulseaudio output. Worked for me.

I myself am a novice in Ubuntu. I hope this will help someone else.

May 3rd, 2008, 10:46 PM
I did a fresh install of Hardy, got sound as normal apart from when playing videos in VLC despite having installed the codecs, etc.

It turned out to be the "Force Detection of Dolby Surround" (under Settings > Preferences > Audio) which was set to "Auto". I changed the setting to Off and I now have sound in VLC.

June 21st, 2008, 07:02 PM
I did a nice, fresh, clean install a while ago and I never really tested VLC because I just wasn't doing anything requiring VLC. Sure enough - today I try and play a podcast I downloaded, and no sound! Kind of the important part, eh? So i followed OP's instructions and now I have sound. Much as I appreciate the work of the developers, if things work in Gutsy I wish they'd just leave it alone.

June 24th, 2008, 09:26 AM
I changed the System -> Preferences -> Sound settings to ALSA for each component. Everything works fine now. I hope a majority of Hardy users had better luck with PulseAudio than I did!

September 11th, 2009, 11:35 AM
I tried all the given solutions, but in vain. I then installed Dragon Player and the sounds works perfectly. Time to watch a movie now!:popcorn: