PDA

View Full Version : [ubuntu] Error on ./configure



kIsS
May 3rd, 2008, 08:19 AM
Hello,

Upon running ./configure i receive this message on the last line;

Please update PKG_CONFIG_PATH to point at location of gtkmm pkgconfig files directory

So! how would i do this? :)

FredB
May 3rd, 2008, 09:04 AM
sudo apt-get install build-essential

sudo apt-get install pkgconfig

Just a guess of course.

ramjet_1953
May 3rd, 2008, 09:07 AM
What are you trying to install?

Have you installed the build essential package?

sudo apt-get install build-essential

Is the package that you are trying to install in the repositories?

Have you enabled the extra repositories in Synaptic?

Have you done your homework and reading-up on compiling from sourcecode and satisfying dependencies?

If you are new to 'nix, I would suggest that you stick to stuff in the repositories and learn to crawl, before you walk.

Regards,
Roger

Artificial Intelligence
May 3rd, 2008, 09:22 AM
Hello,

Upon running ./configure i receive this message on the last line;

Please update PKG_CONFIG_PATH to point at location of gtkmm pkgconfig files directory

So! how would i do this? :)


sudo apt-get update && sudo apt-get upgrade
sudo apt-get install libgtkmm-2.4-dev

Note, this is on 8.04 the libgtkmm might have a lower number in previous version of Ubuntu.

kIsS
May 3rd, 2008, 09:34 PM
Thank you you three :) problem fixed (via the method posted in the first reply).

P.S. yep Roger, i did my homework! ):P