PDA

View Full Version : [ubuntu] VLC stuttering



cartisdm
May 3rd, 2008, 07:37 AM
I installed VLC because I'm not a big fan of totem or the other media players (and I just gave up on trying to get them to work). I'm trying to play a DVD in VLC and it plays the menus etc. but it keeps stuttering. Video is there, audio is there....just acting retarded. I've done the guides and walkthroughs online but nothing seems to be helping me out (in Totem I still get that annoying plugin error message)

Canis familiaris
May 3rd, 2008, 07:43 AM
If you haven't installed your ATi graphics driver, then install it now.
If you have installed it then diable Compiz if it is not disabled already.

cartisdm
May 3rd, 2008, 07:46 AM
If you haven't installed your ATi graphics driver, then install it now.
If you have installed it then diable Compiz if it is not disabled already.

1. Installed
2. Not running :(

treggmo
May 3rd, 2008, 09:46 AM
cartisdm,
Start the DVD in VLC then click on Video > Deinterlace and choose X at the bottom.

opendevlite
May 3rd, 2008, 09:50 AM
This is my fix for audio on playing VCD on VLC, just try this out, it migth work for DVD's also

In VLC go to Settings->Preferences->Audio->Output Modules

Click on "Advanced Options" to view "Audio Output Modules"

in Audio Output Modules, select "ALSA audio output"

Click on "Save"

cartisdm
May 3rd, 2008, 04:07 PM
cartisdm,
Start the DVD in VLC then click on Video > Deinterlace and choose X at the bottom.


Awesoooooooooooome. Worked like a chart, thanks man. Strange I couldn't find a simple fix like that searching through google

treggmo
May 3rd, 2008, 06:19 PM
You're welcome. I found the fix by trial and error myself. I tried setting "X" as default in Preferences > Video > Filters > Deinterlace > Save, but it doesn't stick.

kerti
June 9th, 2008, 07:17 AM
I've managed to play VCDs on VLC, with ALSA as recommended. It works fine, but I notice that VLC simply "freezes" playback when the disc is a bit worn off and thus the file is slightly corrupted. I notice my hard disk light was on during the entire time VLC freezes. Is this normal?

When I play the VCD on Windows, it's also a pain due to poor disc condition, but the player simply skips damaged parts and resumes playback. Also, my hard disk isn't spinning all the time. Is this something to be fixed in VLC?

Another thing, when I play a VCD fullscreen and switch back to windowed, the audio plays but the video wont show. Any hints?

Gyrotwister
June 9th, 2008, 11:40 AM
In VLC go to Settings->Preferences->Audio->Output Modules
Click on "Advanced Options" to view "Audio Output Modules"
in Audio Output Modules, select "ALSA audio output"
Click on "Save"

Fixed my VLC DVD play back sound problem. Thankyou opendevlite.

coolnezz
September 23rd, 2009, 04:01 PM
ugh... nothing worked for me on VLC.
MPlayer is working fine though.

coolbrook
September 23rd, 2009, 04:47 PM
You're bumping a really old thread here. Anyways, FWIW VLC was updated today. The new version is 1.02 (for Jaunty anyway) and since it's an upgrade then it's worth a look.

RandyNose
March 11th, 2012, 04:10 PM
I found that by deleting my .pulse dir in my home dir cleared up my audio issue that I was having with VLC.

Use Nautilus to open your home folder, and check the View Hidden files option under the View menu, then delete the .pulse folder and reboot. This creates a new default config file for pulse audio, and it worked for me. :D

coffeecat
March 11th, 2012, 05:34 PM
Old thread - closed.