View Full Version : [ubuntu] Hardy upgrade, sound and video n o longer work , audiopulse

May 3rd, 2008, 03:54 AM
Just upgraded to Hardy Heron and everything appeared to go well except that sound and video do not work (worked great with gutsy).

No video playback, errors were as follows:

Totem: Failed to connect stream: invalid argument
Mplayer: Mplayer interupted by signal 13 in module: play_audio

No audio playback

Audio tracks just remain at 0:00

I searched the forums and found that audiopulse caused problems with other users so I shut it off and then video worked but no audio. Tried rebooting computer but it went back to the original issues.

May 3rd, 2008, 04:09 AM
Okay, try going to Sessions and deleting the PulseAudio server, then restart Alsa: sudo /etc/init.d/alsa-utils restart

That worked for me.

May 3rd, 2008, 04:11 PM
No joy. I tried those steps and neither video or audio worked, I did like I did before after that and shutoff pulseaudio through the system monitor and then I was able to play just video. I restarted the computer to see if your step would stop pulseaudio from starting up but it still starts up and neither audio or video works.

Here is the terminal screen for the steps you suggested:

sudo /etc/init.d/alsa-utils restart
* Shutting down ALSA... * warning: 'alsactl store' failed with error message 'alsactl: save_state:1251: No soundcards found...'... [fail]
* Setting up ALSA... * warning: 'alsactl restore' failed with error message 'alsactl: load_state:1327: No soundcards found...'... [ OK ]

Thanks for the help though, any other ideas?

May 3rd, 2008, 05:38 PM
Also when trying to use alsamixer i get the following error:

alsamixer: function snd_ctl_open failed for default: No such device

May 6th, 2008, 04:09 AM

May 8th, 2008, 12:26 AM
Okay after about 6 hours of research the sound now works again, and it was not complicated, got to wonder what kind of 'upgrade' this hardy heron is. Basically all I had to do was install the most recent alsa, and unmute the hidden option of 'surround' which is apparently my main speakers.

I went through about 8 walk throughs but the one that did it was:

which was posted by user: groovete @ the following link:

Thanks for all who helped.