View Full Version : [ubuntu] [SOLVED] chown for another partition?

May 1st, 2008, 04:30 AM
I have partitioned my main Ubuntu disk to provide a second ext3 partition for storing files away from the system.

However I have found that goobox cannot extract music files to a folder on it, as access is denied. I have found that the owner of the partition is listed as "Unknown" and is set at read only. How do I access it in a terminal to change the ownership permissions of the partition., This is what I see in Places, (attached) and I want to automount the 44.7 Gb volume and change its ownership to 'douglas'

Thanks for any help.

May 1st, 2008, 09:48 AM
The command to change permissions is chmod, but I can't quite remember how to use it to do disks...

May 1st, 2008, 10:11 AM
easy fixed

open a terminal window and type the following

sudo chown -R douglas:douglas /partition or drive name

e.g. I have a separate partition for downloads and I do the following

sudo chown -R dean:dean /misc
sudo chmod -R 755 /misc

if you have an external hardrive, check in the "media" folder to see what it's called, e.g. mine is "disk" and if I format that I would type

sudo chown -R dean:dean /media/disk
sudo chmod -R 755 /media/disk

hope this helps

May 1st, 2008, 10:56 AM
Hi Dean

with the numbers, ie 755 I have not yet got to grips with them, so which would I use, to give myself the necessary requirement, to access and read write the disk.


May 1st, 2008, 11:05 AM
First you need to tell us where the drive is mounted. Is it in /media/disk ?

If that was the case, you would use
sudo chown -R douglas:douglas /media/disk

May 1st, 2008, 11:15 AM
Yup its /media/disk

douglas@desktop:/media$ ls -l
total 40
lrwxrwxrwx 1 root root 6 2008-04-19 19:40 cdrom -> cdrom0
drwxr-xr-x 2 root root 4096 2008-04-19 19:40 cdrom0
drwxrwx--- 4 douglas douglas 4096 2008-04-15 21:56 disk
drwxr-xr-x 47 root root 32768 1970-01-01 10:00 seagate

Looking at the above I guess I only have to change the "drwxrwx---" bit?

May 1st, 2008, 11:36 AM
So it is definitely disk, not seagate? Because it looks like you have access privileges to disk, but not seagate. If deanjm1963 (http://ubuntuforums.org/member.php?u=85163) is right, then all you have to do is
sudo chown -R douglas:douglas /media/seagate

May 1st, 2008, 09:33 PM
first you need to give yourself ownership with "chown" - "change owner"

sudo chown -R douglas:douglas /media/disk

then you need to give yourself read and write permissions with "chmod" - "change mode"

sudo chmod -R 755 /media/disk

if it's also seagate that you need to access and change permissions, do the above but substitute /media/seagate for /media/disk

May 2nd, 2008, 12:29 AM
I'll have to remember that, I've never really needed to use it before...

May 2nd, 2008, 03:56 AM
Thaks deanjm1963 (http://ubuntuforums.org/member.php?u=85163)

That fixed it. simple really, hope I learn this stuff soon.

Interestingly I thought I might change the ownership of seagate which is an external drive, but using the same process, it will not allow me to change the ownership. it tries to access the various folders in the tree, and each one returns "Operation not permitted" any ideas why that would be?