PDA

View Full Version : [ubuntu] Hardy Heron Mega Problems.



Pap3r
April 30th, 2008, 08:41 PM
Ok, so last night I noticed I was able to upgrade to Hardy Heron... I decided to take a chance. It downloaded all the packages, configured everything, and I decided to let my old packages stay.

Today when I turned my comp back on and went to log in to GNOME, I found that my screen turned to artifacts. Tons of artifacts. They moved with the screen refresh, but I couldn't type and couldn't see anything, could barely make out a window asking for administration privileges. I restarted x, and went back to log in. This time I tried failsafe GNOME. It also screwed up.

I restarted, hoping I'd get lucky, and when I entered kernel 2.6.24.16 I was shown an error that said something about USB and failing to load. Anyway, it didn't mount my old ntfs drive which I had just formatted, and it also didn't load Firestarter. Started up, and the same thing happened.

So I tried rebooting and booting into another kernel I had loaded. This time it worked... almost. Everything loaded in GNOME, except it was in Low Graphics Mode. It said proprietary drivers were in use, but I couldn't increase the Resolution.

I restarted and went into 2.6.24.16 again, and this time I tried KDE. KDE worked. KDE didn't recognize my cd drive, and everything was kind of slow. Games like CS:S booted up, loaded quickly, but were super laggy.

What the hell happened? I want gnome back.

SlappyPappy
May 1st, 2008, 01:38 AM
Can you give some details about your system, hardware etc.?

Pap3r
May 1st, 2008, 01:46 AM
CPU Athlon X2 4600+ @ 2749
Motherboard A8N-SLI Premium
Memory 1g
Graphics Card XFX 7600GT
Hard Drive WD 160G SATA
Sound Card Onboard
Power Supply Rosewill 550w SLI
Case TT Tsunami
CPU cooling Modded CM Aquagate
GPU cooling Stock
OS Ubuntu
Monitor Syncmaster 730B

jimv
May 1st, 2008, 01:56 AM
Try this from a command line:

sudo apt-get remove --purge nvidia-glx*
sudo apt-get install nvidia-glx-new
sudo nvidia-xconfig

Reboot

You've got the same card I have in my desktop, so I know that it should work.

*To drop to a command line when the gui is fudged up, press control+alt+f1

Pap3r
May 1st, 2008, 02:11 AM
Didn't work :(

I don't think it is a driver problem for two reasons, 1) that didn't change anything, and 2)
pap3r|joe-desktop~| cat /etc/X11/xorg.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Thu Feb 14 18:20:37 PST 2008

# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"

# Uncomment if you have a wacom tablet
# InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"
Identifier "Default Layout"
Screen 0 "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "Files"
EndSection

Section "Module"
Load "glx"
Load "v4l"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "stylus"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Identifier "eraser"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Identifier "cursor"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "Monitor"
Identifier "SyncMaster"
VendorName "Generic LCD Display"
ModelName "LCD Panel 1280x1024"
HorizSync 31.5 - 64.0
VertRefresh 56.0 - 65.0
Gamma 1
ModeLine "640x480@60" 25.2 640 656 752 800 480 490 492 525 -hsync -vsync
ModeLine "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
ModeLine "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
ModeLine "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -hsync -vsync
ModeLine "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
ModeLine "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
EndSection

Section "Monitor"
#
Identifier "monitor1"
VendorName "Plug 'n' Play"
ModelName "Plug 'n' Play"
Gamma 1
ModeLine "640x480@60" 25.2 640 656 752 800 480 490 492 525 -hsync -vsync
ModeLine "640x480@72" 31.5 640 664 704 832 480 489 491 520 -hsync -vsync
ModeLine "640x480@75" 31.5 640 656 720 840 480 481 484 500 -hsync -vsync
ModeLine "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
ModeLine "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
ModeLine "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
ModeLine "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
ModeLine "832x624@75" 57.3 832 864 928 1152 624 625 628 667 -hsync -vsync
ModeLine "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
ModeLine "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -hsync -vsync
ModeLine "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -hsync -vsync
ModeLine "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
ModeLine "1280x1024@75" 135.0 1280 1296 1440 1688 1024 1025 1028 1066 +hsync +vsync
ModeLine "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
ModeLine "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
ModeLine "1280x960@75" 129.9 1280 1368 1504 1728 960 961 964 1002 -hsync +vsync
ModeLine "1400x1050@60" 122.6 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
ModeLine "1600x1200@65" 175.5 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
ModeLine "1600x1200@60" 162.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
EndSection

Section "Device"
Identifier "nVidia Corporation G70 [GeForce 7600 GT]"
Driver "nvidia"
BoardName "nv"
BusID "PCI:1:0:0"
Screen 0
EndSection

Section "Device"
#
Identifier "device1"
Driver "nvidia"
BoardName "nv"
BusID "PCI:1:0:0"
Screen 1
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation G70 [GeForce 7600 GT]"
Monitor "SyncMaster"
DefaultDepth 24
SubSection "Display"
Virtual 1280 1024
Depth 24
Modes "1280x1024@60" "1280x960@60" "1024x768@60" "800x600@60" "800x600@56" "640x480@60"
EndSubSection
EndSection

Section "Screen"
#
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "640x480@60" "640x480@72" "640x480@75" "800x600@56" "800x600@72" "800x600@75" "800x600@60" "832x624@75" "1024x768@75" "1024x768@70" "1024x768@60" "1152x864@75" "1280x1024@75" "1280x960@60" "1280x1024@60" "1280x960@75" "1400x1050@60" "1600x1200@65" "1600x1200@60"
EndSubSection
EndSection

Gnome is rendered useless for the moment, I ran those commands through KDE, which shouldn't effect it anyway... I don't think anyway.

EDIT

I was able to get into gnome through Failsafe gnome now.

jimv
May 1st, 2008, 02:14 AM
So KDE works fine, but Gnome is flippin' out?

Pap3r
May 1st, 2008, 02:23 AM
YEs, but silly, silly me.

I forgot I had an nvclock session set to run at GNOME load... The Overclock was stable in 7.10, but I guess 8.04 doesn't like it. Anyway, It loads fine now, however, it doesn't load compiz right off. I mean, compiz icon shows it as grayed out, and my cairo-dock is not transparent. When I switch to compiz as WM it all looks normal. How do I start compiz on start up?

jimv
May 1st, 2008, 09:28 PM
It should start automatically, but try pressing alt+f2 and typing 'compiz --replace'

If that works, then you can add an entry in the Sessions control panel with that command in it. (Session Manager is kind of like MSCONFIG in Windows.)

Pap3r
May 1st, 2008, 11:42 PM
Yeah, that works. Thanks for the help.