PDA

View Full Version : [ubuntu] 5.1 Sound (Logitech X530 + Philips Ultimate Edge)



tomasinho
April 30th, 2008, 07:39 PM
I am new to ubuntu and this is the first problem I couldn't find an answer for on the forums.
Previously the onboard sound card worked fine, however I have hardware for 5.1 sound so would like to get it setup properly. I have messed around with various setting changes I found on the found on other forums and had no success yet. I have also tried changing settings through Alsamixer, Sound and VolumeControl I can't get it to make even one squeak!


This is my pc setup:

Hardy
Intel Onboard sound card (now disabled)
Philips Ultimate Edge Surround Sound Card (5.1 card)
Logitech X-530 (5.1 Surround)

This is what I have done:
sudo gedit /etc/modprobe.d/blacklist


#Disable the on board sound card
blacklist snd_hda_intel

sudo modprobe snd-ice1724

sudo gedit /etc/modules
Then added this at the bottom line.. snd-ice1724

Below is what the terminal tells me through various commands, I cant decipher the problem. Hopefully someone will find the error of my way. Thanks, T



aplay -l


card 0: ICE1724 [ICEnsemble ICE1724], device 0: ICE1724 [ICE1724]

Subdevices: 0/1

Subdevice #0: subdevice #0

card 0: ICE1724 [ICEnsemble ICE1724], device 1: IEC1724 IEC958 [IEC1724 IEC958]

Subdevices: 0/1

Subdevice #0: subdevice #0



lspci -v


03:02.0 Multimedia audio controller: VIA Technologies Inc. VT1720/24 [Envy24PT/HT] PCI Multi-Channel Audio Controller (rev 01)

Subsystem: Phillips Components Unknown device 1906

Flags: bus master, medium devsel, latency 64, IRQ 19

I/O ports at d8a0 [size=32]

I/O ports at dc00 [size=128]

Capabilities: <access denied>


Lsmod

snd_ice1724 92264 3

snd_ice17xx_ak4xxx 5120 1 snd_ice1724

snd_ac97_codec 101028 1 snd_ice1724

ac97_bus 3072 1 snd_ac97_codec

snd_ak4114 10752 1 snd_ice1724

snd_pcm_oss 42144 0

snd_mixer_oss 17920 1 snd_pcm_oss

snd_pcm 78596 6 snd_ice1724,snd_ac97_codec,snd_ak4114,snd_pcm_oss

snd_page_alloc 11400 1 snd_pcm

snd_pt2258 5504 1 snd_ice1724

snd_i2c 6528 2 snd_ice1724,snd_pt2258

snd_ak4xxx_adda 9472 2 snd_ice1724,snd_ice17xx_ak4xxx

snd_mpu401_uart 9728 1 snd_ice1724

snd_seq_dummy 4868 0

dcdbas 9504 0

evdev 13056 3

snd_seq_oss 35584 0

snd_seq_midi 9376 0

snd_rawmidi 25760 2 snd_mpu401_uart,snd_seq_midi

pcspkr 4224 0

snd_seq_midi_event 8320 2 snd_seq_oss,snd_seq_midi

snd_seq 54224 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_mid i_event

snd_timer 24836 2 snd_pcm,snd_seq

herbster
April 30th, 2008, 08:40 PM
Hmm, that's the same sound driver my M-Audio uses and I've had 5.1 working for a long time, this should be easy.

Do you have an ~/.asoundrc file yet? If not, make one:


gedit .asoundrc

Paste this into it:


# 6 channel dmix:
pcm.dmix6 {
type dmix
ipc_key 1024
ipc_key_add_uid false
ipc_perm 0660
slave {
pcm "hw:0,0"
rate 48000
format "S32_LE"
channels 6
period_time 0
period_size 1024
buffer_time 0
buffer_size 8192
}
}

# upmixing:
pcm.ch51dup {
type route
slave.pcm dmix6
slave.channels 6
ttable.0.0 1
ttable.1.1 1
ttable.0.2 0.6
ttable.1.3 0.6
ttable.0.4 0.5
ttable.1.4 0.5
ttable.0.5 0.5
ttable.1.5 0.5
}

pcm.duplex {
type asym
playback.pcm "ch51dup" # upmix first
capture.pcm "hw:0"
}

# change default device:
pcm.!default {
type plug
slave {
pcm "duplex"
}
}

# for aoss
pcm.dsp "duplex"

pcm.dsp1 "duplex"

pcm.10to20 {
type route
slave.pcm default
slave.channels 2
ttable.0.0 1
ttable.0.1 1
}

pcm.pulse {
type pulse
}
ctl.pulse {
type pulse
}


#------------------------end of working file

Now tell me what you hear and paste the output of


speaker-test -c6 -twav -Dplug:dmix6

Hit CTRL+C to end the test.

tomasinho
May 3rd, 2008, 11:07 PM
Hmm, this did not seem to work.

I have looked around for more answers and the Alsa-project it shows that the Ultimate series is blacklisted. http://www.alsa-project.org/main/index.php/ALSA_Blacklist , does that mean it can't work? Surely there must be a way around this.

Also found this http://www.alsa-project.org/main/index.php/Matrix:Module-ice1724 but not sure if it is the right think before i start messing with more settings!

Any more ideas would be much appreciated! T