View Full Version : [ubuntu] Atheros5007 Works Once, Then Stops Working Upon Reboot

April 29th, 2008, 05:43 AM
Hi folks,

I have Ubuntu running on dual partition with Windows Vista on a Compaq laptop. I started with Unbuntu 7 a while back, but wifi didn't work -- no page loads, no network detection, a red light near the keyboard where it detects wifi, etc.. I took the laptop to a friend who knows far more about these issues than I, and we finally got wifi up and running (I'm not sure how, to be perfectly honest, he tried a lot of different drivers). The blue wifi light near the keyboard lights up, and it detects several networks, where available. I even could load web pages, until I got it home.

I got home and then the web page load aspect of things didn't work (Presumably after shutting down and rebooting), though it still lights up a friendly blue on my hardware and detects networks, it just can't seem to do anything with them. And, yes, I made sure to enter my network password and select the type of network and such.

So, some time passes and I hear Unbuntu 8.04 is out and I figure maybe the new code contains a fix. I download that (Using a wired connection) and install through the upgrade program in the old Ubuntu interface. It's a nice build. It even runs flash, something I could never manage with 7.x despite trying flash-free and gnash several times (Through Synaptic) -- but they not only work with the new build, 8.04 just does it, which is great. And things really seemed to look up when I went in, it detected wifi, I entered my password, and the wifi worked -- UNTIL THE REBOOT OF DEATH.

It's worked on two occasions. I know it can work. Something about the shut down or boot process must be interfering. And I can't seem to get it work again no matter what I do, aside from the upgrade to the new version, and then back to the same old problem. I use GRUBB to boot, if that helps.

Anyone know what's going on? My "tech guy" friend got sick of working on the problem about the time he first thought he had it fixed, so I'm basically on my own with this, and I'm mostly technically illiterate. The closest I've come to successfully using a Linux command prompt is being able to type a:\install or cd\mps\civ in MS-DOS years ago. :)

April 29th, 2008, 06:00 AM
Oh, and I guess I should mention the wireless device hardware thing works fine with Windows Vista. I've been using it for a couple months now and only had one problem, which I was able to resolve in a night.

April 29th, 2008, 06:19 AM
I have had a similar problem although i can not get mine to work at all. Its the atheros card on a compaq laptop does anybody have any idea on how to get the darn thing to work?>

April 29th, 2008, 07:16 AM

Upon loading, Internet doesn't work. If I do the manual network configuration thing in the upper-right hand corner of the screen (As represented by the two block computer screens in icon form), and switch to roaming mode, it'll detect several networks. I can select mine and enter the password and the details and it'll connect me. I can even leave roaming mode, and it'll stay connected. I'm posting from Ubuntu via wifi at this moment.

So, I can't get it to automatically find my default wifi in non-roaming mode. By switching to roaming mode, it seems to work. Anyone know why this might be?