View Full Version : [kubuntu] Eclipse Error - Security Component?

April 28th, 2008, 09:57 PM
When I start Eclipse (3.3) and select a Workspace it gives me this message:

Could not initialize the application's security component. The most likely cause is problems with files in your application's profile directory. Please check that this directory has no read/write restrictions and your hard disk is not full or close to full. It is recommended that you exit the application and fix the problem. If you continue to use this session, you might see incorrect application behaviour when accessing security features.

I looked this up and only found one solution:




This did not work for me. Has anyone else run into this problem?

April 29th, 2008, 10:41 PM
I had exactly this problem when trying to run Eclipse 3.3.2 64bit on Hardy 64bit.

Essentially, the solution described here: http://gdub.wordpress.com/2008/04/27/eclipse-security-component-errors/ worked for me.

I executed
mkdir ~/.mozilla/eclipse then gave the new eclipse directory full permissions
chmod 777 ~/.mozilla/eclipse and now eclipse runs fine.

No idea why eclipse needs a directory here. Any ideas anyone?

May 1st, 2008, 09:24 AM
"No idea why eclipse needs a directory here. Any ideas anyone?"

I saw the XUL runner hidden somewhere in the distribution. Thats a possible cause, at least.

Patrik Granlöv
May 29th, 2008, 09:25 AM
I got the same error message when I installed CollabNet Desktop (http://www.collab.net/products/integrations/cdee/getit.html) from Help.

Creating the directory solved my problem also.


January 18th, 2010, 05:01 PM
I suspect the error could be caused by running Eclipse under sudo on the first invocation.

I had a ~/.mozilla/eclipse directory owned by root. Once I changed ownership to myself, it worked fine.

A reboot of Eclipse is required once you have altered the permissions.