PDA

View Full Version : [ubuntu] Quote key quark?



Sean-Michael
April 28th, 2008, 03:05 AM
I seem to have a quark or something I do not understand about my key board. There are about four characters that come from my "quotations key".

Single quotes,

1 =

2 = '

Double quotes,

3 =

4 = "

these are all coming from the key mentioned and I dont really understand it, I use this key a lot for my web work and would like to get it to function like normal!

Thanks,
Sean-Michael.

thomasaaron
April 29th, 2008, 03:15 PM
Please give more info on what the problem is. When that key is pressed without the shift key, it gives single-quotes. With the sift key, it gives double-quotes.

It appears to be providing two different variations of each, but I don't understand when/where that happens. Does it give variations within the same program or in different programs.

Sean-Michael
April 29th, 2008, 09:59 PM
This is happening system wide, let me better explane the behavior of the key.

Single quote when I push the key twice = and once and then the space bar = '


Double quotes when holding the shift key, twice = once and then the space bar = "

Once again I would like it to behave like a normal key.

My laptop is a new Serval Performance running hardy 64 bit.

Thanks,
Sean-Michael.

thomasaaron
April 29th, 2008, 10:50 PM
I've tried to duplicate it, but I'm not having any luck.
It might be a font setting or something.

Give me a call and walk me through it. I'm still not convinced I'm doing it right.

octathlon
April 30th, 2008, 06:33 AM
If you go to System|Preferences|Keyboard, on the layout tab, are you using U.S. English, or is some other layout listed?

Sounds like you might be using U.S. International or some other layout where the apostrophe/quote key is a dead key used for making international characters, since you are having to hit an additonal key before a character appears. If you have more than one layout installed, they are usually toggled by pressing Ctrl+Space.

Sean-Michael
May 1st, 2008, 06:12 PM
I think you got it octathlon,

Late last night I fixed this problem but wasnt quite clear what I had done, I was trying so many things... as you mentioned my Layout is U.S. International (with dead keys).

I think I fixed it by changing the keyboard model but I would like to ask, what is the proper way to fix it? Do I need to use USA layout?

Also, can anyone tell me what the keyboard model should be, mine currently is set at Classmate PC lol

Also sorry about the later reply Thomas, I've been so busy!

Thanks,
Sean-Michael.

thomasaaron
May 1st, 2008, 07:03 PM
USA Layout
Generic 105-Key (Intl) PC

Sean-Michael
May 1st, 2008, 10:04 PM
I tried the settings you suggested thomasaaron and it brings me back to the same problem...

thomasaaron
May 1st, 2008, 10:28 PM
What Octhalon said was interesting.

The setup I gave you is what I have on our shop serval, and I can't seem to duplicate the problem.

Do you have a second keyboard layout installed. If you do, then perhaps you are inadvertently toggling between the two. Let us know if this is not the case, and we'll continue to tinker with it.

It's definitely a configuration issue of some kind. I feel pretty certain about that.

octathlon
May 1st, 2008, 11:37 PM
I just got Hardy installed on my desktop today and it looks like it uses slightly different layout names than Feisty. First make sure your selected keyboard model is Generic 105 key, not Classmate. :) Then if you don't have the correct USA layout in the list, you need to Add it: Layouts-USA and Variants-Default. Then you should Remove whatever other layouts were there, assuming you don't actually want additional layouts that is.

Sean-Michael
May 3rd, 2008, 07:02 AM
It's working now, using the settings you described, but I did have to remove the original layout like you suggested or the problem persisted.

Thank you so much for the help, this one was driving me buggy!
Sean-Michael.

todb
May 6th, 2008, 07:54 PM
Changing the keyboard layout to USA (and not the USA international) will certainly fix this problem. Quotes, backticks, and doublequotes are all affected. Again, to fix:

System > Preferences > Keyboard
Layouts (tab)
Add (button)
Add "USA" and "Default," and hit Add.
Remove the USA Alternative layout.

Unfortunately, "USA Alternative international (former us_intl)" is the default with the stock Ubuntu804desktop VMware pre-built image, so I imagine a bunch of new users are going to run into this behavior out of the box, which is a shame. I did and was irritated for many minutes. :)

jammindice
May 15th, 2008, 12:59 AM
i used the alternate cd to use lvm with encryption and i had this same problem since the keyboard selector is very odd during that installation