View Full Version : [ubuntu] 8.04 not ready yet?

April 27th, 2008, 04:11 PM
I really hate to go here, especially after lambasting Fedora for requiring too many acts of love to get and keep it running.

I had U8.04 beta and reported many issues against it. I believe everything I am about to say I reported back shortly after it went beta.

I have a Dell XPS 720 with quad 6600's, 3 GB mem and two 250GB SATA drives in a bios raid-0 configuration. Vista, which was preinstalled had no problems with it, Fedora8, for all it's faults had no problems with it and installed seamlessly in an 2 PV striped LVM environment of 465GB or so hard drive env.

The operative word there is seamlessly. A year ago I switched to Ubuntu because Fedora required too much work and I have been pretty pleased with it as my primary development environment.

I downloaded the alternate install because Ubuntu does not natively do LVM. With both the U8.04 beta and GA I installed with the bios setting on both SATA drives set to RAID on. After the install on the initial boot I got, again, a grub 2 error. Neither Microsoft nor Fedora have this problem. Whether they honor the bios raid setting I can not say but they don't fail to boot because of it. Turning raid off on both drives allowed the boot to proceed. I configured SATA-0 with the /boot, /root, and swap partitions and SATA1 to be a single LVM PV. It wasn't/isn't clear to me why it did not join the /dev/cor720-mapper/root logical volume, but it didn't. Maybe that was too much to expect. When I noticed the DF cmd only showed approximately 230GB in the logical volume I investigated further and discovered I needed to extend the lv by the extents shown in the pvscan which showed both volumes and nothing allocated from the second PV. After the lvextend the lv showed a total of 465 or so GB. I was happy. However the DF still showed 230GB total memory. So it is not clear to me why Fedora showed all 465GB+ right after the out of the box install yet Ubuntu doesn't. Isn't that done in the kernel and aren't they using the same kernel? For that matter isn't the bios raid handled in the kernel and aren't they the same kernel? No matter, maybe it needed another boot for the kernel to recognize the full LV, maybe DF never recognizes a multiple PV logical volume.

During the beta cycle I ended up using VMWare to run my legacy Windows environments, you know, server consolidation. I really didn't like that solution as, 1) it was not free when KVM and Xen were, and 2) it was actually noticeably slower than native and for $189, I didn't want noticeably slower. I could never get KVM to run properly during beta. I since read articles effectively saying use the command line as virt-manager doesn't enable the CDROM checkbox. I kept getting connection failures and could never get it to even try to boot off a cd much less install anything.

Prior to erasing the beta 8.04 and doing a fresh install of the GA I backed up my home directory up to my NAS unit, all 63GB of it. It took all day yesterday to retrieve the files I wanted, note, I did not replace any of the hidden . files or directories. I eventually noticed that none of the files I had restored were showing up either in the Desktop (for some) or the home dir for the others. Since I wanted to see if a reboot would resolve my df vs. lvdisplay conflict, maybe it would show these files that took all of Saturday to restore. The progress bar on archive manager did progress, very slowly but it did progress so I assumed it was restoring. Oh, and it turns out that archive manager wedged as well and would not enable the expand menu item. I ultimately had to force quit it prior to the reboot.

So this morning, before launching into this missive, I rebooted. 8.04 did not cleanly shut down, I had to power of the machine and, upon reboot, it appeared to hang with the cursor doing a fast blink in the top right. Eventually it did reboot and initialize but the lvdisplay/df issue remains and the files I thought restored yesterday apparently didn't. So all of yesterday was a completely unrequited labor of love, much like I was lambasting Fedora for being.

I realize an awful lot of people worked very hard to get 8.04 to be at all and I certainly applaud their efforts. I would really like this to work. I do not believe I am expecting more of Ubuntu 8.04 than it is supposed to be able to do. The comments about Fedora were made in response to a blog entry and comment that the goal of Fedora (and presumably Linux as a whole) was not to attract a community of users but rather attract a community of developers to work on it. Normally I allows others to live peaceably in their private Idaho's but I couldn't resist a rebuttal. So, while yes, this sounds like a blog entry rather than a request for help and perhaps embryonic bug report, although I already reported these items, save the wedge in archive manager, I would appreciate help on these issues:

Why does Ubuntu not honor the bios RAID setting, when other OS's do?

Is there a configuration issue with LVM or does DF simply not understand a multivolume logical volume. Is this a software bug, a doc bug, or something else?

Why won't virt-manager enable cdrom while it, in theory, is supported in the command line? Is this a software bug or doc bug?

I can't find any help on the connect failure during a virt-install, the log follows.

[Sat, 26 Apr 2008 18:43:19 virt-install 27839] ERROR (virt-install:523) 'virtio_blk'
Traceback (most recent call last):
File "/usr/bin/virt-install", line 519, in <module>
File "/usr/bin/virt-install", line 438, in main
guest, hvm, conn)
File "/usr/bin/virt-install", line 134, in get_disks
disk, size)
File "/usr/bin/virt-install", line 133, in <lambda>
map(lambda d, s: get_disk(d, s, sparse, guest, hvm, conn),
File "/usr/bin/virt-install", line 108, in get_disk
d.virtio = guest.get_virtio_blk()
File "/usr/lib/python2.5/site-packages/virtinst/FullVirtGuest.py", line 206, in get_virtio_blk
return FullVirtGuest.OS_TYPES[self.os_type]["virtio_blk"]
KeyError: 'virtio_blk'
[Sat, 26 Apr 2008 18:46:03 virt-install 27845] ERROR (virt-install:523) virConnectOpen() failed


April 27th, 2008, 04:53 PM
This may not be what you want to hear, but I'll explain how I have setup my system.

Rather than putting the system OS on a raid w/LVM on top, I put it on a plain old WD Raptor drive. This way if a system upgrade or bios upgrade temporarily hoses my raid setup, I can still boot the computer and inspect what is going on. I also don't spend a lot of time moving backups around as you are explaining. In fact, many people isolate home to its own partition so if you need to reinstall the OS for some reason, it wont effect many of your settings. You could even mount it from your backup location if that is possible.

Raid is great for data retention, but it can't match the simplicity of plain old SATA/ide access. Not to mention the majority of your OS will be sitting in ram anyways, I run my computers with swappiness = 0.

Now, any big apps that I want to run with RAID 0 speed or RAID 5 redundancy I have under a software raid. Once during beta, a tool upgrade broke my lvm access however I was still able to boot (with lots of errors of course) figure out was going on and wait for the fix to come down the package chain. If you are using a high-class raid controller, I would definitely use that over a software raid but if you are using the cheap Intel built-in motherboard controllers, I would use software raid over that. The cpu overhead is very low even when Im pushing a lot of data around.

April 27th, 2008, 06:20 PM
At one level I take no issue with anything you have said. But...what you said was, "if it doesn't work, don't use it". I guess kind of the meta message in my first was, 'but I'd really like to use it'. Here is one thing I really want to do, have a multiple RDBMS federated evironment with or without Hibernate and Shards to get better exposure to and experience in data federation. While this doesn't require RAID0, or even Linux, I believe it will help with, as you said, pushing data through, just as gigabit eths will. Some of those partitions/shards I'd like in vm's. I write software professionally so I use my home environment for far more than surfing, email, and playing Doom. Not that there is anything wrong with gaming, it's just something that came along after I was beyond it. I think the onus for everyone in software is to stay relevant, which is what I strive for in a home system. This is another reason why I'd like to stay in Linux because I happen to believe Linux has the promise of being a better development and production platform than the obvious alternative. This is why I took such umbridge with the Fedora blog because my motivation is to write and debug high performance software people will pay to use, not debug questionably working buggy software because it is on the critical path to what I really want to accomplish. This is why I think going for that community of developers over the community of users misses the entire point. The reason people flock to uSoft Windows (not necessarily Vista) is because largely it does, "just work" so people can go about doing what they really want w/o the OS getting in their way. Having said that though, I'd like to know:

Why the Ubuntu platform can't recognize / honor firmware RAID, regardless of whether it is the best approach. When you say swappiness do you mean v=r?

Why is it so difficult to set up a default LVM environment with Ubuntu when it is the default configuration with Fedora? And beyond that HOW does one set this up to work correctly? Which is it, in what I described, I have a two physical volume logical volume giving me 465GB of useable user space, or do I have a 465GB logical volume which will only provide me the first 230GB of usable space? If not why is DF broken? Is DF broken in an LVM environment?

Why can't someone write doc, and if it's done, where is it, on actually building usable VM's with KVM. Why can't one point to a CDROM with virt-manager?

And why does archive manager go unresponsive, disabling the extract button, restore files to nowhere, and fail to shutdwon on exit?

And I am not even complaining about the beta of Firefox which exhibits its own wierd *** broken behavior. OK, FF 3 occasionally darkens for no apparent reason during which time it is totally non-responsive sometimes it recovers and sometimes, granted, mostly during beta, it foretold of FF crashing.

So while yes, I do seem to be editorializing, I would like some resolution to the above points.