View Full Version : [ubuntu] Login Window Resolution

Sleaka J
April 27th, 2008, 11:51 AM
When I installed the nVidia drivers in 8.04 it set my resolution to 1600x1200x60Hz. This wasn't a problem, so I set it back to my preferred resolution of 1280x960x85Hz.

Unfortunately, while the desktop stays at 1280x960x85, whenever I go to the login screen it goes back to 1600x1200x60. Is there a way to edit the screen resolution of the login window to match my desktop resolution and refresh rate? I want them to be both the same so it doesn't need to switch when I login. I'm the only user of my machine so it's not like I need to have any other users in mind.

I've had a play around with some setting and the xorg.conf file and made things worse. Thankfully I was able to get it back to the way it was before.

April 27th, 2008, 12:04 PM
I had same problem (19" monitor with 1280x1024 max res), and it did it, so this could help:

first make a backup copy of xorg.conf with:
sudo cp /etc/X11/xorg.conf /etc/X11/xorg.backup

to edit xorg.conf open it with:
sudo gedit /etc/X11/xorg.conf

- now find Section "Monitor"
- comment following lines (with # sign):
# modeline "1400x1050@60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
# modeline "1600x1200@65" 175.5 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync
# modeline "1600x1200@60" 162.0 1600 1664 1856 2160 1200 1201 1204 1250 +hsync +vsync

- find Section "Screen" (should be next section)
- comment following lines (with # sign)
# Virtual 1600 1200
# Virtual 1280 1024

now save file and restart X11

I hope it will help you


Sleaka J
April 27th, 2008, 12:32 PM
This is what my xorg.conf file looks like

# xorg.conf (X.Org X Window System server configuration file)
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"

Section "Monitor"
Identifier "Configured Monitor"

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Defaultdepth 24

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
Section "Module"
Load "glx"

When I was playing around and made things worse, it had some of the resolutions and screens that you mentioned, but it no longer has those as I reset the file.

Sleaka J
April 28th, 2008, 02:01 PM
So, nobody has any suggestions at all?

April 28th, 2008, 04:44 PM
I have the feeling that this issue is playing up a bit more.


I haven't looked for a bug on launchpad, but have the same problem.

Has anybody found anything solid?

Sleaka J
April 28th, 2008, 07:21 PM
Thank you Maupertus,

I followed the directions rac9876 gave in the thread you linked and it worked pefectly.

Kudos to you.