View Full Version : [xubuntu] Working G3 imac xorg.conf for Hardy 8.04

April 27th, 2008, 07:16 AM
After having a issues getting Hardy to light up the screen, I found this .conf setup to work well.
Might help someone.

# xorg.conf (X.Org X Window System server configuration file)
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbVariant" "intl"
Option "XkbOptions" "lv3:ralt_switch"

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"

Section "Device"
Identifier "Configured Video Device"
BusID "PCI:0:18:0"

Section "Monitor"
Identifier "Configured Monitor"
Horizsync 30-65
Vertrefresh 50-75

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
SubSection "Display"

Modes "1024x768" "800x600" "640x480"

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"

Section "Module"
Disable "glx"
Disable "dri"

April 27th, 2008, 10:08 AM
Congratulations! Seems that nvidia card users are having less problems initially. What exact model of G3 iMac are you using?


July 2nd, 2008, 08:59 PM
thank you it worked for me

imac g3 um 266mhz i think

July 14th, 2008, 03:51 AM
Is any of you able to turn off your monitors only? I'm trying to turn off my monitor on my imac g4, but it only goes orange. The backlight doesn't turn off.

Please, give any hints you ever came across this problem. Thanks!

February 1st, 2009, 05:47 PM
I was asked to load Linux on an old iMac for a guy that wants to gain some familiarity with Linux.
The machine is a blue iMac, model M5521. It has a 350Mhz processor, and it came to me with 256MiB of memory and a clean hard disk of about 7GiB. I chose the Ubuntu 8.04.1LTS powerpc alternate disk, and the install was straightforward, but upon rebooting into the new system, it almost immediately locked up, the screen went blank, and the keyboard became unresponsive. The machine was silent, as if the HDD had spun down, but the light behind the power button was still on.
Much surfing of these forums yielded the 'video=ofonly' bootparm, and that got me a single underscore on screen after boot, but a live keyboard, so I could alt-F1 and login to a text console.
More surfing led me to the need to edit xorg.conf, and 'change' the sync frequencies, but the default xorg.conf didn't have any frequency lines at all. All my stabs failed with no change in symptoms. So I was elated when my searching finally led me to this thread, and it's complete, supposedly working xorg.conf! But alas, it doesn't work for me.
I've installed this xorg.conf in /etc/X11/, and edited /etc/yaboot.conf to remove 'splash' and include 'video=ofonly', then run ybin. In it's current state, the machine will boot without intervention to a login prompt, but then inexplicably, the screen will slowly blink three times before stabilizing.
I never see anything graphical at all. No splash, no gdm, no X.
When I attempt to `startx` from the command line, it throws some messages, and eventually complains of 'no screens found'
I swapped out the memory for a pair of 256MiB sticks I had in the drawer, but that didn't improve the situation.
I'll attach the Xorg.0.log from one of my attempts.
Some things that catch my eye:
I have disabled glx and dri as suggested, and I get these acknowledgements:
(WW) "glx" will not be loaded unless you've specified it to be loaded elsewhere.
(WW) "dri" will not be loaded unless you've specified it to be loaded elsewhere.
...and yet a little bit later, I get these:
(II) "glx" will be loaded even though the default is to disable it.
(II) "dri" will be loaded even though the default is to disable it.

Secondly, in your working xorg.conf, you specify the device address at 0:18:0. In my Xorg.0.log, I see this from the PCI probe:

(--) PCI:*(0:16:0) ATI Technologies Inc Rage 128 PR/PRO AGP 4x TMDS rev 0, Mem @

...and a bit later, as it's loading the R128 driver, it tells me this:
(II) Primary Device is: PCI 00:10:0
(--) Assigning device section with no busID to primary device
(--) Chipset ATI Rage 128 Pro VR PR (PCI) found

The (0,10,0) address seems to agree with what `lshw` tells me.
I don't know if this is significant, but also in the loading of R128, I get this warning:
(WW) ****INVALID IO ALLOCATION**** b: 0xf0000400 e: 0xf00004ff correcting^G
(EE) end of block range 0xefffffff < begin 0xf0000000
(II) window:
[0] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) resSize:
(II) window fixed:
[0] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[B]

Then this:

(II) Loading sub module "fbdevhw"
(II) LoadModule: "fbdevhw"
(II) Loading /usr/lib/xorg/modules/linux//libfbdevhw.so
(II) Module fbdevhw: vendor="X.Org Foundation"
compiled for, module version = 0.0.2
ABI class: X.Org Video Driver, version 2.0
(WW) open /dev/fb1: No such file or directory
(WW) open /dev/fb2: No such file or directory
(WW) open /dev/fb3: No such file or directory
(WW) open /dev/fb4: No such file or directory
(WW) open /dev/fb5: No such file or directory
(WW) open /dev/fb6: No such file or directory
(WW) open /dev/fb7: No such file or directory
(EE) Unable to find a valid framebuffer device
(EE) R128(0): Failed to open framebuffer device, consult warnings and/or errors above for possible reasons
(you may have to look at the server log to see warnings)
(II) UnloadModule: "r128"
(II) UnloadModule: "fbdevhw"
(II) Unloading /usr/lib/xorg/modules/linux//libfbdevhw.so
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Thinking back to my initial install, I seem to remember a question about framebuffer support. The installer implied that selecting the framebuffer device was a 'safer' choice than without it, so that's probably what I chose. Shall I go back and re-install without framebuffer support instead? Can I somehow change that selection now without re-installing?

February 2nd, 2009, 06:50 AM
When I keep banging my head against the wall, sometimes the brick chips a little bit...

I ran `ls -al /dev/fb*`, and discovered only one framebuffer device present, fb0. So I decided to create another. `mknod -m660 /dev/fb1 c 29 1` . Then I tried another startx, and lo and behold, I got a flash of rainbow colors on my screen, followed by a grey screen with an X in the middle. Getting closer...
I went back to xorg.conf and gave it another look. I discovered that I still had in there an 'option usefbdev true' line, so I commented it out. I also had the hunch that the PCI address confusion (0,10,0) vs (0,16,0) might be a simple decimal-hex conversion, so I tried changing to the decimal version (0,16,0). Save, exit, and startx. This time, no flash of random rainbow, but directly to the grey X, and a few seconds later, the Hardy Heron appeared!
But when I tried to launch Firefox, I got a few error dialogs popping up about the 'user switcher' failing, but firefox eventually opened.
I closed it, exited from X, issued a reboot from the shell prompt, and kept my hands off the keyboard. This time, no magic boot incantations, no muss, no fuss, and I got an Ubuntu gdm login! And a few keystrokes later, the full Gnome desktop.
When Synaptic finishes installing the 246 updated packages, I'll shut it down and revert the memory to the 256MB it came with, and see if it still can launch the desktop...

February 2nd, 2009, 08:53 AM
You may want to change your horizontal and vertical to frequencies as shown in this faq:


Even though it addresses a blank screen, these values have been determined to be optimal for G3 iMacs:

HorizSync 58-62
VertRefresh 75-117

February 3rd, 2009, 06:15 AM
Yes, I've seen that thread. Tonight, I tried both sets of freq values. With the set declared in the OP above, xorg sets up for all three resolutions (1024x768, 800x600, 640x480), and it comes up in 1024x768. When I attempt to switch to the others with ctrl-alt-+, I get blank screens until I switch back.
With the set of frequencies in the thread you mentioned, xorg rejects 800x600 and 640x480 with 'hsync out of range', but it still runs in 1024x768. Now when I attempt to switch resolutions, nothing happens at all. I suppose that's better than blank screens.

February 5th, 2009, 02:55 PM
Hi, unclernie

I went back to xorg.conf and gave it another look

Can you give here your xorg.conf, I have the same problems as you with the same iMac model, but I can't make it work ...

I use 8.10