View Full Version : [ubuntu] 6.06 to 8.04 - a few wee problems

Roger D
April 27th, 2008, 06:36 AM

I've upgraded from 6.06 to 8.04 - took some time, but the fact that it works at all is pretty amazing. Three little problems:

1 I've no sound. A month or so ago an update killed the sound on 6.06. It worked with the 7.10 live CD, so I reckoned the move to 8.04 would solved the problem. It hasn't, although it does work with the 8.04 live CD. Must be some simple software tweak, but I don't know what to do.

2 I've no visual effects under Preferences>Appearance. When I click on the Normal option, and try to open a new window there's no orange bar at the top, so no way to control the window. Perhaps this is a function of my fairly modest graphics card - an Asus EN6200LE. This doesn't have a fan, and according to my sensors-applet, is running at 55C, whereas my CPU is running at 40C. Again, I don't know if this is significant.

3 The icons for OpenOffice Writer and Calc are odd. Under 6.06 I'd selected a couple of non-standard icons for these applications. You right click on the icon, select properties, and then click the choose icon button. Currently I've got a very dull blank screen icon for these applications, unlike the other OpenOffice applications where I didn't change the icon. However, when I try and change them, using properties and the choose icon button, the list of offered icons doesn't include anything suitable, and, in particular, it doesn't include the standard icons. They must be around somewhere, but I don't know how to find them.

All help, on any of these, much appreciated.

Roger D

April 27th, 2008, 07:55 AM
I think I had the same problem as you (an update about a month ago killed the sound). The problem turned out to be that some how my /etc/asound.names some how got deleted. If you have the same problem just run `sudo alsactl names` and it should regenerate this file. Also, try looking for the openoffice icons in /usr/share/icons/Human/48x48/apps/

Roger D
April 27th, 2008, 08:25 AM
Many thanks for the response.

One down - two to go. I found the openoffice icons, and all is now OK there - great!.

Still no joy with sound. Nothing seemed to happen in my terminal, with your suggested command. Here's the output:

roger@roger-desktop:~$ sudo alsactl names
[sudo] password for roger:

Any other ideas?

Roger D

Roger D
April 27th, 2008, 08:33 AM
Just had a look in /etc for an asound.name file - it is there. Not sure if this is significant

Roger D
April 27th, 2008, 11:42 AM
Have solved the sound problem. In volume control PCM was off and controls were set a zero. Turned it on, and it now works. Don't know why, but very pleased that it does.

Now just the visual effects problem.