View Full Version : [xubuntu] screen resolution problem

April 27th, 2008, 02:44 AM
Running inspiron 1100 notebook and just internet upgraded from 7.10 to 8.0.4. Having trouble getting screen back to the right resolution. It runs at 800x600 no matter what I do. I have been using linux a long time so here is what I've tried. First I tried the settings gui to no result only resolution was 800x600. I then hard coded the resolution to 1024x768 in xorg.conf. After that I tried switching to VESA and using xrandr with no success. I am stuck. The sudo dpkg-reconfigure xserver-xorg doesn't work anymore. I realize the 845g intel chipset with the i810 driver is lousy but I just want the right resolution dont care about acceleration. Here is my xorg.conf hope you guys are smarter than me. I've gotten dual screens with compiz on both nvidia and ati so I do know what I;m doing.

# xorg.conf (xorg X Window System server configuration file)
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizEdgeScroll" "0"

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY

Section "Device"
Identifier "Generic Video Card"
Driver "i810"
BusID "PCI:0:2:0"

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
HorizSync 30-70
VertRefresh 50-160

Section "Screen"
Identifier "Default Screen"
Device "Generic Video Card"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768"


Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"

# Uncomment if you have a wacom tablet
# InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"
InputDevice "Synaptics Touchpad"

April 27th, 2008, 08:56 AM
this trick works for ubuntu, not sure about xubuntu.

run sudo displayconfig-gtk in a terminal window to configure your monitor and graphics card.

If your monitor is not listed here, please go to the manufactures homepage to get the horizontal an vertical range there.

April 27th, 2008, 02:03 PM
Thank you! That solved my problem with a new install.