View Full Version : [ubuntu] Screen Refresh Rate after upgrading to 8.04

April 26th, 2008, 10:57 PM
Hi guys, back in 7.10 I used a screen resolution of 1280x800 (as high as the resolution dialog allowed) and I could get a refresh rate of something around 60 (I'm not entirely sure, but it was around there).

Now that I updated to 8.04 after installing the nvidia drivers I was glad to see I could go all the way up to 1400x900 (which is the best for my monitor) but not happy to see that the highest refresh rate was 52Hz, even if I tried a lower resolution the refresh rate combo box would not go higher.

So I followed the instructions here:
to try to get 1400x900@60.

I have a LG L192WS monitor and an integrated GeForce 6100.
I'll post my xorg.conf file at the bottom of the post.

The main problem I'm having is that after doing these changes the Screen Resolution dialog still says I'm at 52Hz and I'm not sure if this is correct or not, maybe I did get it to 60 but I can't really tell.

So is there anyway to make sure my refresh rate is at least at 60 now?

Thanks in advance for any help.

xorg.conf (I bolded the stuff I added):

# xorg.conf (X.Org X Window System server configuration file)
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "latam"

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"

Section "Monitor"
Identifier "Configured Monitor"
HorizSync 30-83
VertRefresh 56-75
Modeline "1440x900@60" 108.84 1440 1472 1880 1912 900 918 927 946

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Defaultdepth 24

SubSection "Display"
Depth 24
Modes "1400x900_60.00"

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
Section "Module"
Load "glx"

April 26th, 2008, 11:15 PM
Well, my eyes are quite sore so I'm pretty sure I'm still at 52Hz :-(

April 27th, 2008, 02:10 AM
You can get 1440x900 in Gutsy, all you have to do is reconfgure xorg-xserver and choose 1440x900, don't choose anything higher the highest resolution will be chosen.

Just run 'sudo dpkg-reconfigure xserver-xorg' and choose all defaults. When you reach resolutions choose 1440x900 and any other resolutions you wish. Also, choose Simple instead of Advanced when you reach it as sometimes choosing Advanced will disable Compiz-Fusion. I don't recall the setting but you will know when you get there.

April 27th, 2008, 10:44 AM
I had a similar problem where my monitor was lieing to the nvidia driver about what it could do. I had to disable EDID which as I understand is a way of querying the monitor about it's resolution and refresh rates.

here's how it would look in your xorg.conf

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
Option "UseEDID" "false"

April 27th, 2008, 10:52 AM
Where are you getting these refresh rates from, the tool in gnome or your actual monitor? With the binary nvidia driver the wrong refresh rates get displayed in the gnome tool even though they set the correct ones.

April 28th, 2008, 01:24 AM
Thanks guys, I did some more fiddling around with xorg.conf and used a modeline generated with another tool and I'm pretty sure I got it at 1440x900@70 so its all good now.

Setting the UseEDID option I think made no change because the gnome tool still reported 52Hz but I'm pretty sure it's higher now. I don't know how to query my screen directly though.

Also the xorg log does not report any errors nor warnings.

July 5th, 2009, 10:36 PM
Hi dont know if its to way back to remember, but what tool did you use to get the xorg configured correctly, having the exsact same issue on my buddy's comp, using the exsact same monitor, LG L192ws.

would be really nice to know what tool you used to get it at 1440x900, my friend's videocard is a Nvidia Geforce 7600GS 256MB, AGP thou, so pleace report back with some results, you came up with at that time.

Kind Regards MikeDK