View Full Version : [xubuntu] hardy upgrade : nothing after grub

April 26th, 2008, 03:37 PM
The answer may be already be out there, but I've not found it yet. I upgraded my fully functional machine last night from gutsy to hardy, via internet, and now it won't get past loading grub. Is there something that I should look for in GRUB, or restore GRUB using my gutsy install disk? I'll look for instructions on how to do that. The screen shows 'grub loading', then there's no video signal, then there's a black screen with a cursor in the upper left corner. Any help would be appreciated, thank you!

Note: This is a different machine from the one I'm posting about with the ethernet issues after upgrading to hardy.

April 26th, 2008, 04:08 PM
How long did you wait? Did login screen came after few minutes?

April 26th, 2008, 05:06 PM
I waited at least 5 min with no login screen, though I've read that others have had to wait longer than when on gutsy, so I'll try letting it sit for a while. On gutsy is was set to auto login, and used to bring up the desktop with a minute or 2. Thanks!

April 26th, 2008, 05:57 PM
I let the box run for 30min and so far, no login or desktop, just a black screen and cursor.

April 26th, 2008, 06:47 PM
Read through this thread (http://ubuntuforums.org/showthread.php?t=765195&page=5). You may be caught with the same SATA drives not being recognized. You may need to add 'irqpoll' at the end of your boot string in /boot/grub/menu.lst file.

April 26th, 2008, 07:05 PM
Read through this thread (http://ubuntuforums.org/showthread.php?t=765195&page=5). You may be caught with the same SATA drives not being recognized. You may need to add 'irqpoll' at the end of your boot string in /boot/grub/menu.lst file.

Thank you, I'll check that out, though my situation is a bit unique. I've 5 ide drives and 1 dvd. 2 of the ide drives are on a pci controller which may be causing the problem.

Interestingly, I can boot all the way through to the desktop in recovery mode. I'm not sure what I should be looking for in the logs, or why recovery works when normal doesn't. I noticed that there's a 'checking filesystems' line where it says that something wasn't check 'X' times so it's being forced. The first time it checked /dev/sdbX. I didn't note the number, but the second time it checked /dev/sda1. Why would that have changed and how can I review the entire boot log? Is that in /var/log/syslog?

Thank you, I think I'm making progress!

April 27th, 2008, 01:58 AM
I went into /boot/grub/menu.lst and added irqpoll, but nothing has changed. What else should I check?

Thank you!

April 28th, 2008, 11:38 AM
I think this has to do with the video drivers. I've looked through the xorg.conf and it seems rather barren. I recall there being references to the vesa drivers there when on gutsy. I tried running dpkg-reconfigure xserver-xorg, but nothing changed. I tried reinstalling the fglrx drivers, but I think that was unnecessary. When I run fglrxinfo, it says something to the effect of no video recognized or installed. I really wish I had saved a copy of xorg.conf! I backed up php, samba, proftpd, sshd, but not xorg.conf. How can I reinstall or configure the video? Thank you!

April 28th, 2008, 01:35 PM
I've read that xserver-xorg doesn't configure video as it used to. I tried using gksudo displayconfig-gtk, but every driver I try fails. My card is an ATI Rage 128 IF Pro. I tried rage 128, r128, vesa, vga generic, and when I try 'test', all either fail or the screen becomes that grey checked pattern and the cancel prompt is in the upper left corner, partially off the screen. What driver does the kernel use in recovery mode and how do I implement that, or is there a better alternative?

I also forced a downgrade to xserver-xorg from the gutsy repository, but after words reconfiguring asks the same questions, still sans video configuration. Is a reboot necessary to use the newly installed version?

This exactly hardware configuration did indeed work fine on feisty and gutsy.

Here's my current xorg.conf:

# xorg.conf (X.Org X Window System server configuration file)
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout" "us"

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Emulate3Buttons" "true"

Section "Device"
Identifier "Configured Video Device"
Option "UseFBDev" "true"

Section "Monitor"
Identifier "Configured Monitor"

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"

April 28th, 2008, 02:49 PM
I've heard/read that xserver-xorg was replaced with some x - configure in hardy, does anyone have any information on that? The thread mentioned x - configure, but I can't find any other references. Thanks!

April 29th, 2008, 01:25 PM
While I am having video problems, I can boot into low-graphics mode which isn't a show stopper. The actual problem appears to be with how the machine resumes. I tried pressing ctl+alt+f1 when the screen hung at the cursor, after loading grub and 'starting up'. The machine was waiting for a response to an error resuming. It is trying to resume from a non-existent drive for the swap location. When I hit 'enter' to boot normally, the machine booted. How do I resolve this resume issue? It says, cannot resume from device: /dev/hda2. /dev/hda2 used to be my swap partition until upgrading to hardy, now it's /dev/sda2. Why the change?

My drives used to be:
/dev/hda1 /
/dev/hda2 swap
/dev/hdb1 /home
/dev/hde1 (on pci controller)
/dev/hdg1 (on pci controller)

All of the drives are ide, but now hda through hdc are showing up as sdX, as though they are scsi. My fstab mounted using uuid, but I changed it to the current 'sdX' just in case and rebooted. I'm still getting the resume error prompt. What's going on?