View Full Version : 8.04 Upgrade AMAZING

April 26th, 2008, 02:19 PM
Flawless, absolutely flawless, I only have a few apps installed, that are not from the Ubuntu repo's (lets face there is a lot of stuff in there) but still. I'm a sucker for eye candy so I'm running Compiz Fusion, as well as Avant Window Navigator (AWN), and expecting the hour long upgrade to at the very least, break AWN in some way, due to the fact that it was installed from a 3rd party repo. I also thought there would be a good chance that Copiz Fusion (which relies on proprietary nVidia drivers) would quite possibly be disabled, and then I would have to deal with getting the new drivers installed, and hoping that the maintainers of AWN had an updated version for Hardy.
Then I also have Picasa (I know it uses wine, and that isn't the coolest thing going, but its a great app, and deal with it) who knows what would happen to that.
Well as it shakes out (you probably saw this coming, what with the whole Flawless thing earlier) everything worked, not a single thing had anything that couldn't be fixed in a matter of seconds or minuets, below is a list of the minor, and I stress MINOR issues.
And here I am running the latest version of Ubuntu, an hour and a half after the start of the process with my full desktop no notable snags what so ever (it could have been shorter, but I have a 6 month old that was hungry).

Minor snafu's
- The upgrade GUI tool kept hanging on "Checking Package Manager", running the command line upgrade "sudo do-release-upgrade" did the trick.
- My network connection was unable to resolve my home file servers host name, and my fstab file had a share mapped using the name, I updated the mapping to use the IP address, and that fixed that problem.
- And for some reason the launchers that previously opened folder locations in AWN stopped working, app launchers still worked, so i set up a shell script that opened the same location.

Thats it the few problems I had, and their simple solutions.

Thanks to the Ubuntu team, and the great community that surrounds and supports it.

I made the switch to Linux about 6 Months ago (from windows), so this is my first successful OS upgrade ever, I'm simply amazed that things can work this smoothly.

Thanks again!

April 26th, 2008, 05:38 PM
What version did you upgrade from?

April 26th, 2008, 06:08 PM
Yeah Hardy is awesome .. HIbernation now works on my sony lappy

April 26th, 2008, 06:52 PM
Jerky33, I also had a flawless, painless upgrade. I upgraded from Kubuntu Gusty Gibbon. My only slight issue was having to reconfigure Vmware Player for the new kernel. That took all of one minute.

April 26th, 2008, 07:00 PM
I also upgraded this morning on one of my computers from 7.10 to 8.04 - absolutely perfect! Even FF3b5 is working so so far with no problems!

April 26th, 2008, 07:22 PM
Holy crap, I just noticed hibernating works now!!!1 :guitar::guitar::guitar:
But suspend still doesn't...

April 26th, 2008, 08:05 PM
actually awn is in the repos

April 26th, 2008, 08:08 PM
I too, had a flawless upgrade from Gutsy 32-bit to Hardy 32-bit. Everything worked. Funny thing is, I wanted to try the Hardy 64-bit on my laptop. So, I did a fresh install of Hardy AMD64. I got everything to work so I am happy with Hardy.

April 26th, 2008, 08:17 PM
I just finished upgrading from Gutsy. Everything went smooth, my wireless even reconnected after start-up. My old wireless issues have been worked out as well.

Plus suspend works!

I'm pretty happy with it so far.


April 26th, 2008, 09:42 PM
spnkybnky, I upgraded from 7.10.
And knowledgeispwr, I too had to run the vmware setup script for vmworkstation 6.0, and like you said, it took all of one minuet.

April 26th, 2008, 09:54 PM
Great to see a positive post :)

I upgraded from Gutsy to Hardy via the admin > SPM with no problem - it was a breeze but with abaited breath ;)

Everthing works great but, I think next time I'll backup then update as I was worried, just in case ... (needlessly) :)

Canonical© and the community - good on ya and deeply appreciated - truely :D

April 26th, 2008, 09:55 PM
I just updated last night, and I agree. I used to have to type in the password every time I wanted to connect to the internet network, but now Ubuntu just automatically connects.

April 26th, 2008, 09:56 PM
My upgrade went pretty flawless also, just a little slow due to traffic I'm sure. I started it last night in the evening, and ended up going to bed before it was done. This morning my computer was waiting for my to answer 1 question, then 10 minutes later it was rebooting to start on Hardy!

Only issues I've seen are more of a slight hassle on my part, since I change some icons around etc and had to move them to the desired directory again (and I couldn't remember exactly which directory! doh!).

Then only "real" issue I have is Yahoo games doesn't seem to want to work with FF3b. Keeps telling me I don't have Java enabled, but everything else Java wise is working just fine, so I am not sure if it is something with FF3 of Yahoo. Knowing Yahoo as I do, I tend to lean to the latter.

April 27th, 2008, 09:54 AM
Have to agree with that!
I upgraded from Gutsy using the alternate CD and it was absolutly flawless.
Thanks for the good work!