PDA

View Full Version : [ubuntu] 8.04 Upgrade - Wireless (3945) + Network Manager problems ...



W. James MacLean
April 25th, 2008, 04:08 PM
Having upgraded to 8.04 last night, my wireless has disappeared, and the network-manager applet along with it (both worked fine prior to the upgrade).

I'm not sure where to start in describing the problem.

1) According to the release notes, one needs to disable "roaming" on any network interfaces that Network Manager is to manage (System -> Administration -> Network). However, when I get the Network Settings dialog box, and I try to enable "Wireless Connection", I see no mention of any "roaming" feature ...

2) I tried removing all references to eth1 (my wireless interface) from /etc/network/interfaces, but this did not appease network-manager. I also tried reducing the entry to


auto eth1
iface eth1 inet dhcp

but this did not help either.

3) When I check iwconfig, I get


$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

eth1 IEEE 802.11g ESSID:"" Nickname:""
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Tx-Power=27 dBm
Retry min limit:7 RTS thr:off Fragment thr=2346 B
Power Management:off
Link Quality:0 Signal level:0 Noise level:0

It also seems I do not get a DHCP connection:


$ sudo dhclient eth1
[sudo] password for maclean:
Internet Systems Consortium DHCP Client V3.0.6
Copyright 2004-2007 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wmaster0: unknown hardware address type 801
wmaster0: unknown hardware address type 801
Listening on LPF/eth1/00:13:02:a1:57:5a
Sending on LPF/eth1/00:13:02:a1:57:5a
Sending on Socket/fallback
DHCPREQUEST of 192.168.2.22 on eth1 to 255.255.255.255 port 67
DHCPREQUEST of 192.168.2.22 on eth1 to 255.255.255.255 port 67
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 5
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 9
No DHCPOFFERS received.
Trying recorded lease 192.168.2.22
PING 192.168.2.1 (192.168.2.1) 56(84) bytes of data.

--- 192.168.2.1 ping statistics ---
1 packets transmitted, 0 received, +1 errors, 100% packet loss, time 0ms

No working leases in persistent database - sleeping.

Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0


4) I tried re-installing Network Manager, but had no success.

I don't know where to start with this, any thoughts??

Cheers,

James

dtgolder
April 26th, 2008, 03:38 PM
This thread worked for me and got my Broadcom/NDISWrapper working:

https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx/Feisty_No-Fluff

Look for the Hardy fix (almost at the end)

W. James MacLean
April 26th, 2008, 08:38 PM
Thanks for your help ... unfortunately I bit the bullet and wipe Hardy out, and have just finished re-installing 7.04. I'd have had to do this anyways I think, as there were a number of other 'show stoppers'.

Cheers,

James