View Full Version : [ubuntu] Ipod can't be seen Banshee

April 25th, 2008, 02:09 PM
I have an old 4th Gen Ipod, i think, anyway, I installed Banshee for synaptic and it does not recognize the IPOD. IPod is recognized by Gutsy and Rhythmbox, but I want to try out Banshee.

Also, once Banshee recognizes the Ipod, how do stop Rhythmbox from opening whenever I attach the IPOD?

April 25th, 2008, 03:31 PM
Ok, figured it out, apparently the 2 problems were interrelated. Banshee was not seeing my IPod because Rhythmbox was using it first. So to solve it, I fixed it so that IPod will run Banshee instead of Rhythmbox,

For those with similar noobie problems, the method is just to replace rhythmbox with banshee in System -> Preferences -> Removable Drives and Media -> Multimedia Tab -> Portable Music Players

Then that's it, whenever you attach your ipod it will run banshee and be detected by banshee

April 27th, 2008, 10:21 AM
In Hardy Heron, portable media was removed for the Removable Drives and Media, there is a similar option in Preferred Applications, don't know if this is the same but I know that this did not help detect my ipod in banshee.

April 29th, 2008, 03:49 PM

After trying Preferred Applications again, and choosing Custom and manually typing 'banshee', my IPod can be seen again by banshee. Somehow choosing Banshee from the dropdown list does not work.


Lost it again. It ran once, so at least I know that it was not banshee. Somehow Heron is messing it up and goes back to Rhythmbox. If only I know where to locate the actual configuration file it is messing with.

May 1st, 2008, 03:40 AM
I also had problems with Banshee recognizing my ipod after upgrading to Hardy. Based on a comment in this bug report https://bugs.launchpad.net/ubuntu/+source/banshee/+bug/139226 I installed podsleuth and now it seems to be working.

May 1st, 2008, 11:43 AM
thanks for pointing me to the right direction, i don't know if podsleuth had anything to do with it but the trick that worked was making all the users a member of haldaemon

Ernesto RD
August 6th, 2009, 12:19 AM
Tried all the methods above, non worked. My ipod was just insivible to banshee

But i found the solution...

Just Remove Rhythmbox! :)
go to synaptics pacacke manager, and mark rhythmbox to completely uninstall, uninstall it, and thats it.
now banshee can see my ipod just fine.

hope this helps

December 29th, 2009, 08:32 PM
thanks installing podsleuth helped out a lot.

January 13th, 2010, 03:07 PM
Hope it could be useful


I have faced with the same issue after upgrading to Karmic.


January 19th, 2010, 11:29 PM
Hey, running 9.10 Karmic, with Banshee and a 5th Gen 30gb Ipod video.

Banshee was not recognizing the ipod, then I tried
a) plug in ipod (so it automounts)
b) start banshee
c) right click the ipod icon on the desktop, and unmount (not eject or sfely remove)
d) open nautilus and re-mount the ipod.

Voila. Banshee finds it, as does podsleuth. Podsleuth gives an error (Ipod found but is not known) but as long as banshee works, I don't care.

Oh - and I still have Rhythmbox installed, and Banshee will put OGG files on the Ipod. I tried the same fix, both with and without Rockbox installed. Banshee does not seem to know or care what firmware is installed.

Something about the automount seems to confuse Banshee and Podsleuth, so one must manually undo it and redo it.

I know I could turn off automounting, but this is not hard and I do want automounting for other media types.


January 20th, 2010, 02:46 PM
I'm sorry but what do you mean by 'open nautilus'?

January 21st, 2010, 10:58 PM
Nautilus is the name of the graphical file management tool (aka file browser) - you should be able to start it by hitting places - desktop (there are other ways). Then the ipod should appear over in the left hand column, and if you select it, it should mount it.

once mounted, an icon should appear on the desktop, and also in the lefthand column of banshee.


January 22nd, 2010, 12:04 AM
Follow the guide in my signature for a pretty solid fix around for this problem.

January 27th, 2010, 09:48 AM
Hi guys,

this issue has been fixed with 1.5.4 version (formerly "1.5.4~really1.5.2-0ubuntu1~hyper2~karmic").

The banshee team released it the 21st of January. You can update your Karmic by using the banshee PPA repository as explained here




January 31st, 2010, 03:30 PM
The new update helped (I think). But just in case you're still not seeing your iPod, try disabling and enabling the iPod Support. Open up Banshee, go to Edit -> Preference -> Extensions. Untick iPod Support and restart Banshee. (Your iPod shouldn't be mounted at this point otherwise, Banshee just might hang, as it happened to me).

After disabling, re-enable it and now mount your iPod.


January 31st, 2010, 04:22 PM
That sounds good that they fixed it in the recent update. I just got a fresh install and have not had time to hook up my ipod.

February 6th, 2010, 02:32 AM
OK, I am having all these same problems. I tried uninstalling musicmatch and I still can't get ipod to appear in Banshee. I am right now trying to install podsleuth but I have no idea how. I found this page: http://download.banshee-project.org/podsleuth/ and I downloaded: podsleuth-0.6.6.tar.gz from this page: http://download.banshee-project.org/podsleuth/LATEST-IS-0.6.6/

Now, if I did download the correct things to install podsleuth, what do I do after downloading the .gz file? I tried running install-sh in terminal and it changed nothing. There is no install instructions ... just a readme telling me a whole bunch of programmer mumbo jumbo. Any help would be appreciated as I haven't had access to my ipod in months.

February 6th, 2010, 03:06 AM
Follow the guide in my signature for a pretty solid fix around for this problem.

This worked. Thanks.