PDA

View Full Version : [ubuntu] 8.04 doesn't detect SATA drive



SomalianViking
April 25th, 2008, 01:06 AM
I am new here, and am attempting to install ubuntu 8.04(AMD64 desktop version) on a my system but am getting errors that I beleive might be related to my sata hard drive. When booting from the Live cd I get an error that looks something like this:

[XXX.XXXXXXXXX] ata5: COMRESET failed (errno=-16) //X's are random numbers

When using the LiveCD install it gets to step 4 and doesn't detect the drive while setting up the partitions, it appears as though there is no drive. Ive tried installing using the alternative CD, and was actually able to see and configure the partitions on my drive, but got errors when trying to continue and actually apply the changes.

If anyone knows how to stop the problem and get ubuntu to see my drive I would greatly appreciate it. Thanks.
~Jamie

EDIT:
Here are my system specs and I am dual booting from my HDD:
ASUS A8N32-SLI Deluxe
AMD Opteron 185 2.6GHz
2Gb Kingston DDR400
400Gb Seagate SATA HDD
Antec 650W PSU
nVidia 8800 GTX

lugolu
April 25th, 2008, 01:31 AM
I am using 7.10.
On Monday I downloaded Ubuntu 8.04 RC and I wanted try it.
When I put live cd while it was loading a lot of errors were showed.
I have also a SATA drive.
And when linux was running I couldn't see any folder or file in the partitions.

SomalianViking
April 25th, 2008, 03:00 AM
I just tried installing it again with the 8.04 alternate CD. Even after being able to access my /dev/sda partitions while trying to set up the partitions, i received this error:

Error opening /dev/sda: no such file or directory

After I got this error and went back into the partition setup it would not detect my drive at all. It then brought up a list of driver for me to try to install to detect the device. None of which looked remotely familiar to me, so I had no luck there. This seems to be a pretty common problem with 8.04. Perhaps I will waste an hour and download 7.10 until this gets resolved.

Black_Diamond
April 25th, 2008, 05:02 AM
I also have a problem with SATA drives not being visible. The previous version of Ubuntu had a harder time recognizing the SATA controller in this machine. Windows Vista is already installed. So the hard drive is installed correctly.

When I try to install it, it just displays the initfs prompt. It would be nice if it gave some more diagnostic information. The Live CD can boot into Ubuntu. It just can't find the hard drive.

I'm using the 64-bit version of Ubuntu 8.04.

My machine is a Shuttle G5 computer with the following specs:
Intel Core 2 Duo E8400 @ 3.00GHz
2GB RAM
Intel G33
Intel ICH9DH
Marvell Gigabit Ethernet
nVidia GeForce 2 7800GT

Black_Diamond
May 23rd, 2008, 09:08 AM
I may have found the solution for this problem.

I also tried Fedora Core 9, and it had the same problem. Windows finds the hard drives just fine. The error message on Fedora Core 9 was a little more informative. It showed an error message, which was something about 19h and using irqpoll when booting. The irqpoll option doesn't work!

I fiddled with the BIOS settings, and that seems to have fixed my problem. There were several options that I changed. I don't remember all the changes, but essentially I changed the SATA drive setting and a CPU setting to use the older non-native settings. Some of the settings stated that they were fine for Windows XP and Windows Vista, but they weren't okay for Windows 2000. I guess Linux wants to do things the old way. Sorry I can't be more specific, but other people may want to check their BIOS settings.