View Full Version : [ubuntu] 7.10 upgrade to 8.04 Fail!

April 24th, 2008, 11:40 PM
I was very happy for the 8.04 upgrade and some of its features but it appears it wont show me them. After upgrade from 7.10 to 8.04 upon reboot my screen was way to big and could not see the log on section but i guessed and when it went to log me in i got the error down at the bottom of the page. Using boot to fail safe mode i ran the xserver thingy and upon reboot i got a normal screen:) and loged on everything looked fine. Then i did a normal reboot and i got the same error when i first booted.

small window pops up. summery here

your last session only lasted less then 10 sec....if you have not loged off properly..... may have not enough space... update may of failed..

xmodmap unable to open display ':1'
canot open display
xsession error

n. I do have a nvida card that worked fine in 7.10 so did all my other hardware. Please help my log on!!!!

ps when my screen was to big i tried logging on and got the same message too. sorry about bad grammer and spelling the screen is killing my eyes with its wrong refresh rate that cant be swichted.

April 24th, 2008, 11:42 PM
the servers are over ran wait a little bit

April 24th, 2008, 11:50 PM
what does the server have to do with it??? i downloaded the iso with bit torrent and upgraded that way. I am not touching the severs right now with my problem.

As far as the update went it said it finished with out any problems its when i reboot that it went to hell

April 25th, 2008, 12:03 AM
Using boot to fail safe mode i ran the xserver thingy and upon reboot i got a normal screen:)

Your X.org is borked, then. Was it "dpkg-reconfigure xserver-xorg -phigh" that you ran?

April 25th, 2008, 12:16 AM
First Try This (AKA Plan A):

sudo /etc/init.d/gdm stop
cp /etc/X11/xorg.conf /home/yourhome/xorg.conf.bak
sudo rm /etc/X11/xorg.conf
sudo apt-get install build-essential
sudo chmod a+x /home/yourhome/NVIDIA*
sudo /home/yourhome/NVIDIA*
sudo /etc/init.d/gdm start
gksudo gedit /etc/modules
add "nvidia" without quotes to the file and save and exit
gksudo gedit /etc/default/linux-restricted-modules-common
add "nv" to the disabled modules list, save, and exit

If all went well you should have something that seems right, if not then:

Second Try This (Plan B):

sudo /etc/init.d/gdm stop
sudo rm /etc/X11/xorg.conf
sudo nvidia-xconfig <--do this if the Nvidia wizard didn't set things up right(generally not needed)
sudo dpkg-reconfigure -phigh xserver-xorg <-- do this if you already tried nvidia-xconfig and it didn't work
sudo /etc/init.d/gdm restart
And if all else fails, we made a back up copy of your xorg.conf, you can restore it by:

Last Try This (Ruh-Roh):

sudo cp /home/yourhome/xorg.conf.bak /etc/X11/xorg.conf
Then paste a cat of that file here for more help.

As an aside, its been my experience that the best way to do a distribution upgrade is to do a clean install. It would also be wise to learn to use the manual partition manager portion of the install wizard, this way you can create /home on its own partition(if you have not already done so) this makes future distribution upgrades much simpler, or even trying other flavors of linux. A strong warning before doing a distribution upgrade, if you do not have /home on its own partition already, then before you do anything else, backup all important data that is located in your /home directories or that may be stashed anywhere else on the system for that matter or else it will be forever gone never to be seen or heard from again.

And as always, the sane computing mantra is hoooooommmmme backup-alot-save-my-saaaniiiityeeee-hooooooommmmmme

April 25th, 2008, 05:46 AM
Thanks for your help!!! but it did not fix the problem.]

Plan a and typed rm /etc/X11/...... it said there was no such file. Then later when i tried it again it said no such file at this point cp /etc/x11/...

I still contuned with the steps but i dont see any differnce. Still getting the error on normal log in

Plan B

It says i dont have a xserver.xorg

did i mess typing that up, or is it possible i dont have a xorg??? Unless you see somthing obvous dont spend much time on it as I DO have a seperate home directory and have no real problem reinstalling 8.04 after a format. Just wanted to go the easy :lolflag: way and do the upgrade

# xorg.conf (X.Org X Window System server configuration file)
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Emulate3Buttons" "true"

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"

Section "Monitor"
Identifier "Configured Monitor"

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Defaultdepth 24

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
Section "Module"
Load "glx"

April 25th, 2008, 07:30 AM
OK well things have improved a bit. I went to eat dinner and came back and rebooted the computer. Runs fine now can log in.

So i guess it worked thanks again. lol but now i have another problem it wont let me up date, says it needs 3 files to finish. So it only gives me a "finish your update icon, when i click it it wants files from a cd i dont even have hum. haha But i think that is an easy fix

Xiong Chiamiov
April 25th, 2008, 07:58 AM
I don't know if this was part of your problem, but you need to pay careful attention to things like "xserver.xorg" vs "xserver-xorg" and "x11" vs "X11".

April 26th, 2008, 12:39 AM
Hi, GeForce 6600GT here, upgraded and got the same problem (running in low graphics mode) as you guys. tried ENVY, without success.

I tried plan 'A', but couldn't get past sudo chmod a+x /home/colin/NVIDIA*

it told me that directory didn't exist. plan 'B' got me going with the correct resolution, but 3d is still not working. tried NVIDA X Settings, and that's broken. also something weird i noticed: in Hardware Drivers, there are no drivers listed.

any ideas beyond a complete reinstall?

EDIT: Ok, i got the Hardware Drivers to see my card and install the closed source driver, enabling 3d... I noticed there were 2 similar kernels in GRUB: i had been selecting the first, which was 2.6.24-16-386. I changed to 2.6.24-16-386-generic and got my card working. maybe this will help someone else!

April 27th, 2008, 01:09 AM
Xiong Chiamiov.... i did type it in right, i was just typing fast here so i did not repeat it 100%

dentarthurdent-- i contuined to have problems after i got the Nvidia working. IT got stuck on a update and would not install a program. Hung up everytime. Also had some wierd things going on. So my advise to you and what i did is just do a format reinstall from fresh. Ubuntu 8.04 does not like to be upgraded! It seems a lot of people are having problems with it. So save your self the trouble.

I have been running it 48 hours now from a fresh install and its working great! lots of bug are fixed over 7.10