PDA

View Full Version : [ubuntu] 8.04 will not let me log in



-=Viper=-
April 24th, 2008, 10:02 PM
Ok so i know the disk is fine by the way because i used it on another computer and im on it now full install no problems. ok so i tried it first in the PC that would not work and im kind of annoyed. I also know its not the drive because i swaped it out and put a new one in (cd drive). the PC that will not work is a HP Pavilion a1129n. please help. the live disk wont let me log in...just tries...crashes...back to login screen...by the way the install worked on it...just xserver wont work when i try or gnome...gnome failsafe works

Peter09
April 24th, 2008, 10:28 PM
Sorry,
not understanding your problem. Have you installed Hardy, but cannot get a GUI session?

PC

sterilegenie
April 25th, 2008, 01:52 AM
Ok so i know the disk is fine by the way because i used it on another computer and im on it now full install no problems. ok so i tried it first in the PC that would not work and im kind of annoyed. I also know its not the drive because i swaped it out and put a new one in (cd drive). the PC that will not work is a HP Pavilion a1129n. please help. the live disk wont let me log in...just tries...crashes...back to login screen...by the way the install worked on it...just xserver wont work when i try or gnome...gnome failsafe works

I think I have the same problem as you...
When running the live cd it goes to the login screen but crashes and brings you back to the login screen. Is this what is happening to you as well? If so I think it has something to do with the x session that 8.04 is trying to use. I am going to try few things after my /home directory is done being copied to another drive.

Wish4Me
April 25th, 2008, 02:13 AM
I think I have the same problem as you...
When running the live cd it goes to the login screen but crashes and brings you back to the login screen. Is this what is happening to you as well? If so I think it has something to do with the x session that 8.04 is trying to use. I am going to try few things after my /home directory is done being copied to another drive.

Yes. This is exactly what happened with me too. After you login it crashes and it goes blank then goes back to login. If you try to shutdown it apears the whole linux kernal crashes and then shutsdown, maybe.

Wish4Me
April 25th, 2008, 02:31 AM
": this is really frustrating. Can I get help?

-=Viper=-
April 25th, 2008, 02:50 AM
yea I really want to figure this out...oh wish4Me are you using an ATI card? that MIGHT be the problem. since my nvidia PC's dont have a problem. I am reinstalling 7.10 right now on my other machine...its annoying

sterilegenie
April 25th, 2008, 02:54 AM
Im using an ATI card as well, a Radeon X200 to be exact and I believe it to be the culprit. Heron must be trying to use an unsupported value in the x configuration.

rigo50
April 25th, 2008, 02:56 AM
I had the same problem earlier. All you need to do is reboot the computer, if it does not reboot, just keep your finger on the power button and shut down the system.

While it is rebooting before it opens the menu, hit any keyboard button to reboot from the live UBUNTU CD (make sure your PC by default seek the CD/DVD boot to start up with, if not change the settings in your BIOS, to make sure it boots from a bootable CD)

I have an HP a1210 n AMD

-=Viper=-
April 25th, 2008, 03:08 AM
yea im running a onboard 200M and rigo...i dont get it...haha

sterilegenie
April 25th, 2008, 03:11 AM
I had the same problem earlier. All you need to do is reboot the computer, if it does not reboot, just keep your finger on the power button and shut down the system.

While it is rebooting before it opens the menu, hit any keyboard button to reboot from the live UBUNTU CD (make sure your PC by default seek the CD/DVD boot to start up with, if not change the settings in your BIOS, to make sure it boots from a bootable CD)

I have an HP a1210 n AMD

I dont understand what this has to do with the x session crashing while trying to login but... OK.

-=Viper=-
April 25th, 2008, 03:16 AM
yea sterilegenie your right...it doesnt have anything to do with it...i think...also im going to try a alternitive install if this last test doesnt work. if it does then yay if it doesnt ill tell you if you need an alternitive install to get it to work

rigo50
April 25th, 2008, 03:18 AM
I don't understand it either, but it worked for me. Evidently there is a bug in the installation process

HINT: If Installation screwed up try this:

Boot up the live CD, go to a terminal, and type:
sudo mkdir /recovery
sudo mount -t ext3 /dev/hda1 /recovery
sudo cp -R /recovery/home_backup /recovery/home
sudo cp /recovery/etc/fstab_backup /recovery/etc/fstab

Then, reboot.

Bodsda
April 25th, 2008, 03:22 AM
i would suggest using onboard graphics to log in and install the graphics card drivers then plug ur card back in see if that helps,. if you dont have onboard graphics try booting in single user mode and installing the drivers

sterilegenie
April 25th, 2008, 03:25 AM
I don't understand it either, but it worked for me. Evidently there is a bug in the installation process

HINT: If Installation screwed up try this:

Boot up the live CD, go to a terminal, and type:
sudo mkdir /recovery
sudo mount -t ext3 /dev/hda1 /recovery
sudo cp -R /recovery/home_backup /recovery/home
sudo cp /recovery/etc/fstab_backup /recovery/etc/fstab

Then, reboot.

Well thats the problem, we cant boot into the live session, x crashes when it tries to load the live session. Are you following me now? I am downloading the alternate cd to see where i get with that.

rigo50
April 25th, 2008, 03:25 AM
Someone posted earlier a different solution:

If your live CD won't boot, and you have an nvidia card...
I've spent the last few hours trying to figure out why my Live CD of 8.04 would not boot. It started to boot and then sent me to a screen full of distorted green and white lines.

Then it suddenly occured to me. I had my monitor plugged into my video card, and nvidia can cause problems.

So, I went to BIOS and reverted back to my onboard intel chipset, and woila! It worked! I'm now installing Hardy, and I'm excited!

So, if you've had this problem, give this workaround a try!

http://ubuntuforums.org/showthread.php?t=765845

"http://ubuntuforums.org/showthread.php?t=765845

Wish4Me
April 25th, 2008, 03:32 AM
I also have an ATI. Its the Radeon Xpress 200. I cant take out the card. How do I boot ubuntu... and the live CD DOES boot. It just wont login. We all have ATI cards. rigo50, You arent helping us. Different problem. I dont know if i can revert to intel chipset with my card.

-=Viper=-
April 25th, 2008, 03:34 AM
.Someone posted earlier a different solution:

If your live CD won't boot, and you have an nvidia card...
I've spent the last few hours trying to figure out why my Live CD of 8.04 would not boot. It started to boot and then sent me to a screen full of distorted green and white lines.

Then it suddenly occured to me. I had my monitor plugged into my video card, and nvidia can cause problems.

So, I went to BIOS and reverted back to my onboard intel chipset, and woila! It worked! I'm now installing Hardy, and I'm excited!

So, if you've had this problem, give this workaround a try!

http://ubuntuforums.org/showthread.php?t=765845

"http://ubuntuforums.org/showthread.php?t=765845
I am on built in...so that does not help me. and i dont get green lines. this is useless...im hopiong the alternitive install will fix my problem.

-=Viper=-
April 25th, 2008, 03:35 AM
I also have an ATI. Its the Radeon Xpress 200. I cant take out the card. How do I boot ubuntu... and the live CD DOES boot. It just wont login. We all have ATI cards. rigo50, You arent helping us. Different problem. I dont know if i can revert to intel chipset with my card.

sorry for double post but

Wish4Me we are using the same card...you are on the built in card so its the card i think...i think we ati users are to be left out in the cold for a bit sadly. i dont know though...im trying a fresh install right now and i hope that fixes it...wont know till morning tho

sterilegenie
April 25th, 2008, 04:55 AM
I have figured out how to fix our problem!!

I installed the alternate cd and when the login screen appears select the safe mode and login as normal. Once there go to System- Administration and select the ATI restricted driver. It will download and install then ask you to reboot. Once you reboot and are at the login screen change the session back to Gnome and login as normal. Enjoy!!

Wish4Me
April 25th, 2008, 06:55 AM
I have figured out how to fix our problem!!

I installed the alternate cd and when the login screen appears select the safe mode and login as normal. Once there go to System- Administration and select the ATI restricted driver. It will download and install then ask you to reboot. Once you reboot and are at the login screen change the session back to Gnome and login as normal. Enjoy!!

I figured it out that Gnome-Failsafe worked when i changed the session to that. However, regular gnome doesnt work. I dont know how to fix the ATI driver or if that is even the problem. How do I install it, i go to System->Administration->HardwareDrivers and put in my password. It says ATI Fire GL is Enabled but not its Status is "Not in use." How do I fix this?

-=Viper=-
April 25th, 2008, 12:45 PM
I figured it out that Gnome-Failsafe worked when i changed the session to that. However, regular gnome doesnt work. I dont know how to fix the ATI driver or if that is even the problem. How do I install it, i go to System->Administration->HardwareDrivers and put in my password. It says ATI Fire GL is Enabled but not its Status is "Not in use." How do I fix this?

that is what it says on my nvidia PC....how do i fix this also

(installing 8.04 again on my desktop. lets see if this works)

-=Viper=-
April 25th, 2008, 01:15 PM
Sorry for another double post but the trick to install the driver does not work because my driver came preinstalled. i tried uninstalling it and reinstalling and it did nothing...any other ideas? its starting to get annoying (i didnt use an alternitive install disk by the way. i just used my live disk...any ideas?)

sterilegenie
April 25th, 2008, 01:48 PM
that is what it says on my nvidia PC....how do i fix this also

(installing 8.04 again on my desktop. lets see if this works)

I thought you said you had a radeon x200 card? If so your system should not be loading the firegl driver, so I guess you need to fix that first.

-=Viper=-
April 25th, 2008, 02:27 PM
I thought you said you had a radeon x200 card? If so your system should not be loading the firegl driver, so I guess you need to fix that first.

ok im gonna try a reinstall with the text based installer soon...should that make any difference. i would really like 8.04 to work...i have two dead PC's till i get it working XD so any ideas?

Wish4Me
April 25th, 2008, 04:16 PM
Yeah. Gnome started working normally after a Few FAILSAFE boots but if I dont run the Os in failsafe it still crashes randomly. Im pretty sure its a graphic crash as the screen gets all ****** up after whatever I am doing. The constant Crashing is really getting annoying. Its making me question ubuntu.


I thought you said you had a radeon x200 card? If so your system should not be loading the firegl driver, so I guess you need to fix that first.

I am using the x200 card. I dont know about him. So i should be loading that driver? It says its not enabled. Not even when I just load gnome without failsafe. :confused:

-=Viper=-
April 25th, 2008, 06:04 PM
Yeah. Gnome started working normally after a Few FAILSAFE boots but if I dont run the Os in failsafe it still crashes randomly. Im pretty sure its a graphic crash as the screen gets all ****** up after whatever I am doing. The constant Crashing is really getting annoying. Its making me question ubuntu.



I am using the x200 card. I dont know about him. So i should be loading that driver? It says its not enabled. Not even when I just load gnome without failsafe. :confused:


I am using a x200 in my desktop. A 200M in my laptop (which is running windows for my ipod. im gonna have to see if it affects my laptop card. i am about to give up hope on 8.04 because it hates me and stay with 7.10 for a few months more (3rd install of it in the past 10 days) I tried an alternitive disk but it was croupted so that was usless and i dont feel like trying it agian so ill just load 7.10 back on that PC. Now i really would like to get 8.04 working because i like it (like i said before...i hate it on my other pc...a pentium 3 XD) yea so if i could get my HP to read it i would be thrilled. anyone got any ideas...i dont wana wait for 8.10

Wish4Me
April 25th, 2008, 11:09 PM
Hmm. No help. Quite ******* annoying. If ubuntu crashes one more time im switching to Fedora.

-=Viper=-
April 26th, 2008, 02:07 AM
Hmm. No help. Quite ******* annoying. If ubuntu crashes one more time im switching to Fedora.

i just made the move back to ubuntu 7.10 again. DOES ANYONE HAVE ANY IDEA ON HOW TO MAKE 8.04 WORK!?!?!?!?!?!

uranus65
April 26th, 2008, 02:36 AM
After reading through the various posts I am a little confused. I will relate what happened to me when I installed 8.04 because it sounds somewhat similar. After the install, which I did clean and without booting to the LiveCD, the login screen would play the drum sound and return to the login screen. I tried this a couple of times with the same result. I selected the Options thing in the lower left corner and changed sessions from "last session" to "gnome..." The login then worked. I can't remember exactly what it said without rebooting but I think the main problem was that it was trying to recover my "last session" which no longer existed.

sterilegenie
April 26th, 2008, 08:04 PM
Ok for everyone that has the radeon x200 video card i will explain again how to get 8.04 to work.

First install using the alternate cd.

Second once installed and your at the login screen, change the session to "failsafe" and log in.

Third once logged in install Ati drivers by going to System---> Administration----> Hardware Drivers.

Fourth Reboot system.

Fifth When you reach the login screen from the reboot change session to "gnome" and make it permanent when asked.

Sixth Login and enjoy 8.04 and Compiz effects!

Toadmund
April 26th, 2008, 08:22 PM
I have the ATI radeon xpress 200g.
I also had the login problems.
Installing the the graphics driver in 'System->Administration->hardware drivers' after I logged in through gnome failsafe then switching back to gnome or x (one of them?) in 'select session' on the login screen worked for me.

gnatman
April 27th, 2008, 10:26 PM
First time here guys, I am having the same problem;
I log in, hear music, then it refreshes, drum sounds, back to login screen. I can login Failsafe gnome. I go hardware drivers, 'ATI Fire GL' enabled is checked, but has red dot and says "not in use". I place curser over "not in use" it says, this driver is necessary....there is no free/open alternative. if driver is not enabled, hardware will not work. I have integrated ATI Radeon x300. Thanks for any help!

Peter09
April 27th, 2008, 10:44 PM
try using envyng, its in the repositories or you can download by


sudo apt-get install envyng-gtk
and you may need

sudo apt-get install envyng-core

once these are installed


envyng -t

and ask it to install the ATI driver.

PC

gnatman
April 28th, 2008, 03:04 AM
Peter09, thanks so much. It worked. It took me a bit, as it usually takes me awhile for things to sink in. I reread the 'for beginners' posts a couple of times, and what do you know? some of it sank in! Thanks again, now to get it the rest set up, and try and learn some more.

Wish4Me
April 28th, 2008, 03:21 AM
Actually this way gets you the offical one and its a helluva lot easier.
In terminal do:
sudo apt-get update
sudo apt-get install linux-restricted-modules-generic restricted-manager
Then go to Administrator -> Hardware and install. Bingo.

Also, My massive crashing problems i was complaining about earlier had to do with Firefox. Since ive stopped using it no more crashes :P

-=Viper=-
April 28th, 2008, 07:43 PM
try using envyng, its in the repositories or you can download by


sudo apt-get install envyng-gtk
and you may need

sudo apt-get install envyng-core

once these are installed


envyng -t

and ask it to install the ATI driver.

PC
It worked! THANKS!!! i thankd your post :D

Peter09
April 29th, 2008, 06:39 AM
Thanks,
enjoy Ubuntu

PC