PDA

View Full Version : [ubuntu] Sansa e260 not being read



stevek123
April 24th, 2008, 04:10 AM
When I attach my Sansa e260 mp3 player thru the usb, the system recognizes the unit and the add-on microSD card and opens desktop folders. The folders of both are there - listed separately. The mp3 music on the microSD is there and plays like it should. None of the folder contents in the base unit are recognized (but the folders are-they just read as empty!). The system recognizes that there is data space used up there, but still says folders are empty. This is with the unit set as autodetect or in MSC mode. The music files there are mp3 format and the photos are jpg format. I looked at System-> Pref-> HardwareInfo and it looks like they are identified the same by my system. At this point, I assume it is a firmware issue. How to beat it???

BTW-I googled and tried installing MTP protocols to see if I could get around this and they didnt work for me (I AM a noob so I might not have done it right...)

stevek123
April 24th, 2008, 05:20 AM
Now I'm screwed! I tried the advice on this thread http://ubuntuforums.org/showthread.php?t=620558
I downloaded banshee and added the line .is_audio_player in my unit root and now it is not recognized at all!!!! I get an icon in top rt for usb/unable to get data. hloy moly what a pain...

SZF2001
April 26th, 2008, 10:20 AM
Did you try switching to MSC mode? Or do you absolutely need MTP?