PDA

View Full Version : [ubuntu] Dual monitors



Dlinx71
April 23rd, 2008, 07:52 PM
Hello all,
I hope I can get some help here. I have just installed Ubuntu 8.04 and so far I really like it. I am having an issue with the nvidia drivers. I have installed all updates and the newest nvidia-glx drivers for my 7300. I have also installed nvidia-settings. I am running 2 Dell 1707fpv monitors. One on the vga connection and the other on DVI. I can do twin view on the system just fine, but instead of one giant desktop I would like two seperate desktops with their own panels, so that when I maximize a program it only maximizes on one monitor or the other. I have attached the xorg.conf file. I am a newbie, so please forgive me if I have missed something. Both monitors are set at 1280x1024 60hz. Which is their max res.

gsmanners
April 23rd, 2008, 08:35 PM
If you run this:

gksudo nvidia-settings

You can then change the Display Configuration to give you "Separate X screen" rather than "TwinView". Then "Save to X Configuration File" and restart X (ctrl-alt-backspace).

Dlinx71
April 23rd, 2008, 09:36 PM
I have done this and my secondary monitor just shuts down like it is getting no signal.I have tried multiple resolution settings, but the monitor stay off until I set it to twinview.
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by failsafeDexconf, using
# values from the debconf database and some overrides to use vesa mode.
#
# You should use dexconf or another such tool for creating a "real" xorg.conf
# For example:
# sudo dpkg-reconfigure -phigh xserver-xorg
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "vmmouse"
EndSection

Section "Device"
Identifier "Configured Video Device"
Boardname "NVIDIA GeForce 7 Series"
Busid "PCI:2:0:0"
Driver "nvidia"
Screen 0
Vendorname "NVIDIA"
Option "NoLogo" "True"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
Vendorname "Generic LCD Display"
Modelname "LCD Panel 1280x1024"
Horizsync 31.5-64.0
Vertrefresh 56.0 - 65.0
modeline "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
modeline "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
modeline "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
modeline "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
modeline "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
Gamma 1.0
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
Defaultdepth 24
SubSection "Display"
Depth 24
Modes "1280x1024@60" "1280x960@60" "1024x768@60" "800x600@60" "800x600@56" "640x480@60"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen 0 "Default Screen" 0 0
EndSection
Section "Module"
Load "glx"
Load "v4l"
EndSection
Section "device" #
Identifier "device1"
Boardname "NVIDIA GeForce 7 Series"
Busid "PCI:2:0:0"
Driver "vesa"
Screen 1
Vendorname "NVIDIA"
EndSection
Section "screen" #
Identifier "screen1"
Device "device1"
Defaultdepth 24
Monitor "monitor1"
Option "RenderAccel" "True"
Option "Twinview"
Option "MetaModes" "1280x1024@60 1280x1024@60"
SubSection "Display"
Depth 24
Modes "1024x768@60" "800x600@60" "800x600@56" "640x480@60"
EndSubSection
EndSection
Section "monitor" #
Identifier "monitor1"
Vendorname "Generic LCD Display"
Modelname "LCD Panel 1024x768"
Horizsync 31.5-48.0
Vertrefresh 56.0 - 65.0
modeline "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
modeline "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
modeline "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
Gamma 1.0
EndSection
Section "ServerFlags"
EndSection

gsmanners
April 24th, 2008, 02:22 PM
Like I said, you have to restart X before you'll see improvement.

Dlinx71
April 24th, 2008, 04:20 PM
I have restarted x multiple times, as I did yesterday. After setting it to separate X screens, it continues to disable my second monitor on restart of X. =) It is a tad frustrating.

Dlinx71
April 24th, 2008, 11:36 PM
NM I got it, but it was a strange fix. Went into nvidia-settings enabled second monitor. Hit save to X configuration. Since nvidia-setting failed every time I asked it to save. It kept saying I didn't have permission. I used sudo gedit /etc/X11/xorg.conf and that took care of the permission issue. Hit preview and cut and pasted the whole deal to xorg.conf. Restarted X with ctrl alt bkspce and it worked. I can't believe I pounded my head against the wall for so long. Oh well fun fun when it is fixed.