View Full Version : [ubuntu] Apple keyboard

April 23rd, 2008, 03:14 AM
I am new to Ubuntu, so please be kind. I am having a problem. I have installed Ubuntu with the default keyboard (generic 105 key (intl) PC, layout Germany). I setup a user with admin priveleges. I setup a launcher (gksudo "gnome-open %u"). When I drag a file to it, gedit asks for a password, I enter and all works fine. With this keyboard layout, I get funny characters / translates to -, and many others. I set keyboard to Apple and English. Everytime I do the same it asks for the password, but never recognizes it. I am able to login and have the password recognized. Any ideas? How can I have my cake and eat it too?

Running Ubuntu 7.10 on Alum. Intel iMac 20"

April 23rd, 2008, 09:55 AM
Sorry, looks like I posted in wrong forum. My guess is this problem is not unique to Intel MAC. Feel free to move, I couldn't figure out how to.

April 23rd, 2008, 03:19 PM
I have made some progress on this. I think I setup my password with the default keyboard settings (Generic 105-key (intl) PC, German). Then I changed my keyboard to "Apple", English. I redid this and now seem to have my password in sync.

I now have a new problem. On the login screen, my y and z keys are interchanged. My password has a "z" in it, so I have to key "y" for my password to take. Any ideas?

January 9th, 2013, 02:05 AM
i had the same problem i just went through a bunch of keyboard styles until i found the right one. english canadian worked with my 2007 mactel:biggrin:

January 9th, 2013, 02:06 AM
From the Ubuntu Forums Code of Conduct (http://ubuntuforums.org/index.php?page=policy).

If a post is older than a year or so and hasn't had a new reply in that time, instead of replying to it, create a new thread. In the software world, a lot can change in a very short time, and doing things this way makes it more likely that you will find the best information. You may link to the original discussion in the new thread if you think it may be helpful.
Thread closed.