View Full Version : [ubuntu] sandisk mp3 player issue

April 23rd, 2008, 02:09 AM
I won a Sandisk e260 mp3 player - supposedly designed to work with win mplayer 10+. It is a 4G base unit and I have a 2G microdisk added into it. The unit has 3 usb options in its menu = autodetect, MTP, MSC. I run it regularly on my winXP machine - and it works thru mplayer and also thru windows explorer. Its packed with music I'd love to listen to while I'm here working ...or figuring out how ubuntu works....

My ubuntu comp does not recognize it in msc mode or mtp mode. I googled this and found I'm not only person struggling with Sansa units. Most 'fixes' were way beyond my grasp but I tried a couple of things to enable mtp - but that hasnt panned out (plus I'm a noob and clueless to what I was really doing). The unit is readily detected in autodetect mode and my file system will show the folders in the base unit and the folders and all the music on the microdisk - but the music on the base drive is not there. When I use Amarok, with the unit set as 'generic', I get same response = microdisk perfect, base unit = folders only. Both filesystem and amarok recognize the available space on the base unit but the mp3 files just wont load. Any help out there??? [I google/saw installation steps for win32 and mplayer but the steps were too complicated for me to understand...]

April 23rd, 2008, 03:19 AM
Try this link from anythingbutipod.com


Start at post 28 :)

They seem to be having luck with banshee (it's in the repositories)

I hope this helps