View Full Version : [ubuntu] Wireless light blinking, have wireless

April 23rd, 2008, 01:51 AM
Upgraded to Hardy tonight.

Worked great.

I have a wireless connection, but the wireless light is blinking, driving me NUTS!

Intel Wireless, System76 Serval Performance Type 1

It worked great on Gutsy.

How can I get the light to stop blinking?

Is the Intel Wireless driver part of the kernel now?

April 23rd, 2008, 07:15 PM
I hate to bump.

The laptop is working fine on the internet, there are no performance issues.

The light is blinking and before, in Gutsy, is would burn solid with no blinking. It is a slow blink, not fast.

It is using the iwp3945 wireless drivers for my Intel wireless.

Any help appreciated.

April 23rd, 2008, 08:06 PM
Blinking! My light is not even blinking, it worked as it should on gutsy i.e. blinking while connecting and solid while connecting now with an up to update RC its always off.

April 24th, 2008, 12:20 AM
Blinking! My light is not even blinking, it worked as it should on gutsy i.e. blinking while connecting and solid while connecting now with an up to update RC its always off.

Mine stops blinking after I stop using the Bluetooth mouse and internet for a couple of minutes, but continues to blink if I start surfing or move the mouse.

April 24th, 2008, 01:23 AM

sudo apt-get install linux-backports-modules-hardy-generic

September 18th, 2008, 12:43 AM
wifi light is blinking for me since I upgraded to Intrepid Ibex (8.10) one week ago. and it is not pleasant.

I noticed that blinks when there is Tx or Rx. As indicator is technically ok, but my PC is a laptop and the wifi led is 3cm below the screen, so I can perceive it constantly blinking and becomes uncomfortable.

any of you have also this issue?

October 5th, 2008, 10:43 AM

i have the same problem with ubuntu 8.10! before on 8.04 and 7.10 there was no blinking!!! But for now it is not anoing because the LED is almost under the keypad and i can't see it :) but if there will be any fixes great!!


October 7th, 2008, 03:34 AM
Same here since the 8.10 install. Works great but keeps blinking at me in odd intervals.

Used the...

sudo apt-get install linux-backports-modules-hardy-generic
fix but said

Couldn't find package linux-backports-modules-hardy-generic

As all of us have asked, help would be greatly appreciated.

October 8th, 2008, 10:06 PM
Yes. Crazy blinking since the upgrade to Intrepid for me too. Have a Dell D820 - can furnish more details if required!



October 9th, 2008, 02:59 PM
Steady, annoying blinking in Ibex as well.

October 11th, 2008, 12:01 PM
To get the linux kernel backports you have to enable backports in your repos.

Go to

System --> Administration --> Software Sources

Click the third tab over that is labeled "Updates"

go down the list and click the box for unsupported updates (hardy-backports) or Ibex if that applies to you.

November 1st, 2008, 01:22 PM
unfortunatly the "sudo apt-get install linux-backports-modules-intrepid-generic" solution does not work on intrepid ibex :( installed the backport, restarted, and I am still staring at a very, very annoying blinking wifi led (blinks on tx and rx, as someone stated earlier)

I hope to find a solution to this quickly, it really annoys me.
I also hope they release a more bug-free compiz for intrepid, the current one is giving me hell :(

update: this bug is posted on lauchpad (https://bugs.launchpad.net/ubuntu/+source/linux/+bug/250211). There are some workarounds, like turning the led off, or reducing its blink cycle.

one of the posts on the bugreport recommends this (http://blog.drinsama.de/erich/en/linux/2008052101-iwlwifi-blinking.html) workaround. Didnt work for me, but I got the idea od the script and will modify it to my notebook (XPS m1530) when I have more time.

All I can say, is **DAMN** how the hell did they let this get into the final release?!?! its not exactly a hard to find bug, and plenty of people are having this problem!
Anyway, will post back here once I get a solution that works for me.

November 2nd, 2008, 03:37 AM
Same problem on a Dell D620 led is blinking.

I tried the backports module without no luck
same as adding a none to in the /trigger

It is still a quite annoying continuous blinking.

November 2nd, 2008, 04:22 PM
This is an old thread regarding Hardy.

It should actually be closed at this point because I don't think that it matters after the -21 kernel update.

You may want to post a thread about this issue that actually involves Intrepid.

November 2nd, 2008, 04:30 PM
Thread Closed at the request of the original poster.