View Full Version : sudo issues

April 22nd, 2008, 09:46 PM
I can no longer sudo when it asks for my password I input it and nothing happens, when I type su and then try to put in my password it has an authentication error. What do I do?

April 22nd, 2008, 09:49 PM
When you enter your password for sudo it will never show any input, this is normal :)

Just enter your password (making sure you type it correctly of course ;)) and hit enter. That's it :)

April 22nd, 2008, 09:49 PM
After you type in your password, do you press enter?

April 22nd, 2008, 09:51 PM
yup just hit enter when your done typing your password and it should take it!
I was in your position once lol. Took me forever to figure it out =]


April 22nd, 2008, 09:53 PM
if I type sudo fdisk -l it will ask for my password, I enter it and hit enter and nothing happens then I tried to su and then use fdisk but I could not su (see above). I know this is the correct password is there any way to reset my password perhaps?

April 22nd, 2008, 09:55 PM
Hmm, sounds a bit odd.

What happens if you do
sudo aptitude update Does it do anything then?
Just for the record - that will basically check to see if there are any system updates :)

April 22nd, 2008, 10:05 PM
nothing happens

April 22nd, 2008, 10:15 PM
issue solved: booted into recovery mode and:
adduser username admin

booted normally and sudo works