View Full Version : [ubuntu] Hosed my Firefox after Hardy install

April 22nd, 2008, 08:07 AM
After upgrading to Hardy, so many of my extensions didn't work in Firefox 3, that I thought I'd try to downgrade back to FF2. So I used Synaptic to uninstall FF3 and installed FF2.

It runs ok, but I can't figure out how to get it to see my existing profile and extensions and such.

It sees my bookmarks, and my extensions are shown in the Addons menu, but none of them seem to be actually installed, and I can't adjust the settings. The preferences buttons for each extension in the Addons menu just don't do anything.

What did I do wrong, or do I need to reinstall all the extensions to get them working again?


April 22nd, 2008, 02:42 PM
I'm in exactly the same situation.
I've tried removing an extension or reinstalling it but it won't let me.
I'm wondering if I need to try and completely wipe firefox and reinstall it and then import my profile back in but the problems I have with it now may be connected with the profile so that may make no difference.

This is why I don't normally do betas :rolleyes:

April 22nd, 2008, 05:54 PM
I never did get FF2 working right, but was able to reinstall FF3. I'll just live with the extensions that do work, and wait for the others to notify me when the updates are available.

April 23rd, 2008, 02:04 PM
I had to wipe version 2 and delete my profile from the home directory then reinstall. Then reinstall my addons. Got it back to how it was now. Still have Firefox 3 on another machine so will keep an eye on that for when its ready for my main use.
It wasn't just the extensions for me, version 3 was crashing every time I tried to click a link to a media file such as mp3 or mpeg either to open it in the browser or select save link as. I'm not sure if this a known firefox bug or just some kind of conflict with something on my system.