PDA

View Full Version : An interesting dilemma (fluxbox, pcmanfm)



TheOrangePeanut
March 29th, 2008, 08:34 AM
In pcmanfm's options, I chose a background image for my wallpaper. It looks good, but now I don't get fluxbox's menu when I right-click on my desktop. If I close this browser, I actually have no way of launching any programs haha. You can see that I'm in quite a mess. How can I fix this? I'm running Arch, btw.

kerry_s
March 29th, 2008, 11:11 AM
use fbdesk, it's made for fluxbox desktop icons. let fluxbox do the background as usual through the startup or overlay( http://fluxbox-wiki.org/index.php/Style_overlay )
http://fluxbox.sourceforge.net/fbdesk/

or use rox-filer instead, it's smaller, faster, more configurable and it has the compatibility setting to pass the right click.
put> rox -s & <in your ~/.fluxbox/startup

K.Mandla
March 30th, 2008, 12:21 AM
In pcmanfm's options, I chose a background image for my wallpaper. It looks good, but now I don't get fluxbox's menu when I right-click on my desktop. If I close this browser, I actually have no way of launching any programs haha. You can see that I'm in quite a mess. How can I fix this? I'm running Arch, btw.
I've noticed that before in Openbox too. I think it's because PCMan (http://ubuntuforums.org/member.php?u=164092) intended that file manager to run alongside the rest of that desktop suite, which means lxpanel would handle most of the work of the right-click menu.

You might consider filing a bug report with him, since it does seem counterintuitive. Or you might PM him and see if he can give you an idea; he's active around here from time to time. (And he writes great software, by the way.)

I'll move your thread to the Arch section, since you're using Arch. :)

urukrama
March 30th, 2008, 01:35 AM
You could add a keybinding for the desktop menu in the keys file. Something like the following:


Mod1 F1 :RootMenu

This will bring up the root menu when the keys Alt and F1 are pressed.

eriqjaffe
March 30th, 2008, 05:34 AM
There's an option hidden in the PCManFM desktop preferences to "show WM menu with right click" which may be causing problems.

webaake
April 2nd, 2008, 05:13 PM
I have the same dilemma on Openbox/LXDE with pcmanfm. Default I have some one colored background, but after starting pcmanfm from lxpanel it takes over the whole desktop with icons, colors and wallpaper and obmenu isn't available. I have to kill it to be able to use obmenu again.

It seems a bit strange that a file manager acts as desktop, or have I misundertood pcmanfm ?? Is there a way to fix this.

I run Openbox 3.4.6.1, pcmanfm 0.3.6.2, lxsession-0.3.2
, lxde-common-0.3.0.1 and lxpanel 0.2.9.0.

webaake
April 2nd, 2008, 05:58 PM
Solved it! I unclicked the option "show desktop icons" in preferences and it now functions as filemanager should do, in my opnion.

I'm not much for desktop icons cluttering the desktop anyway, and pcmanfm IS really fast!

Thx pcman!